19:03 <rbasak> #startmeeting Technical Board
19:03 <meetingology> Meeting started at 19:03:09 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <rbasak> #topic Action review
19:03 <rbasak> seb128 and mwhudson to talk to docs team at sprint, follow up at 2026-05-19 meeting
19:03 <mwhudson> oh hi
19:03 <teward> o/
19:04 <rbasak> This is in relation to the ubuntu-policy migration from package to GitHub I guess?
19:04 <seb128> yes
19:04 <seb128> the discussion did happen, Simon is going to "split vcs commits in rich history"
19:04 <mwhudson> i have some notes from these meeting somewhere ...
19:05 <rbasak> Thanks
19:05 <rbasak> No action for the TB for now then? If so, shall I drop the action item?
19:05 <rbasak> review revised snapd SRU exception proposal https://github.com/ubuntu/ubuntu-project-docs/pull/542
19:05 <seb128> yes, drop for now
19:05 <rbasak> I haven't looked at this yet.
19:05 <seb128> me neither :/
19:05 <rbasak> #action review revised snapd SRU exception proposal https://github.com/ubuntu/ubuntu-project-docs/pull/542
19:05 * meetingology review revised snapd SRU exception proposal https://github.com/ubuntu/ubuntu-project-docs/pull/542
19:05 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:05 <rbasak> Andreas posted https://lists.ubuntu.com/archives/technical-board/2026-May/003131.html
19:06 <rbasak> And there was some discussion in the SRU team about it.
19:06 <rbasak> AIUI, the TB's position remains unchanged for now
19:07 <rbasak> Unless someone disagrees, I don't see any action for the TB here either.
19:07 <rbasak> I don't see any other ML activity from April or May that is outstanding.
19:08 <rbasak> #topic Check up on community bugs and techboard bugs (standing item)
19:08 <rbasak> #info No recent bug activity.
19:08 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:08 <mwhudson> one thing that came up is that i don't think the outcome of the meeting we had with mark was recorded anywhere?
19:08 <rbasak> Let's discuss in AOB?
19:09 <mwhudson> sure
19:09 <rbasak> Next chair will be seb128, with teward as backup
19:09 <rbasak> #topic AOB
19:09 <rbasak> So FTR, we did chat with Mark about the topic of that thread (HWE enablement and request for an exception).
19:10 <rbasak> Christian did email some notes privately to TB members.
19:10 <seb128> are you mixing meetings?
19:11 <rbasak> My summary would be: there will be no general exception. Case-by-case exceptions may be considered, but we expect them to be few and narrowly scoped. Requests will need to go to the TB. So far there have been none.
19:11 <seb128> the one Christian intended was the CUDA one?
19:11 <seb128> or was he there also for the SRU exception?
19:11 <rbasak> I think so yes. But that hasn't been taken to the TB yet to my understanding.
19:11 <rbasak> I guess he was there for both items?
19:11 <mwhudson> it was the same meeting that we discussed CUDA and the hardware SRUs
19:12 <rbasak> The CUDA exception (permitting /usr/local in multiverse in Resolute) was given as a one-off and I believe documented in the bug.
19:12 <seb128> no it was not
19:12 <seb128> I mean it was not the same meeting
19:12 <seb128> or was it?
19:12 <seb128> those sprints wiped my memory :-(
19:12 <rbasak> I thought it was. I only attended the one meeting with Mark recently
19:13 <seb128> ok, sorry, I'm the one confused
19:13 <rbasak> It's probably easier for me to remember as I no longer meet with Canonical people often :)
19:14 <seb128> anyway, I think your summary is accurate
19:14 <rbasak> Thanks
19:14 <seb128> now I guess it is on record for those who find IRC logs :p
19:15 <rbasak> Agreed, thanks
19:15 <rbasak> mwhudson: anything else to discuss on this?
19:16 <mwhudson> rbasak: well i think it would be a good thing to have on the record the expectations around an exception request
19:16 <rbasak> Hmm.
19:16 <rbasak> We agreed some things that won't be acceptable, such as that an upgrade to the latest LTS must always work.
19:17 <rbasak> And that it would be for very special cases, not for regular hardware enablements
19:18 <mwhudson> i can't really remember the details from the meeting but at least i have christian's notes (i think i kind of lost track of the thread in the actual meeting tbh)
19:18 <rbasak> I'm not sure it's really possible to record expectations around an exception request though, since exceptions are by definition exceptional and we agreed to take them case-by-case.
19:18 <mwhudson> at least we have christian's notes
19:18 <rbasak> This is something that I think is being lost by a queue of SRU "exception requests" being fielded by the SRU team.
19:18 <rbasak> Because they aren't exceptions.
19:19 <mwhudson> anyway i don't have a concrete proposal for this today
19:19 <rbasak> Yet these requests are being seen as something that Ubuntu developers must go through for some reason.
19:19 <rbasak> As if it's a regular process.
19:20 <rbasak> Anyway.
19:20 <rbasak> I guess there's nothing further to discuss for now?
19:20 <mwhudson> i think so
19:21 <seb128> I guess not
19:21 <seb128> it feels like something that somehow should be documented but unsure where/how
19:21 <seb128> just for transparency reasons/so people understand how the expection was added the day we have one
19:22 <seb128> maybe worth a bug on launchpad for our backlog?
19:25 <seb128> anyone still around? are IRC split still a thing? ;-)
19:25 <rbasak> I don't mind if you want to do that, and I'll happily give you feedback on a draft.
19:25 <mwhudson> i am still here!
19:26 <rbasak> However...
19:26 <seb128> ok, let me add a bug for the backlog for now
19:26 <seb128> or...?
19:26 <rbasak> it does feel a bit like proving a negative.
19:27 <rbasak> My preference would be to wait until we have an actual concrete exception request, and then we can dig into that by asking questions, rather than trying to predict what we will want to know or what we might consider approving by guessing the scenario we will be asked to consider.
19:28 <rbasak> I do expect the person requesting an exception to understand well the expectations behind the policy for which they are requesting an exception, though.
19:29 <rbasak> But I think our position and reasoning behind it is well documented between the SRU documentation and the ML thread
19:29 <rbasak> I also think it's reasonable to expect someone driving such an exception to have studied those things.
19:29 <seb128> well, the position could be "There is no standard SRU exception for HWE enablement but the TB agreed to review <special requests with a better wording>"
19:30 <rbasak> I'm fine if you want to state that, but for me that reduces to "the TB agrees to consider any reasonable request made by an Ubuntu developer" which is always a true statement.
19:30 <seb128> I agree that it will be easier once we have a concrete case
19:31 <seb128> I would just open the bug as a reminder to document things the day we have one
19:31 <rbasak> They're not going to have success if they re-request something that isn't substantially different to something that has already been considered and declined, of course, but that's also always true, and I think it's fine for it to be up to the person requesting an exception to have done their research.
19:31 <seb128> I don't plan to push toward drafting or publishing anything for now
19:31 <rbasak> OK
19:32 <seb128> I guess we can move on
19:32 <seb128> no other AOB from me
19:32 <rbasak> Thanks!
19:32 <rbasak> #endmeeting