20:06 <teward> #startmeeting Technical Board Meeting
20:06 <meetingology> Meeting started at 20:06:09 UTC.  The chair is teward.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:06 <meetingology> Available commands: action, commands, idea, info, link, nick
20:06 <teward> howdy all
20:06 <teward> #topic Action Review
20:06 <teward> #subtopic teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
20:06 <teward> carrying that over
20:06 <teward> #action teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
20:06 * meetingology teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
20:06 <teward> #subtopic Provide feedback in "RFC: SRU Exception for transitional hardware enablements (tHWE)" thread once additional data is made available (waiting on PE team data)
20:06 <teward> did we ever get the PE team data?
20:07 <mwhudson> frank did email the list. i haven't really read his email though...
20:07 <teward> i must have missed it, but we'll move the action item to "Provide feedback"... ("team members processing email about this") so we can allindicate we have to reply / feedback
20:07 <rbasak> I'm still working my way through his extensive set of bugs.
20:08 <mwhudson> https://lists.ubuntu.com/archives/technical-board/2026-January/003091.html
20:08 <teward> Then I'll set this action item as "review frank's email and then provide feedback", unless you want us to wait rbasak
20:08 <mwhudson> teward: might want to check you didn't get silently unsubscribed, i think this has been happening to some people
20:08 <rbasak> No need to wait - I think everyone should read now and reply to the list with an opinion.
20:08 <seb128> ack
20:09 <rbasak> This has dragged on long enough.
20:09 <seb128> indeed :-/
20:09 <rbasak> I don't think my questions have been answered, but I think it's time to stop going back and forth and make a decision.
20:10 <rbasak> How about we allow these next two weeks for opinions on the ML and then plan to make a final decision in our next meeting?
20:10 <mwhudson> ok
20:10 <teward> +! on that
20:10 <teward> +1 *
20:11 <teward> #action (all members) Provide feedback in "RFC: SRU Exception for transitional hardware enablements (tHWE)" thread now that data is available
20:11 * meetingology (all members) Provide feedback in "RFC: SRU Exception for transitional hardware enablements (tHWE)" thread now that data is available
20:11 <seb128> +1
20:11 <teward> i'm skipping around the agenda slightly for a moment
20:12 <teward> #topic Scan the mailing list archive for anything we missed (standing item)
20:12 <teward> oops
20:12 <teward> oh no that's right
20:12 <teward> #subtopic Temporary block of @canonical.com sending to @lists.ubuntu.com
20:12 <teward> rbasak: i remember discussing this briefly with you did this ever get addressed?
20:12 <rbasak> I've heard nothing from IS on this topic, and AFAICT they have not taken any action :-(
20:12 <rbasak> I have fixed the occasional ML whose admin access I have when I've bumped in to it.
20:13 <rbasak> But we need it comprehensively applied to all MLs, and only IS can do that.
20:13 <teward> ok then let me take this as a CC/TB joint member and poke IS with the Aaron Prisk and Mauro Gaspari hammers.
20:13 <teward> is there an RT ticket?
20:13 <rbasak> Yes
20:13 <rbasak> I mentioned it in the thread
20:13 <teward> i see it
20:13 <teward> sorry i'm on a tiny screen as my second monitor today
20:14 <teward> And it looks like Mark is on board with the change too
20:14 <teward> (given the small wall of text I posted too in reply to Mark)
20:14 <teward> i'll follow up
20:14 <seb128> thanks
20:14 <teward> #action teward to reach out to Canonical Community Team to prod IS on issues with lists.u.c needing 'munge from' set for DMARC compliance on ALL mailing lists
20:14 * meetingology teward to reach out to Canonical Community Team to prod IS on issues with lists.u.c needing 'munge from' set for DMARC compliance on ALL mailing lists
20:14 <rbasak> I don't think it's a question of the decision, just getting the priority for IS to look at it rather than us sysadmining by proxy :-/
20:14 <teward> back to the agenda
20:15 <teward> rbasak: i know aaron prisk has a line on IS director so we can escalate it there
20:15 <teward> which i'll do after this meeting and a snack
20:15 <teward> #topic snapd SRU exception request
20:15 <teward> #link https://lists.ubuntu.com/archives/technical-board/2025-September/003050.html
20:15 <teward> #link https://code.launchpad.net/~ernestl/sru-docs/+git/sru-docs/+merge/493382
20:16 <teward> #link https://documentation.ubuntu.com/project/tech-board/3rd-party-software-sources/
20:16 <teward> notes from last time:
20:16 <teward> snapd SRU exception request needs further discussion, remains as an active agenda item for discussion
20:16 <teward> snapd SRU exception request discussion has opened up policy questions that require further discussio
20:16 <teward> did we make any forward movement on this?
20:16 <rbasak> I did mention our discussion with the SRU team but received no comment :-/
20:16 <rbasak> I can follow up again in the next SRU team meeting
20:16 <teward> #action rbasak to follow up on snapd SRU exception request discussion w/ SRU team
20:16 * meetingology rbasak to follow up on snapd SRU exception request discussion w/ SRU team
20:17 <teward> #topic Check up on community bugs and techboard bugs (standing item)
20:17 <teward> i don't see anything on either of those lists still for us
20:17 <teward> pther than some old techboard items i think need to be poked / checked?
20:18 <teward> like "Inactive DMB members can stall DMB progress"- could have sworn there was policies for that in place before I stepped down from DMB
20:19 <mwhudson> i have forgotten most of the context for that one. it doesn't seem to be a live issue at the moment
20:19 <teward> indeed it hasn't seemed to move since 2023 so not sure what  it needs on that
20:19 <rbasak> The issue was that the DMB can't decide to remove its own members.
20:19 <rbasak> So they need TB support to implement a policy that achieves that.
20:19 <rbasak> But it's currently not an issue within the DMB
20:19 <teward> #subtopic Bug #2015921 - Inactive DMB members can stall DMB progress
20:19 <teward> #link https://bugs.launchpad.net/techboard/+bug/2015921
20:19 <rbasak> So maybe not worth our (limited) time right now.
20:19 <teward> so then we can just let this sit triaged
20:19 <teward> rbasak: agreed
20:20 <teward> #subtopic Bug #2125525 - The membership process of core Ubuntu teams should be documented
20:20 <teward> #link https://bugs.launchpad.net/techboard/+bug/2125525
20:20 <teward> seb128: this one's assigned to you
20:20 <teward> it's triaged though so i think it's an 'ongoing thing'
20:20 <seb128> yes, no progress so far but still on my backlog
20:21 <teward> #subtopic Bug #2110133 - Use of snaps breaks user expectations of stability
20:21 <teward> #link https://bugs.launchpad.net/techboard/+bug/2110133
20:21 <teward> tied to an ubuntu-x1e-settings side, and it looks like it was patched there - "Drop snap channel, switch to non-stable channels since it is not compatible with principles 2 and 3 of the Ubuntu 3rd party software policy"
20:22 <teward> so not sure this is still an issue.
20:22 <rbasak> That sounds like it's fixed
20:23 <teward> objection to marking the TB bug "fix released" then?
20:23 <mwhudson> we do have a policy on this now, does this bug predate that? was it filed to prompt all this stuff?
20:23 <teward> any objection*
20:23 <rbasak> I think the bug came after the policy
20:24 <mwhudson> i guess it's only a bug on techboard for visibility and given the other task is fixed the techboard can be too?
20:24 <teward> yeah at the filing of the bug it was for visibility. We can either fix-released or just Opinion it, either way it drops from the 'active bugs' list
20:24 <rbasak> I'd say Fix Released, as that's our belief
20:24 <mwhudson> fix released imo
20:24 <teward> +1 for fix released
20:25 <teward> and done
20:25 <teward> now this one spawned from a policy discussion i know we all had
20:25 <teward> #subtopic Bug #2125527 - New Ubuntu specific packages should have a corresponding launchpad bug
20:25 <teward> #link https://bugs.launchpad.net/techboard/+bug/2125527
20:26 <rbasak> That's waiting for someone to drive I think
20:26 <teward> you're marked as assigned
20:26 <teward> > The next step would be to draft that proposed policy and do a PR against https://canonical-ubuntu-project.readthedocs-hosted.com/staging/new-packages/, details like recommended vs mandatory can be discussed there.
20:26 <rbasak> O
20:26 <rbasak> OK
20:27 <teward> looks like AAs agree that it's better that new packages direct to Ubuntu need a corresponding bug with a corresponding tag, but that's assigned to you i can unset it if you don't want to drive it
20:27 <rbasak> Consider it in my backlog. I think the HWE request needs addressing first
20:27 <teward> +1
20:27 <teward> that's all the bugs then
20:27 <teward> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
20:28 <mwhudson> i feel like i haven't chaired in a while
20:28 <teward> mwhudson: i was about to say, i chaired the past two including this one, you want it?
20:28 <mwhudson> sure
20:29 <mwhudson> seb128, rbasak: one of you as backup?
20:29 <seb128> I can do
20:29 <teward> #note mwhudson will chair next TB meeting, seb128 is backup.
20:29 <teward> #topic AOB
20:29 <teward> anything else for discussion?
20:30 <mwhudson> nothing from me
20:30 <teward> i have nothing, anything from you seb128, rbasak?
20:31 <seb128> nothing from me
20:31 <rbasak> Nothing from me.
20:31 <rbasak> Thank you!
20:31 <teward> perfect, then i'll call the end of the meeting
20:31 <teward> #endmeeting