19:03 <mwhudson> #startmeeting technical board
19:03 <meetingology> Meeting started at 19:03:30 UTC.  The chair is mwhudson.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <mwhudson> #topic action review
19:04 <mwhudson> #subtopic mwhudson to handle RT ticket to IS to set riscv64 status as official for Questing onward
19:04 <mwhudson> this is done! hooray
19:04 <mwhudson> next two look kind of redundant
19:05 <mwhudson> oh maybe not
19:05 <mwhudson> #subtopic rbasak to follow up on ML thread regarding riscv64 'official' status / TB definition of what the 'official' designation/flag means.
19:05 <teward> they're similar but not exactly the same
19:05 <mwhudson> rbasak: i don't think this really happened?
19:06 <rbasak> I did email the thread
19:06 <rbasak> https://lists.ubuntu.com/archives/technical-board/2025-August/003046.html
19:06 <mwhudson> oh yes you did
19:07 <mwhudson> i guess the intent behind this thing is to codify what we thing official means in a more generalized sense
19:07 <mwhudson> do we think that has been done?
19:08 <mwhudson> because the next item is "rbasak to follow up in ML thread on "official" flag and riscv64 official status" and for sure that has been done
19:08 <mwhudson> one sec
19:11 <mwhudson> ok back
19:11 <rbasak> Oh, OK. I didn't interpret the action item to mean that we wanted more general documentation on this.
19:11 <rbasak> If that's what you mean?
19:12 <mwhudson> well i don't remember why we have to actions in the agenda, honestly
19:12 <mwhudson> *two
19:12 <mwhudson> i think i am happy to draw a line under all this for now and no further action required
19:12 <rbasak> I think it's fine as it is, tbh
19:12 <rbasak> +1
19:12 <mwhudson> seb128, teward: thoughts?
19:12 <rbasak> (I don't think that every TB decision needs separate documentation; this is a fairly minor thing)
19:14 <seb128> I missed a few meetings due to holidays and I'm also unsure to understand why there was another action item there...
19:15 <seb128> I'm happy to just move on for now, doesn't look like any action is really needed
19:15 <mwhudson> let's move on
19:15 <mwhudson> #subtopic teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC (carried over)
19:15 <teward> @seb128 there were action items added because we didn't have you here and came to conclusions
19:15 <teward> with quorum
19:15 <teward> to get it all handled because it was reraised as an issue
19:15 <teward> mwhudson: carry over
19:15 <seb128> ah ok
19:16 <mwhudson> teward: ack
19:16 <seb128> thx
19:16 <mwhudson> #subtopic seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:16 <teward> that one ^^ however is still yours :P
19:17 <seb128> yes, carry over, we are making progress with processes and documentation but not there yet
19:17 <mwhudson> ack
19:18 <mwhudson> #subtopic (unassigned, needs a driver) Future action item: require a notification to either ubuntu-devel@ or Discourse when we're there for new Ubuntu-only packages regardless of target pocket.
19:19 <teward> i think that'll still need a driver but it was listed as a future action item if someone wanted to take it, i don't think it's a *mandatory* item at this point but would be a nice to have
19:19 <seb128> is that having Debian ITP style annonces made mandatory for Ubuntu?
19:19 <mwhudson> i'm guessing noone is champing at the bit to take this on
19:19 <mwhudson> seb128: yes
19:19 <teward> mwhudson: yeah i'm definitely not
19:19 <seb128> is that really a thing for the TB to decide/enforce?
19:19 <teward> seb128: that came from one of rbasak's "I'd like to see..." things
19:20 <seb128> I think that is a good practice and we should encourage it, unsure if that needs to be a requirement though...
19:20 <teward> i forget all the specific context around it
19:20 <rbasak> IMHO, there have been various inappropriate new packages introduced into Ubuntu in the past year or two, which only get flagged after the fact
19:20 <mwhudson> seb128: it feels like it probably is, this kind of policy is our remit isn't it?
19:20 <seb128> isn't that an AA issue if those go through NEW though?
19:20 <seb128> I feel like it's more an AA topic
19:20 <rbasak> AAs aren't reviewing for package appropriateness, AFAIK
19:20 <seb128> I'm happy to take it for discussion with the AA team
19:21 <seb128> they do gate things to enter in the archive so maybe they should?
19:21 <mwhudson> ok that would be good i guess
19:21 <doko> AAs should do these checks for source packages, licenses, etc,
19:21 <mwhudson> the AA team are definitely on the enforcement side of this, not sure about policy side
19:21 <seb128> do you have an example of "inappropriate"
19:22 <rbasak> See for example bug 2103602
19:22 <teward> if you're going to discuss things with the AA, remind them to **triple check** before just removing a package without notifying flavor teams when things're seeded.  ongoing issue with things (and we decided I think to gently nudge the AAs about that stuff)
19:22 <teward> just adding notes ;)
19:23 <seb128> ack
19:23 <rbasak> Apparently nobody reviewed this from a "what's wrong with add-apt-repository" perspective (which already integrates various classes of other common repositories, such as the Canonical Cloud Archive)
19:23 <seb128> We do need someone in charge of those decisions though
19:24 <seb128> Because even if those are announced and problems discussed on e.g -devel, what at the end if the uploader doesn't change their mind?
19:24 <rbasak> linux-mtk is another example, which was added to Jammy but not to newer releases, in contradition to SRU policy and the principle that hardware enablements should always be backports.
19:24 <mwhudson> well this seems more a failure of aa review, would an announcement have really helped?
19:25 <doko> rbasak: well, that would be responsibility of the SRU team
19:25 <rbasak> mwhudson: which example?
19:25 <rbasak> doko: the SRU team doesn't review kernel packages
19:25 <mwhudson> rbasak: add-nvidia-repositories
19:26 <rbasak> mwhudson: OK, so in that example, I think there would have been much more opportunity to say "why not add-apt-repository" and then we would have had that discussion. I'd have probably brought it up.
19:26 <rbasak> My understanding is that new packages in Ubuntu are rare, so it shouldn't be much of a problem to have the opportunity to collectively discuss them.
19:28 <mwhudson> i certainly have no problem with the general idea
19:28 <teward> where NEW is specific to Ubuntu and not NEW via autosyncs you mean
19:28 <teward> just to clarify ;)
19:28 <rbasak> seb128: if the discussion results in a clear lack of consensus, then the uploader isn't allowed to upload. They can only act by consensus, or escalate to a responsible team.
19:28 <seb128> I think it's fine to at least recommend emailing devel for new packages
19:29 <rbasak> teward: right
19:29 <doko> there is no NEW for debian source imports
19:29 <mwhudson> doko: yeah stuff coming via debian is not the topic here
19:29 <seb128> there is no review, they are gated by the the NEW queue though
19:29 <rbasak> Also there are probably routine things like versioned toolchain source packages that can probably be skipped
19:30 <seb128> yes, same as we do for MIR
19:30 <rbasak> No need to announce the use of an existing established pattern
19:31 <seb128> so do we consider that a topic for the TB to decide on?
19:31 <rbasak> Maybe we should ask the AAs opinion first
19:31 <seb128> and if so we want to decide on recommended vs mandatory here/now?
19:31 <mwhudson> seb128: imo yes
19:32 <mwhudson> or what rbasak says :)
19:32 <rbasak> But apart from that, yes :)
19:32 <seb128> I do plan to bring that topic to our weekly AA sync meeting in any case
19:32 <rbasak> Thanks :)
19:32 <seb128> and I'm happy to own getting the Ubuntu Documentation updated to include the outcome
19:32 <seb128> do we postpone to next time to wait for the AA team opinion?
19:32 <rbasak> +1
19:32 <doko> I mean, we already have source packages in NEW waiting for several weeks ... I'm justd afraid that situation gets worse
19:32 <mwhudson> yeah
19:33 <rbasak> doko: I'm deliberately not asking for anyone to have to wait for agreement. It wouldn't block anything
19:33 <mwhudson> something like "seb128 to discuss requiring email to ubuntu-devel before ubuntu-only package introduction idea with AAs"?
19:33 <seb128> doko, we are not speaking about reviewing Debian imports. Having a pre-discussion on devel shouldn't make a difference on review time, it might help to catch problems ahead and reduce review load
19:34 <seb128> mwhudson, +1
19:34 <mwhudson> #action seb128 to discuss requiring email to ubuntu-devel before ubuntu-only package introduction idea with AAs
19:34 * meetingology seb128 to discuss requiring email to ubuntu-devel before ubuntu-only package introduction idea with AAs
19:34 <mwhudson> #topic Scan the mailing list archive for anything we missed (standing item)
19:34 <mwhudson> i don't think there is anything
19:35 <mwhudson> #topic Check up on community bugs and techboard bugs (standing item)
19:35 <mwhudson> also nothing afaik
19:35 <mwhudson> #action Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:35 * meetingology Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:36 <mwhudson> bah
19:36 <mwhudson> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:36 <mwhudson> iirc it's teward's turn. who should be backup?
19:37 <seb128> I missed my turn in the weeks I was off so probably fair if it's me
19:37 <mwhudson> ok
19:37 <mwhudson> #agreed teward to chair, seb128 back up
19:37 <meetingology> AGREED: teward to chair, seb128 back up
19:37 <mwhudson> #topic AOB
19:37 <teward> wait i thought i chaired last week o.O
19:37 <teward> but ok
19:37 <mwhudson> i don't have anything today
19:37 <mwhudson> teward: oh oops
19:38 <rbasak> Nothing from me thanks
19:38 <teward> mwhudson: no worries, just was saying "Meh"
19:38 <seb128> I can chair the next one, if you know how to undo and update the action :p
19:38 <teward> but i'm fine to chair i'm way overdo :)
19:38 <seb128> no AOB from me either
19:38 <teward> @seb128 it's glitchy, so we can just do an #AGREED "Actually smoeone else to chair, teward as backup" or such
19:38 <teward> Undo is glitchy :P
19:38 <teward> no AOB here
19:39 <seb128> ack
19:39 <teward> more coffee required though :D
19:39 <mwhudson> #agreed actually seb128 to chair, teward as back up
19:39 <meetingology> AGREED: actually seb128 to chair, teward as back up
19:39 <mwhudson> ok we're done i think
19:39 <seb128> 👍
19:39 <mwhudson> #endmeeting