16:01 <rbasak> #startmeeting Developer Membership Board
16:01 <meetingology> Meeting started at 16:01:43 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:01 <meetingology> Available commands: action, commands, idea, info, link, nick
16:02 <rbasak> The agenda looks out of date
16:02 <juliank> I think there's only one sosreport PPU?
16:02 <utkarsh2102> yeah
16:02 <rbasak> I'll just skip ahead to arif-ali's PPU application shall I?
16:02 <cpaelzer> yes, Arif for PPU on sos(report)
16:02 <lvoytek> sounds good
16:02 <rbasak> #topic sos(report) PPU Application by Arif Ali
16:02 <utkarsh2102> let's do that first and then move to the other things
16:02 <rbasak> Welcome arif-ali!
16:02 <utkarsh2102> there^ :)
16:03 <arif-ali> Hey folks, back again
16:03 <bdrung> \o
16:03 <rbasak> (also, welcome cpaelzer, lvoytek and juliank!)
16:03 <lvoytek> thx :)
16:03 <juliank> :)
16:03 <bdrung> sorry, i my body demanded a nap and i just woke up
16:03 <arif-ali> For those that don't know me, My name is Arif, and part of the support team at Canonical, and have been at Canonical 5.5 years
16:03 <arif-ali> My application is at https://wiki.ubuntu.com/arif-ali/sosreportPerPackageUploadApplication
16:04 <cpaelzer> I do not know how prepped everyone is, I did some pre-study and have copy and paste question blocks if you do not mind - but being new I do not want to dominate this too much WDYT?
16:04 <juliank> go for it and it gives us time to multi task :)
16:05 <rbasak> Previous meeting log here: https://new.ubottu.com/meetingology/logs/ubuntu-meeting/2025/ubuntu-meeting.2025-02-03-16.02.html
16:05 <rbasak> #link https://new.ubottu.com/meetingology/logs/ubuntu-meeting/2025/ubuntu-meeting.2025-02-03-16.02.html
16:05 <cpaelzer> ok, the new IRC client wants me to copy these line by line
16:05 <cpaelzer> We have recently worked on an SRU together and I was quite pleased,
16:05 <cpaelzer> but reading the old log
16:06 <cpaelzer> made me see a few weak spots indeed. I didn't see them in our joint
16:06 <cpaelzer> work but wanted to be sure so I prepared some questions about this
16:06 <cpaelzer> and more.
16:06 <cpaelzer> Q0 - Overcoming deficiencies identified last time
16:06 <cpaelzer> Please report a bit what you have done since last application
16:06 <cpaelzer> to overcome the shortcomings (we will check and ask about them later,
16:06 <cpaelzer> but what additional learning or practise did you have since last meeting:
16:06 <cpaelzer> that is Q0 - up to you arif-ali
16:06 <cpaelzer> (FYI I have up to Q3)
16:07 <arif-ali> So, 2 SRUs for sosreport, and 1 major sync that involved a name change in Debian, and hence Ubuntu, and 2 further syncs
16:08 <arif-ali> I have used extra powers on launchpad that allowed me to run autopkgtests on PPA to ensure that all goes through without any regressions, or at least less regressions
16:09 <arif-ali> I have read trough various docs on SRU team rota, so that I know who to talk to, this was especially helpful with my non sos SRUs
16:10 <arif-ali> The previous FF, I had ~5 syncs and had discussed these in the Ubuntu Devel matrrix with one of the core devs, who coincidentally was a DMB member previously
16:12 <juliank> Which other non-sos SRUs have you done?
16:12 <arif-ali> the rename caused various issues (primarily due to same version with old and new package), where I had to speak to Archive Admins to remove old package, and do seed update for the updated package to ensure that the package would migrate as the new package was in universe
16:12 <arif-ali> openvswitch and dpdk
16:13 <arif-ali> I worked with cpaelzer on the dpdk one, so he's aware of the work on that one
16:13 <cpaelzer> True, and a bit on openvswitch with Heitor I can see int he sponsorship miner
16:14 <cpaelzer> OK, that should have given you plenty of exposure to the things you only have known to some extend last time - thanks. Should I go to the next question?
16:15 <rbasak> Sure. I have a question ready too, but you go first.
16:15 <cpaelzer> ok, going for Q1 and then you can go next before I go further ...
16:15 <cpaelzer> Q1 - because there were some rough answers last time - uploads
16:15 <cpaelzer> What exactly happens when someone does run syncpackage?
16:15 <cpaelzer> Please ensure to go into
16:15 <cpaelzer> - Required permissions of the one executing the command (if important at all)
16:15 <cpaelzer> - Involved bugs (who creates them, when, and are they strictly required?)
16:15 <cpaelzer> - Once syncpackage ran, what is the next place to look for to ensure
16:15 <cpaelzer> a new version makes it into Ubuntu?
16:16 <cpaelzer> that is Q1 - up to you arif-ali
16:18 <arif-ali> I've only used the request symc package once, while I was working on improving the differences n=between Debian and Ubuntu, and that came through, that was almost a year ago. The rest of the sos packages were auto-sync'd
16:18 <arif-ali> With the way I did, it automatically crated the bug, and detailed the version that needs sync'ing
16:19 <arif-ali> and then a person with upload rights would upload the package
16:20 <arif-ali> for this page details some of it, https://wiki.ubuntu.com/SyncRequestProcess
16:20 <juliank> If you were given upload rights, how would you act on the sync request bug?
16:21 <juliank> i.e. how would you actually sync the package manually
16:22 <arif-ali> it's not something I've done any research on, but my guess is that I would grab the dsc, sign the package, and then upload using dput
16:23 <rbasak> To be fair, a person who can't upload (yet) won't have any experience with the tooling to actually do the thing, only to request it :)
16:23 <cpaelzer> correct
16:24 <juliank> nothing further on that point from me
16:24 <cpaelzer> and we have to admit, under the cover syncpackage kind of does it like that for you (not really but close enough) :-)
16:24 <cpaelzer> rbasak: you had another question waiting - up to you then?
16:24 <rbasak> Note: please *don't* manually upload for a sync :)
16:24 <rbasak> Let's say it's 16 September (2025), and you discover a really important bug in sos 4.9.2-1 in Questing. You have the necessary patch to fix it at hand. What should you do?
16:27 <arif-ali> My normal route is to upload to Debian, which would go into unstable, as Debian would face the bug as well. Once the auto sync report suggests what it would with the auto sync. Then I would use the available tools to sync the package across
16:28 <lvoytek> When you do a new release of sos in Debian, under what circumstances will it not auto-sync into the Ubuntu devel release?
16:28 <arif-ali> This is one of the key issues I found in FFE last time, and had one of the core devs sync them
16:29 <rbasak> Is there anything else you need to do before you sync the package across after it is available for sync, from my scenario above?
16:29 <arif-ali> Feature Freeze will prevent it to auto-sync
16:30 <utkarsh2102> it's the Debian Import freeze that prevents the auto-sync not the Feature Freeze. It just happens on the same day for obvious reasons. :)
16:30 <arif-ali> I would get a feature freeze exception, and explain the reasons
16:30 <rbasak> It's a bugfix, not a feature change.
16:30 <rbasak> (in my scenario)
16:30 <rbasak> So there is no feature freeze exception needed.
16:30 <rbasak> But what *do* you need?
16:31 <arif-ali> We need to document this as a bugfix-only upload
16:32 <arif-ali> Ideally, imo in a LP bug
16:33 <rbasak> Try checking the release schedule
16:33 <rbasak> "Let's say it's 16 September (2025)..."
16:34 <arif-ali> I was looking at wrong Date, apologies
16:35 <arif-ali> It would be Beta Freeze, so we need manual approval from the release team, as documented at https://wiki.ubuntu.com/BetaFreeze
16:36 <rbasak> OK, good. So let's say that the release team grant the exception via the bug, and you've put the bug reference into your upload somehow (skipping the details for now).
16:36 <rbasak> You upload, and then the package enters questing-proposed and builds there.
16:36 <rbasak> What do you need to ensure next?
16:37 <arif-ali> All the versions of the package need to build, but in sos case it's architecture is any
16:37 * juliank suggests double checking that statement
16:37 <arif-ali> We need to ensure that all the autopkgtests are green and pass the tests, with any of it's dependancies as well
16:38 <arif-ali> once all green, they should migrate automatically
16:39 <rbasak> Where are you looking to see that all the autopkgtests are green?
16:39 <arif-ali> update_excuses page
16:40 <rbasak> OK
16:40 <arif-ali> you can also go to autopkgtests.ubuntu.com/packages/sos or equivalent and check the live status too
16:40 <rbasak> If the excuses page says "Valid candidate" but it still isn't migrating, where do you look next, or find documentation on what to do next?
16:40 <utkarsh2102> was about to type the same, hehe
16:42 <arif-ali> Although I haven't necessarily used the next step, there is the update output page, I've not had to decipher that yet
16:42 <arif-ali> This is detailed in https://wiki.ubuntu.com/ProposedMigration#Migrating_packages_from_-proposed_to_release
16:42 <rbasak> OK, good.
16:43 <rbasak> That ends my line of questioning, thanks
16:43 <juliank> I have a basic packaging question.
16:43 <cpaelzer> go first juliank
16:43 <cpaelzer> my Q2/Q3 can wait unless we run out of time
16:43 <juliank> To go back to my comment above, can you explain the difference between Architecture: any and Architecture: all and when to use them?
16:45 <arif-ali> yeah, that was my mistake in my answer previously; all is when a package has a that can run on any architecture, and doesn't necessarily need to be compiled
16:45 <arif-ali> I've not used the any one before, my hunch is that the binary can be used on any architecture no matter where it was compiled
16:46 <bdrung> your explanation for any and all sound identical to me
16:47 <arif-ali> something like python would be all, as the code uses interpreting languages
16:47 <arif-ali> they're not necessarily binaries in the package
16:49 <juliank> Can you imagine a scenario that needs you to change sos to Architecture: any?
16:50 <arif-ali> ok, I probably need to back-track, sos was any before, and we changed it to all :)
16:50 <arif-ali> if we have architecture dependant files, that can only run on that architecture would need to be any, so amd64 binaries can only run on amd64 type machines
16:51 <juliank> OK, so that satisfies me, the previous explanations were a bit um loose
16:51 <juliank> Do we have time for cpaelzer's Q3?
16:51 <cpaelzer> I'd go for it
16:51 <cpaelzer> Q2 - because there were some rough answers last time - pockets
16:51 <cpaelzer> Please remember or quickly check "pockets" in
16:52 <cpaelzer> #link https://documentation.ubuntu.com/server/tutorial/managing-software/#where-do-packages-come-from
16:52 <cpaelzer> - a) Please tell me which of those exist in Noble and which in Questing (as of now)
16:52 <cpaelzer> - b) If there is any difference between these releases - why is that?
16:52 <cpaelzer> that is Q2 - up to you arif-ali
16:52 <cpaelzer> and I think we skip Q3 - that is not too important and we covered most above already
16:53 <arif-ali> So, noble will have release, proposed, updates, security and backports
16:54 <arif-ali> questing, afaik, will only have release and propsoed
16:54 <arif-ali> primarily because questing is a development release
16:54 <cpaelzer> TBH - fine with me at this level
16:54 <cpaelzer> thanks
16:55 <bdrung> cpaelzer, did you want to have a practical or technical correct answer to your question?
16:55 <cpaelzer> I do not want to steal too much time, voting or other questions?
16:55 <juliank> We have 5 mins left, I'd suggest voting
16:56 <rbasak> Anything else before a vote?
16:56 <lvoytek> good to go
16:56 <rbasak> #vote Grant PPU for sos and sosreport to arif-ali
16:56 <meetingology> Please vote on: Grant PPU for sos and sosreport to arif-ali
16:56 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:56 <rbasak> +1
16:56 <meetingology> +1 received from rbasak
16:56 <cpaelzer> bdrung: I have enough over the issues we have seen last time. Let us not go to the tech-correct as we know updates exists but isn't used except weird times and ... - not going into that and not expecting anyone should know :-)
16:56 <rbasak> I think there are a few misunderstandings, but I think you've passed the bar for PPU for me.
16:56 <juliank> +1
16:56 <meetingology> +1 received from juliank
16:56 <rbasak> There are of course deep dive technical topics that I don't expect you to know in detail yet :)
16:57 <rbasak> Thank you for maintaining sos in Ubuntu!
16:57 <lvoytek> +1 I think you'll do a great job maintaining sos, it'll be good to learn the tooling with permissions now too
16:57 <meetingology> +1 I think you'll do a great job maintaining sos, it'll be good to learn the tooling with permissions now too received from lvoytek
16:57 <utkarsh2102> +1; thank you for all the good work but also please don't hesitate to ask when in doubt. remember: prevention is much better than cure. :)
16:57 <meetingology> +1; thank you for all the good work but also please don't hesitate to ask when in doubt. remember: prevention is much better than cure. :) received from utkarsh2102
16:57 <cpaelzer> +1 for PPU I'm also fine, please continue to work on other packages, to gather more depth on other cases and behaviors
16:57 <meetingology> +1 for PPU I'm also fine, please continue to work on other packages, to gather more depth on other cases and behaviors received from cpaelzer
16:57 <juliank> FWIW, re the "how to actually sync" question earlier, I wanted to see "I will check how to sync packages" over "upload .dsc", given no knowledge of syncpackage
16:58 <bdrung> +1 the answers this time are a step further than last time, but there is still room to grow (in case you want more upload rights)
16:58 <meetingology> +1 the answers this time are a step further than last time, but there is still room to grow (in case you want more upload rights) received from bdrung
16:58 <rbasak> #endvote
16:58 <meetingology> Voting ended on: Grant PPU for sos and sosreport to arif-ali
16:58 <meetingology> Votes for: 6, Votes against: 0, Abstentions: 0
16:58 <meetingology> Motion carried
16:58 <lvoytek> congrats!
16:58 <juliank> Congrats arif-ali
16:58 <utkarsh2102> woot! congratulations, arif-ali \o/
16:59 <rbasak> Would a new DMB member like to try driving the actual changes?
16:59 <arif-ali> thanks guys, appreciate all the advice that everyone has given me over the past 6 to 12 months
16:59 <rbasak> I'll need to do the PPU ACL though as that's TB only
16:59 <rbasak> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application is what needs following
16:59 <rbasak> I'll happily follow along with you.
16:59 <utkarsh2102> happy to do the announcement and such
16:59 <rbasak> Congratulations arif-ali
16:59 <utkarsh2102> am i considered new given i was added recently also? :P
17:00 <rbasak> Nah you're established now :)
17:00 <lvoytek> sure I can try out the process
17:00 <utkarsh2102> go ahead!!!
17:00 <rbasak> #action lvoytek tok announce arif-ali's successful application
17:00 * meetingology lvoytek tok announce arif-ali's successful application
17:01 <rbasak> #action lvoytek to arrange ACL changes for arif-ali
17:01 * meetingology lvoytek to arrange ACL changes for arif-ali
17:01 <rbasak> Thanks lvoytek!
17:01 <lvoytek> np
17:01 <rbasak> #topic AOB
17:02 <juliank> Has the TB actually announced the new appointments to the DMB yet?
17:02 <utkarsh2102> yes
17:02 <rbasak> As we're out of time, let's skip ahead to AOB, and defer the routine actions to the next meeting
17:02 <utkarsh2102> yes
17:02 <utkarsh2102> i want to propose a new time
17:02 <utkarsh2102> and a new format of meeting
17:02 <utkarsh2102> so it'll take a bit to convince others
17:02 <utkarsh2102> so let's do that next time
17:02 <jbicha> I had one mailing list item for AOB, or to mention for review later https://lists.ubuntu.com/archives/devel-permissions/2025-June/002842.html
17:02 <juliank> Perhaps send an email about that, so we can ponder about it
17:03 <utkarsh2102> jbicha
17:03 <utkarsh2102> jbicha: i'll get to it
17:03 <utkarsh2102> i've been planning on doing that
17:03 <jbicha> 👍
17:03 <utkarsh2102> but then didn't know if i were gonna get re-elected :P
17:03 <juliank> (my comment was re new meeting format)
17:03 <utkarsh2102> so wanted to wait it out
17:03 <utkarsh2102> juliank: yes, gotcha
17:03 <utkarsh2102> can do
17:04 <rbasak> jbicha: thanks. FWIW, it's supposed to be under "Outstanding mailing list requests to assign" in the agenda, when we have time
17:04 <juliank> Re announcement of appointments; I never saw an email, so what list am I missing?
17:04 <rbasak> juliank: u-d-a@
17:05 <juliank> Huh that is surprising, I'll go doubel check
17:05 <rbasak> https://lists.ubuntu.com/archives/ubuntu-devel-announce/2025-June/001376.html
17:05 <rbasak> #endmeeting