16:03 <rbasak> #startmeeting Developer Membership Board
16:03 <meetingology> Meeting started at 16:03:30 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:03 <meetingology> Available commands: action, commands, idea, info, link, nick
16:04 <rbasak> #topic Deferred Items from Last Meeting
16:04 <rbasak> tsimonq2 to briefly discuss confusion between the DMB and UMB on who should be reviewing a specific application, and their followup ping to the UMB.
16:04 <rbasak> tsimonq2 and rbasak to provide a summary of the Matrix-related discussion in the TB meeting as agreed there. Do we want to move meetings to Matrix?
16:04 <rbasak> tsimonq2 to double-check whether https://lists.ubuntu.com/archives/devel-permissions/2025-March/002810.html was the right decision with the wider board
16:05 <rbasak> tsimonq2: around?
16:05 <rbasak> I guess we'll need to carry those forward then.
16:06 <rbasak> #action tsimonq2 to briefly discuss confusion between the DMB and UMB on who should be reviewing a specific application, and their followup ping to the UMB.
16:06 * meetingology tsimonq2 to briefly discuss confusion between the DMB and UMB on who should be reviewing a specific application, and their followup ping to the UMB.
16:06 <rbasak> #action tsimonq2 and rbasak to provide a summary of the Matrix-related discussion in the TB meeting as agreed there. Do we want to move meetings to Matrix?
16:06 * meetingology tsimonq2 and rbasak to provide a summary of the Matrix-related discussion in the TB meeting as agreed there. Do we want to move meetings to Matrix?
16:06 <rbasak> #action tsimonq2 to double-check whether https://lists.ubuntu.com/archives/devel-permissions/2025-March/002810.html was the right decision with the wider board
16:06 * meetingology tsimonq2 to double-check whether https://lists.ubuntu.com/archives/devel-permissions/2025-March/002810.html was the right decision with the wider board
16:06 <rbasak> #topic Review of previous action items
16:06 <rbasak> We seem to have essentially the same topic twice?
16:06 * rbasak teward to resolve the wiki / Discourse process ambiguity (carried over)
16:06 * rbasak tsimonq2 to reach out to Agathe Porte (gagath) to determine if they are willing to do their application via Matrix meeting instead of IRC meeting. (presuming tsimonq2 will be present)
16:06 * rbasak tsimonq2 to announce Mate Kukri's application success and assign permissions.
16:07 <rbasak> teward sends his apologies
16:07 <rbasak> So I'll carry these over as well I guess
16:07 <rbasak> #action teward to resolve the wiki / Discourse process ambiguity (carried over)
16:07 * meetingology teward to resolve the wiki / Discourse process ambiguity (carried over)
16:07 <rbasak> #action tsimonq2 to reach out to Agathe Porte (gagath) to determine if they are willing to do their application via Matrix meeting instead of IRC meeting. (presuming tsimonq2 will be present)
16:07 * meetingology tsimonq2 to reach out to Agathe Porte (gagath) to determine if they are willing to do their application via Matrix meeting instead of IRC meeting. (presuming tsimonq2 will be present)
16:07 <rbasak> #action tsimonq2 to announce Mate Kukri's application success and assign permissions.
16:07 * meetingology tsimonq2 to announce Mate Kukri's application success and assign permissions.
16:07 <rbasak> #topic Application review:  rasdaemon PPU Application by Taihsiang Ho
16:07 <rbasak> tai271828: welcome
16:08 <tai271828> o/ hi! everyone!
16:08 <rbasak> tai271828: there seem to be many items missing from your application
16:08 <rbasak> tai271828: please could you explain what instructions you have followed to get to this stage, so we can address the relevant documentation?
16:08 <rbasak> tai271828: for example, https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda points out to email devel-permissions@ - what led you to missing that?
16:08 <tai271828> certainly, on my way. mostly ubuntu wiki pages. let me find them out
16:09 <tai271828> I firstly checked this page  https://wiki.ubuntu.com/Ubuntu/ForDebianDevelopers , the session "How can I get upload rights in Ubuntu for the packages I maintain in Debian?"
16:10 <tai271828> the page guided me to https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
16:11 <tai271828> the missing email is simply due to my careless read. I read the doc long time ago and summarized what I need to do. apparently I did not make a note of my action items properly
16:11 <rbasak> tai271828: OK. Do you consider yourself to meet the expectations set at https://wiki.ubuntu.com/UbuntuDevelopers#PerPackage currently?
16:12 <tai271828> let me re-read again
16:12 * tai271828 reading
16:12 <bdrung> you were not the only one missing the mailing list step. So I would have expected that the documentation could be improved.
16:13 <rbasak> bdrung: we have "improved" the wiki a number of times on this point. I'm not sure what more we can do, really. The note is right there next to the table to edit.
16:14 <bdrung> rbasak, maybe add that as comment to the application template?
16:14 <rbasak> bdrung: do you really think that would help?
16:15 <tai271828> @rbasak, I think these two items could be DMB's concerns: 1) "access grant does not permit sole-maintainership" 2) I do not have history to be sponsored for uploading packages to ubuntu (although I consider myself is familiar with process specific to ubuntu)
16:16 <rbasak> tai271828: where you do think you stand wrt. "need to show a history of effective collaboration with other developers in Ubuntu"?
16:19 <tai271828> @rbasak, I was ex-canonicaler and coworked with people around ubuntu (mainly kernels) other than core developers. I know where and who to reach out for help in the ubuntu eco system.
16:20 <tai271828> maybe some ubuntu kernel ML history?
16:20 <tai271828> or discourse posts?
16:20 <bdrung> The kernel package has its own special rules.
16:21 <tai271828> I meant, maybe let me collect some ML records and discourse posts from me in the past. do they sound justified to DMB?
16:21 <rbasak> tai271828: no, I think you need far more than that.
16:22 <rbasak> For example, you have zero endorsements or comments from other Ubuntu developers in your applicaation
16:22 <rbasak> And AFAICT you have zero sponsored uploads to Ubuntu.
16:23 <tai271828> @rbasak, I see. per zero sponsored uploads: yes you are right
16:23 <rbasak> Are you working for Canonical at the moment?
16:23 <tai271828> @rbasak, no. left a few months ago
16:24 <rbasak> OK. So, for rasdaemon PPU specifically, I suggest that you use the sponsorship queue for genuinely required Ubuntu-specific uploads
16:24 <rbasak> You can contact patch pilots using #devel:ubuntu.com on Matrix
16:24 <tai271828> @rbasak, that sounds! thanks for the tip!
16:25 <rbasak> If you do not need Ubuntu-specific uploads, then you don't really need upload permission to the package in Ubuntu.
16:26 <rbasak> If you do need Ubuntu-specific uploads, then you can start by getting sponsorship from patch pilots, and then once you have developed a track record of good work *in Ubuntu*, you can apply again, and we can look at what those sponsors say about your work, together with your upload history.
16:26 <tai271828> @rbasak, I came to apply for the upload permission due to requests from the ubuntu community, including canonical, and I personally interested in contributing to ubuntu after leaving canonical
16:26 <bdrung> rbasak, I added an "application announcement" paragraph to https://wiki.ubuntu.com/UbuntuDevelopment/DeveloperApplicationTemplate - let's see if that makes a difference
16:26 <tai271828> @rbasak, got it. thanks for the feedback!
16:27 <bdrung> tai271828, we have the sponsoring process for starting contributors.
16:27 <rbasak> I don't intend to call for a vote to consider this application - I don't think there would be any point. Any objections? Anything further to discuss on this application?
16:28 <tai271828> I do have a question on my application before you move forward, may I?
16:28 <bdrung> no vote needed. i fully agree with rbasak.
16:28 <rbasak> tai271828: sure - go ahead
16:32 <tai271828> when I read this page, I thought the PPU will be granted through the PPU application as I am the Debian maintainer of the package application https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess  Having the history of the upload history to ubuntu is justified to me. I am just thinking if I can make the instruction clearer.
16:32 <rbasak> "Debian Developers applying for Per-Package upload rights" -> AFAICT, you are a DM, not a DD?
16:32 <tai271828> and particularly this page https://wiki.ubuntu.com/Ubuntu/ForDebianDevelopers  "hey are granted direct upload permissions to the Ubuntu archive for that set of packages."
16:33 <rbasak> "To exercise this process, the DD should first be an existing Ubuntu developer, for example by applying for PPU as per the above process..."
16:33 <tai271828> @rbasak, yes DM
16:33 <rbasak> So you need to have PPU first.
16:34 <tai271828> yes, I want to emphasize, even thought you are DD, you still need to show ubuntu contribution history prior to PPU application
16:35 <bdrung> yes, because you need to show that you know the differences of Ubuntu and demonstrate that you can work with the other Ubuntu developers.
16:35 <rbasak> So you need to have PPU first, which has the same set of requirements as anyone else to get PPU, and those requirements are documented.
16:35 <tai271828> when the package is maintained by you in Debian
16:36 <tai271828> do get me wrong. showing the history and proof that we know the differences is reasonable. I am not questioning the rules. the rule is justified
16:36 <rbasak> I am reminded of https://devguide.python.org/documentation/style-guide/#audience: "Be careful accepting requests for documentation changes from the rare but vocal category of reader who is looking for vindication for one of their programming errors..."
16:36 <rbasak> I am happy to consider documentation improvements, and I don't think our documentation is perfect.
16:36 <tai271828> I am sharing an user feedback to the wiki description after reading the wiki page.
16:37 <rbasak> But I don't think any improvement to our documentation will have prevented this misunderstanding. Our expectations are, IMHO, clearly documented in this case.
16:37 <rbasak> So I appreciate the feedback, but my personal opinion is that there is no improvement to be made here.
16:37 <tai271828> got it. thank you for your feedback and time. I appreciate them.
16:38 <rbasak> However, bdrung might think differently and I have no objection if others (you, anyone else) would like to edit the wiki.
16:38 <tai271828> no worries. I don't expect any improvement will be made right now. just try to exchange opinions , more like brainstorming
16:38 <rbasak> Sure.
16:39 <rbasak> Thank you for working on rasdaemon in both Debian and Ubuntu! I hope you do continue to look after this packages for us.
16:39 <tai271828> will do. I appreciate your time and feedback!
16:39 <rbasak> #topic Outstanding mailing list requests to assign
16:40 <rbasak> I see a private message from Brett which I think should probably be public? I can ask him to resend.
16:41 <rbasak> I don't see any other ML threads that require action.
16:41 <rbasak> #topic Open TB bugs
16:41 <rbasak> #info No open TB bugs
16:41 <rbasak> #topic AOB
16:41 <rbasak> AOB?
16:41 <bdrung> yes
16:43 <bdrung> https://wiki.ubuntu.com/DeveloperMembershipBoard says "You can reach the board by email" pointing to developer-membership-board@lists.ubuntu.com. Should we extend that saying that this one is a private one for private matters and suggest using devel-permissions@ for public matters?
16:43 <rbasak> That's a good point, and I agree
16:46 <bdrung> suggestions for reformulating that?
16:47 <rbasak> How about just s/developer-membership-board/devel-permissions/, and add a note saying that the mailing list is public; if exceptionally private communication is required, such as discussing the performance of an individual, then use the private list at ...?
16:47 <rbasak> How about just s/developer-membership-board/devel-permissions/, and add a note saying that the mailing list is public and our general process and policy discussions are public; if exceptionally private communication is required, such as discussing the performance of an individual, then use the private list at ...?
16:49 <bdrung> yes, sounds good
16:50 <bdrung> with links named "here" replaced by the actual names
16:50 <rbasak> OK. Thanks!
16:50 <rbasak> AOAOB?
16:52 <rbasak> #endmeeting