19:03 <rbasak> #startmeeting Technical Board
19:03 <meetingology> Meeting started at 19:03:51 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <teward> rbasak: hair-on-fire @ dayjob
19:04 <rbasak> #topic Action review
19:04 <rbasak> teward: as always? :)
19:04 <rbasak> all TB members (teward, mwhudson, rbasak, seb128) to read up
19:04 <rbasak> on Open Source AI Definition and consideration of proposal to endorse the definition
19:04 <teward> worse - domain controllers on fire
19:04 <rbasak> I already did that and replied to the thread
19:04 <mwhudson> haven't done this, sorry :(
19:05 <teward> yeah i've gotta look back on that as well
19:05 <rbasak> #action Remaining TB members (teward, mwhudson, seb128) to read up on Open Source AI Definition and consideration of proposal to endorse the definition.
19:05 * meetingology Remaining TB members (teward, mwhudson, seb128) to read up on Open Source AI Definition and consideration of proposal to endorse the definition.
19:05 <seb128> I didn't manage to do that yet, sorry :/
19:05 <rbasak> mwhudson to propose course of action around techboard membership of buildd admins
19:05 <mwhudson> yeah haven't done that yet either i'm afraid
19:06 <rbasak> #action mwhudson to propose course of action around techboard membership of buildd admins
19:06 * meetingology mwhudson to propose course of action around techboard membership of buildd admins
19:06 <rbasak> rbasak to follow up on https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html with the release team.
19:06 <rbasak> We can expect a reply by 18 April: https://matrix.to/#/!HIqUfDuodVisBWdrTr:ubuntu.com/$zxOAAo7_zaQXSKRZ09TgChQa44_oXOLNrxCFg2_5BxA?via=ubuntu.com&via=matrix.org&via=matrix.debian.social so I'll carry that over
19:07 <rbasak> #action rbasak to follow up on https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html with the release team.
19:07 * meetingology rbasak to follow up on https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html with the release team.
19:07 <rbasak> seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process
19:08 <seb128> so, I did run your script over the coredev set at Canonical and did a merge proposal with all the teams that got listed by the script which got merged earlier this week
19:08 <rbasak> Nice. Thanks!
19:08 <seb128> np!
19:08 <rbasak> Anything else needed with that then?
19:08 <seb128> I think that should perhaps be done on regular basis
19:09 <seb128> but nothing for now at least
19:09 <seb128> unsure how to track that though
19:09 <rbasak> Yeah we have no mechanism for recurring tasks :-/
19:09 <rbasak> Probably not worth taking that on right now, given the relatively low importance of this?
19:09 <seb128> I would drop it from the TB side yes
19:10 <rbasak> ack
19:10 <rbasak> Next: seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:10 <seb128> I will try to get it as part of a JIRA cycle-template on the Canonical side
19:10 <rbasak> OK, so carry over?
19:10 <seb128> that was about the previous item
19:10 <seb128> this one yes carry over
19:10 <rbasak> #action seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:10 * meetingology seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
19:10 <seb128> but we are making progress
19:10 <rbasak> Ah, OK, thanks.
19:11 <seb128> AA is working on documentation, we will get that published at some point next cycle
19:11 <seb128> (thanks Christian)
19:11 <rbasak> teward to report to the CC what we don't desire an election right now, and will reconsider in six months
19:11 <teward> thats done
19:11 <rbasak> Thanks!
19:11 <rbasak> teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:12 <teward> carry that one over
19:12 <rbasak> #action teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:12 * meetingology teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
19:12 <rbasak> teward to write up a proposal for how the move away from the wiki will work
19:12 <teward> also carry that one over, I've been a little busy with other stuff at the moment to address that one
19:13 <rbasak> #action teward to write up a proposal for how the move away from the wiki will work
19:13 * meetingology teward to write up a proposal for how the move away from the wiki will work
19:13 <rbasak> tsimonq2 to study "look into scripting for packages in flavor-specific overlays" from https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24 and suggest to the TB what needs doing there
19:13 <rbasak> tsimonq2: around?
19:13 <tsimonq2> o/
19:13 <tsimonq2> I'm still typing out my prepared statement, I suppose I can send the first part and keep typing in irssi...
19:14 <tsimonq2> As I mentioned in the previous meeting, I had the opportunity to take an initial look at this and talk to flavors. The conclusion I'd like to draw here (not officially quorate, but *de facto*) is that zero of the ten flavors have an extremely strong grasp of their seed tooling and management. Many flavor representatives are able to tell me bits and pieces, but this is something that I think we
19:14 <tsimonq2> could all generally use some professional development on. How do they work? How does seed inheritance work? How does livecd-rootfs actually pick up the seeds, and can we write some "break glass in case of emergency" documentation for knowing where to find some of that stuff in the code?
19:14 <tsimonq2> I have some nascent tooling that I intended to get finished up before this meeting, but it's not quite there yet. Release-critical bugs and other paperwork/$dayjob items took priority on that front over the last few weeks.
19:14 <tsimonq2> Essentially, I want to make this easy as "go check a report, be able to mark something as part of your set or not, and have a clean, robust workflow."
19:14 <rbasak> The existing documentation is here: https://wiki.ubuntu.com/SeedManagement
19:14 <tsimonq2> Here's what I'd propose... keep the delegation to me, but expect results from me next meeting.
19:15 <rbasak> OK, thanks!
19:15 <tsimonq2> rbasak: I'll add "make that existing page more visible" as part of this. :)
19:15 <rbasak> So I'll carry the action item over as-is for now.
19:15 <tsimonq2> Sounds good!
19:15 <rbasak> #action tsimonq2 to study "look into scripting for packages in flavor-specific overlays" from https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24 and suggest to the TB what needs doing there
19:15 * meetingology tsimonq2 to study "look into scripting for packages in flavor-specific overlays" from https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24 and suggest to the TB what needs doing there
19:16 <rbasak> #topic Should we endorse the Open Source AI Definition?
19:16 <rbasak> Is there anything to discuss on this?
19:16 <tsimonq2> o/ yeah, actually.
19:16 <mwhudson> tsimonq2: i do have some (internal, but for no good reason) documentation on seeds, i'll get it to you somehow
19:17 <teward> given that we still have to review it i would say 'not yet' rbasak but that's only my opinion
19:17 <tsimonq2> AI definition> This is something I personally have deep interest in and would like to provide my (long) opinion on the Technical Board to.
19:17 <mwhudson> i agree with teward
19:17 <tsimonq2> Is there a good place to put my notes for your consideration?
19:17 <rbasak> #info Deferred until TB members' homework is done
19:17 <seb128> +1
19:17 <tsimonq2> mwhudson: I look forward to making this story better for everyone, thanks in advance for that :)
19:17 <mwhudson> (btw i still don't think my subscription to the techboard mailing list has been approved...)
19:18 <rbasak> tsimonq2: could you reply to the ML thread?
19:18 <rbasak> mwhudson: it's a regular public list - I don't think there's anything needed apart from your own confirmation
19:18 <tsimonq2> rbasak: Sure, although the specific point I'm unsure on is, Merlijn indicated his notes should be non-public, and I'd like to rigourously use those.
19:18 <teward> mwhudson: directly mesage me with the email account you want registered and I'll just manually subscribe you by hand
19:19 <teward> if you still have issues
19:19 <mwhudson> oh grr the confirmation thingies are in spam. sigh.
19:19 <rbasak> tsimonq2: in that case, https://launchpad.net/~techboard/+contactuser maybe? Or use TB members' individual addresses. We don't have any other private contact point, I don't think.
19:19 <tsimonq2> rbasak: I'm interested in bringing up that specific point in AOB. ;)
19:19 <tsimonq2> But, thanks. :)
19:20 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:20 <rbasak> I don't see anything outstanding
19:20 <mwhudson> agreed
19:20 <rbasak> #info No outstanding ML threads not already handled elsewhere
19:20 <rbasak> #topic Check up on community bugs and techboard bugs (standing item)
19:21 <rbasak> The only TB bug is the one on DMB inactivity causing stalls. I think the more general case is still with the CC?
19:21 <rbasak> #info No outstanding bugs not already handled elsewhere
19:22 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:22 <teward> rbasak: which bug is that again?
19:22 <teward> for my awareness
19:22 <mwhudson> https://bugs.launchpad.net/techboard/+bug/2015921
19:22 <teward> thank you mwhudson
19:22 <rbasak> #info The next chair will be seb128 with teward as backup
19:22 <rbasak> #topic AOB
19:22 <seb128> ack
19:23 <teward> ack
19:23 <seb128> I've a question for teward
19:23 <teward> seb128: 42!
19:23 <seb128> teward, you pinged on matrix the archive admin team
19:23 <seb128> was it about the carry over item I have about onboarding/better documentation?
19:23 <seb128> or was it something different that I didn't understand?
19:24 <teward> seb128: the last ping to the AA team was for approving an item i wanted synced for Plucky unrelated to TB.  The ping before was for the carried over item
19:24 <seb128> ok, thanks for confirming. Feel free to ping me directly about that one if you have any question
19:25 <teward> sounds good
19:25 <seb128> we are working on resolving the situation, it's just going to take a bit longer
19:25 <seb128> --
19:26 <tsimonq2> In an entirely hypothetical, made-up scenario, let's say someone has a strong disagreement with, e.g. one of the core teams. Archive Administrators, Release Team, something like that. It's something that falls within the Technical Board's jurisdiction, but it's a sensitive or private topic. What would be the Technical Board's official recommendation or set of best practices be when intending to
19:26 <tsimonq2> contact you privately? Would this potentially be privately via a specific email? A private Matrix group chat?
19:26 <tsimonq2> Again, I'm not bringing something up specific in here. I'd just like to know all of my options ahead of time in case one particular thing I'm working on goes horribly wrong or in bad faith. I believe this falls under "being considerate when making bold decisions" under the Code of Conduct, simply as a point of reference for the "why" I'm asking.
19:27 <rbasak> The first thing to do - which I don't think is done often enough - is to exhaust respectful discussion with that team, to the point where you all agree that you are at an impasse and what exactly that impasse is.
19:28 <rbasak> If that needs to be done privately, then communicate in some appropriate way subject to what the team prefers
19:28 <rbasak> If you've agreed you're at an impasse (or if the team is not being constructive towards achieving agreement on at least that), then TB escalation would be the next step.
19:29 <rbasak> If this needs to be done privately, then communicate in some appropriate way subject to what the team prefers
19:29 <rbasak> For the TB, private email should work, and if necessary the TB generally all have PGP keys you can use.
19:30 <rbasak> https://launchpad.net/~techboard/+contactuser is available as a fallback, but it's difficult to continue a thread from there IIRC.
19:30 <seb128> yes, you can't reply to those emails afaik
19:30 <mwhudson> i think it basically sends a separate mail to each member
19:30 <seb128> I mean it will reach the sender but not the rest of the team
19:30 <tsimonq2> I precisely agree with what you're saying, and while it's not something I'm personally perfect on, I truly hope I've become much better over time. I certainly appreciate the thorough clarity though, for people generally curious (I've heard similar questions over my time in Ubuntu.)
19:31 <rbasak> We have Matrix now, too, as well as Discourse messages
19:31 <rbasak> Although it's perhaps slightly more painful to identify TB members' addresses/aliases on those platforms
19:31 <seb128> discourse messages? that's something I've not experienced yet :)
19:31 <tsimonq2> (I also have one other AOB point, much more technical, when you all are satisfied.)
19:31 <rbasak> Hamburger menu -> Messages -> +
19:32 <seb128> thx
19:32 <mwhudson> yeah i would put discourse messages at the bottom of the list after email (possibly signed) and matrix
19:32 <Eickmeyer> If I may (Discourse hat on): Discourse groups are a thing where one can message a whole group of people, so if the teams wanted to set-up something like that, they can contact moderators or staff.
19:33 <rbasak> Oh, one more thing. When you _do_ escalate to the TB, be sure to summarise what discussions you've already had with the responsible team, or else that's the first thing you're going to get asked.
19:33 <rbasak> Thanks Eickmeyer!
19:33 <Eickmeyer> :)
19:33 <rbasak> tsimonq2: I think we're done. Next item?
19:34 <tsimonq2> Sounds good :) thanks, one sec
19:34 <mwhudson> (i think discourse as a way to publically communicate with the various hatted groups is a decent idea i want to explore, but not today)
19:34 <Eickmeyer> mwhudson: And privately, too!
19:35 <tsimonq2> For my last AOB point this time around, I've been somewhat closely following the discussion around CMake 4.0. I have the exact notes from the Fedora Developer who submitted the Change Proposal there, including affected packages. We're talking at least several thousand packages that will need a spot-check to ensure they're compatible, and it affects every single package in the Qt/KDE stack.
19:36 <tsimonq2> I'd like the Technical Board to at least keep this on the back of the radar as something to be aware of, even though I'm primarily going to be working with the Release Team on it. If you have any questions or if *anyone*, TB member or not, wants the start to my notes, just ask. I'd really appreciate the help.
19:36 <tsimonq2> I'm not 100% sure yet, but I get the gut feeling we're going to try to do this ahead of Debian, one way or another, given Trixie freezes... at the very least, this is awareness.
19:36 <tsimonq2> That's all :)
19:37 <rbasak> Is there an ML thread or Discourse thread on this?
19:37 <seb128> thanks the heads up. My personal reaction to that (I don't think it's a TB topic) is "do we really need to go ahead of Debian there?"
19:38 <rbasak> This is the sort of thing that I don't think is a TB topic unless there's difficulty in achieving consensus amongst Ubuntu developers.
19:38 <mwhudson> i agree that i don't really think this is a TB topic but also i'm not sure where else would be good to raise it.
19:38 <seb128> -devel?
19:38 <rbasak> ubuntu-devel@ please
19:38 <seb128> or -release
19:38 <mwhudson> well yes
19:38 <rbasak> Right
19:38 <mwhudson> but i guess the conversation will stall there :-) should still try
19:39 <rbasak> It might well stall, but then you get to achieve consensus by yourself if nobody else wants to drive :-)
19:39 <seb128> I would push back on the idea of going ahead of Debian unless it creates real problems
19:40 <tsimonq2> seb128: What I can see happening, and again this is all speculative at this point, is someone will "absolutely need" a new shiny feature in CMake 4.0, and they'll introduce it before Feature Freeze either next cycle or the one after.
19:40 <tsimonq2> I totally agree it should be Debian-first, but also, being on Debian Qt/KDE, this is something I need to have my eyes on anyway. Why not give Ubuntu details about it, allowing us to make a really great, informed decision, while also helping my Debian friends? :)
19:41 <seb128> :-)
19:41 <tsimonq2> I can do Discourse or I can do mailing list. I have no preference.
19:41 <rbasak> I'll leave it to you to decide :)
19:41 <RikMills> KDE have only just agreed to raise minimu form 3.16 to 3.22
19:41 <RikMills> *minimum from
19:42 <rbasak> Can we defer discussion for that future thread please?
19:42 <tsimonq2> I'll err on the side of Discourse for now, just so I can do Markdown formatting. :P
19:42 <rbasak> OK. Any other AOB?
19:42 <seb128> not from me
19:42 <mwhudson> nor me
19:42 <rbasak> #endmeeting