19:01 <teward> #startmeeting Ubuntu DMB Meeting - 19:00 UTC, 2025-03-17
19:01 <meetingology> Meeting started at 19:01:12 UTC.  The chair is teward.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:01 <meetingology> Available commands: action, commands, idea, info, link, nick
19:01 <teward> Greetings everyone, welcome to the Ubuntu Developer Membership Board meeting for March 17, 2025.
19:02 <teward> right now there's three of us here, with Simon maybe showing up
19:02 <teward> let me quickly run through things then I'll get to the application
19:02 <teward> #topic tsimonq2 to briefly discuss confusion between the DMB and UMB on who should be reviewing a specific application, and my followup ping to the UMB.
19:02 <teward> they're not here so i'll defer it
19:02 <teward> #topic tsimonq2 and rbasak to provide a summary of the Matrix-related discussion in the TB meeting as agreed there. Do we want to move meetings to Matrix?
19:03 <teward> Simon may not be here, but you are rbasak, do you want to discuss this or defer it since Simon's not here?  (We could move this to mailing list discussions)
19:03 <rbasak> Simon ported meetingology to Matrix
19:03 <rbasak> That was the main blocker for moving the use case for this channel over, I think?
19:04 <teward> and just an FYI the #ubuntu-devel channel for IRC has moved over to Matrix, so it makes sense the DMB meetings might move over to matrix.  I'm not against it, bdrung, thoughts?
19:04 <rbasak> I suggested that since Simon is on the DMB, it might be useful for the DMB to experiment with the move, and see how it goes - if a suitable applicant is also willing
19:04 <rbasak> tsimonq2 I mean, not schopin
19:05 <bdrung> Moving the meeting to Matrix makes sense to me.
19:05 <teward> right i mieant tsimonq2 in my statement too, not schopin who is not here and apologized ahead of time.
19:05 <teward> rbasak: bdrung: I think it's a good idea to test-trial it, we'll just have to talk to one of the upcoming people  who have an application and see if they're willing to be the Guinea Pig there
19:05 <rbasak> The applicant at the next meeting is gagath (not here right now)
19:06 <teward> we can reach out independent of IRC to see if they're willing / able
19:06 <rbasak> So if she and tsimonq2 can both make it, maybe we can try that on Matrix?
19:06 <bdrung> teward, I agree
19:06 <rbasak> Right - only with gagath's consent
19:06 <rbasak> We can probably leave that as an action item for tsimonq2 to arrange
19:06 <teward> i agree
19:06 <rbasak> If we're all happy with it
19:07 <bdrung> +1
19:07 <teward> #action tsimonq2 to reach out to Agathe Porte (gagath) to determine if they are willing to do their application via Matrix meeting instead of IRC meeting. (presuming tsimonq2 will be present)
19:07 * meetingology tsimonq2 to reach out to Agathe Porte (gagath) to determine if they are willing to do their application via Matrix meeting instead of IRC meeting. (presuming tsimonq2 will be present)
19:07 <teward> that one's easy.
19:07 <teward> #topic Review of previous action items
19:07 <teward> #subtopic teward to resolve the wiki / Discourse process ambiguity (carried over)
19:07 <teward> yeah i'm carrying that over almost perpetually because we also have to figure where do we want all this to officially live, wiki or Discourse.  That's its own ML discussion
19:08 <teward> #action teward to resolve the wiki / Discourse process ambiguity (carried over)
19:08 * meetingology teward to resolve the wiki / Discourse process ambiguity (carried over)
19:08 <teward> #topic Application Review
19:08 <teward> #subtopic Ubuntu Core Developer by Mate Kukri
19:08 <teward> #link https://wiki.ubuntu.com/mkukri/CoreDevApplication
19:08 <teward> mkukri: are you around?
19:08 <mkukri> yes
19:09 <teward> Would you mind introducing yourself here, while we let those who haven't reviewed your application yet review it, and come up with questions for you?
19:10 <mkukri> sure. i work for canonical, on the foundations team, my primary duties are maintaining bootloader packages, related tests, security updates, etc
19:10 <mkukri> i also do other miscellaneous ubuntu development somtimes
19:10 <rbasak> mkukri: o/ welcome!
19:10 <rbasak> mkukri: you said "some historical (design) mistakes are hard to fix". I agree. Could expand on what you would change if it were easy?
19:12 <mkukri> well, most recent example is the image build tooling i had to make some changes to, i dont really like either the debian-cd, or cdimage codebases
19:12 <rbasak> OK
19:13 <tsimonq2> Hello, sorry I'm late.
19:13 <mkukri> also a lot of packaging scripts/Makefiles, primarily thinking of grub2 here are really awfully ugly, but making it nice is too risky perhaps
19:13 <mkukri> also i sometimes wish the process of changing things in the archive was more akin to sending pull requests in other projects
19:16 <bdrung> liking the debian-cd / cdimage codebase would be an indicator for voting against upload right :D </joke>
19:17 <bdrung> mkukri, you wrote "Be more proactive at getting my SRUs through" - what would you do to get the SRUs through?
19:18 <mkukri> primarily i think i need to bug the SRU team more often :)
19:18 <mkukri> but that was written a while ago, i think some more recent things maybe went betteer, although there are probably still some pending old grub srus
19:18 <tsimonq2> mkukri: I have a hypothetical scenario for you. Let's say, for some odd reason (and I'd hope this never happens) a GRUB bug pops up exactly 10 days before the release date. You have identified the problem and have a working, tested patch ready. What are your next steps for ensuring it is included? Who would you ping, where, and what would you say?
19:18 <bdrung> mkukri, looking at the current SRUs in progress there is also things you could do.
19:20 <mkukri> tsimonq2: assuming the patch is simple enough and confidence is high. release team, and archive admin with a strong written justification. otherwise 10 days before release uploading a revert might be better instead
19:20 <tsimonq2> mkukri: Assume a revert is out of the question, it's been in there for a while.
19:21 <mkukri> i mean like revert by bumping a version and doing the horrible really thingy
19:21 <mkukri> but that still needs the same freeze exception i guess
19:21 <tsimonq2> Where would you communicate with the RT and AAs on this?
19:21 <tsimonq2> (One more assumption I'll add, this is a completely public bug.)
19:22 <mkukri> LP bug first, then ubuntu-release IRC channel, and mailing list, (and i guess matrix these days)
19:22 <rbasak> Where would you communicate with the RT and AAs on this> and what exactly would you be asking them to do, using their privilege/authority?
19:23 <mkukri> i guess i need to get the package out of the unapproved queue first
19:23 <mkukri> then get it out of proposed after the tests are good
19:23 <mkukri> although to be 100% honest im not sure how (and if?) proposed migrations are frozen
19:24 <rbasak> OK, and which team is responsible for making that decision?
19:26 <mkukri> i assume archive admins have ACLs, but the release team has to agree?
19:26 <mkukri> but also im a bit uncertain and would double check :)
19:27 <rbasak> OK let me try another angle.
19:27 <rbasak> tsimonq2 asked who you would ask and what you would say
19:27 <rbasak> You answered release team *and* archive admins
19:27 <rbasak> What are you saying to each, or are you unsure?
19:28 <rbasak> I'm rephrasing because I don't expect you to know what *they* have to do, but I do want to see that you understand what *your* interactions are expected to be with them.
19:28 <mkukri> release teams signs off on the FFe, then based on that archive admin approves the upload
19:28 <mkukri> but i dont know if final freeze is different
19:29 <rbasak> Where is the FFe process documented?
19:29 <mkukri> https://wiki.ubuntu.com/FreezeExceptionProcess
19:29 <rbasak> OK. I'm happy to move on.
19:29 <tsimonq2> I'm satisfied.
19:29 <bdrung> mkukri, what would you do in case you are uncertain?
19:30 <mkukri> first read the wiki, if still uncertain, ask on IRC/Matrix and/or ask colleagues with more experience
19:30 <tsimonq2> Do you upload if you're unsure? :P
19:30 <mkukri> no
19:30 <tsimonq2> right answer
19:31 <mkukri> certainly not grub
19:31 <rbasak> What's your approach to peer review?
19:31 <tsimonq2> ^^^ I had drafted a longer form question basically saying that
19:31 <rbasak> Do you get peer reviews for every upload and expect to continue, or anything less than that?
19:31 <tsimonq2> (re: peer reviews)
19:32 <mkukri> for grub2, and most complex and/or core packages, i would, unless i need to do an emergency critical regression fix where all qualified reviewers are out of office
19:32 <mkukri> but i might upload high confidence universe merges or proposed migration fixes if sufficiently trivial
19:33 <rbasak> OK
19:33 <rbasak> I'm ready to move to a different topic if we're done with peer review questions?
19:33 <tsimonq2> To add on top of that, once rbasak is satisfied; if you were to be granted these permissions, you will also have access to sponsor uploads for others. Could you describe what steps you would take before providing an ACK or NACK on the upload? A summary is okay.
19:33 <bdrung> mkukri, back to the SRU topic: What would be needed to push the SRU https://bugs.launchpad.net/ubuntu/+source/pillow/+bug/2084457 forward?
19:35 <mkukri> tsimonq2: review the diff first to see if the changes make sense, then look at provided build/test log or build it myself to smoke test it
19:35 <mkukri> ACK if it builds correctly, and the only gripes are like trivial issues that i can either fix in place or that dont matter, NACK otherwise
19:37 <tsimonq2> Thanks; that suffices for what I asked for (a summary).
19:37 <mkukri> bdrung: better regression testing of pillows functionality on affected all affected architectures which i didnt have, and maybe reupload so thaty the only flag change is just frame-pointer
19:37 <mkukri> although im not personally sure if that SRU is entirely justified unless someone has a usecase for profiling pillow specifically in noble
19:39 <bdrung> mkukri, do you know where to look if a SRU is blocked by lacking verification (like this example) or if it could released by the SRU team?
19:39 <mkukri> there is an sru dashboard i have a bookmark for somewhere
19:39 <tsimonq2> mkukri: After bdrung is good, one last question before I'm personally ready to vote, and it should be pretty quick. (Boolean or text answer is okay.) If granted Core Developer, do you have a "first upload" planned?
19:40 <bdrung> mkukri, this one? https://ubuntu-archive-team.ubuntu.com/pending-sru.html
19:40 <bdrung> i am done with my questions about SRUs
19:40 <mkukri> bdrung: yes, just found the like as well
19:41 <mkukri> tsimonq2: there is a grub security update juliank reviewed that i need to get signed for secure boot then upload, so i suppose that
19:42 <mkukri> s/like/link
19:42 <juliank> Did you pick the NTFS fix now?
19:42 <mkukri> yes
19:42 <juliank> Cooo
19:42 <mkukri> i wanted to get another ack from you of course
19:42 <mkukri> bins are in the ppa tho
19:43 <rbasak> mkukri: if you had to verify that a package that needs to be binary pocket copied over to the main was built correctly, what exactly would you need to check,if you weren't familiar with the PPA being used?
19:43 <bdrung> mkukri, If there is a new upstream version in Debian would you sync it (as of today)?
19:44 <mkukri> today, no, feature freeze is a thing
19:45 * juliank notices now that this is the dmb meeting
19:45 <tsimonq2> juliank: Welcome, hello ;)
19:45 <teward> juliank: yes i was gonna nag you and mkukri about that that the process outside of DMB has no bearing on DMB ;)
19:45 <tsimonq2> mkukri: Thanks.
19:45 <teward> but i chose not to :P
19:45 <tsimonq2> teward: Blame me, I asked about it. :P
19:45 <teward> tsimonq2: everything is already your fault so :p
19:45 <tsimonq2> :D
19:46 <teward> any other questions for mkukri?
19:46 <rbasak> ^
19:46 <rbasak> I had one above
19:46 <bdrung> speaking of blaming Simon, should I elaborate syncing new upstream releases using edk2 as example?
19:46 <teward> mkukri: if you had to verify that a package that needs to be binary pocket copied over to the main was built correctly, what exactly would you need to check,if you weren't familiar with the PPA being used?  --rbasak
19:47 <bdrung> I ran out of useful questions.
19:47 <mkukri> rbasak: only thing i see binary copied like that is grub2, where the packages are uploaded with the correct version numbers, and the the ppa has the correct pockets enabled.
19:47 <mkukri> other things, im not sure why exactly i would binary copy anything, but beyond reviewing the sources and checking the above 2, i would need to check first
19:47 <tsimonq2> (There's reasons to binary copy things, but you have to be surgical and precise about it.)
19:48 <rbasak> OK let's focus on grub2
19:48 <rbasak> What else is a hard requirement for those builds?
19:48 <rbasak> I can think of two, although I will happily stand correct if I'm wrong.
19:49 <rbasak> I think this is important though, since you will be doing these unsupervised
19:49 <mkukri> grub bins are built in ppa with only the security pockets enabled due to them sometimes being copied to -security
19:49 <mkukri> also sometimes we cross series copy binary packages, but only freestanding ones that dont have host library deps
19:49 <rbasak> Available pockets is important, yes
19:49 <rbasak> Anything else?
19:50 <mkukri> i guess the enabled architectures matter too
19:50 <rbasak> That's another :)
19:50 <rbasak> Any more?
19:51 <mkukri> i guess you can change available components (like main, restricted), and add ppas as dependencies to ppa, but ive not seen the latter used
19:52 <teward> > FYI we have 8 minutes left in the scheduled time of the meeting.
19:52 <rbasak> I think you're close enough. You need the build to not use build dependencies that won't make it to the main archive - otherwise it could be unreproducible to our users. Build dependencies can come from the same PPA as well as other configured ones
19:53 <teward> any other questions for mkukri?
19:53 <bdrung> not from my side
19:53 <rbasak> mkukri: what happens after you upload to the development release? Are there any other steps you need to take?
19:53 <mkukri> rbasak: ah yes that makes a lot of sense, i certainly didnt think of that here, but the archive should of course be buildable
19:54 <tsimonq2> To add a fun fact, the only other place I know of binary copies being used is with Qt transitions, where bootstrapping is intense and can take up to several days.
19:54 * juliank is sad to not get complex questions about signing keys and how to ensure the right one is used
19:54 <mkukri> rbasak: make sure the autopkgtests past and my uplaod migrates
19:54 <rbasak> mkukri: if it doesn't, what are your next steps?
19:54 <teward> juliank: do you want to raise such a question here for us to consider?
19:54 <teward> (we're now down to 5 minutes left in scheduled meeting time)I
19:54 <juliank> Nah it's late
19:55 <juliank> And I don't think even the archive admins know
19:55 <mkukri> debug the tests, sometimes a retry is enough (or retry migration-reference/0), other times it needs a re-upload with changes to fix the tests (or a regression the tests caught)
19:55 <rbasak> OK
19:55 <rbasak> No more questions from me - I appreciate we're tight on time.
19:55 <teward> any more questions tsimonq2 ?
19:55 <tsimonq2> nope - all good
19:55 <teward> i have none because usually rbasak asks all the same questinos I have xD
19:56 <teward> #vote Core Dev Rights for Mate Kukri (mkukri)
19:56 <meetingology> Please vote on: Core Dev Rights for Mate Kukri (mkukri)
19:56 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:56 <tsimonq2> +1
19:56 <meetingology> +1 received from tsimonq2
19:56 <bdrung> I let rbasak ask the question as well since he is better at phrasing them
19:56 <teward> #voters tsimonq2 bdrung rbasak teward
19:56 <meetingology> Current voters: bdrung, rbasak, teward, tsimonq2
19:56 <bdrung> +1
19:56 <meetingology> +1 received from bdrung
19:56 <teward> +1
19:56 <meetingology> +1 received from teward
19:57 <rbasak> (writing)
19:59 <rbasak> +1 but weakly - I didn't have time to finish asking my usual questions, but your track record looks good and combined with your endorsement covers the usual areas I'd like to see. It's difficult to objectively identify but I sense that you're missing some of the detail, but I think you've crossed my bar for understanding what you don't know, and will ask questions as appropriate. Please keep doing
19:59 <meetingology> +1 but weakly - I didn't have time to finish asking my usual questions, but your track record looks good and combined with your endorsement covers the usual areas I'd like to see. It's difficult to objectively identify but I sense that you're missing some of the detail, but I think you've crossed my bar for understanding what you don't know, and will ask questions as appropriate. Please keep doing received from rbasak
19:59 <rbasak> that, together with peer review, etc.
20:00 <teward> #endvote
20:00 <meetingology> Voting ended on: Core Dev Rights for Mate Kukri (mkukri)
20:00 * tsimonq2 elbows teward 
20:00 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
20:00 <meetingology> Motion carried
20:00 <rbasak> An example in that is understanding the distinction between the release team and archive admins, and not unnecessarily pinging the wrong team.
20:00 <teward> tsimonq2: because it's 4PM and i'm being nagged by DAYJOB for a meeting, you gotta wait a few seconds :P
20:00 <tsimonq2> mkukri: Congratulations!
20:01 <teward> mkukri: congratulations on receiving Core Dev rights!
20:01 <bdrung> congratulations!
20:01 <tsimonq2> 🎉🎉
20:01 <teward> who wants to take the action items of replying on the list and assigning the perms?
20:01 <tsimonq2> I volunteer
20:01 <mkukri> thanks folks
20:01 <bdrung> I had a similar feeling than rbasak on the final freeze questions.
20:01 <teward> #action tsimonq2 to announce application success and assign permissions.
20:01 * meetingology tsimonq2 to announce application success and assign permissions.
20:01 <teward> #topic Outstanding mailing list requests to assign
20:02 <tsimonq2> mkukri: You've been added to the team; I hear permissions go into effect instantly.
20:02 <teward> I don't see any, but that's due to the insane spam flood, though there is the items on pitti's request and a contributing developer application we were handling async on the ML
20:02 <teward> #topic Open TB bugs
20:02 <teward> Don't see any of those either
20:02 <teward> #topic Select a chair for the next meeting
20:02 <tsimonq2> teward, bdrung: btw, I'd encourage one (or both of you) to follow up on pitti's app and the two (sorry) threads on it. It's currently +3
20:03 <teward> next in the list is utkarsh2102, with it circling back to bdrung as backup
20:03 <bdrung> I'll respond to pitti's application after the meeting
20:03 <teward> #info next in the list is utkarsh2102, with it circling back to bdrung as backup
20:03 <tsimonq2> "We have a list?"
20:03 <teward> #topic AOB
20:03 <teward> anything else?
20:04 <teward> i know we're over time
20:04 <teward> (and my bosses are nagging me for attention)
20:04 <bdrung> half of the DMB members will end in two month
20:04 <tsimonq2> yes I have a few things but we're over time
20:04 <tsimonq2> punt to next meeting on my stuff
20:04 <bdrung> Do we need to start the voting process?
20:04 <teward> check.  add them as agenda items tsimonq2
20:04 <teward> bdrung: probably, but we can discuss that on the ML i believe
20:04 <teward> since we're over on time here
20:04 <tsimonq2> Oh, and I'm +0 on both DKMS applications. I abstain from kernel/DKMS stuff as I am entirely unfamiliar.
20:05 <bdrung> teward, okay
20:05 <teward> cool cool
20:05 <teward> #endmeeting