20:00 <rbasak> #startmeeting Technical Board
20:00 <meetingology> Meeting started at 20:00:00 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:00 <meetingology> Available commands: action, commands, idea, info, link, nick
20:00 <rbasak> mwhudson, teward: welcome!
20:00 <rbasak> And is seb128 here?
20:00 <teward> *loud burp*
20:01 <mwhudson> hello
20:01 <teward> note i'm also cross-handling the mailing list spam problem as well simultaneously, so i'm 80% here, 20% there.
20:01 <teward> just an fyi
20:01 <rbasak> I made some last moment additions to the agenda
20:01 <rbasak> #link https://wiki.ubuntu.com/TechnicalBoardAgenda
20:01 <rbasak> #topic New board members and the meeting schedule
20:02 <rbasak> mwhudson, teward: welcome!
20:02 <rbasak> :)
20:02 <rbasak> So the first question I think is: where are we with the meeting schedule, and does it need changing?
20:03 <mwhudson> it is ok for me currently but will become a bit of problem when timezones shift in a few weeks
20:03 <mwhudson> depending a bit on how long meetings tend to take
20:04 <rbasak> Which way do you need it to move?
20:04 <teward> mwhudson: meaning it will need to be held later for you, or earlier?  Asking 'cause my timezones already shifted this past weekend and Mondays are 'decent' in the sense i don't get a trillion conflicts
20:04 <teward> s/Mondays/Tuesdays/
20:04 <rbasak> Right now the meeting is pegged to Europe/London including DST.
20:04 <rbasak> We could peg it to UTC instead.
20:04 <seb128> I'm here, sorry for being late, always tricky to be back on time at the computer at this time in the evening
20:05 <mwhudson> currently it is 9am. 7-9 is a bad time for meetings for me. 6 or 6:30 would be fine, or after 0900 is fine (but starts to get hostile for europe)
20:05 <rbasak> So that's really two questions I think: what timezone do we want to use, and then what time in that timezone?
20:05 <mwhudson> 0700-0730 would probably be ok too
20:05 <rbasak> For me it's currently 8pm Europe/London. 9pm would work equally well for me.
20:05 <rbasak> Or even 10pm
20:06 <rbasak> 7pm more difficult, but I can manage. 6pm is a no really, as its prime childcare time.
20:06 <teward> rbasak: TO BE FAIR I think we should pin to UTC
20:06 <teward> because UTC has no DST/shifting timezones
20:06 <teward> by pinning to UTC, we  can adjust accordingly
20:06 <teward> (most other meetings set by Mauro, etc. for governance and other things use UTC as a fixed point)
20:07 <seb128> the issue with ajusting to UTC is that a time that might work in winter for some will perhaps not work in summer
20:07 <rbasak> I agree - then everyone only gets one DST shift every DST change season, and only if they themselves have DST.
20:07 <teward> seb128: same problem if we fix to London
20:07 <seb128> where if you align on e.g London time, then you have a few weeks off between DST gaps
20:07 <teward> because DST shifts aren't uniform over the planet
20:07 <seb128> yes, but then the gap is a few weeks and not 6 months
20:07 * tsimonq2 waves but goes back to lurking until appropriate
20:08 <rbasak> seb128: DST is inverse for mwhudson though, so it'd be a two hour shift for him and a zero hour shift for us otherwise, I think?
20:08 <mwhudson> if we leave the meeting where it is it will be 7am for me. we can try that.
20:09 <teward> if we intend to keep it on a tuesday, then regardless of DST for me we can shift it by 2 hours earlier or up to 4 hours later and it should be fine for me.
20:09 <teward> if we have to adjust it
20:09 <teward> any earlier in the day and it conflicts with DAYJOB regular meetings
20:10 <rbasak> I'm not sure I'm following everyone's preferences due to timezone maths.
20:10 <mwhudson> it is very confusing
20:10 <rbasak> mwhudson wants to keep it as it is I think: Europe/London 2000?
20:10 <teward> i think we need to look at calendars with localized timezones
20:10 <rbasak> I'm OK with that.
20:10 <rbasak> How does that work with teward?
20:10 <teward> rbasak: no objection, the 'time shift' means relative to current scheduled time
20:10 <teward> not localized time
20:11 <mwhudson> i am aware i am not being very coherent, sorry
20:11 <rbasak> "Europe/London 2000" is intended to be unambiguous :)
20:11 <teward> i.e. `now() - 2hr >= now >= now() + 4hr` for available time ranges for the meeting
20:11 <teward> i have no problem with that time
20:11 <rbasak> seb128: are you OK with Europe/London 2000, continuing as we were?
20:11 <seb128> current time works for me, one hour earlier is challenging and if we do that I will probably be half there for a third to an half of the meeting trying to get the kids to bed
20:12 <mwhudson> keeping as is (2000 london) is probably ok. moving 30-60 mins earlier would be better for me but if it starts getting awkward for others lets just keep the current time for now
20:12 <rbasak> OK so I think we've agreed to keep it as it is for now?
20:12 <teward> yep, and if we have to change it we can in the future
20:12 <seb128> one hour later would also work, 2 hours is getting in the too late zone and I would probably not be able to stay for the hour
20:12 <mwhudson> rbasak: +1
20:12 <seb128> +1
20:12 <rbasak> #agreed We're keeping the schedule the same for now: Europe/London 2000
20:12 <meetingology> AGREED: We're keeping the schedule the same for now: Europe/London 2000
20:12 <rbasak> Also, note that it's every other week
20:13 <rbasak> Any other meeting administration that we need to discuss?
20:13 <seb128> IRC vs matrix?
20:13 <rbasak> I've got that as a later agenda topic
20:13 <teward> that's its own topic seb128
20:13 <teward> in the agenda items
20:13 <seb128> ack
20:13 <seb128> sorry I was late and didn't have time to check the agenda, doing that now
20:13 <rbasak> #topic Action review
20:13 <rbasak> This might take a while
20:14 * rbasak amurray to look into scripting for packages in flavor-specific overlays (seb128, 20:04)
20:14 <rbasak> I'm not sure I understand what that means
20:14 <mwhudson> i certainly don't
20:14 <tsimonq2> That's likely the seed-related task.
20:14 <rbasak> This is where meeting logs are helpful :)
20:15 <tsimonq2> I provided amurray some details privately (he did end up following up with me), but I'm happy to also send those to seb128.
20:15 <tsimonq2> There is a non-public element to that, that I'd rather discuss privately. (It's a secondary note.)
20:15 <seb128> https://irclogs.ubuntu.com/2025/01/14/%23ubuntu-meeting.html#t20:09
20:15 <rbasak> Looks like it used to be owned by vorlon :-/
20:15 <seb128> "I recall it was to try and help the flavors better understand what packages were in what sets etc - but I can try and take it I guess"
20:16 <seb128> quote from Alex during that meeting
20:16 <seb128> does anyone want to own that one?
20:17 <rbasak> ...
20:17 <mwhudson> it's a bit hard to commit to given the lack of understanding. i can try to ask around to find out
20:17 <seb128> I personally don't feel like I would do a good job at it, I've too much to do already and it's not a topic I'm that familiar with, it would probably end up being pushed over for ages
20:17 <rbasak> Here we are
20:17 <tsimonq2> (I have the complete details for whoever claims it.)
20:17 <rbasak> #link https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24
20:18 <seb128> tsimonq2, you understand it and can provide context?
20:18 <teward> tsimonq2: oh so that's why you're lurking here today :)
20:18 <tsimonq2> seb128: Sure, would you like the context now? I can probably get away with that secondary note if I strip out PII.
20:18 <tsimonq2> teward: that and meetingology
20:18 <seb128> tsimonq2, well, mwhudson rather than me it seems :)
20:19 <seb128> rbasak, that url gives me a Not Found page
20:19 <teward> works here
20:19 <rbasak> Hmm, wfm
20:19 <tsimonq2> Essentially, Scarlett from Kubuntu had written a since-discarded hacky script to do some of this. We've had tooling in the past. Essentially, it's a function of ensuring that the germinate output for each flavor aligns with the packages in their packageset.
20:20 <tsimonq2> The element that might be sneaky is, I know of more than one flavor that has used the supported seed to gain upload access to packages they probably don't need access to.
20:20 <rbasak> I think there are two overlapping things here - the packageset, important for DMB ACL purposes, and the TB / release team matters of which flavour takes responsibilty for which packages, which is probably more relevant for team package subscriptions
20:21 <teward> I agree with rbasak, 100%, i was about to say something similar
20:21 <mwhudson> it doesn't feel like automatically aligning package sets and seeds sounds sensible
20:21 <teward> rbasak: stop reading my mind xD
20:21 <mwhudson> but some kind of mismatch report would be useful?
20:21 <tsimonq2> I think whoever writes the tooling in 2025 has to have both that rationale in mind (which I agree with), and some sensible heuristics.
20:21 <tsimonq2> mwhudson: A mismatch report would certainly be a welcome start.
20:22 <rbasak> There's some previous discussion on exactly this nuance in the previous meeting I linked above
20:22 <rbasak> Could we delegate an initial look to tsimonq2, perhaps?
20:22 <rbasak> There's no reason that has to be done by a TB member.
20:22 <tsimonq2> I would accept such a delegation and report back to the TB next meeting, if agreed upon.
20:22 <mwhudson> yeah some kind of summary would definitely be useful
20:22 <rbasak> Only some final decision should that be needed
20:24 <rbasak> Sounds like we're agreed?
20:24 <mwhudson> +1
20:24 <seb128> +1
20:24 <teward> +1
20:24 <rbasak> #action tsimonq2 to study "look into scripting for packages in flavor-specific overlays" from https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24 and suggest to the TB what needs doing there
20:24 * meetingology tsimonq2 to study "look into scripting for packages in flavor-specific overlays" from https://irclogs.ubuntu.com/2024/02/13/%23ubuntu-meeting.html#t20:24 and suggest to the TB what needs doing there
20:24 <rbasak> Thanks tsimonq2!
20:25 <tsimonq2> Happy to help! :)
20:25 <teward> tsimonq2: dangerous statement, just sayin ;)
20:25 <rbasak> (sorry for the slowness; I'm here, just looking things up and typing etc)
20:25 * rbasak seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations (seb128, 20:05)
20:25 <seb128> carry over please...
20:25 <rbasak> #action seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:25 * meetingology seb128 to continue working with AA and Release teams to document their membership process and link to it from https://wiki.ubuntu.com/TechnicalBoard#Team_Delegations
20:26 * rbasak sil2100 to follow up on the Cinnamon 24.04 LTS Qualification to ensure the listed contacts can action the flavor (seb128, 20:06)
20:26 <rbasak> Unfortunately we don't have a TB member who is also on the release team any more
20:26 <rbasak> I'm not sure what we need to do about this.
20:26 <rbasak> Personally I've held the view that this kind of work should be delegated to the release team, but Steve disagreed.
20:27 <mwhudson> is this a permissions thing? like making sure flavour leads have the ability to do $foo?
20:27 <teward> rbasak: we can revisit that decision now. do we wish to delegate this handling to the Release team?
20:27 <teward> because it SOUNDS like this is something the Release Team should handle, not TB
20:27 <tsimonq2> I do recall this actually being solved recently. Joshua would know for sure whether this still needs to be actioned or not.
20:27 <rbasak> My understanding of what this is: every LTS, each flavour must meet certain criteria to qualify, mainly about supportability
20:28 * Eickmeyer has full ability to action Cinnamon
20:28 <rbasak> teward: let me find the thread
20:28 <tsimonq2> Eickmeyer: (I think that the general point is (ref: discussions in #flavors:ubuntu.com) that there should be a *distinct* contact for each flavor with permissions.)
20:29 <rbasak> #link https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005858.html
20:29 <Eickmeyer> tsimonq2: That's true, and I'm the designated uploader per Joshua.
20:30 <tsimonq2> Eickmeyer: Not to re-hash that entire long discussion, but I'd argue that your interests are more in Edubuntu and Ubuntu Studio, and Joshua needs to receive a bigger (warm, friendly) push to seek PPU, when ready.
20:30 <rbasak> I disagreed with Steve's response and wanted to speak to him to see if I could convince him otherwise. But his time was limited for health reasons, and whenever we synced it tended to be at the bottom of the priority list, so I never actually found the time :-/
20:31 <rbasak> Essentially, I think the release team *should* be able to make this kind of decision. And it's fine if that's not everybody on the release team, but some people on it should be able to deal with contention should it occur - that applies to other release team decisions anyway, as we've seen recently.
20:31 <teward> rbasak: let's make it an action item then to actually follow up with the release team and see if Steve's assessment was right
20:32 <teward> if it's not and the Release Team is willing to take that, then we can push for delegation as a next vote.
20:32 <seb128> it seems his argument was mainly about how the release team members would feel about having to take such decisions, should we check with the current release team if they would be ok with that responsability?
20:32 <rbasak> OK. Since I have opinions not followed up in the thread, I certainly should be able to write something up, and I can take that action.
20:32 <teward> seb128: reading my mind with the "follow up with release team" action item and such :p
20:32 <seb128> :)
20:32 <teward> rbasak: +1
20:32 <mwhudson> yes agreed.
20:32 <seb128> +1 also
20:32 <rbasak> #action rbasak to follow up on https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html with the release team.
20:32 * meetingology rbasak to follow up on https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html with the release team.
20:33 <rbasak> What I'll do is move the thread to the ubuntu-release@ list and ask the release team there.
20:33 <mwhudson> i am also sort of fine with the situation where the release team makes the decision in effect but relies on the TB to tell people about it
20:33 <mwhudson> but let's ask first indeed
20:33 * rbasak seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process (seb128, 20:12)
20:33 <utkarsh2102> can I help with something from the RT side?
20:34 <seb128> carry over please
20:34 <tsimonq2> utkarsh2102: Stick around, please ;)
20:34 <seb128> utkarsh2102, I don't think that's needed but thanks
20:34 <mwhudson> can i get some context on that? (possibly out of band)
20:34 <seb128> we have a clear action path
20:34 <rbasak> utkarsh2102: hi! See https://lists.ubuntu.com/archives/ubuntu-release/2023-December/005859.html, but I will follow up with some further opinion first. Essentially we'd like to hear the release team's opinion before considering it again.
20:34 <rbasak> #action seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process
20:34 * meetingology seb128 to continue the discussion with IS and propose the script from rbasak or its output to be integrated in their process
20:34 <teward> rbasak: or seb128: contextual notes about 'script' for IS?
20:34 <teward> just you know for reference.
20:34 <seb128> utkarsh2102, oh, sorry, I misread your question
20:34 <rbasak> mwhudson: this is about Canonical leavers being removed from ~techboard and suchlike
20:34 <mwhudson> rbasak: ah!
20:35 <tsimonq2> Ahh, that's noticeable from the community side, too.
20:35 <mwhudson> thx
20:35 <utkarsh2102> okeydoke, sounds good. ubuntu-release ML is a good idea to start that discussion in.
20:35 * rbasak amurray to draft an updated description for the TB nominations process on ubuntu.com (seb128, 20:18)
20:35 <rbasak> #link https://ubuntu.com/community/governance/technical-board
20:36 <rbasak> This is about that page not reflecting reality
20:36 <rbasak> Exactly how TB elections should work has been a matter of recent discussion within the CC, since I raised some concerns with the current election
20:37 <rbasak> AIUI, we should see some firmer documented process soon.
20:37 <rbasak> So I suggest that we don't carry this action item further for now - let's wait for the CC to define something, then we can update the documentation following that.
20:37 <tsimonq2> (Not to make it seem like I must chime in on everything here,) S_kia noted publicly after receiving indirect Ubuntu Membership recently that it's somewhat unclear to newcomers on who can vote on what. Might be worth adding this as a note to that.
20:37 <teward> with the CC hat on btw: we know more now as the CC than we did before with regards to the election process.  You can assign a "triage" task to me to take it to the CC
20:38 <teward> *takes CC hat off* (we forget i wear many hats)
20:38 <teward> tsimonq2: i think the TB is voted on not necessarily by ubuntu members but people with *upload privileges*
20:38 <rbasak> #action teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
20:38 * meetingology teward to follow up with "who can vote" and documentation at https://ubuntu.com/community/governance/technical-board with the CC
20:38 <rbasak> Thanks teward!
20:38 <teward> but i'll make sure the CC comes up with definintions
20:39 <rbasak> That's all the previous action items covered
20:39 <tsimonq2> teward: Yeah, exactly. That's precisely the point that was unclear, and I can see it :)
20:39 <teward> (since i'm CC as well and can decompartmentalize as i have to, it makes sense I can carry this one across the borders between TB and CC)
20:39 <rbasak> #topic Board vacancy
20:39 <teward> i have an AOB that falls in line with "meeting venue" stuff but i'll wait ;)
20:39 <rbasak> #link https://discourse.ubuntu.com/t/new-ubuntu-technical-board-2025/56187/2
20:40 <rbasak> Thanks amurray for all his work on the TB over the last couple of years - but he has now stepped down.
20:40 <rbasak> Therefore there is a vacancy.
20:40 <rbasak> I understand that the CC would like the TB to decide what they want to do about this.
20:40 <teward> this question came up in the Governance meeting today btw - namely whether or not we should hold an election on this to fill the slot.  CC currently is looking to TB to provide guidance before they do anything.
20:40 <rbasak> IMHO, there's no need for an election right now, and we can continue with four board members (+ Mark) for the time being.
20:41 <rbasak> But that's just MHO and the TB needs to decide.
20:41 <rbasak> I can give my reasons if people are interested
20:41 <seb128> please do
20:41 <teward> I personally don't see any reason we need to immediately hold an election for the fifth spot.  Our current workload and tasks don't seem that they'd be a problem for four + Mark if there's a tie.
20:41 <teward> but that's just my opinion
20:42 <mwhudson> i don't have any strong opinions here, i would be fine continuing as 4 for now i think
20:42 <rbasak> Two reasons. First reason. Excluding people who have stepped down or withdrawn, we have had a call for nominations very recently and we seem to have a shortage of candidates.
20:43 <rbasak> If we open the call again, I'm not sure how many people we'd get, and that number could further be restricted by the shortlisting process.
20:43 <teward> Which, by the way, the shortlisting process is entirely in Mark's hands
20:43 <rbasak> If we get eg. just one person left, or even two, would we really be getting people elected who the electorate want elected?
20:44 <rbasak> Second reason. Arguably, those who wish to be nominated recently had that opportunity and turned it down. It was so recent that I think it'd be perfectly fair to consider that the opportunity for nominations "this cycle" are over.
20:44 <seb128> my opinion is that we had been struggling moving on some of the items (as the carry over we just listed from the previous boards show), and that's was true before the recent shortage of members, so not being a member short would be nicer. Now I don't know if that worth going through a new election round now...
20:44 <rbasak> OTOH, we could decide that we can try again in six months.
20:44 <rbasak> Minor additional reason: DMB elections are due in a couple of months, so there's just a bunch of admin and people deciding and stuff to do, and it doesn't seem worth it for just one seat.
20:44 <rbasak> .
20:45 <teward> seb128: i agree we could use the 5th member, but i also think we're going to run into the 'fatigue' and 'lack of ablebodied people' problem, so I think we could wait a couple of months or 6 months and determine any election bit then
20:45 <mwhudson> making sure the DMB is well staffed seems more urgent indeed (not that i am nominating myself for that)
20:45 <teward> and RE: rbasak's concern about no "no other candidate" option, i'll bring that up to the CC
20:45 <teward> i also agree making sure the DMB is well staffed is more urgent
20:45 <teward> (and I even said I'd not rerun for DMB if elected TB so I *limit* the number of hats I have)
20:45 <rbasak> I understand that the CC is leaning on defining specifically *not* having a a "No further candidates" option, FWIW.
20:45 <seb128> I think waiting 6 months probably makes sense yes
20:46 <tsimonq2> rbasak: Idea on that front, feel free to reject if unreasonable: if the electorate typically expects five members, would it be fair to make this a shortened TB term (1 year) and do a full election cycle in a year, or maybe longer, like a year and a half from now? I fear there may be regrets some time in.
20:46 <tsimonq2> (Just a thought.)(
20:46 <teward> rbasak: i don't think we've had a clear discussion point on that, but that falls into the "get guidance from CC' task assigned
20:46 <rbasak> I'd be more amenable to having a TB election *if* it includes a "No further candidates" option and successful candidates are required to beat that option, since that would make most of my concern moot.
20:46 <teward> we in that message being the CC
20:47 <rbasak> tsimonq2: I think those elected have been fairly elected for two years, and their terms shouldn't be shortened now.
20:47 <tsimonq2> No objections.
20:48 <seb128> I agree with rbasak, I don't think it would be fair to the currently elected members
20:48 <rbasak> OK, so where are we? Report to the CC that we don't desire an election right now?
20:48 <mwhudson> so in summary, we take no action here and have a fresh election in 6 months?
20:48 <mwhudson> rbasak has better phrasing
20:48 <Eickmeyer> Just a thought: What about the idea of a temporarily appointed TB member until an election can be done?
20:49 <rbasak> Do we specifically want to request an election in six months? Or leave that open for the future?
20:49 <seb128> I would revisit in 6 months to see how we are doing with capacity
20:49 <rbasak> If we leave it open, we might better understand whether we feel that we need the capacity or not.
20:49 <mwhudson> rbasak: +1
20:49 <rbasak> Eickmeyer: who would we appoint?
20:50 <Eickmeyer> rbasak: that would be up to the TB, I'd think.
20:50 <rbasak> That seems...awkward.
20:50 <seb128> I don't like that idea
20:50 <tsimonq2> And unprecedented.
20:50 <Eickmeyer> It was just a thought, no worries.
20:50 <teward> if we have any 'appointing' that'd be by Mark not the TB
20:50 <rbasak> I appreciate people making suggestions!
20:50 <teward> since Mark makes final-say on who's on the TB or not
20:50 <seb128> I would have been fine to include the first non elected candidate from the current election if we had one but we don't
20:51 <rbasak> OK, so I think we're settling on: "Report to the CC what we don't desire an election right now, and will reconsider in six months"
20:51 <mwhudson> yes
20:52 <seb128> +1
20:52 <rbasak> teward: fancy taking that action please?
20:52 <teward> well it's  implied I will since I"m already handling TB->CC with both hats :P
20:52 <teward> so yep
20:52 <rbasak> #action teward to report to the CC what we don't desire an election right now, and will reconsider in six months
20:52 * meetingology teward to report to the CC what we don't desire an election right now, and will reconsider in six months
20:52 <rbasak> #topic Meeting venue: move to Matrix?
20:53 <rbasak> It's the cool thing to do I hear
20:53 <rbasak> Especially as tsimonq2 has ported meetingology (thanks!)
20:53 <tsimonq2> ;D
20:53 <rbasak> However, I suggested in this channel just before the meeting that maybe everybody all at once might be too painful.
20:53 <mwhudson> in general we clearly should move at some point and probably fairly soon
20:53 <rbasak> And the DMB has tsimonq2 on it, so maybe the DMB could give it a try first.
20:53 <mwhudson> but i don't know if that means for the next meeting
20:53 <rbasak> Iron out any snags, and then we can move after that.
20:54 <tsimonq2> rbasak: With my DMB hat on, +1, but let's discuss in a DMB capacity next meeting.
20:54 <tsimonq2> #link https://discourse.ubuntu.com/t/announcing-meetingology-matrix-edition/56734
20:54 <tsimonq2> As a general note specifically to the TB, if you find anything overly objectionable, of course I respect the veto power ;)
20:54 <rbasak> #agreed We intend to move soon, but will wait for the better-placed DMB to move first.
20:54 <meetingology> AGREED: We intend to move soon, but will wait for the better-placed DMB to move first.
20:55 <rbasak> Any objections?
20:55 <mwhudson> no
20:55 <teward> nope
20:55 <seb128> no
20:55 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
20:56 <rbasak> Q/R Cycle Debian Import Freeze: Synchronizing with Debian in a Sustainable Way
20:56 <rbasak> #link https://lists.ubuntu.com/archives/technical-board/2025-March/002982.html
20:56 <tsimonq2> https://lists.ubuntu.com/archives/ubuntu-devel/2025-March/043287.html
20:56 <mwhudson> which has been redirected to ubuntu-devel@ and i want to reply to there but haven't yet
20:56 <mwhudson> agree it's not a tech board topic
20:56 <rbasak> I said that I think this should be considered by the release team in the first instance, tsimonq2 posted to ubuntu-devel@ but nobody has replied yet.
20:56 <seb128> agreed, that's more of a release team topic
20:57 <rbasak> utkarsh2102: ^ I wonder if you could get an opinion from the release team on tsimonq2's proposal, please?
20:57 <teward> I'd say it's not a TB topic, and should go throuhg -devel or orelease team.  Let's give it some time before we jump on anything, it's only been a few days at most (including weekend)
20:57 <mwhudson> (unless it has to become one for some reason)
20:57 <teward> oops i fail to spell
20:57 <tsimonq2> rbasak: This is precisely why I asked utkarsh2102 if he could stick around, if possible. ;)
20:57 <utkarsh2102> \o
20:57 <rbasak> Ah :)
20:57 <tsimonq2> CTA: If TB members could respond sometime in the coming weeks in their individual capacities, barring a full-on NACK from RT, I'd appreciate it.
20:58 <utkarsh2102> would love to move to Matrix for DMB!
20:58 <utkarsh2102> I think threads can really help - it gets hard to follow sometimes.
20:58 <utkarsh2102> wait!
20:58 <utkarsh2102> i was being asked something else :P
20:58 <rbasak> :)
20:59 <tsimonq2> I was going to say, that's a +3 from the DMB (unless Robie is +0?) but wrong meeting ;)
20:59 <utkarsh2102> okeydoke, it's a not something I can reply quickly. Give us a bit of time, I'll bring it up in the Release team meeting.
20:59 <rbasak> I will be +1 but not until the next meeting, so that everyone gets the opportunity to opine first :)
20:59 <seb128> tsimonq2, I've to read your email again but is your assumption that Debian will still be frozen by Q-cycle Ubuntu FF?
20:59 <rbasak> utkarsh2102: of course - thank you!
20:59 <tsimonq2> seb128: Yes.
21:00 <rbasak> There's also Should we endorse the Open Source AI Definition?
21:00 <rbasak> #link https://lists.ubuntu.com/archives/technical-board/2025-January/002973.html
21:00 <rbasak> I answered with my opinion.
21:00 <rbasak> You may wish to opine too.
21:00 <rbasak> I'm not sure there's any other action for the TB right now.
21:00 <tsimonq2> utkarsh2102: wfm, thanks :)
21:00 <seb128> tsimonq2, you could have stated that for readers, the wiki lists 2025-05-15 as Hard Freeze and usually Ubuntu summer FF is around August
21:00 <tsimonq2> seb128: Indeed, noted, thanks :)
21:01 <rbasak> I don't see any other ML discussion that needs to be raised here.
21:01 <seb128> I haven't been following closely Debian freezes length in recent releases but that seems long
21:01 <teward> rbasak: agreed no action on that needed for TB right now
21:01 <mwhudson> rbasak: ok this does feel like a techboard thing but i am not going to come up with an opinion right now
21:01 <rbasak> Does anyone else have anything on this topic?
21:01 <tsimonq2> (There usually is some time between Hard Freeze and final release. Sorry to distract from the second ML point.)
21:01 <teward> i have some AOB but nothing more on this topic
21:01 <seb128> rbasak, there was the AI topic?
21:01 <rbasak> seb128: mentioned above
21:01 <seb128> ah sorry, I got caught checking the Debian freeze dates :p
21:01 <teward> seb128: that was just brought up - suggesting there's no Tb action needed at the moment and we should voice our opinions on the thread, etc. irst.
21:02 <rbasak> I'm eager to try threads on Matrix to help with this kind of thing :)
21:02 <seb128> ack
21:02 <seb128> lol, let's see
21:02 <mwhudson> is it worth having an action for us all to consider this, to make sure it gets brought up next meeting?
21:02 <seb128> my experience is that I keep loosing messages and not finding pings on matrix
21:02 <seb128> unsure if element is the wrong client to use or if I'm holding it wrong :)
21:02 <rbasak> Is that an "action" or something to add to the agenda for the next meeting?
21:02 <rbasak> Either way I'm fine with it.
21:03 <teward> rbasak: i think that's an agenda topic not an action item
21:03 <mwhudson> i guess it's more the latter
21:03 <teward> but +1 on making it an agenda item for next meeting
21:03 <rbasak> OK added to the agenda.
21:04 <rbasak> Please read ahead though.
21:04 <teward> ^^ that
21:04 <rbasak> #topic Check up on community bugs and techboard bugs
21:04 <rbasak> #info No community bugs open
21:04 <mwhudson> there is only the "inactive DMB member" bug
21:05 <rbasak> There's a more general CC item discussing how to handle that more generally at the moment, so I'd like to defer that for now.
21:05 <mwhudson> fair enough.
21:05 <rbasak> #info "Inactive DMB members can stall DMB progress" deferred for the related CC item; no other techboard bugs open
21:05 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
21:05 <teward> wait i have AOB
21:06 <rbasak> That's next on the agenda
21:06 <teward> 👍
21:06 <rbasak> #info seb128 will be chair, with teward as backup
21:06 <teward> used to that being last on the agenda xD
21:06 <mwhudson> i can chair the next one as the time is still good for me. after that i'm less sure
21:06 <mwhudson> oh ok :)
21:06 <seb128> ack
21:06 <teward> looks like it's on rotation :)
21:06 <teward> ack
21:06 <rbasak> We usually just go down the list
21:06 <mwhudson> fair enough
21:06 <rbasak> But if you want to swap then that's fine too
21:06 <teward> i'll let seb and mwhudson decide on that one :)
21:06 <mwhudson> well i don't want to chair the one in 4 weeks
21:06 <tsimonq2> teward: FTR, you get to chair the next DMB meeting. ;P
21:07 <rbasak> Having extra people available to chair is not a problem :)
21:07 <teward> tsimonq2: FTR, you owe me a sixpack of beer so.
21:07 <teward> :P
21:07 <seb128> mwhudson, I'm happy to swap if that works better for you
21:07 <rbasak> #undo
21:07 <meetingology> Removing item from minutes: INFO
21:07 <mwhudson> seb128: let's do that then
21:07 <rbasak> #info mwhudson will be chair, with teward as backup
21:07 <tsimonq2> teward: *Uno reverse card, stack four card*
21:07 <rbasak> teward: you have implemented #undo, right :-P
21:07 <seb128> :)
21:07 <rbasak> #topic AOB
21:07 <teward> i have two AOB items
21:08 <seb128> go
21:08 <teward> #subtopic Mailing List Spam - Generic, Targeting All
21:08 <teward> I've been aware of increasing campaigns targeting all the mailing lists.  I'm currently working as a 'point of contact' with IS to combat this spam via an RT ticket, implementing specific regexes with Canonical IS at the lists.u.c endpoint
21:09 <teward> any subteams or delegated teams from the TB downwards seeing influxes of ML spam can reach out to me with addresses or suggested regexes
21:09 <teward> that one's just an informational
21:09 <tsimonq2> rbasak: #undo> one word: redactions. :P
21:09 <teward> this one's more complex.
21:09 <teward> #subtopic Consider moving documentation, etc. to Discourse?
21:10 <teward> Everything on the wiki is fine as it is, but as the wiki becomes increasingly hard to maintain, a lot of governance teams and such have started shifting their documentation, etc. over to the Discourse.  Have we considered whether we want to do this with TB documentation, etc.?
21:10 <rbasak> There's also https://canonical-ubuntu-governance-docs.readthedocs-hosted.com/en/latest/
21:10 <teward> that as well
21:10 <seb128> I was going to say
21:10 <teward> i'm happy to move this to ad-hoc or ML discussion, but the wiki is still where our Agenda, etc. lives so
21:11 <teward> we might want to consider at least moving *that* to Discourse or such
21:11 <seb128> and some other teams use github, https://github.com/canonical/ubuntu-mir
21:11 <teward> but i don't know how everyone is on Time right now so I'm happy to put that as a "future discussion" item
21:11 <rbasak> This has the benefit of being driven by git, which is much better for preserving history, identifying who made a change, ensuring that policy changes are properly decided and not just arbitrarily changed, and that kind of thing
21:11 <tsimonq2> One last quick AOB note for the very end after teward's point, the second Governance Sync session starts in approx. 50 minutes. If you don't have an invite to either the morning or evening session, let me know, I can connect you with the right people (or message Mauro Gaspari/Aaron Prisk.)
21:12 <mwhudson> using discourse for the agenda makes sense, i'd prefer documentation in git over wiki or discourse i think
21:12 <seb128> +1
21:12 <rbasak> eg. I wanted the SRU docs on git specifically because we've had people changing documented SRU policy giving themselves approval for things that the SRU team disapprove of, that type of thing.
21:12 <teward> i agree with discourse for agenda, documentation in git over wiki or discourse
21:12 <Eickmeyer> If I may, discourse keeps track of history as well.
21:12 <seb128> I'm unsure on readthedocs vs github
21:12 <teward> @seb128 RTD is a rendering of data from GH or such for doc formats, I believe. Which can be fed by git, etc.
21:12 <teward> rather than a wiki
21:13 <rbasak> Eickmeyer: it does, but in a Discourse specific way, so when we move to the next thing, it's a royal pain.
21:13 <tsimonq2> seb128: GitHub powers ReadTheDocs, not sure how public this is so I'll partially redact that Canonical [redacts] for RTD, thus it's Preferred(tm).
21:13 <rbasak> FTR, I did export SRU documenation history to git from Moin, as proof that I care about this. I think it's important.
21:14 <mwhudson> i'm not particularly sure what technical board documentation there even is, mind
21:14 <Eickmeyer> rbasak: Specifically, this button: https://i.imgur.com/h3GGgU1.png shows who made what revision and when, and it's fairly easy to scroll back and fourth with the bottom button as show here: https://i.imgur.com/H2SsXox.png
21:15 <rbasak> Eickmeyer: right, but where's the export-to-git option?
21:15 <Eickmeyer> Maybe discussion for another time, but why would you need that? It's not git.
21:15 <rbasak> Eickmeyer: and say you want to find out when a particular line was added. Where's the tooling to do that?
21:16 <Eickmeyer> You'd just use that interface in the last box there. It shows which revisions were made.
21:16 <seb128> mwhudson, I think mostly the description/overview on https://wiki.ubuntu.com/TechnicalBoard and the Agenda
21:16 <rbasak> I don't want to search hundreds of revisions by hand. We have better tooling for that nowadays.
21:16 <Eickmeyer> Full context:
21:16 <Eickmeyer> https://i.imgur.com/HfXkx6C.png
21:16 <teward> given the agenda is Fluid, it makes sense for that to be on Discourse IMO, but the overview could live elsewhere.
21:17 <Eickmeyer> Oh, that didn't help at all. Hang on...
21:17 <seb128> yes, I think we all agreed to have the agenda on discourse
21:17 <Eickmeyer> https://i.imgur.com/Ul73SrW.png
21:17 <rbasak> Yeah I'm fine with the agenda being moved
21:17 <mwhudson> ok, are we all agreed on: "agenda on discourse. docs in git" as a direction? details to be fleshed out later
21:17 <seb128> Eickmeyer, you don't really have a 'git blame' equivalent there though
21:17 <seb128> mwhudson, +1
21:18 <Eickmeyer> seb, no, but it clearly shows what addition was made and by whom. In this case I added a line.
21:18 <seb128> yes, I think the point is for when you want to find back a changeset made 3 years ago to remember who did it and in which context
21:18 <rbasak> OK so we're agreed on direction. Is there anything else to discuss on this topic?
21:18 <seb128> I don't think so
21:18 <rbasak> AOAOB?
21:19 <seb128> but also discourse doesn't have PRs for contributors to propose changes for example
21:19 <seb128> no AOB from me
21:19 <mwhudson> i do not have anything more
21:19 <Eickmeyer> seb128: In that case, that's where it's in the form of a discussion. I realize it's not developer-focused where everyone is used to GIT, but I guess it's for a more non-technical mindset.
21:19 <mwhudson> (i want to talk about OEM archives at some point but this is *definitely* not the time)
21:20 <teward> rbasak: you can action-item me for moving the Agenda to Discourse if you want
21:20 <teward> i'll have to work with Discourse admins to set up the proper topic tag for it anyways
21:20 <rbasak> teward: are we ready for that?
21:20 <teward> rbasak: i mean if we're ready to *move* the Agenda, i.e. a standing "I'll offer to take it"
21:20 <rbasak> There are a bunch of pages to move if we want to keep everything coherent.
21:20 <teward> s/if we're/when we're/
21:20 <rbasak> I'm not sure we agreed to move it right now. Or is that what people want right now?
21:21 <rbasak> I've been editing the agenda wiki today and it seemed OK
21:21 <teward> yeah we should be OK, when we're ready I can handle moving the Agenda over, I don't mind either way right now
21:21 <mwhudson> maybe the action is to have a proposal for how it will work (like a new topic for each meeting, created just after the previous one?)
21:21 <teward> i misrtead sseb ;)
21:21 <rbasak> Good idea
21:21 <teward> i agree with mwhudson
21:21 <rbasak> As we're over time, let's do that.
21:21 <seb128> +1
21:21 <teward> +1
21:21 <rbasak> #action teward to write up a proposal for how the move away from the wiki will work
21:21 * meetingology teward to write up a proposal for how the move away from the wiki will work
21:21 <mwhudson> (is the meeting expected to last 60 minutes in general?)
21:22 <rbasak> mwhudson: I think most meetings are done in 20-40 minutes. Today's was extra long.
21:22 <rbasak> Officially I've always considered it to be a 60 minute slot.
21:22 <mwhudson> ack
21:22 <rbasak> Thank you for your patience everyone! I suppose the first meeting was always going to take a while; we seem to have got through about an order of magnitude more than is required for most meetings today.
21:22 <rbasak> #endmeeting