19:15 <schopin> #startmeeting Developer Membership Board
19:15 <meetingology> Meeting started at 19:15:21 UTC.  The chair is schopin.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:15 <meetingology> Available commands: action, commands, idea, info, link, nick
19:15 <rbasak> If we're unanimously +1, then one of the absentees could finish it by email.
19:15 <schopin> I believe we have one applicant for MOTU today, mirespace ?
19:16 <mirespace> yes o/
19:16 <schopin> #topic MOTU Application
19:16 <schopin> #link https://wiki.ubuntu.com/MiriamEspanaAcebal/MOTUApplication
19:17 <schopin> mirespace: hi :). Could you please introduce yourself?
19:17 <mirespace> Hello. My name is Miriam España Acebal (two surnames), and I work as a distro engineer in the CPC team at Canonical, where I started in 7/2021 in the Server team. I usually deal with Microsoft-related packages because I'm on the Azure team. My last adventures involve WALinuxagent and the to-be-packaged rust-based GuestProxyAgent, but I also dedicate time to general distro work.
19:17 <mirespace> My application was linked above
19:19 <schopin> Thanks :)
19:19 <mirespace> yw :)
19:19 <teward> because i'm not caffeinated enough yet today, CPC = ?  (For the IRC logs)
19:19 <mirespace> Canonical Public Cloud (sorry!)
19:20 <teward> no worries, i should know this but i haven't had enough coffee :)
19:20 <schopin> I don't think even I knew that the first C was for Canonical.
19:20 <mirespace> I think that there is a debate on that... in the last sprint, we only have Public Cloud in our badges
19:25 <rbasak> OK so I'll start I guess! Let's say that it's after feature freeze in the cycle, and you're considering a package update from 1.2.3-1 to 1.2.4-0ubuntu1. What do you need to check for compliance with feature freeze, if anything?
19:26 <utkarsh2102> hey heey
19:26 <mirespace> No new features  and/or ABI/API changes for a package can be uploaded after Feature Freeze, so I would check that first
19:26 <teward> o/ utkarsh2102
19:26 <utkarsh2102> can someone send a scrollback please?
19:27 <rbasak> mirespace: OK! So say that you look and there is a small feature change. You think the release team might grant an exception. How should you ask them for one?
19:27 <schopin> utkarsh2102: done, check MM
19:28 <mirespace> I will create a bug requesting a FeatureFreezeException following https://wiki.ubuntu.com/FreezeExceptionProcess
19:29 <utkarsh2102> thanks, schopin! o/
19:29 <mirespace> I can also ask in the ubuntu-release channel if someone on the release team can take a lok if I'm not sure enough, or tag the bug
19:30 <mirespace> ubuntu-release tag
19:31 <mirespace> Depending on what moment of the cycle we were, for no bother a lot the release team if they are in a critical task
19:31 <rbasak> I'm not aware of an ubuntu-release tag. Is that documented anywhere?
19:31 <mirespace> s/lok/look/
19:31 <utkarsh2102> it's subscribing ~ubuntu-release not tagging the bug :)
19:31 <mirespace> https://wiki.ubuntu.com/FreezeExceptionProcess, the last point on FeatureFreeze for new upstream versions
19:32 <mirespace> yes, true
19:32 <mirespace> my fault
19:32 <rbasak> OK :)
19:33 <rbasak> So let's say that your FFe is granted, and you upload. It then gets "stuck in proposed". What does this mean, and where do you find documentation on how to handle this situation?
19:33 <utkarsh2102> question: I see Christian sponsoring a lot of uploads - at least definitely reviews - why is he not endorsing the application?
19:33 <mirespace> That means that the migration process  is failing at some point (test regressions, FTBFS, ...)
19:34 <mirespace> Documentation about this can be find at https://wiki.ubuntu.com/ProposedMigration
19:34 <mirespace> and also at https://github.com/canonical/ubuntu-maintainers-handbook/blob/main/ProposedMigration.md
19:34 <utkarsh2102> so what do you do then - if you see something that has not migrated, what are the next steps?
19:34 <mirespace> I coul check if the package appears at https://ubuntu-archive-team.ubuntu.com/proposed-migration/update_excuses.html
19:35 <mirespace> utkarsh2102: cpaelzer_ sponsored my ServerApplication, maybe that's the reason
19:36 <mirespace> Once, in the update_excuses,  I could check if there is a regression marked in some of the autopkgatest ran, for some architectures also
19:36 <utkarsh2102> what if it's not listed there?
19:36 <utkarsh2102> and the package is still not migrating
19:37 <utkarsh2102> well, it's listed there but there's nothing informational :)
19:37 <mirespace> I could check britney output https://ubuntu-archive-team.ubuntu.com/proposed-migration/update_output.txt
19:37 <utkarsh2102> coolio
19:37 <mirespace> To see if some dependencies problem arose
19:37 <utkarsh2102> what would you if you see your package there?
19:38 <utkarsh2102> let's say you upload "moarvm" package
19:38 <utkarsh2102> and it's listed there as:
19:38 <utkarsh2102> trying: moarvm
19:38 <utkarsh2102> skipped: moarvm (0, 6, 681)
19:38 <utkarsh2102> got: 57+0: a-7:a-5:a-28:i-2:p-5:r-5:s-5
19:38 <utkarsh2102> * armhf: nqp, prove6, raku-file-find, raku-file-which, raku-getopt-long, raku-hash-merge, raku-json-class, raku-json-fast, raku-json-marshal, raku-json-name, raku-json-optin, raku-json-unmarshal, raku-librarycheck, raku-license-spdx, raku-log, raku-meta6, raku-readline, raku-tap-harness, raku-test-meta, raku-uri, raku-zef, rakudo
19:38 <utkarsh2102> what does that mean
19:38 <mirespace> I tried to fix something like that with a R package, following Adrien Nader recommendation in ubunut-devel mail list
19:38 <utkarsh2102> what will you do next?
19:39 <mirespace> Is trying to install moarvm, but skipping in armhf arch
19:40 <mirespace> The numbers I think are related to attemps
19:40 <mirespace> and I probably will look for that dependencies to see if something are preventing that for installing in that arch
19:40 <utkarsh2102> hm, okeydoke
19:40 <utkarsh2102> sorry for hijacking, rbasak - back to you!
19:41 <schopin> mirespace: Let's say you're about to upload a merge of a library from Debian, how would you check for possible transitions it would trigger?
19:41 <mirespace> I should read more on britney doc
19:42 <mirespace> I would check the reverse dependencies the library has
19:42 <schopin> What would you check them for?
19:43 <mirespace> if there is some ABI chekcs, I would check if looking for that changes in the rdependencies qith objdump, for example
19:43 <mirespace> s/chekcs/changes/
19:44 <mirespace> s/qith/with
19:44 <mirespace> I did that for https://bugs.launchpad.net/ubuntu/+source/heimdal/+bug/2036253
19:44 <mirespace> Which is the most similar to a transition I worked on
19:44 <schopin> A fairly special case :)
19:45 <schopin> Assuming upstream and Debian know of the ABI breakage, how would that show in the new version of the package?
19:45 <schopin> For that hypothetical, let's assume intentional breakage rather than one caused by toolchains
19:46 <mirespace> Ah, that question has a trick I remember ....
19:47 <mirespace> I'm checking this  because I don't remember  https://www.debian.org/doc/manuals/debian-kernel-handbook/ch-versions.html
19:47 <mirespace> mmm ... too quick that is for the kernel
19:48 <schopin> are you familiar with the concept of soname?
19:48 <mirespace> I waS CHECKING https://www.debian.org/doc/debian-policy/ch-sharedlibs.html#dependencies-between-the-packages-of-the-same-library
19:50 <mirespace> soname : shared object name, I used it with simbol changes
19:51 <schopin> How is it used in the packaging of a library?
19:51 <mirespace> And the bump to the new version is made because they need to be installable concurrently
19:52 <mirespace> libfoo-version.so
19:53 <mirespace> or libfoo.so.version
19:53 <rbasak> So on my system libjpeg-turbo8 ships /usr/lib/x86_64-linux-gnu/libjpeg.so.8.2.2. What's the soname likely to be?
19:53 <mirespace> 8.2.2
19:53 <rbasak> (and it also ships /usr/lib/x86_64-linux-gnu/libjpeg.so.8 -> libjpeg.so.8.2.2)
19:54 <mirespace> JPEG_8.2.2
19:56 <rbasak> May I move on from transitions and ask a final question?
19:56 <schopin> Alas, no, it would be libjpeg.so.8
19:57 <schopin> rbasak: fine with me.
19:57 <rbasak> mirespace: let's say you add a delta to package in universe during +1 maintenance. How will you ensure that it doesn't get left behind in the next cycle if Debian updates the package and it doesn't autosync because of the delta? What's the process in Ubuntu to ensure that this doesn't happen, for a package in universe?
19:58 <mirespace> Oh, yes... I cannot process under  nervouss, sorry: clear here: A shlibs file represents an SONAME as a library name and version number, such as libfoo VERSION, instead of recording the actual SONAME. If the SONAME doesn’t match one of the two expected formats (libfoo-VERSION.so or libfoo.so.VERSION), it cannot be represented, in the doc I linked above
19:59 <mirespace> - Ways to follow-up later changes in merges:
19:59 <mirespace> - If it needs a patch, because we’re modifying code outside debian folder in quilt format (3.0), we can put there in the description of the patch following DEP3 guidelines
19:59 <mirespace> - If the merge review was done through MR in Launchpad, put it there, being careful of having the bug linked to the MR.
19:59 <mirespace> - You can add a final comment to the bug
19:59 <mirespace> - You can add a more descriptive comment in the commit that probably would be affected in the future merge
20:00 <rbasak> I don't think that answered my question. Can you try reading it again please? Take your time, and ask me to clarify if you need.
20:00 <schopin> FYI, we're out of time so i'll call for a vote after that question has been answered.
20:01 <mirespace> Merges in universe will appear at https://merges.ubuntu.com/universe.html?showProposed=true&showMergeNeeded=true&showLongBinaries=true
20:02 <rbasak> Yes - they'll appear there - but what's the *process* to ensure that an Ubuntu package with a delta won't languish in that report forever?
20:02 <utkarsh2102> i've also had questions - i'm not super decided yet but time constraints,, oh well :)
20:02 <mirespace> rbask: the question is how the package appears on MOm or how we handle oa package that appears in mom?
20:02 <utkarsh2102> rbasak: i have a hard stop - it's 1:32 AM here. do you want to do votes already?
20:02 <utkarsh2102> teward, schopin?
20:03 <schopin> I'm also close to my hard stop.
20:03 <teward> i don't have a hard stop but my need for caffeine is making me hit one
20:03 <mirespace> filling a bug for the next merge, subscribing someone also (the last autor)
20:03 <rbasak> OK I think we need to move on to voting :-/
20:04 <mirespace> or a team that has it in the team mapping package
20:04 <schopin> #vote Miriam to get MOTU rights
20:04 <meetingology> Please vote on: Miriam to get MOTU rights
20:04 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
20:06 <rbasak> -1
20:06 <meetingology> -1 received from rbasak
20:06 <rbasak> I'm not sure on your understanding of transitions. I think you might understand enough to know when to ask questions though. You see to understand the packaging uninstallability / migration side, but perhaps not the mapping from soname to binary side so well.
20:07 <rbasak> I'm also not so sure on your understanding of Ubuntu's merge process. I'm concerned that delta in Ubuntu will be left behind to languish.
20:07 <rbasak> I was willing to give you the benefit of the doubt on one of those two topics, but I don't think I can for both, sorry! I think you're really close though. Please keep up the good work!
20:07 <schopin> -1 Robie basically wrote much faster than I could organize my thoughts but it's a very similar reasoning.
20:07 <meetingology> -1 Robie basically wrote much faster than I could organize my thoughts but it's a very similar reasoning. received from schopin
20:08 <rbasak> I also appreciate that this may be a matter of not conveying understanding in a stressful IRC meeting :-/
20:08 <mirespace> And I'm sorry, I'm not exposed to transitions per se... I need to look for them with someone who wants
20:09 <schopin> mirespace: A good way to touch transitions during +1 shifts is to work on NBS packages, as those are usually a symptom of ongoing transitions.
20:10 <mirespace> schopin: thanks for the trick, crossing finger for my next shift hold something related
20:10 * rbasak needs to go now, sorry
20:12 <utkarsh2102> -1; i was mostly +0 as I was not super decided as of yet. I've seen Miriam do good work on the CPC side and managing other things but on the other, I feel there's a room for improvement, needed for MOTU. Whilst the answers lead me towards -1, I am also not happy with the endorsements - few endorsers have only sponsored a limited number of packages.
20:12 <utkarsh2102> Those who have sponsored more haven't endorsed the application. I'd also like to see if that can be fixed for the next time. But as I said, Miriam is doing great stuff and I look forward to seeing her get MOTU and then eventually core-dev pretty soon!
20:12 <meetingology> -1; i was mostly +0 as I was not super decided as of yet. I've seen Miriam do good work on the CPC side and managing other things but on the other, I feel there's a room for improvement, needed for MOTU. Whilst the answers lead me towards -1, I am also not happy with the endorsements - few endorsers have only sponsored a limited number of packages. received from utkarsh2102
20:13 <utkarsh2102> teward?
20:13 <teward> 01 reasoning to follow
20:14 <teward> -1 reasoning to follow
20:14 <meetingology> -1 reasoning to follow received from teward
20:14 <utkarsh2102> ok, I reallyyyyy need to drop - thanks for chairing schopin. I'll drop now.
20:14 <utkarsh2102> see you all soon! o/
20:15 <teward> I have seen some promising things in your history, but I fear you don't have the necessary knowledge to properly work on packages as a MOTU without supervision. Additionally, I agree the issue with your endorsements is concerning since none of the primary sponsors of your work endorsed things, which makes me a little concerned they may have intentionally not endorsed you.
20:16 <schopin> #endvote
20:16 <meetingology> Voting ended on: Miriam to get MOTU rights
20:16 <meetingology> Votes for: 0, Votes against: 4, Abstentions: 0
20:16 <meetingology> Motion denied
20:16 <mirespace> Thank you all
20:16 <schopin> #action schopin to announce the results on the ML.
20:16 * meetingology schopin to announce the results on the ML.
20:17 <mirespace> It's the problem or being in a no-distro team
20:17 <mirespace> s/or/of/... nut that's known :)
20:17 <schopin> So sorry, I really have to run so I call this meeting to an end (at least as far as the bot is concerned)
20:17 <schopin> #endmeeting