21:10 <sil2100> #startmeeting Developer Membership Board
21:10 <meetingology> Meeting started at 21:10:09 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
21:10 <meetingology> Available commands: action, commands, idea, info, link, nick
21:10 <sil2100> #topic PPU Applications
21:10 <sil2100> #subtopic Joshua Peisach
21:10 <sil2100> #link https://wiki.ubuntu.com/itzswirlz/Applications/UbuntuCinnamonPPUApplication
21:11 <sil2100> AlsoItzSwirlz: o/
21:11 <AlsoItzSwirlz> sil2100: hi!
21:11 <sil2100> AlsoItzSwirlz: hello! Can you introduce yourself briefly? :)
21:11 <AlsoItzSwirlz> here's the sponsorship miner for everyones convenience: https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=itzswirlz2020%40outlook.com&sponsoree_search=email
21:11 <AlsoItzSwirlz> sil2100: Fun way:
21:11 <AlsoItzSwirlz> I'm just a kid who's four, each day I learn some more, I like exploring I'm Cailou.
21:12 <AlsoItzSwirlz> Serious way: high school student at bergen county academies, I first used ubuntu about five years ago, installed it on a real machine three years ago and on my laptop its my daily driver
21:12 <sil2100> ;)
21:12 <AlsoItzSwirlz> I run the ubuntu cinnamon remix as my hobbyist project - goal is to eventually reach flavor status
21:14 <sil2100> Thanks!
21:14 <sil2100> Time for questions!
21:14 <utkarsh2102> "For example, instead of syncing from Debian latest or going to Ubuntu unstable for building the latest version of Cinnamon, I’d just rebuild everything for no reason." - eeks :)
21:14 <kanashiro[m]> AlsoItzSwirlz: you mentioned you make mistakes in your application, what are your plans to avoid that from now on?
21:14 <AlsoItzSwirlz> utkarsh2102: shh
21:15 <AlsoItzSwirlz> kanashiro[m]: Most mistakes as in minor packaging things or how I approach situations. It has changed a lot since I joined debian cinnamon team and spent more time in the Ubuntu world
21:15 <AlsoItzSwirlz> For a while I used to source/format a ubuntu cinnamon package as quilt, which made basically no sense
21:16 <utkarsh2102> I see no uploads for Hirsute, Impish, Jammy? is there a specific reason why?
21:16 <AlsoItzSwirlz> also, back then, especially when i started the project i was very, I guess uneducated is a good word, about release cycles. Back then, I didn't understand what syncpackage/requestsync was, I didn't really understand the release process as well
21:17 <AlsoItzSwirlz> utkarsh2102: They are in the ubuntu cinnamon remix ppa, see ~ubuntucinnamonremix
21:17 <AlsoItzSwirlz> Hold on, getting off the bus. BRB (give me 2 min)
21:17 <sil2100> ;)
21:19 <AlsoItzSwirlz> utkarsh2102: Here's the stable PPU repo we have been using and will be ditching this release now that the packages are in universe: https://launchpad.net/~ubuntucinnamonremix/+archive/ubuntu/all
21:19 <AlsoItzSwirlz> only relevant ones are the ubuntucinnamon-* packages
21:19 <utkarsh2102> alright! why not the main archive, though?
21:20 <AlsoItzSwirlz> back then i was also slightly confused about the process of PPU.
21:20 <AlsoItzSwirlz> I used to think that you could have your packages in a PPA, and then apply for PPU status and then your packages get imported
21:21 <utkarsh2102> uh
21:21 <utkarsh2102> okay
21:21 <AlsoItzSwirlz> but apparently MOTU's can sponsor, and so i got the help i needed. Though, I should've known that MOTU's can sponsor my packages into the archives and should've done it sooner.
21:21 <utkarsh2102> MOTU and coredevs, either
21:21 <utkarsh2102> s/and/or/ :)
21:22 <utkarsh2102> okay, I have another (serious) question
21:22 <utkarsh2102> looking at the packages at https://launchpad.net/~ubuntucinnamonremix/+archive/ubuntu/all/+packages
21:22 <AlsoItzSwirlz> Alright. hit me
21:22 <utkarsh2102> let's take the first one
21:23 <utkarsh2102> src:calamares-settings-ubuntu
21:23 <utkarsh2102> calamares-settings-ubuntu | 1:20.04.2.1 | focal-updates/universe | source
21:23 <utkarsh2102> calamares-settings-ubuntu | 1:22.04.4   | jammy/universe         | source
21:23 <utkarsh2102> calamares-settings-ubuntu | 1:22.04.4.2 | jammy-updates/universe | source
21:23 <utkarsh2102> calamares-settings-ubuntu | 1:22.10.11  | kinetic/universe       | source
21:23 <utkarsh2102> this is what rmadison shows
21:23 <utkarsh2102> however, you've uploaded 1:22.09 to focal in that PPA?
21:24 <utkarsh2102> do you think that's correct? if so, why? if not, why?
21:24 <AlsoItzSwirlz> So yeah, I knew about that very late after I initially forked calamares-settings-ubuntu from Lubuntu. However until I switched to Ubiquity for cinnamon remix i didn't need to use calamares anymore except for maintenance
21:25 <AlsoItzSwirlz> utkarsh2102: because versioning, i wanted to keep it consistent
21:25 <utkarsh2102> how's that consistent? :(
21:25 <AlsoItzSwirlz> Consistent as in with the date i released/made the changelog, not the point version
21:25 <AlsoItzSwirlz> I also had messed up my branches. Before I used fish as a shell (which showed me I was messing up) I did once end up pushing focal changes under the master branch which at the time was impish
21:25 <utkarsh2102> do you see any problems with the versioning?
21:26 <AlsoItzSwirlz> utkarsh2102: no, but i think that once i accidentally versioned it based on the date i can't go back (at least that's what I think)
21:26 <AlsoItzSwirlz> I don't believe unless causing a lintian warning that you can have a version 1.0 then a 2.0 then a 1.1 release
21:28 <AlsoItzSwirlz> utkarsh2102: i am aware that this conflicts with another package under the same source name which can also cause stability issues
21:28 <utkarsh2102> what if a user who's using Focal + your PPA upgrades to Jammy?
21:29 <AlsoItzSwirlz> utkarsh2102: calamares-settings-ubuntu is only installed on the live isos, it doesn't get installed on the user's host system
21:29 <AlsoItzSwirlz> utkarsh2102: also, since it's a ppa upgrading it using sudo do-release-upgrade will disable it until the user manually re-enables it, in which again it won't be installed
21:30 <utkarsh2102> I mean, you said, you only pushed to PPA because you thought you'd get PPU rights and then push those packages to the archive yourself. But with that versioning scheme, it'd be a mess, in my opinion :(
21:31 <AlsoItzSwirlz> utkarsh2102: i could also have pushed something to the unstable ppa
21:31 <AlsoItzSwirlz> https://launchpad.net/~ubuntucinnamonremix/+archive/ubuntu/unstable <- though i doubt that'll be useful
21:32 <AlsoItzSwirlz> utkarsh2102: again, this is an installer package that isn't in use anymore. 20.04.5 is the last release/image made using it
21:33 <utkarsh2102> one last question from my end: suppose you have 1.2.3-1 version of a package, say X, in Focal, Jammy, and Kinetic and you want to fix a bug in all of them - how are you gonna do that? and what versions are you gonna pick?
21:33 <AlsoItzSwirlz> 1.2.3-1ubuntu0.1
21:33 <utkarsh2102> for all of them?
21:33 <AlsoItzSwirlz> ^ as the version, i'd do it by doing a pull-lp-source of them
21:34 <utkarsh2102> ok, no more questions from me! \o
21:34 <AlsoItzSwirlz> utkarsh2102: not for all, take the latest release and add after the debian release -1 or -2, 'ubuntu' and then whatever version it needs
21:34 <AlsoItzSwirlz> utkarsh2102: with my sru's i've done that
21:35 <utkarsh2102> could you tell me the exact versions you'd use, please, for all the 3 releases (if not same)?
21:35 <utkarsh2102> to be precise: 1.2.3-1 is in Debian but you want to fix it in Ubuntu now
21:35 <utkarsh2102> it's Ubuntu specific, how'd you do it then^
21:35 <AlsoItzSwirlz> So if focal, jammy, and kinetic were all 1.2.3-1, I'd make it 1.2.3-1ubuntu0.1
21:36 <AlsoItzSwirlz> if jammy was 1.2.5-1, i'd make it 1.2.5-1ubuntu0.1
21:36 <AlsoItzSwirlz> just append the ubuntu to the version revision
21:36 <AlsoItzSwirlz> https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=itzswirlz2020%40outlook.com&sponsoree_search=email - all non-UCR packages i've added +ubuntu0.1
21:37 <AlsoItzSwirlz> exception being cinnamon in groovy, which was before the release
21:37 <sil2100> AlsoItzSwirlz: but would you use the same version for all the series?
21:38 <AlsoItzSwirlz> sil2100: by version as in the numbers before the hyphen or after it
21:38 <utkarsh2102> version = the whole string :)
21:38 <sil2100> AlsoItzSwirlz: I mean the final full version. Would you use 1.2.5-1ubuntu0.1 as the version number for your SRU for focal and jammy?
21:38 <AlsoItzSwirlz> It depends on what the latest release that contains that bug is. You would grab the latest version, obtained by pull-lp-source and then work from there
21:39 <AlsoItzSwirlz> sil2100: If 1.2.5-1 was the original version in both focal and jammy before i made my patch, yes
21:39 <kanashiro[m]> in the proposed scenario you have 1.2.3-1 in both releases
21:39 <AlsoItzSwirlz> then 1.2.3-1ubuntu0.1
21:40 <kanashiro[m]> what would happen during the upgrade if you use the same version in both SRUs?
21:40 <AlsoItzSwirlz> kanashiro[m]: nothing? the package would be up to date?
21:41 <kanashiro[m]> is this the desired outcome?
21:41 <AlsoItzSwirlz> the only exception to the ubuntu0.1 is if the package already had a patch. If I made another patch after 1.2.5-1ubuntu0.1, I would name it 1.2.5-1ubuntu0.2
21:41 <AlsoItzSwirlz> kanashiro[m]: if the host system already has the update installed, yeah?
21:41 <sil2100> AlsoItzSwirlz: so this would not work like that sadly. The ubuntu archive, in theory, doesn't allow multiple packages of the same version with different contents. So if you upload 1.2.3-1ubuntu0.1 to jammu and then want to upload it with the same version number to focal, it will be rejected
21:42 <AlsoItzSwirlz> 1.2.5-1 to 1.2.5-1ubuntu0.1 results in upgrade
21:42 <kanashiro[m]> AlsoItzSwirlz: in this case, where you have the same version in more than one release, the recommended way is to add the release number to the version string. For instance, 1.2.3-1ubuntu0.20.04.1, 1.2.3-1ubuntu0.22.04.1 and so on
21:42 <AlsoItzSwirlz> ah, thats why for the caribou fix it was 0.20.10 because caribou hasn't had a new release in a long time - https://launchpad.net/ubuntu/+source/caribou/0.4.21-7ubuntu0.20.10.1
21:42 <sil2100> AlsoItzSwirlz: it would have to be a binary copy from jammy to focal, but then you would have jammy-compiled binaries on a focal system, which can (depending on the toolchain and library differences) cause issues
21:43 <sil2100> AlsoItzSwirlz: basically when backporting a change to stable series, you need to use different version numbers for every upload, and make sure that the version is smaller in the older releases
21:44 <AlsoItzSwirlz> noted, i've never tried backporting anything that was already in the ubuntu archives
21:45 <kanashiro[m]> AlsoItzSwirlz: out of curiosity: how would you decide if a change in cinnamon for instance should target Debian or Ubuntu? Since you have been doing some work in Debian as well
21:46 <AlsoItzSwirlz> kanashiro[m]: if it was a distro-specific change, which to my knowledge any distro config is set in gsettings overrides
21:47 <AlsoItzSwirlz> Most of the time, like for bug fixes it will be applicable to latest and devel ubuntu
21:47 <AlsoItzSwirlz> upstream -> debian -> ubuntu
21:47 <utkarsh2102> if you want to fix a bug in the devel release of both the distributions, how'd you go about it?
21:48 <AlsoItzSwirlz> utkarsh2102: fix in debian, get the debian fix uploaded, wait for debian resync
21:48 <AlsoItzSwirlz> if after debian import freeze requestsync it
21:48 <AlsoItzSwirlz> or, under permissions, syncpackage
21:48 <utkarsh2102> what if it's a feature that you added and not just a bug fix?
21:49 <utkarsh2102> would you do the same thing? or would you do anything different?
21:49 <AlsoItzSwirlz> Same thing unless it was close to a release
21:49 <utkarsh2102> is there something you'd be careful about?
21:49 <AlsoItzSwirlz> For example, I wouldn't requestsync a package if it introduced a new feature super close to a release
21:50 <AlsoItzSwirlz> if debian is still being in devel for a while, then that's fine
21:50 <AlsoItzSwirlz> to clarify - i do not have debian upload rights either
21:51 <AlsoItzSwirlz> Oh, and always test new features before uploading.
21:51 <sil2100> AlsoItzSwirlz: following up on what utkarsh2102 said: do you know what feature freeze is in Ubuntu?
21:51 <AlsoItzSwirlz> sil2100: No new features are supposed to be added and autosync stops.
21:52 <AlsoItzSwirlz> If we are past feature freeze, then I would manually patch individually Ubuntu
21:52 <utkarsh2102> how would you add a feature after the feature freeze then?
21:52 <AlsoItzSwirlz> utkarsh2102: I wouldn't do that. In the previous context I didn't know you were talking post feature freeze
21:53 <AlsoItzSwirlz> if a debian update had a bug fix, requestsync. if a debian update contained a new feature past feature freeze AND a bug fix, only patch the bug fix in ubuntu
21:54 <utkarsh2102> thanks, no more questions from me. teward, sil2100, kanashiro, feel free to take over^
21:55 <teward> no questions
21:55 <kanashiro[m]> we are almost reaching the top of the hour, no questions from me
21:55 <sil2100> o/
21:55 <sil2100> Okay, let's vote in this case
21:56 <sil2100> #vote ItzSwirlz to get PPU rights for cinamon-related packages (list in application)
21:56 <meetingology> Please vote on: ItzSwirlz to get PPU rights for cinamon-related packages (list in application)
21:56 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
21:58 <utkarsh2102> writing a reason to send along, gimme a sec
22:00 <sil2100> +0 I like the contributions and I like packaging in general, but I'm a bit concerned about some of the answers to questions regaring versioning for SRUs. I would personally love ItzSwirlz to have upload rights, but maybe hone his skills a bit more and then try again in a few weeks. To remove the rough edges
22:00 <meetingology> +0 I like the contributions and I like packaging in general, but I'm a bit concerned about some of the answers to questions regaring versioning for SRUs. I would personally love ItzSwirlz to have upload rights, but maybe hone his skills a bit more and then try again in a few weeks. To remove the rough edges received from sil2100
22:02 <teward> -1 While I've always admired ItzSwirlz's effort for packaging and such in general, I see little to no SRU activity on their sponsorship miner, and only a focus on current versions.  I would like to see a lot more effort in bugfixing in SRUs, not just focus on current-devel-release which seems to be their primary drive.  I would also like to see more knowledge of what various devel processes are for ...
22:02 <meetingology> -1 While I've always admired ItzSwirlz's effort for packaging and such in general, I see little to no SRU activity on their sponsorship miner, and only a focus on current versions.  I would like to see a lot more effort in bugfixing in SRUs, not just focus on current-devel-release which seems to be their primary drive.  I would also like to see more knowledge of what various devel processes are for ... received from teward
22:02 <utkarsh2102> -1; reasons to follow:
22:02 <meetingology> -1; reasons to follow: received from utkarsh2102
22:02 <utkarsh2102> I don't have any doubts in your work or your technical skills and I am sure you'll be a great addition to Ubuntu but I am afraid that having lack of basic Ubuntu process/cycle knowledge (only in certain parts) might cause problems (for instance, in -devel uploads or SRUs, et al). I think you need to work on those bits a little and you'll be perfectly fine in a few weeks. I am happy to sponsor your work meanwhile as well! :)
22:02 <teward> ... namely if you cannot remove a feature addition from a bug, you need to focus on things.  You also need more knowledge of all the overarching devel processes, because they're important for every package.
22:03 <teward> (This is not a permanent -1, I just don't believe you have the knowledge yet to upload on your own, nor the evidence to support knowledge of the dev processes for stable releases *and* devel releases)
22:03 <teward> kanashiro[m]: ?
22:03 <AlsoItzSwirlz> yeah, i only have one devel release patch i've ever done, that is the cinnamon groovy one
22:04 <kanashiro[m]> -1 thanks for all the work you have been doing in the cinnamon remix, I see the impact of all that in the desktop ecosystem. However, I believe you need some more deep understanding regarding versioning and processes. And from your application, I am not still confident you should have access to the archive even for those packages, since you are not used to ask first (you mentioned you do things first and then thing about them).
22:04 <meetingology> -1 thanks for all the work you have been doing in the cinnamon remix, I see the impact of all that in the desktop ecosystem. However, I believe you need some more deep understanding regarding versioning and processes. And from your application, I am not still confident you should have access to the archive even for those packages, since you are not used to ask first (you mentioned you do things first and then thing about them). received from kanashiro[m]
22:04 <kanashiro[m]> I'd wait a bit more, develop a bit more your skills and then apply again. And this should not disencourage you, keep up the good work.
22:04 <AlsoItzSwirlz> ok
22:04 <sil2100> #endvote
22:04 <meetingology> Voting ended on: ItzSwirlz to get PPU rights for cinamon-related packages (list in application)
22:04 <meetingology> Votes for: 0, Votes against: 3, Abstentions: 1
22:04 <meetingology> Motion denied
22:04 <teward> sil2100: that's not enough for a quorate vote, we need the rest of the DMB to weigh in
22:05 <sil2100> It's always a bit sad when a vote is not successful
22:05 <sil2100> Yes
22:05 <teward> so we'll have to move that to ML or next meeting probably.  ML is probably faster
22:05 <sil2100> I'll send out an e-mail to the rest, asking for votes. If not, we'll take it on the next meeting
22:05 <sil2100> #action sil2100 to send out an e-mail requesting for votes from absent DMB members
22:05 * meetingology sil2100 to send out an e-mail requesting for votes from absent DMB members
22:06 <AlsoItzSwirlz> sil2100: one abstained and 3 against, there are a total of 7
22:06 <AlsoItzSwirlz> if the other 3 voted yes it'd be a tie
22:07 <sil2100> ...true, I think I got confused here myself
22:07 <sil2100> AlsoItzSwirlz: eh, sorry about that. I still remember when my first attempt at becoming a MOTU failed, it's never a nice feeling
22:07 <AlsoItzSwirlz> sadge
22:08 <AlsoItzSwirlz> this is actually my first application
22:08 <AlsoItzSwirlz> i joined the ubuntu discourse around feb 2019 i've never applied for anything, haven't gone to any other board
22:08 <sil2100> AlsoItzSwirlz: then treat this as a practice. And return for a successful one in a few!
22:08 <AlsoItzSwirlz> whenever that time will be, thanks to my long school day
22:09 <utkarsh2102> don't hesitate to reach out in case you need help/assistance/sponsorship. :)
22:09 <sil2100> Okay, since we're out of time, let me end the meeting. I'll take the action item of annoucements
22:09 <sil2100> #action sil2100 to follow up on actions for ItzSwirlz's application
22:09 * meetingology sil2100 to follow up on actions for ItzSwirlz's application
22:09 <AlsoItzSwirlz> o/
22:09 <sil2100> #endmeeting