15:01 <ddstreet> #startmeeting Ubuntu Backporters
15:01 <meetingology> Meeting started at 15:01:26 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:01 <meetingology> Available commands: action, commands, idea, info, link, nick
15:01 <ddstreet> #topic previous action items
15:01 <ddstreet> #subtopic ddstreet update tooling, requestbackport, backportpackage (carried over)
15:01 <luna__> Hey backporters
15:01 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
15:01 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
15:01 <ddstreet> hi luna__
15:02 <ddstreet> #subtopic ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:02 <ddstreet> #action ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:02 * meetingology ddstreet get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
15:02 <ddstreet> #subtopic ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:02 <ddstreet> #action ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:02 * meetingology ddstreet look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
15:02 <ddstreet> #subtopic ddstreet send ML reply to continue thread re: clarification on specific wording for no-bug-required backport exceptions
15:02 <ddstreet> this one, i actually did
15:02 <mapreri> saw the mail, ty
15:03 <ddstreet> #subtopic ddstreet finish updating charter/policies, send email to ML to request team review
15:03 <ddstreet> and i did this one as well, and sent an email
15:03 <ddstreet> those both probably should get discussed on the ML, unless either of you want to discuss them now
15:03 <ddstreet> #subtopic ddstreet sched next meeting for aug 31 15:00 UTC
15:03 <ddstreet> i did this one, of course :)
15:04 <luna__> done
15:04 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
15:04 <mapreri> cheer for ddstreet actually doing his tasks!
15:04 <ddstreet> i assume carry all yours mapreri?
15:04 <mapreri> boos for mapreri not doing :(
15:04 <ddstreet> lol, i only did the 2 easiest tasks :)
15:04 <mapreri> pls yap
15:04 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
15:04 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
15:04 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:04 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
15:05 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:05 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
15:05 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
15:05 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:05 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (carried over)
15:05 <ddstreet> #subtopic mapreri start thread on ML about how to use bug status to define meaing in process
15:05 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:05 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process (carried over)
15:05 <ddstreet> ok that's all previous items
15:06 <ddstreet> moving on :)
15:06 <ddstreet> #topic open mailing list items
15:06 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
15:06 <ddstreet> as mentioned before, we should probably keep this on the ML
15:06 <mapreri> still in inbox, yes.
15:06 <ddstreet> but please let's all remember to reply before next mtg :)
15:06 <ddstreet> #action clarification on specific wording for no-bug-required backport exceptions
15:06 * meetingology clarification on specific wording for no-bug-required backport exceptions
15:07 <ddstreet> #subtopic charter/policies
15:07 <luna__> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-February/022680.html
15:07 <ddstreet> thanks luna__!
15:07 <luna__> a bit to slow with the copy and paste tough
15:07 <ddstreet> this will need review from you both, so no need to discuss now, but hopefull we can finalize it on the ML and/or by next mtg
15:08 <ddstreet> ok that's all the ml threads, unless i'm missing something
15:08 <luna__> #link https://lists.ubuntu.com/archives/ubuntu-backports/2022-August/022925.html
15:08 <ddstreet> ah thanks again :)
15:09 <ddstreet> #topic open bugs needing discussion
15:09 <mapreri> haven't even looked at what's open now :(
15:09 <ddstreet> i reviewed the dh-python bug, and there were some issues there
15:09 <ddstreet> unit193 said it should just be dropped, so i believe teward[m] marked it wontfix
15:10 <luna__> i can't see it as open
15:10 <ddstreet> i dont know of anyone here thinks it might be worth looking into backporting it
15:10 <ddstreet> #link https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1983414
15:10 <ubottu> Launchpad bug 1983414 in dh-python (Ubuntu) "[BPO] dh-python 5.20220403 to focal" [Undecided, Fix Released]
15:11 <luna__> yep teward teward[m] has indeed closed it as not fixing
15:11 <teward[m]> ddstreet: correct i did a won'tfix on one of the bugs because Unit mentioned in the message it should be dropped given $REASONS
15:11 <ddstreet> the main issue, at least from my relatively quick review, was the py2 dh_python2 script, which did a pkg move, so that would need to be properly handled in the backport
15:11 <mapreri> holed on
15:11 <mapreri> the main reason behind that bpo was to have the pyproject support, right?
15:11 <mapreri> IIRC
15:11 <ddstreet> yep that's my understanding
15:12 <ddstreet> and that would require a few other backports for deps
15:12 <teward[m]> "This is needed to refresh the yt-dlp package as it has support for 'environment markers'"
15:12 <mapreri> I understand that such reason still stands, so I think I'd want to look at it as imho it makes sense to have
15:12 <teward[m]> pybuild-plugin-pyproject <-- not tested
15:12 <mapreri> ddstreet: what's "a few"?
15:12 <ddstreet> #link https://bugs.launchpad.net/ubuntu/+source/dh-python/+bug/1983414/comments/1
15:12 <ubottu> Launchpad bug 1983414 in dh-python (Ubuntu) "[BPO] dh-python 5.20220403 to focal" [Undecided, Fix Released]
15:12 <ddstreet> i listed the deps in my comment
15:13 <ddstreet> specifically, python3-{build,installer,tomli} packages
15:13 <ddstreet> which aren't available in focal.
15:13 <mapreri> doesn't sound like a goal-blocker to me, just bpo those all?
15:13 <ddstreet> yeah i think it's quite doable
15:13 <mapreri> also I'm not sure there is a problem with the python2 thing?
15:14 <ddstreet> but just would need someone to do the dep backports, and properly adjust the backported dh-python package
15:14 <mapreri> I don't see having the bpo package be uninstallable with something in the main suite as a problem?
15:14 <ddstreet> you mean the conflicts with python2?
15:14 <mapreri> yep
15:14 <ddstreet> i mean i'd certainly prefer to address that, no?
15:15 <mapreri> or, indeed, if that's only for dh_python2 is trivially solvable sure, but anyway, even if unsolved I don't think it's a blocker to me?
15:15 <ddstreet> but then users of the backported dh-python would not be able to run any py2 script
15:15 <mapreri> it's certainly preferable yes
15:15 <mapreri> I'm mostly trying to understand how you feel about that particular point
15:16 <ddstreet> personally, i think it should be fixed
15:16 <ddstreet> i mean, if dh-python was actually *providing* python2, then that might be ok, but it's conflicting (which will force removal) of python2 only due to a single dh_python2 script
15:17 <ddstreet> i think the right approach is to remove the dh_python2 from the backport, and remove the Conflicts: python2
15:17 <mapreri> if it's only for that single script, it's probably best to drop it from dh-python yes
15:17 <mapreri> it's B+R, not conflicting iiuc
15:17 <mapreri> anyway, I got your point
15:17 <ddstreet> that's certainly my preference, but it will depend on the details once someone gets into doing it
15:17 <ddstreet> right B+R sorry
15:18 <mapreri> I doubt I'd be able to pick up, but since it's something that might make sense to have, if unit193 wants to pick it up again at least I know your position :)
15:18 <mapreri> (as I will tell him that I'm all for it and not give up just after one review!)
15:18 <ddstreet> so should we reopen the bug, and/or add an action item for us to look at it?
15:19 <ddstreet> yeah my review didn't mean to shut his work down
15:19 <mapreri> I think it's fine as it is, I'll more informally poke him
15:19 <ddstreet> ok hopefully we won't forget about it :)
15:20 <ddstreet> i guess if he wants to backport yt-dlp anymore, he'll need to either fix that backport, or work on dh-python backport :)
15:20 * mapreri just did
15:20 <mapreri> IRC++
15:20 <ddstreet> also fyi, i did approve one of his yt-dlp backports, which failed due to dh-python dep missing
15:20 <mapreri> so it's bd-uninst atm?
15:21 <ddstreet> #link https://launchpad.net/ubuntu/+source/yt-dlp/2022.08.19-1~bpo20.04.1
15:21 <mapreri> doesn't look failed to me?
15:21 <mapreri> sorry, wrong page
15:21 <mapreri> meh
15:22 <mapreri> feel free to action me to poke him some more on this
15:22 <mapreri> I think this is the first time.  how harsh should we be about unbuilt packages?
15:22 <ddstreet> #action mapreri poke unit193 about yt-dlp dep on dh-python
15:22 * meetingology mapreri poke unit193 about yt-dlp dep on dh-python
15:23 <ddstreet> well, he did upload both yt-dlp *and* dh-python, so if i'd accepted dh-python, then the yt-dlp upload would have built
15:23 <ddstreet> so it's partially my fault for not realizing that before i accepted the yt-dlp upload
15:23 <luna__> accept and rebuild?
15:23 <ddstreet> buuuuut it certainly would have been better for him to not upload yt-dlp until dh-python was accepted
15:23 <mapreri> I kind of believe this should go in that page describing when an upload is acceptable without a tracking bug report
15:24 <ddstreet> luna__ yeah, if we do finally accept the dh-python backport, we can just do a rebuild of the yt-dlp
15:24 <mapreri> if it requires special attention and the uploader knows of it, I reckon a bug is warrented.
15:24 <luna__> ddstreet: sounds good
15:24 <mapreri> (in fact, no rebuild is needed, lp would pick it up by itself since it's in bd-uninst)
15:24 <ddstreet> mapreri yep i agree, the previous yt-dlp uploads have been bugless which i think was fine, but yeah once there's any complexity like this, we do need a bug
15:24 <mapreri> (i think at least)
15:24 <luna__> ah
15:25 <ddstreet> ah didn't know it would automatically rebuild
15:25 <mapreri> it's not a *re*build after all
15:25 <ddstreet> right :)
15:25 <ddstreet> didn't build at all yet :)
15:25 <luna__> true
15:25 <ddstreet> ok, anything else for that bug?
15:26 <mapreri> none from me
15:26 <luna__> not from me
15:26 <ddstreet> #link https://bugs.launchpad.net/ubuntu/+source/elfutils/+bug/1987356
15:26 <ubottu> Launchpad bug 1987356 in elfutils (Ubuntu) "[BPO] elfutils/0.187-1 from Kinetic" [Undecided, Fix Committed]
15:26 <ddstreet> i think this one is done and published, does it just need to move to fix-released?
15:27 <ddstreet> i'll go ahead and mark it as such, since it does seem released
15:27 <luna__> https://packages.ubuntu.com/jammy-backports/elfutils ?
15:27 <mapreri> seems like you just did lol
15:28 <luna__> seems to be in the repos
15:28 <ddstreet> and there are 2 more bugs, but both appear to need a sponsor
15:28 <ddstreet> #link https://bugs.launchpad.net/ubuntu/focal/+source/ipmctl/+bug/1968076
15:28 <ubottu> Launchpad bug 1968076 in ipmctl (Ubuntu Focal) "[BPO] ipmctl with support for CPS hardware" [Undecided, New]
15:28 <ddstreet> #link https://bugs.launchpad.net/ubuntu/jammy/+source/limnoria/+bug/1983415
15:28 <ubottu> Launchpad bug 1983415 in limnoria (Ubuntu Jammy) "[BPO] limnoria 2022.6.23-1 to jammy" [Undecided, New]
15:29 <mapreri> tbh, I would rather not look at anything more right now, as I have another meeting coming up on the hour and I'd like to prepare for it :3
15:29 <ddstreet> ack, i think we can leave the unsponsored ones alone
15:29 <ddstreet> ok that's all open bugs
15:30 <ddstreet> #topic AOB
15:30 <ddstreet> anything else from anyone?
15:30 <ddstreet> luna__ you have any topics?
15:30 <luna__> nope
15:30 <ddstreet> ok final subtopic then, next meeting
15:30 <ddstreet> #subtopic next mtg date
15:30 <ddstreet> 1 month from now?
15:31 <mapreri> mh
15:31 <ddstreet> sep 28?
15:31 <luna__> works for me
15:31 <mapreri> 28 is looking crowded for me, what about oct 5 instead?
15:31 <ddstreet> oct 5 works for me
15:31 <luna__> have another meeting 5th Oct, but i don't do much backports work just curious so its okay to go without me
15:31 <mapreri> (I also have a bit of travel the week before, that's why I'm not suggesting sep 21)
15:32 <mapreri> mind you, I *can* do sep 28th, it's just that my agenda will look messy :3
15:32 <mapreri> teward[m]: ?
15:32 <teward[m]> no issue of oct 5, sept. 28 is a no go
15:33 <ddstreet> let's do oct 5 then
15:33 <ddstreet> same time, 15:00 UTC
15:33 <mapreri> that makes it easy i guess
15:33 <mapreri> sure
15:33 <ddstreet> luna__ if you have interest in joining backporters team, feel free to let us know in a mtg or ML :-)
15:34 <ddstreet> #action ddstreet schedule next mtg Oct 5 15:00 UTC
15:34 * meetingology ddstreet schedule next mtg Oct 5 15:00 UTC
15:34 <luna__> will think about it and do if so
15:34 <ddstreet> ok i think that's all the topics, last chance for anything else?
15:34 <ddstreet> #endmeeting