19:05 <rbasak> #startmeeting Ubuntu Technical Board
19:05 <meetingology> Meeting started at 19:05:05 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:05 <meetingology> Available commands: action, commands, idea, info, link, nick
19:05 <vorlon> rs2009: community members are welcome to edit the wiki page to add things to our agenda; but we would normally at least cover this under email follow-up
19:06 <rs2009> sure vorlon, just added it
19:06 <rbasak> Why don't we start with Unity, as rs2009 and saif are here?
19:06 <rbasak> #topic Ubuntu Unity's official flavor proposal
19:07 <rs2009> here's our proposal: https://wiki.ubuntu.com/UbuntuUnity/22.10/Proposal
19:07 <rs2009> I also sent an email regarding this yesterday
19:07 <rbasak> Following the recent thread on the techboard ML, we've been looking into how to make the new flavour process better and clearer. But that's still a work in progress.
19:07 <rbasak> So some of this is still in flux.
19:07 <vorlon> the proposal looks good to me overall, just a few things that I think it's important to lock down vs the policy
19:07 <vorlon> rbasak: right, I'm assuming we should be using the current wiki page for assessing this flavor proposal
19:08 <rbasak> I'm fine with that in principle, but the current wiki page doesn't really define who does what.
19:08 <rbasak> I'm not that familiar with the details, and also IMHO this kind of thing should be delegated to the release team. So I'd like to essentially leave this to you for now.
19:09 <sil2100> I'm also in general +1 on the flavor proposal, and I'm happy to see the progress they made towards this goal
19:09 <rbasak> If you're happy, I'm happy. I figure we just need a list of todos for the Unity team.
19:10 <sil2100> Should we do a formal vote for acknowledging the new flavor in-progress?
19:10 <vorlon> governance-wise I think the TB is who should be signing off on flavors
19:10 <vorlon> but leaning on the release team for specifics is fine
19:10 <rbasak> I agree the TB should have final sign-off. But yes - I'd like to do that only if the release team have examined and that they are happy.
19:10 <rbasak> But +1 in principle, of course.
19:11 <vorlon> rs2009: one thing we need to hear is that seb128 is willing to be officially the uploader for the flavor (as opposed to just an Ubuntu developer who pitches in)
19:13 <rs2009> vorlon: I understand. He's been the MOTU who's been uploading the packages all these years and is already the official uploader of the packages
19:14 <rs2009> in fact, he told me just yesterday that he's in the process of uploading the latest Unity 7.6 packages to kinetic
19:14 <vorlon> rs2009: otherwise, I think the next steps are for you to go through the sections on https://wiki.ubuntu.com/RecognizedFlavors labeled "Guidelines to have an image added to dailies" and "Guidelines to become and remain a recognized flavor" and confirm that you're meeting all these requirements (and document in your proposal how they are met).  For Release Team, please coordinate in #ubuntu-release
19:14 <vorlon> on IRC
19:14 <vorlon> and you can consider the IS check-off done, we know have the space right now
19:15 <rs2009> sure, we've gone through the sections and I can confirm that we've already completed all the steps under "Guidelines to become and remain a recognized flavor"
19:15 <rs2009> (we have actually been planning this since two years)
19:15 <saif> As a flavour that was once the main face of Ubuntu,  with an established infrastructure, Unity should clearly be on the official flavour list. It defined ubuntu  and distinguished it from others with a passionate following despite everything that ha
19:16 <saif> Etc...
19:17 <vorlon> rs2009: right - can you document this explicitly on the wiki page?  E.g. "Leading members have signed Ubuntu Code of Conduct" can you point on the wiki page to who has signed the CoC?
19:17 <rs2009> sure, I'll do it right away. Leading members are me and Khurshid, and we've already signed the CoC
19:18 <rs2009> our QA lead, Maik, is an Ubuntu member and has also signed the CoC
19:18 <vorlon> saif: I appreciate the sentiment, but software stacks change over time, and it is not a foregone conclusion that it be an official flavor because there's a community that liked the UX - we have a process :)
19:18 <vorlon> I think that covers us for next steps on ubuntu-unity then
19:19 <rbasak> rs2009: are you clear on your next steps? Any other questions?
19:19 <rbasak> Please do ask on the mailing list if you get stuck with anything.
19:20 <rs2009> rbasak: yep, I am. thanks :) will the voting happen today?
19:20 <rbasak> I think all steps need to be complete before we make a final decision.
19:20 <vorlon> agreed
19:21 <vorlon> wiki page updated, confirmation from seb128 that he's agreeing to be on the hook
19:21 <sil2100> rs2009: but in general, so far you are on track, so don't worry!
19:21 <sil2100> Hopefully this will just be a formality
19:22 <rbasak> Agreed. I think everyone is happy with this being an official flavour in principle. It's just about the technical arrangements and ensuring that there are enough qualified developers to be able to support it, etc.
19:22 <rs2009> vorlon: I just completed the steps
19:22 <rs2009> I've updated the proposal with all the needed info
19:23 <rbasak> I don't see a statement of commitment _from_ seb128?
19:24 <rs2009> oh, I'll get a statement from him. Will try to do it while this meeting is on
19:24 <rbasak> Sure, thanks.
19:24 <rbasak> I think he's busy in European evenings though. But feel free to try :)
19:24 <rbasak> #topic Action review
19:24 * rbasak (everyone) review the Ubuntu Backports Team Charter for ratification
19:25 <rbasak> This needs carrying over still I think.
19:25 <rbasak> #action (everyone) review the Ubuntu Backports Team Charter for ratification
19:25 * meetingology (everyone) review the Ubuntu Backports Team Charter for ratification
19:25 * rbasak rbasak to finalize third-party seeded snap security policy
19:25 <rbasak> I'll discuss this under its own topic
19:25 * rbasak vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:25 <rbasak> Blocked on the above
19:25 * rbasak sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:25 * vorlon nods
19:25 * rbasak rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:25 <rbasak> This needs carrying over still
19:25 <rbasak> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:25 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:26 * rbasak cyphermox to re-ping the CC regarding the TB nominations and election
19:26 <rbasak> cyphermox, sil2100: any updates please?
19:26 <Eickmeyer> CC member here, sorry about that, if I have to run the elections on that, I will.
19:26 <sil2100> My action item is still in the works...
19:26 <Eickmeyer> Most of the CC has been very absent as of late, unfortunately.
19:27 <rbasak> Right now we're one member down, and the remainder's terms expire at the end of this year.
19:28 <rbasak> With the Christmas/New Year shutdown in the way, it might be an idea to try to gather the full set of nominations all at once, but up to you.
19:28 <rbasak> Thanks Eickmeyer  :)
19:28 <rbasak> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:28 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:29 <rbasak> I guess we'll carry over cyphermox's action for now then.
19:29 <Eickmeyer> rbasak: I'll see what I can do. We've been pinged by Phil with little response. Only a couple of us have been very active lately, and it's been trying on us to do all of the lifting.
19:29 <rbasak> #action cyphermox to follow up with the CC regarding the TB nominations and election
19:29 * meetingology cyphermox to follow up with the CC regarding the TB nominations and election
19:29 <rbasak> #topic Definition of our third party repository policy. See https://docs.google.com/document/d/1apUKR4gtOrfPGCWmtoebaQUhoy-fG8Cyo3VKJyhnpD0/edit
19:30 <rbasak> #link https://docs.google.com/document/d/1apUKR4gtOrfPGCWmtoebaQUhoy-fG8Cyo3VKJyhnpD0/edit#
19:30 <rbasak> I've been making good progress here. I think I'm now running up against needing to speak to individual snap maintainers, and also get a few other bits from other TB members please.
19:30 <vorlon> which bits do you need from us?
19:30 <rbasak> It's all for the snap specific stuff that is Appendix A
19:31 <rbasak> The specifics of how snap channels and branches needs to be documented here. sil2100 had some input, and so does https://wiki.ubuntu.com/UbuntuSeededSnaps
19:32 <rbasak> Next, should we remove cyphesis-cpp and ember and add them to the sync blocklist as they're pulling in snaps?
19:32 <rbasak> I will contact the maintainers first of course.
19:33 <vorlon> is it ok for us to review these questions offline after the meeting?
19:33 <rbasak> But then, does it need to be our policy that it's not OK for us to sync Debian packages that do this without someone in Ubuntu advocating for their inclusion and ensuring that they meet our requirements?
19:33 <rbasak> Sure
19:34 <rbasak> I'll add some comments pointing out these bits to the doc then I guess.
19:35 <rbasak> (done)
19:36 <rbasak> I think the final thing is: are we now ready and committed enough to this plan to start speaking to snap owners on bringing existing snaps into alignment with this draft policy?
19:36 <vorlon> I think so yes
19:36 <rbasak> OK. Thanks!
19:36 <rbasak> I'll start arranging that next.
19:37 <rbasak> Any other comments on this topic?
19:37 <rbasak> #action rbasak to finalize third-party seeded snap security policy
19:37 * meetingology rbasak to finalize third-party seeded snap security policy
19:37 <rbasak> #action vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:37 * meetingology vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:37 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:38 <rbasak> "Reviving the patch pilot program"
19:38 <rbasak> I'm already speaking to Philipp on this and have volunteered my TB hat.
19:38 <rbasak> "Ubuntu Technical Board at the Ubuntu Summit 2022"
19:38 <rbasak> Same here
19:39 <rbasak> "New Official Flavor Process Issues" continues - I'm in touch with those involved.
19:39 <rbasak> I think that's all recent ML activity covered.
19:39 <rbasak> Is there anything I've missed?
19:39 <rbasak> #topic Check up on community bugs (standing item)
19:39 <rbasak> #info
19:39 <rbasak> There are currently no open bugs.
19:39 <rs2009> I haven't yet received a response from seb128. would it be okay if I get the confirmation by tomorrow and then ping y'all to request for a voting?
19:40 <rbasak> rs2009: there's no rush. I'm happy to vote by email. The blocker for my vote is people on the release team (eg. vorlon, sil2100) confirming that they consider you to be ready.
19:41 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:41 <rbasak> It'll be sil2100 with cyphermox as backup.
19:41 <rbasak> #topic AOB
19:41 <rbasak> AOB?
19:41 <Fallen> I wanted to check in if you have put some thoughts in to tracking the TB work e.g. on launchpad?
19:42 <sil2100> o/
19:42 <rbasak> I'd be quite happy with a Launchpad project dedicated to this.
19:43 <rs2009> Khurshid is suggesting that he would be willing to be the official uploader for Ubuntu Unity as a flavor if given universe upload rights
19:44 <rs2009> if that's okay, Khurshid is willing to send a confirmation right away
19:44 <sil2100> rs2009: does Khurshid have upload rights to universe right now already?
19:45 <rbasak> rs2009: that's fine, but first he's got to get those rights.
19:45 <vorlon> rs2009: the policy requires that someone already be approved as an uploader stand for the flavor
19:45 <sil2100> We encourage to apply for MOTU via the DMB if anything!
19:45 <rbasak> There's a process for getting uploader status. It involves demonstrating capability and competency.
19:46 <rbasak> So please do get that - but I don't think you can fulfil this requirement on the new flavour proess without having it first.
19:46 <rbasak> We'd like to help you do that!
19:46 <rbasak> But it's not an immediate thing.
19:47 <rs2009> Khurshid doesn't currently have upload rights, but he's an experienced member and just suggested this so thought of checking with y'all. I'll get a confirmation from seb128 or Dimitri from the Compiz team and get back (will send it to the release team tomorrow)
19:47 <sil2100> rs2009: excellent o/
19:47 <rbasak> Great. Thanks!
19:47 <rbasak> Any other AOB?
19:48 <rbasak> #endmeeting