19:21 <sil2100> #startmeeting Developer Membership Board
19:21 <meetingology> Meeting started at 19:21:24 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:21 <meetingology> Available commands: action, commands, idea, info, link, nick
19:21 <teward> we did mattia.  frank is xo
19:21 <teward> continjed to today*
19:21 <rbasak> I think he said he was on vacation?
19:21 <sil2100> #topic Ubuntu Core Developer Applications
19:21 <rbasak> IIRC I asked him to update us with a new date
19:22 <teward> and new applicant athos
19:22 <sil2100> Let's start off with the person here
19:22 <teward> rbasak: ack
19:22 <sil2100> #subtopic Athos Ribeiro
19:22 <sil2100> athos: o/
19:22 <athos> o/
19:22 <sil2100> athos: hello! Could you please introduce yourself?
19:22 <sil2100> #link https://wiki.ubuntu.com/AthosRibeiro/UbuntuCoreDeveloperApplication
19:22 <athos> Hello! I am a software engineer @ canonical working in the server team. Mostly working on ROCKs, PHP, and PostgreSQL atm. You can find more details on the application page :)
19:23 <rbasak> As I always do for colleagues, I'll abstain unless required to vote for quorum and everyone else is anonymous.
19:23 <sil2100> Excellent. Let's take 5 minutes in case DMB members need a moment to browse the application (like me for instance)
19:25 <lucaskanashiro[m> I'll follow rbasak on that
19:26 <bdmurray> Given the number of members here won't we need your votes?
19:26 <rbasak> Yeah maybe. Let's see what everyone else thinks first though.
19:27 <teward> if we have abstains from lucaskanashiro[m and rbasak then we are not quorate for this application
19:27 <rbasak> > unless required to vote for quorum and everyone else is anonymous.
19:28 <lucaskanashiro[m> sorry, I did not check the quorum. If needed I'll vote
19:28 <sil2100> Okay, do we have any questions fot athos ?
19:29 <sil2100> athos: have you worked on any transitions other than the PHP8.1 one (as mentioned by Bryce's endorsement)?
19:31 <athos> not really. I could fing no opportunities for any lately :) I did perform one or 2 no-change rebuilds that were missing from the ICU 70 soname bump though
19:31 <sil2100> athos: okay! Just a quick check up then: how can transitions be started? What usually happens?
19:31 <athos> and while this is not a transition, I also performed a bootstrap for sbcl a couple weeks ago (ppc64el) which required a few reverse deps rebuilds.
19:33 <sil2100> (aka. what event can 'trigger' a transition)
19:33 <athos> well, let's say there is a soname bump in a lib. Ideally the developer performing the upload should communicate stakeholders about the transition and verify the work needed for that (checking reverse deps). After the upload (trigger) the fun starts. no change rebuilds, debuging, verifying dep8 tests, etc
19:35 <athos> btw, the ubuntu maintainer handbook has a nice page regarding transitions. Before this one was written, I had a hard time finding any docs regarding those (both in debian and in ubuntu): https://github.com/canonical/ubuntu-maintainers-handbook/blob/main/Transitions.md
19:37 <sil2100> Ok thanks!
19:37 <sil2100> Any other questions?
19:38 <sil2100> bdmurray, lucaskanashiro[m, rbasak, teward: ?
19:38 <sil2100> Or should we move to voting?
19:38 <rbasak> No questions from me, thanks (because he's a colleague, etc)
19:38 <lucaskanashiro[m> nothing from me
19:38 <teward> nothing from me
19:38 <bdmurray> athos: What kind of change would require a Feature Freeze excaption?
19:39 <bdmurray> exception
19:40 <athos> changes introducing new features to a package. e.g., we are on feature freeze and there is a new php minor release, which fixes some important bugs, but introduces a new type as well
19:41 <bdmurray> What if there was not a new type?
19:43 <athos> While one could argue there is no new features, only bug fixes, I'd still rather file a FFe since we have a minor version bump and the FFe would also serve the purpose of getting the change reviewed
19:43 <athos> if it was just a single patch being applied, then I would not file the FFe
19:44 <bdmurray> Alright, that's it from me.
19:45 <sil2100> Okay then, let's vote!
19:46 <sil2100> #vote Athos Ribeiro to become an Ubuntu Core Developer
19:46 <meetingology> Please vote on: Athos Ribeiro to become an Ubuntu Core Developer
19:46 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:46 <sil2100> +1
19:46 <meetingology> +1 received from sil2100
19:46 <lucaskanashiro[m> +1
19:46 <meetingology> +1 received from lucaskanashiro[m
19:46 <teward> +1
19:46 <meetingology> +1 received from teward
19:47 <bdmurray> +1
19:47 <meetingology> +1 received from bdmurray
19:47 <sil2100> #endvote
19:47 <meetingology> Voting ended on: Athos Ribeiro to become an Ubuntu Core Developer
19:47 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
19:47 <meetingology> Motion carried
19:47 <sil2100> athos: congratulations!
19:47 <rbasak> Congratulations!
19:47 <sergiodj> athos: yay!
19:47 <sergiodj> :)
19:47 <sarnold> congratulations athos :)
19:47 <athos> thanks! :)
19:47 <sil2100> #action sil2100 to add athos to the ubuntu-core-dev team
19:47 * meetingology sil2100 to add athos to the ubuntu-core-dev team
19:48 <sil2100> #action sil2100 to announce athos's successful application
19:48 * meetingology sil2100 to announce athos's successful application
19:48 <sil2100> Okay, let's quickly move on
19:48 <sil2100> #topic Review of previous action items
19:49 <sil2100> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:49 <sil2100> Is that still ongoing? If yes, let's carry over!
19:49 <teward> unless someone wants to do that instead, carry over
19:49 <sil2100> I'll carry over, but anyone with free cycles please feel free to pick this up
19:50 <sil2100> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:50 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
19:50 <sil2100> #topic Outstanding mailing list requests to assign
19:50 <sil2100> I don't think we have any?
19:50 <sil2100> Please correct me if I'm wrong
19:51 <sil2100> #topic AOB
19:51 <sil2100> (since no Open TB bugs)
19:51 <sil2100> Anything we want to talk about?
19:52 <sil2100> I don't think I have anything
19:52 <teward> nothing here
19:52 <sil2100> #endmeeting