16:02 <ddstreet> #startmeeting Ubuntu Developer Membership Board
16:02 <meetingology> Meeting started at 16:02:23 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:02 <meetingology> Available commands: action, commands, idea, info, link, nick
16:02 <teward> but can weigh in on apps
16:02 <teward> so o/
16:02 <ddstreet> let's start with the chairing list, for members who haven't caught up on email after the holidays yet
16:03 <ddstreet> (even though it's later in the agenda, hopefully it won't take long)
16:03 <ddstreet> #topic DMB rotating chair list
16:03 <ddstreet> #link https://lists.ubuntu.com/archives/devel-permissions/2021-December/001845.html
16:03 <ddstreet> the replies were positive, so I updated the agenda page
16:03 <ddstreet> does any member have any objections to bring up to the new chair list?
16:04 <ddstreet> rbasak do you want to be included in the chair list?
16:04 <ddstreet> currently it's just sil2100 and myself
16:04 <rbasak> I'm happy to chair but can't when I have a concurrent meeting, like right now.
16:04 <rbasak> I don't know how that works with a specific list and expectations on such a list.
16:05 <ddstreet> ack, let's leave you off the chair list then, but i dont think anyone will have any problem if you want to chair on any specific mtg date and volunteer to
16:05 <ddstreet> ok moving on, no previous action items to review (besides long-term ones)
16:05 <ddstreet> #topic PPU application from Luca Boccassi
16:06 <ddstreet> bluca you around?
16:06 <bluca> hi
16:06 <ddstreet> Hello! can you introduce yourself?
16:06 <bluca> sure!
16:06 <ddstreet> #link https://wiki.ubuntu.com/bluca/PerPackageUploaderApplication
16:06 <bluca> I put details on that wiki link, but in short: I'm a software eng by trade, currently working at msft
16:06 <bluca> been a debian developer since ~2017 with upload rights
16:07 <bluca> been working with various folks from Canonical on a few packages, like src:dpdk, and would like to step up the collaboration and effort with PPU
16:07 <bluca> that's the short version :-)
16:07 <ddstreet> thanks! I'll give some time for rbasak and sil2100 to review the application details
16:08 <ddstreet> and as you saw, I did already review everything over email and provided my +1 on the ML
16:08 <rbasak> bluca: thank you for looking after you packages in Ubuntu! I'm concerned though that there's a mismatch of expectations in your application though. Giving upload access to DDs for their packages in Ubuntu isn't automatic. It's predicated on the applicant having a demonstrated understanding of Ubuntu-specific processes. But I don't see much (if any) evidence of that in your application. Is it your
16:08 <rbasak> view that you meet this requirement already?
16:08 <ddstreet> oh and time for teward to review application as well, sorry teward i just saw you joined
16:09 <bluca> I believe so - now I'm not the greatest expert (yet) but I have been working with other folks like cpaelzer who constantly show me the ropes w.r.t. ubuntu-specific processes
16:09 <bluca> I do u nderstand the different requirements, schedule cadence, timing, channels that ubuntu has w.r.t. debian, for example
16:09 <bluca> (eg: sru processes for stable fixes)
16:11 <bluca> I do not plan to go gun-blasting, but start slowly and asking for help when in doubt
16:11 <rbasak> https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=*Boccassi*&sponsoree_search=name is the list of sponsored uploads you have already.
16:11 <rbasak> There I see one backport, and a single SRU that took two uploads to get right I think?
16:11 <sil2100> I'm still reading the application, if anything. I have a concurrent meeting right now + just got back from holidays
16:12 <cpaelzer> Saw the highlight, indeed I can confirm that bluca does really well whatever he does. And TBH the ubuntu-specifics I told him he knows, and I'm very sure that he'd ask if he runs into something unknown.
16:12 <bluca> yes - given cpaelzer has full upload rights, he does the uploads himself when we work on src:dpdk
16:12 <rbasak> In the SRU bug, it looks like your upload needing quite a bit of correcting on the Ubuntu-specific procedural details - like you didn't know them at all at the time.
16:12 <cpaelzer> That isn't a core-dev application where we expect that he knows all forward and backward, I'm rather confident he will do really well with what he applies for here
16:12 <rbasak> eg. https://bugs.launchpad.net/ubuntu/+source/azure-cli/+bug/1897586/comments/4
16:12 <ubottu> Launchpad bug 1897586 in azure-cli (Ubuntu Focal) "azure-cli: global import of antlr4 for optional sub-feature" [Undecided, Fix Released]
16:13 <rbasak> I very much appreciate your contributions to Ubuntu here.
16:13 <bluca> yes - all learning experiences :)
16:13 <rbasak> But the usual expectation is to see a track record of generally correct Ubuntu uploads with respect to Ubuntu-specific process. I don't see that at all here.
16:14 <rbasak> So feel free to correct me if I'm mistaken or missing something, but I would like to see that track record in the form of sponsored uploads before granting this request.
16:15 <bluca> sure, it will require annoying cpaelzer a bit more :-P but it can happen
16:15 <sil2100> I guess bluca is a debian developer, right?
16:15 <bluca> y
16:16 <rbasak> What I generally suggest is to deliberately make the new developer prepare all the uploads.
16:16 <rbasak> And get them sponsored.
16:16 <rbasak> That helps build up a demonstrated track record and helps give everyone else confidence about their understanding too.
16:16 <rbasak> I appreciate you're a DD so I have no concern about the quality of your work in general - this is just for the Ubuntu-specific bits.
16:17 <bluca> the way we usually work on src:dpdk is that I upload to Debian and Christian to Ubuntu to make things faster - but there's no harm in me doing a few more sponsored uploads for the coming LTS changes and so on
16:17 <bluca> so that's not a problem at all
16:18 <rbasak> I would prefer that as it would force you to do all the Ubuntu-specific bits yourself, which would demonstrate that you do understand them.
16:18 <bluca> makes sense
16:19 <rbasak> Anyway, that's just my opinion. I only have one vote :)
16:20 <rbasak> And I'd like to reiterate that I very much appreciate and value your contribution. Just that I'd prefer the Ubuntu-specific bits that you do to be reviewed until you have a demonstrated record of getting them right, and that's what's missing at the moment. The mechanism we use for that is sponsorship :)
16:20 <ddstreet> teward sil2100 any q from you?
16:20 <sil2100> bluca: regarding that: sorry if this was already answered somewhere, but did you before work on any of the packages from the Ubuntu POV? Like, checking proposed-migration for it, preparing the paperwork etc.?
16:22 <bluca> in terms of ubuntu-specific paperwork, I worked on it directly myself only a couple of times that were linked above - getting some late bug fixes in 20.04 before it shipped, and getting a new backport in focal
16:23 <sil2100> bluca: to know a bit more if you'd be able to shepheard packages by yourself - once you upload some package to, let's say, Ubuntu jammy, and you see that your package is stuck in jammy-proposed and not moving: how would you investigate?
16:24 <bluca> (maybe it was after it shipped? there was some bug in openconnect, memory is faint at this point)
16:25 <sil2100> *shepherd
16:26 <bluca> it would depend if it's a new (binary: or source: new) package I guess - if it is, if I remember correctly it's at that step that it needs an ack, like ftp-new in debian
16:26 <bluca> if it's not new, I'd go and look at the process on the wiki, as I don't remember it off the top of my head - and if I get stuck, I'd ask for help from the friendly collaborators on irc :-)
16:27 <bluca> I can't remember if it's at that stage or another that autopkgtest gates migration, but that's one of the obvious things to look at
16:29 <ddstreet> teward sil2100 rbasak any further questions or comments?
16:29 <rbasak> No more questions from me thanks
16:30 <ddstreet> ok let's move to a vote then
16:30 <teward> none from me sil and robie asked wbat i was gonna ask
16:30 <teward> fyi still on via my phone so replies are slower
16:31 <ddstreet> #vote Grant Luca Boccassi PPU rights
16:31 <meetingology> Please vote on: Grant Luca Boccassi PPU rights
16:31 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:31 <rbasak> -1 for reasons already stated. I'd very much appreciate you continuing to work with existing sponsors and build up that track record so that I can vote +1 for you in the near future!
16:31 <meetingology> -1 for reasons already stated. I'd very much appreciate you continuing to work with existing sponsors and build up that track record so that I can vote +1 for you in the near future! received from rbasak
16:31 <ddstreet> +1 i voted on the ML already, with my reasoning
16:31 <meetingology> +1 i voted on the ML already, with my reasoning received from ddstreet
16:33 <teward> -1 after review of your answers I believe a little more time with sponsors to build your track record of uploads and process knowledge will help.  I hope with that we can +1 you in the future, but for now I need to see more of a track record.
16:33 <meetingology> -1 after review of your answers I believe a little more time with sponsors to build your track record of uploads and process knowledge will help.  I hope with that we can +1 you in the future, but for now I need to see more of a track record. received from teward
16:33 <teward> sil2100:
16:33 <sil2100> +0 sadly I have to abstain here. I still think that bluca should be able to do the right thing when needed, but maybe I'd like to see a bit more playing around with Ubuntu packages themselves, like watching proposed-migration - as this is always a bit of a different thing
16:33 <meetingology> +0 sadly I have to abstain here. I still think that bluca should be able to do the right thing when needed, but maybe I'd like to see a bit more playing around with Ubuntu packages themselves, like watching proposed-migration - as this is always a bit of a different thing received from sil2100
16:34 <ddstreet> #endvote
16:34 <meetingology> Voting ended on: Grant Luca Boccassi PPU rights
16:34 <meetingology> Votes for: 1, Votes against: 2, Abstentions: 1
16:34 <meetingology> Motion denied
16:34 <ddstreet> so *technically* the vote isn't denied, since we are missing 3 members
16:35 <bluca> it's ok, I can do sponsored uploads for a couple of months and resubmit :)
16:35 <ddstreet> but it would require a unanimous +1 from the remaining 3 members to approve, and 2 of them are not active anymore
16:35 <ddstreet> yep i think that's the best course of action :)
16:35 <bluca> thanks for the feedback!
16:35 <teward> which brings me to a q at AOB ;P
16:35 <teward> but i will wait for that one
16:35 <ddstreet> i dont think we have anything else, the ML item was discussed at the top
16:35 <ddstreet> #topic AOB
16:35 <ddstreet> teward all yours! :)
16:36 <teward> given two of our members are inactive - one for well over a year at this point - do we need to start looking @ restaffing for the inactives?
16:37 <teward> or at least discuss how to handle this case.
16:37 <ddstreet> since our recent rule for attendance was approved late last year, those 2 members will become 'inactive' at the first meeting in Feb
16:37 <teward> since we're here i bring it uo as a questio  but not needing today's action
16:38 <ddstreet> meaning, yes, we should plan to replace them ASAP after the 2022-02-07 meeting
16:38 <teward> especially since i am heading back in to the eye doc's chair now.  o/
16:38 <sil2100> bluca: from my POV, I guess even if you'd just take a look at our ProposedMigration process, try to play around with it a bit, it should be a +1 then ;)
16:38 <sil2100> (at least from me)
16:38 <teward> ddstreet: 👍
16:38 <sil2100> ddstreet: +1
16:39 <ddstreet> teward i can add an action item for the 2022-02-07 mtg to schedule a new vote for their seats
16:40 <ddstreet> #action ddstreet add item for 2022-02-07 meeting to schedule vote for 2 open seats
16:40 * meetingology ddstreet add item for 2022-02-07 meeting to schedule vote for 2 open seats
16:40 <teward> ddstreet: yep that will work
16:40 <ddstreet> ok anythign else from anyone?
16:41 <ddstreet> let's call it then
16:41 <ddstreet> #endmeeting