16:02 <ddstreet> #startmeeting Ubuntu Backporters
16:02 <meetingology> Meeting started at 16:02:15 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:02 <meetingology> Available commands: action, commands, idea, info, link, nick
16:02 <mapreri> sure
16:03 <ddstreet> for the action items of mine, i won't mention the ones that are done (i'll just remove them when i edit the page)
16:03 <ddstreet> #topic ddstreet email ubuntu-devel list to announce re-opening of backports (carried over)
16:03 <ddstreet> not yet :(
16:03 <ddstreet> i was thinking maybe this should wait until we update backportpackage, to possibly avoid anyone's confusion with using it?
16:03 <ddstreet> in any case, the announcement probably can wait until jan
16:04 <ddstreet> #action ddstreet email ubuntu-devel list to announce re-opening of backports (carried over)
16:04 * meetingology ddstreet email ubuntu-devel list to announce re-opening of backports (carried over)
16:04 <mapreri> imho we can do regardless of backportpackage, just mentioning it it's still not ready
16:04 <ddstreet> ack
16:04 <mapreri> should we open a proper bug(s) against u-d-t for these things, assigned to the proper people, etc? :)
16:04 <ddstreet> yeah that's probably a good idea
16:04 <mapreri> then you can just mention the bug in the mail, etc
16:04 <ddstreet> yep, do you want an action to open the bug? or should i open it
16:05 <mapreri> if you can do it, ♥
16:05 <ddstreet> yep :)
16:05 <ddstreet> #action ddstreet open bug on u-d-t to update backportpackage script
16:05 * meetingology ddstreet open bug on u-d-t to update backportpackage script
16:05 <ddstreet> #topic ddstreet raise topic of rescheduling meeting on ML
16:05 <ddstreet> i think i forgot about this one
16:06 <ddstreet> i'll carry it over then
16:06 <ddstreet> #action ddstreet raise topic of rescheduling meeting on ML
16:06 * meetingology ddstreet raise topic of rescheduling meeting on ML
16:06 <ddstreet> seems i didn't do anything since the last meeting...
16:06 <ddstreet> #action ddstreet update wiki page clarifying requestors should subscribe ~ubuntu-backporters to BPO bugs
16:06 * meetingology ddstreet update wiki page clarifying requestors should subscribe ~ubuntu-backporters to BPO bugs
16:06 <ddstreet> #action ddstreet update internal KB page with details about uploads going to 'New' instead of 'Unapproved' queue (carried over)
16:06 * meetingology ddstreet update internal KB page with details about uploads going to 'New' instead of 'Unapproved' queue (carried over)
16:06 <mapreri> bad ddstreet ! :P ♥
16:07 <ddstreet> hey, at least i managed to get this meeting scheduled...that's 1 action i completed xD
16:07 <ddstreet> #topic mapreri propose text for membership process to add to KB page (carried over)
16:07 <ddstreet> carry over i assume?
16:07 <mapreri> ya
16:07 <ddstreet> #action mapreri propose text for membership process to add to KB page (carried over)
16:07 * meetingology mapreri propose text for membership process to add to KB page (carried over)
16:08 <ddstreet> #topic mapreri upload all the tools
16:08 <mapreri> "in progress" i guess
16:08 <ddstreet> hey progress is good!
16:08 <mapreri> debhelper is done though, which is basically the basics
16:08 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
16:08 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
16:08 <mapreri> since dh13 is used by most of those tools
16:08 <ddstreet> yep, and i approved it in all the releases, so should be published now
16:09 <mapreri> i've just build u-d-t/focal using it (pulling from the archive)
16:09 <mapreri> ^^
16:09 <ddstreet> awesome :) you'll reupload udt to focal-backports?
16:10 <ddstreet> i'll accept the bionic udt right after the mtg, i was just waiting for debhelper there to publish
16:10 <ddstreet> and i think our process of one person uploads, another reviews/accepts is good
16:10 <mapreri> yap! just uploaded
16:10 <mapreri> i kicked the build when the mtg started
16:10 <ddstreet> sweet! i'll review it after the mtg
16:10 <ddstreet> #topic mapreri clean up https://bugs.launchpad.net/~ubuntu-backporters/+subscribedbugs
16:10 <mapreri> i think i did it
16:11 <ddstreet> yep looks done
16:11 <ddstreet> thanks!
16:11 <mapreri> oh yes
16:11 <ddstreet> #topic mapreri fix lintian to not complain about ~bpo suffix
16:11 <mapreri> will you fix-release the bugs which you accepted the upload?
16:11 <ddstreet> ah right i will do that
16:11 <mapreri> i filed https://bugs.debian.org/1001399 for that
16:11 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
16:11 <ddstreet> #action ddstreet fix-released bugs for accepted uploads
16:11 * meetingology ddstreet fix-released bugs for accepted uploads
16:12 <mapreri> [15 05:10:53 PM] -queuebot- Unapproved: ubuntu-dev-tools (focal-backports/universe) [0.185~bpo20.04.1 => 0.187~bpo20.04.1] (no packageset)
16:12 <ddstreet> do we need to keep the action around until lintian is updated?
16:12 <mapreri> probably, it's also not yet fixed
16:12 <mapreri> please also link it in the agenda, so at least we remember to look at it every so often
16:12 <mapreri> (if it needs prods, etc)
16:12 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399)
16:12 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399)
16:12 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
16:12 <ddstreet> yep
16:13 <ddstreet> #topic teward update tooling, requestbackport (carried over)
16:13 <mapreri> he said he would give this action up?
16:13 <ddstreet> i believe he asked for these to get reassigned since he's super busy with work
16:13 <ddstreet> yep
16:13 <ddstreet> unless you want 'em, i can take the action items - though i doubt i'll get to it before the new year
16:13 <mapreri> i "could" take it, but I'm sure i wouldn't get it done before eoy
16:13 <ddstreet> me as well
16:13 <ddstreet> i'll take the actions, but of course feel free to jump on it if you want to
16:14 <mapreri> ack
16:14 <mapreri> fine by me
16:14 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
16:14 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
16:14 <ddstreet> i assume the unassigned actions probably are still pending:
16:14 <mapreri> oh actually
16:14 <ddstreet> #topic (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:14 <mapreri> backportpackage should be done already i think
16:15 <mapreri> i might have accidentally already fixed it
16:15 <ddstreet> oh ok awesome! lol
16:15 <mapreri> s/me/unit193/
16:15 <mapreri> https://git.launchpad.net/ubuntu-dev-tools/commit/?id=cd4d717551f74b4dff4e7326fb2f655168ded69e
16:15 <ubottu> Commit cd4d717 in ubuntu-dev-tools "backportpackage: change the ubuntu backports version following the new policy from the Backporters team"
16:15 <ddstreet> sweet well i'll leave the action just to check it then (along with requestbackport)
16:15 <ddstreet> nice!
16:15 <mapreri> i don't use the tool myself though, so…
16:16 <ddstreet> yeah, we should figure out some tooling at some point, at least for our review process
16:16 <ddstreet> i still haven't looked at the 'queue' tool
16:16 <ddstreet> anyway, tooling's likely a 2022 target
16:16 <mapreri> yap
16:16 <ddstreet> #action (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:16 * meetingology (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:17 <ddstreet> #action (unassigned) define process/procedure for adding new members (carried over)
16:17 * meetingology (unassigned) define process/procedure for adding new members (carried over)
16:17 <mapreri> wasn't this assigned to me
16:17 <mapreri> ?
16:17 <ddstreet> i think it was, but i think last mtg you asked for it to be moved to unassigned
16:17 <mapreri> ah ok
16:17 <ddstreet> do you want it back? :)
16:17 <mapreri> i still plan on doing it, but it seems i'm stuck with plenty of other things
16:17 <mapreri> I don't want to hog all of the actions!
16:17 <ddstreet> lol
16:17 <mapreri> (especially when it's unlikely I'd get them done by the fortnight)
16:18 <ddstreet> obviously feel free to do it if you get to it
16:18 <ddstreet> #topic (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls
16:18 <ddstreet> i'll leave this unassigned too but i think you were planning on doing it at some point
16:18 <ddstreet> #action (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:18 * meetingology (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:19 <ddstreet> ok that's all the previous action items!
16:19 <mapreri> yeah i plan for it, but dch's code is much scarier than backportpackage's :>
16:19 <ddstreet> i think our process is working pretty well so far
16:19 <ddstreet> i don't have any other topics, besides me reviewing the udt uploads right after the mtg
16:20 <ddstreet> anything from you?
16:20 <mapreri> I plan on doing that inkscape's bpo as well soon, which is, after libreoffice that "cut the queue", the first non-base-tools bpo i guess?
16:20 <mapreri> i might plan for other backports as well "soon", but i guess you'll see the bugs/mails for them as they come
16:21 <mapreri> i also think it's working sanely enough for now.  it seems to me we totally need to figure out the queue tool, and see if/how that thing interacts with the bugs
16:21 <mapreri> it's clear that we are going to forget the bugs behind with our current review workflow?
16:21 <ddstreet> yep, that's definitely our weak point now
16:21 <ddstreet> agreed
16:21 <ddstreet> let's put an action item just because it does need to get figured out
16:22 <mapreri> i fear it's going to require uploaders to put the tracking bug in the changelog, which likely is a good idea to do anyway?
16:22 <mapreri> add an action to see if we should/need add a point in the wiki page about this?
16:22 <ddstreet> #action (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs
16:22 * meetingology (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs
16:22 <ddstreet> i think the wiki already says to do that doesn it?
16:23 <mapreri> i guess I don't even remember the text i co-wrote
16:23 <ddstreet> hmm maybe it doesnt
16:23 <ddstreet> lol me neither xD
16:23 <ddstreet> ok lemme action that just to make sure
16:23 <mapreri> https://wiki.ubuntu.com/UbuntuBackports#Preparing_the_Backported_Package it's only talking about the version i think
16:23 <ddstreet> #action make sure wiki page includes requirement to add LP:# tag in backport changelog
16:23 * meetingology make sure wiki page includes requirement to add LP:# tag in backport changelog
16:24 <ddstreet> yep does need to be added
16:24 <mapreri> in which case, backportbackage/dch could/should add a LP:#xxxxx template in the text as well
16:24 <ddstreet> yep definitely
16:25 <ddstreet> we don't need a specific action for that though, i think that's part of the whole 'look at backportpackage/requestbackport tooling' action
16:25 <mapreri> sure, let's keep it that way for now
16:25 <ddstreet> ok i do need to schedule the next mtg too
16:25 <ddstreet> #action ddstreet schedule next meeting
16:25 * meetingology ddstreet schedule next meeting
16:26 <ddstreet> 2 weeks would be right at the end of the year, should we skip it and put the next mtg in jan?
16:26 <ddstreet> it would be jan 12
16:26 <mapreri> i'm cool with dec 29th tbh
16:26 <mapreri> at least
16:27 <mapreri> right now it sounds like a day i should be available
16:27 <ddstreet> sounds good, i'll schedule it then, but i might not be able to make it, not sure yet
16:27 <mapreri> what do you say of marking it for the 29th, and then let's see if we can actually make it, at most push it back to jan then?
16:27 <ddstreet> yep sounds good
16:27 <mapreri> s/most/worst/
16:28 <ddstreet> anything else before we wrap? sorry to rush the mtg
16:28 <mapreri> (…is "most" even correct in English there?  that's coming from my italian leaking in :>)
16:28 <mapreri> I'm good, besides me thinking about grammar now /o\
16:28 <ddstreet> lol, yeah 'at most' is correct english, but not in that sentence :)
16:29 <ddstreet> ok let's wrap then, thanks!
16:29 <ddstreet> #endmeeting