16:04 <ddstreet> #startmeeting Ubuntu Backporters Team
16:04 <meetingology> Meeting started at 16:04:55 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:04 <meetingology> Available commands: action, commands, idea, info, link, nick
16:05 <ddstreet> ok let's run thru the previous action items quickly
16:05 <ddstreet> #topic previous action items
16:05 <ddstreet> #subtopic ddstreet reply to previous ML requests and open backport request bugs indicating change in process (carried over)
16:06 <ddstreet> carrying this over (and either of you feel free to handle it as well of course)
16:06 <ddstreet> #action ddstreet reply to previous ML requests and open backport request bugs indicating change in process (carried over)
16:06 * meetingology ddstreet reply to previous ML requests and open backport request bugs indicating change in process (carried over)
16:06 <ddstreet> #subtopic ddstreet update wiki docs with new process (carrired over)
16:06 <ddstreet> done
16:06 <ddstreet> and mapreri has the WIP page
16:06 <ddstreet> (let's discuss that after the previous action items)
16:06 <ddstreet> #subtopic ddstreet try to edit help.u.c page https://help.ubuntu.com/community/UbuntuBackports
16:07 <ddstreet> done, and i think we can all edit this page as we see fit, or at least i am able to for sure
16:07 <ddstreet> #suptopic mapreri propose text for membership process to add to KB page
16:07 <ddstreet> carry over i assume?
16:08 <ddstreet> #action mapreri propose text for membership process to add to KB page (carried over)
16:08 * meetingology mapreri propose text for membership process to add to KB page (carried over)
16:08 <ddstreet> #subtopic teward update tooling, requestbackport (carried over)
16:08 <mapreri> oh yes, actually I forgot /o\
16:08 <teward> carry over
16:09 <ddstreet> #subtopic teward review backportpackage tool (carried over)
16:09 <ddstreet> carry both right?
16:09 <teward> correct
16:09 <ddstreet> #action teward update tooling, requestbackport (carried over)
16:09 * meetingology teward update tooling, requestbackport (carried over)
16:09 <teward> been a tad busy with stuff still, FT job kinda took all my time >.>
16:09 <ddstreet> #action teward review backportpackage tool (carried over)
16:09 * meetingology teward review backportpackage tool (carried over)
16:09 <ddstreet> #subtopic (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:09 <ddstreet> #action (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:09 * meetingology (unassigned) define details on handling members/leads who are no longer participating (carried over)
16:10 <ddstreet> #subtopic (unassigned) define process/procedure for adding new members (carried over)
16:10 <ddstreet> #action (unassigned) define process/procedure for adding new members (carried over)
16:10 * meetingology (unassigned) define process/procedure for adding new members (carried over)
16:10 <ddstreet> #subtopic (unassigned) create list of packages excluded from backporting (carried over)
16:10 <ddstreet> i think this one's done by mapreri
16:10 <ddstreet> at least the initial list
16:11 <mapreri> I think we can consider that done
16:11 <mapreri> it should just grow over time as cases come by
16:11 <ddstreet> yep
16:11 <ddstreet> ok that's all the action items
16:11 <ddstreet> let's move to the WIP wiki page
16:11 <ddstreet> #topic wiki page
16:11 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports/WIP
16:12 <ddstreet> mapreri i just reviewed it and responded to your ML email, +1 on everything with a couple minor comments
16:12 <mapreri> I'm applying your suggestions right now actually
16:13 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2021-October/021819.html
16:13 <ddstreet> for reference to those reading along
16:13 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-backports/2021-November/021820.html
16:14 <ddstreet> teward any feedback on the wiki page changes?
16:14 <mapreri> there, all applied
16:14 <ddstreet> great, and also thanks for opening the RT to get the wiki page history log working :)
16:15 <mapreri> if you think it's cool enough I can moved that WIP thing over to the main page too
16:16 <teward> no objection other than what changes have been made, though i'm missing an email so let me check the archive
16:16 <teward> yep no other feedback or complaints you hit all mine ddstreet
16:16 <teward> looks fine otherwise
16:18 <teward> back in like 2 seconds have to answer the door for LUNCH
16:18 <mapreri> then I suppose we can go ahead
16:18 <mapreri> should we start actually handling packages? :3
16:18 <ddstreet> mapreri one last thing, can you replace the TBD in the 'Reason for Backport' section with a link down the the 'special cases' section, or just replace it with 'as listed below'
16:19 <mapreri> oh good point
16:19 <mapreri> sure
16:19 <ddstreet> or, maybe just remove that line entirely; it's kind of redundant now
16:19 <ddstreet> either way
16:19 <teward> mapreri: i think anything pending in the existing 'requests' sections needs to be just denied (the old way) and resubmitted if someone wants to get a backport still but using the new process
16:19 <teward> as for handling packages, anything currently in the queue without active requests per the process is also not prepared
16:20 <teward> my 2 cents in regards to "should we start actually handling packages"
16:20 <mapreri> sure
16:20 <mapreri> but we said to reject them once we actually have a page to point them to
16:20 <teward> right but that goes hand in hand ;)
16:21 <mapreri> so I think we can move WIP to the main page, then reject everything, then I can upload stuff (devscripts and u-d-t!), you two review them, and then let's open the gates for all by a mail to ubuntu-devel@ or such?
16:21 <mapreri> should we do ubuntu-devel-announce@? :O  in ubuntu that's pretty much unused besides when the cycles starts/freezes…
16:21 <teward> we should at least email ubuntu-devel i think
16:22 <teward> but -announce i don't think is needed for it
16:22 <ddstreet> yeah i think just stick to ubuntu-devel, the -announce is moderated and reserved for select announcements anyway i think
16:23 <mapreri> I moved the WIP text to the main page
16:23 <ddstreet> i'm +1 on moving WIP to the main page and starting to handle packages! :)
16:23 <ddstreet> \o/ hurray :)
16:23 <mapreri> your +1 is already too late :P
16:23 <ddstreet> lol
16:23 <ddstreet> retroactive +1
16:24 <ddstreet> so i guess we're fully "running" now right?
16:24 <mapreri> I guess
16:24 <ddstreet> wiki page is up to date, i don't think anythign else is needed on the community page right? https://help.ubuntu.com/community/UbuntuBackports
16:25 <mapreri> I'll have to read that page again at a different time
16:25 <ddstreet> ack, and you should be able to edit it, if needed
16:25 <mapreri> btw, I'll upload udt/focal-bpo later today, and you can mess with the queue and see if/how that works?
16:26 <ddstreet> yep i have a bit of time today, so i can process it once you upload
16:26 <mapreri> alright
16:26 <mapreri> after the mtg
16:27 <ddstreet> mapreri also re: the bug i opened lp:1947192 i'm thinking now we should just close that as wontfix, yeah?
16:27 <ubottu> Launchpad bug 1947192 in ubuntu-dev-tools (Ubuntu Hirsute) "[SRU] version 0.185" [Low, In Progress] https://launchpad.net/bugs/1947192
16:27 <ddstreet> i shouldn't have opened it in the first place
16:27 <mapreri> I think you need to assign a few actions (me uploading this, you reviewing the queue, somebody writing the -devel mail, ...)
16:27 <mapreri> I'll try to close that in the bpo upload, let's discover if that works?
16:28 <mapreri> (i don't think it will, but let's try)
16:28 <ddstreet> #action mapreri upload u-d-t to focal
16:28 * meetingology mapreri upload u-d-t to focal
16:28 <ddstreet> #action ddstreet review u-d-t upload to focal
16:28 * meetingology ddstreet review u-d-t upload to focal
16:29 <ddstreet> who wants to write the email to -devel?
16:29 * mapreri looks grumpily at the ppc64el autopkgtest queue, stopping u-d-t 0.186
16:29 <ddstreet> lol, yeah i heard there were some problems there (i've been out on vacation for a week, just back today)
16:29 <mapreri> I'll happily give that up.  in the next ~10 days I'll be busy with family stuff, so not really up for more tasks atm
16:29 <teward> won't be me, i'm moving mt email between environments at the moment, so limited ability to email.
16:30 <teward> (so I can't send the email at the moment)
16:30 <ddstreet> ack no prob i can take it
16:30 <mapreri> i can review your draft if you want to
16:30 <ddstreet> #action ddstreet email ubuntu-devel list to announce re-opening of backports
16:30 * meetingology ddstreet email ubuntu-devel list to announce re-opening of backports
16:30 <ddstreet> yep lemme action that too
16:30 <ddstreet> #action ddstreet send draft email to mapreri before ubuntu-devel list
16:30 * meetingology ddstreet send draft email to mapreri before ubuntu-devel list
16:31 <ddstreet> ok i think that's everything right?
16:31 <mapreri> for this topic yes at least
16:31 <ddstreet> and i already have the actions for respoinding to open bugs and ML emails
16:31 <mapreri> and I think also for the other membership thing as well since that's waiting on me to draft the KB page I guess
16:32 <ddstreet> yeah i think we got that in the earlier actions
16:32 <ddstreet> #topic all other business
16:32 <ddstreet> did i miss anything? or any other topics?
16:33 <mapreri> somebody pls get `DEB_VENDOR=ubuntu dch --bpo` to DTRT pls :puppy_eyes:
16:34 <ddstreet> #action (unassigned)  get `DEB_VENDOR=ubuntu dch --bpo` to DTRT pls
16:34 * meetingology (unassigned)  get `DEB_VENDOR=ubuntu dch --bpo` to DTRT pls
16:34 <ddstreet> lol
16:34 <mapreri> :*
16:35 <ddstreet> should i schedule another mtg in 2 weeks? just in case?
16:35 <ddstreet> it would be Nov 17
16:35 <mapreri> by then I'll have pretty much just come back from messy times, but I think we should regardless, at least to check in and keep up momentum
16:36 <ddstreet> yep sounds good, it has been useful to have these mtgs at least as a target date for getting stuff done, in addition to the actual meeting content
16:36 <mapreri> mh dh 13 is not available in focal-bpo :(
16:36 <ddstreet> #action ddstreet schedule following meeting for Nov 17
16:36 * meetingology ddstreet schedule following meeting for Nov 17
16:37 <ddstreet> yeah i wonder if debhelper might be the first thing we need to backport
16:37 <mapreri> I wanted to go with something less critical first
16:37 <ddstreet> otherwise we'll probably have to adjust the dh version for backported packages
16:37 <mapreri> I'll just s/13/12/ in this case, it doesn't matter
16:37 <ddstreet> yep
16:38 <mapreri> note how somebody randomly did backport debhelper 12 to focal-bpo some time ago :>
16:40 <ddstreet> mapreri what method do you use to check what's in the -backports pocket for releases? like, for a release you're not running
16:41 <mapreri> (oh, actually that was bionic not focal, sorry)
16:41 <ddstreet> ah ok
16:41 <mapreri> i was going by memory
16:41 <ddstreet> i was wondering why rmadison didn't show it
16:42 <ddstreet> ok i think we're all wrapped up then
16:42 <mapreri> anyhow, I've got plenty of chroots and run apt policy there; or look at the launchpd ui.  for whatever reason i never got my fingers into typing rmadison :!
16:42 <mapreri> E: ubuntu-dev-tools changes: backports-upload-has-incorrect-version-number 0.185~bpo20.04.1
16:42 <mapreri> another action ↑ :P
16:42 <mapreri> fix lintian
16:43 <mapreri> I'm sure lechner would do that right away once told
16:43 <mapreri> I: ubuntu-dev-tools changes: backports-changes-missing
16:43 <ddstreet> #action (unassigned) fix lintian to not complain about ~bpo suffix
16:43 * meetingology (unassigned) fix lintian to not complain about ~bpo suffix
16:43 <mapreri> do we care about this in ubuntu?
16:43 <mapreri> is about using -v in dpkg-genchanges to include more than one entry in the Changes: field of the .changes file
16:44 <mapreri> used to be mandatory for debian backports, but it's not mandatory anymore (though I still take care of it)
16:44 <ddstreet> i tend to think probably not, right?
16:45 <ddstreet> it could be a really long list, or in some cases might not even be possible e.g. with a new major version
16:45 <mapreri> I also seem to remember launchpad is clever about that, at least it closes all bugs even if the .changes file doesn't mention them all, somehow.
16:45 <mapreri> why wouldn't be possible?
16:45 <mapreri> I can assure you that it's very much possible to do :>
16:46 <ddstreet> it would just include the entire changelog then, right?
16:46 <mapreri> there is also -v0 to include all of the changelog in the .changes (example is when backporting a package that wasn't present in the target distribution
16:46 <mapreri> )
16:46 <mapreri> but yes, I don't think we care here
16:46 <ddstreet> i'm fine either way; it seems like it probably would just introduce noise instead of helping
16:47 <mapreri> I'm sure it would make many new contributors not used to low-level tooling (dpkg-genchanges in this case) scratch their heads :D
16:47 <ddstreet> yeah i know there are some people who have ACL to upload who either don't know about needing to use -v or just forget about it
16:48 <ddstreet> ok we're coming up to the end, any final items before we wrap up?
16:49 <mapreri> not from me
16:49 <mapreri> teward: ?
16:49 * mapreri also just dput, let's see
16:49 <teward> nope
16:49 <teward> none
16:50 <mapreri> Rejected:
16:50 <mapreri> Mismatch in binaryfulness. (arch) False != (files) True
16:50 <mapreri> dammit, I keep forgetting this lp thing :\
16:50 <ddstreet> hmm i've not hit that before
16:51 <mapreri> you likely don't build all of your uploads locally before uploading the resulting thing
16:52 <ddstreet> i usually build the binaries in a separate container, while i build my source to upload on my main system
16:52 <mapreri> https://bugs.launchpad.net/launchpad/+bug/1699763
16:52 <ubottu> Launchpad bug 1699763 in Launchpad itself "source uploading with a .buildinfo containing hashes for binary is rejected" [Undecided, Confirmed]
16:53 <mapreri> also when uploading to ubuntu I need to be careful to upload the .changes generated in right env, else it won't have the Launchpad-Bug-Fixed field, etc etc.
16:53 <mapreri> ddstreet: anyway, it's in the queue now :)
16:53 <mapreri> guess this is all for today!
16:53 <ddstreet> awesome! i'll review asap :)
16:54 <ddstreet> thanks all!
16:54 <ddstreet> #endmeeting