15:01 <teward> #startmeeting DMB Meeting - April 5, 2021
15:01 <meetingology> Meeting started at 15:01:55 UTC.  The chair is teward.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:01 <meetingology> Available commands: action, commands, idea, info, link, nick
15:02 <teward> #chairs ddstreet rafaeldtinoco rbasak teward
15:02 <teward> #chair ddstreet rafaeldtinoco rbasak teward
15:02 <teward> screw you too bot
15:02 <meetingology> Current chairs: ddstreet, rafaeldtinoco, rbasak, teward
15:02 <teward> welcome to the APril 5th DMB meeting!
15:02 <teward> So let's review the last action items
15:02 <teward> #topic Previous Action Items Review
15:03 <teward> ... I guess meetingology is being slow and needs a kick but I'mma continue
15:03 <teward> #subtopic ddstreet edubuntu seed <-> pkgset (carried over)
15:03 <ddstreet> carry again please
15:03 <teward> ok
15:04 <teward> #subtopic ddstreet to reduce the scope of meeting scheduling mistakes
15:04 <teward> i see you revised the agenda page
15:04 <ddstreet> yeah, if everyone is ok with the changes, this is done
15:04 <teward> nice.  moving on
15:04 <teward> #subtopic rbasak to announce waveform's successful application
15:04 <rbasak> Done
15:05 <teward> nice
15:05 <teward> #subtopic rbasak to add waveform's PPU ACL items
15:05 <rbasak> Done
15:05 <teward> and...
15:05 <teward> #subtopic rbasak to resolve Alex's request for an alternate meeting venue/time for his application
15:06 <rbasak> I think that's resolved now, but I should follow up and confirm in the ML now that we have a quorate number of members saying they can make it.
15:06 <rbasak> Unless there are objections, I'll change the meeting time on that particular day to the agreed time (so no meeting at the usual time - the regular meeting will move for that day only)
15:07 <teward> so should i leave that action item until you confirm there's a quorate number of members?
15:07 <rbasak> Sure
15:07 <teward> ok
15:07 <teward> gimme 1 second to catch up i'm writing the agenda in gedit as we go because the bot's fubar
15:08 <teward> so we have no packageset/ppu applications or SRU developer applications and Alex is still pending the ML stuff so
15:08 <teward> #topic Ubuntu Core Developer Applications
15:08 <teward> #subtopic Gunnar Hjalmarsson
15:08 <teward> #link https://wiki.ubuntu.com/GunnarHj/CoreDevApplication
15:08 <teward> GunnarHj: hello!  Please introduce yourself and say a bit about you while we review your application and come up with any questions for you!
15:09 <GunnarHj> Hi DMB!
15:11 <GunnarHj> I've been around for a decade, and have contributed with desktop and i18n stuff mostly. My special profile has resulted in a need to touch quite a few packages both in main and universe. So finally I decided to apply for core-dev to make life easier both for me and my sponsors.
15:11 <rbasak> Hello!
15:12 <rbasak> Can you tell us what steps you would expect to take if one of your uploads gets stuck in proposed?
15:13 <GunnarHj> I would visit the excuses page to find out the reason. Maybe retry some tests, or maybe dig deeper into the cause if needed.
15:14 <rbasak> OK, thanks.
15:14 <rbasak> And what would you do if you want to add a new feature to a package three weeks before release?
15:15 <GunnarHj> File a FFe request bug.
15:15 <rbasak> Thank you :)
15:16 <rafaeldtinoco> seb did a good job in his endorsement (splitting cases by MIR, FFe, etc)
15:17 <rafaeldtinoco> GunnarHj: I see your merges given as examples are 'recent' and the most complex one is gnome-terminal (I guess)
15:18 <rafaeldtinoco> no questions from me
15:18 <GunnarHj> rafaeldtinoco: That's probably true.
15:19 <teward> no questions from me.
15:20 <rbasak> GunnarHj: what do you know of seeds and transitions?
15:21 <GunnarHj> rbasak: I'm quite familiar with the seeds, and have submitted a few related merge requests during the years. Not sure which kind of transitions you mean, though.
15:22 <rbasak> I mean library transitions - soname bumps.
15:23 <GunnarHj> rbasak: Ah, thanks. Can't say I have dealt with it much, but I remember one case (libpinyin) a couple of years ago.
15:23 <rbasak> What would you do if you are uploading a package that involves a soname bump?
15:24 <rbasak> And how would you recognise that this is the case?
15:25 <GunnarHj> I'd need to make sure to get the dependencies right, and probably refresh the symbols file if any.
15:26 <rafaeldtinoco> 1.1.1+git20200624+ds2-10ubuntu1 (example of symbols change from GunnarHj, not necessarily because of SONAME bump)
15:26 <rafaeldtinoco> opencc ^
15:27 <rafaeldtinoco> coming from debian in this case
15:27 <GunnarHj> rafaeldtinoco: That was for another reason (A MIR team request for a symbols file).
15:27 <rafaeldtinoco> yep, I saw it later
15:28 <rbasak> OK, tanks
15:28 <rbasak> thanks
15:28 <rbasak> No more questions from me.
15:28 <rafaeldtinoco> ddstreet: ^
15:28 <ddstreet> none from me
15:29 <ddstreet> i think we're ready to vote teward
15:29 <teward> yep 1 moment phone just rang
15:30 <teward> !vote Gunnar Hjalmarsson CoreDev
15:30 <ubottu> teward: I am only a bot, please don't think I'm intelligent :)
15:30 <teward> #vote Gunnar Hjalmarsson CoreDev
15:30 <meetingology> Please vote on: Gunnar Hjalmarsson CoreDev
15:30 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
15:30 <rbasak> +1 GunnarHj has a long and excellent track record in contributions and uploads directly in Ubuntu. I'm confident that he will make an excellent core dev. Thank you for your work!
15:30 <meetingology> +1 GunnarHj has a long and excellent track record in contributions and uploads directly in Ubuntu. I'm confident that he will make an excellent core dev. Thank you for your work! received from rbasak
15:30 <teward> #voters rbasak teward rafaeldtinoco ddstreet
15:30 <meetingology> Current voters: ddstreet, rafaeldtinoco, rbasak, teward
15:30 <teward> +1
15:30 <meetingology> +1 received from teward
15:30 <ddstreet> +1
15:30 <meetingology> +1 received from ddstreet
15:31 <teward> rafaeldtinoco: ^
15:31 <rafaeldtinoco> Im very happy with the work GunnarHj has been doing. Despite his 'limited technical skills' as phrased by him, I think he will be a great addiction to the core dev team . Thank you for all your work and +1 from me.
15:31 <rafaeldtinoco> +1
15:31 <meetingology> +1 received from rafaeldtinoco
15:31 <teward> #endvote
15:31 <meetingology> Voting ended on: Gunnar Hjalmarsson CoreDev
15:31 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
15:31 <meetingology> Motion carried
15:31 <ddstreet> congrats!
15:31 <teward> Congratulations GunnarHj!
15:31 <rafaeldtinoco> GunnarHj: congratulations
15:31 <rbasak> Congratulations!
15:31 <rafaeldtinoco> and thanks!
15:32 <GunnarHj> Wow, thanks for your showed trust in me. :)
15:32 <rbasak> GunnarHj had a special arrangement with a glob-based packageset that I think we can remove now
15:32 <teward> who wants to handle the rights assignment, removal of the packageset rights, and announcement?  (won't be me i'm busy this week)
15:32 <rbasak> I don't think that needs a vote because it's effectively a no-op in terms of ACL capability for him, just a tidy up.
15:32 <rbasak> I can take the actions and I'll clean up at the same time.
15:32 <teward> rbasak: agreed, doesn't need a vote 'cause we can just tidy it up
15:32 <teward> cool
15:32 <GunnarHj> rbasak: Indeed, that can be dropped. But please add me to core-dev first.
15:33 <rbasak> GunnarHj: of course :)
15:33 <teward> #action rbasak to handle GunnarHj core-dev rights, announcement, and post-coredev packageset/acl cleanups.
15:33 * meetingology rbasak to handle GunnarHj core-dev rights, announcement, and post-coredev packageset/acl cleanups.
15:33 <teward> there're no MOTU applications. so...
15:33 <teward> #topic Outstanding mailing list requests to assign
15:33 <teward> I don't know of any
15:34 <teward> And we don't have any open TB bugs so...
15:34 <teward> #action Next meeting chair
15:34 * meetingology Next meeting chair
15:34 <teward> Dan's listed as next
15:34 <ddstreet> sounds good
15:34 <teward> #topic Any Other Business
15:34 <rafaeldtinoco> thanks for the agenda updates
15:34 <rafaeldtinoco> much better now
15:35 <rafaeldtinoco> with logs at the end
15:35 <rafaeldtinoco> etc
15:35 <teward> agreed
15:35 <teward> any other business?
15:35 <rafaeldtinoco> nope, thanks for chairing
15:35 <teward> 5
15:35 <teward> 4
15:35 <teward> 3
15:35 <teward> 2
15:35 <teward> 1
15:35 <teward> thanks everyone!
15:35 <rafaeldtinoco> and congrats again to GunnarHj
15:35 <teward> #endmeeting