19:04 <teward> #startmeeting DMB Meeting
19:04 <meetingology> Meeting started Mon Nov  2 19:04:42 2020 UTC.  The chair is teward. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:04 <meetingology> 
19:04 <meetingology> Available commands: action commands idea info link nick
19:04 <teward> hello everyone :)
19:04 <teward> welcome to the Nov. 2nd meeting for DMB.
19:05 <sil2100> rafaeldtinoco: which applicant? Guess we might have to move that one to e-mail voting then
19:05 <sergiodj> sil2100: me :)
19:05 <rafaeldtinoco> (sil2100: ill be +1 only if everybody else is)
19:05 <teward> lets start with the previous action items first.
19:05 <sergiodj> sil2100: rafaeldtinoco and I are part of the same team
19:05 <teward> #topic Review of previous action items
19:05 <teward> #subtopic rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
19:05 <sil2100> \o/ ;)
19:06 <rafaeldtinoco> teward: done
19:06 <teward> nice
19:06 <rafaeldtinoco> dmb kb page has a session now
19:06 <rafaeldtinoco> pointing to git urls for seeds and packageset<->seed code
19:06 <teward> nice nice, glad to see that :)
19:06 <rafaeldtinoco> https://wiki.ubuntu.com/UbuntuDevelopers#PackageSetSync
19:06 <teward> #link https://wiki.ubuntu.com/UbuntuDevelopers#PackageSetSync
19:06 <teward> perfect, anything else with this one or can we move on?
19:07 <rafaeldtinoco> nope we can move on
19:07 <teward> nice
19:07 <teward> #subtopic ddstreet edubuntu seed <-> pkgset (carried over)
19:07 <teward> ddstreet: that one was yours
19:07 <ddstreet> need to carry over, sorry
19:07 <teward> #action ddstreet edubuntu seed <-> pkgset (carried over)
19:07 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
19:07 <teward> moving on to next item
19:07 <teward> #subtopic rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:07 <teward> this one's an rbasak one, my guess is carry over until he checks in
19:07 <rafaeldtinoco> yep
19:08 <teward> #action rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:08 * meetingology rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:08 <teward> #subtopic rafaeldtinoco to go through openstack packageset and identify packages in other sets and determine which is best to keep
19:08 <rafaeldtinoco> done.
19:08 <sil2100> \o/
19:08 <rafaeldtinoco> I have updated groovy and hirsute packagesets for openstack
19:08 <rafaeldtinoco> (this will be done every cycle now, with openstack team helping)
19:09 <sil2100> rafaeldtinoco: thanks!
19:09 <teward> yay! glad to see we're making a lot of progress and the OpenStack team is going to work with us on this!  It'll probably help with all those SRUs I keep showing up in the sponsoring queue xD
19:09 <rafaeldtinoco> my pleasure!
19:09 <teward> nice.  So, the next item on the list then...
19:09 <teward> ERR:LAG
19:09 <teward> #topic Heads Up
19:10 <teward> Just a heads up to you all: i was recently elected to the Community Council, while it doesn't affect my judgement here, it's something we should be aware of anyways :)
19:10 <teward> until Mark says I can't, I'll have all the hats :P
19:10 <teward> now onto ACTUAL work...
19:10 <rafaeldtinoco> teward: wow, thats nice
19:10 <rafaeldtinoco> teward: I was missing the council
19:10 <rafaeldtinoco> glad you're there
19:10 <oSoMoN> congrats teward
19:11 <teward> myself and a few others are there, just wanted to make it known in case things start conflicting DMB/CC duties
19:11 <ddstreet> congrats teward!
19:11 <teward> in case I abstain from votes in the future more often that's probably why
19:11 <sergiodj> congrats, teward!
19:11 <teward> and thank you all.
19:11 <sil2100> Congrats o/
19:11 <teward> #subtopic teward elected to Community Council, notice to rest of DMB on that change in how it affects teward's votes
19:11 <teward> now onto other business
19:11 <teward> #topic Ubuntu Core Developer Applications
19:12 <teward> we have two coredev applications today for consideration.
19:12 <teward> #subtopic Olivier Tilloy (oSoMoN)
19:12 <teward> oSoMoN: say hello and introduce yourself to us :)
19:13 <oSoMoN> Hello, I'm Olivier, I work at Canonical on the Ubuntu Desktop team
19:13 <oSoMoN> have been there for 3.5 years, and 10 years at Canonical in various teams
19:13 <oSoMoN> In my time on the desktop team I've been increasingly resorting to sponsoring for package uploads and autopkgtest triggers, especially lately when I joined the +1 maintenance team, and that's the main reason for my application
19:13 <oSoMoN> along with being a core dev always having been a sort of long-term goal in my involvement in Ubuntu
19:14 <teward> #link https://wiki.ubuntu.com/OlivierTilloy/CoreDevApplication
19:14 <teward> (apparently that was never sent through... I blame LAG!)
19:15 <oSoMoN> I was going to paste it
19:15 <oSoMoN> thanks
19:15 <teward> yep
19:15 <rafaeldtinoco> im already there :o)
19:15 <teward> i meant to do that shortly after my last message, but lagging hard on my side - borrowing parents' internet while my apartment is literally frozen (heater busted)
19:16 <teward> thanks for introducing yourselv oSoMoN!  Any questions from DMB team members?
19:16 * rafaeldtinoco reading application
19:16 <sil2100> oSoMoN: quick question: when investigating a package FTBFS in the archive, what would you say might be the most frequent reasons?
19:17 <oSoMoN> ah, there are many possible reasons :)
19:17 <oSoMoN> it can be an arch-specific issue
19:17 <sil2100> What possible causes come to your mind? List a few you had experienced
19:17 <oSoMoN> or a toolchain update
19:17 <oSoMoN> or a missing build dep
19:18 <sil2100> Regarding missing build-deps, did you have a case before where a package FTBFS because of not being able to resolve a build-dependency even though that dependency is already in Ubuntu?
19:19 <sil2100> Can something like that happen? And why?
19:19 <oSoMoN> well yes in the past where build deps for packages in main needed to be in main too, but that requirement was relaxed a while back
19:20 <oSoMoN> or the build dep is not available for all the architectures the package builds on
19:20 <sil2100> That's what I wanted to hear, thanks o/
19:22 <rafaeldtinoco> oSoMoN: I have seen that one of the things you list as objective is to do +1 maintenance without the need of being sponsored (which makes sense). Could you talk about the issues you have found ? What makes you pick one issue instead of other ?
19:23 <oSoMoN> during the shifts I did, I focused quite a lot on the nodejs migration, which was a big hairy one, and that was motivated by it blocking firefox updates, which I maintain
19:23 <oSoMoN> I also picked a bunch of packages at random to get out of my comfort zone
19:24 <oSoMoN> having been explicitly told that I shouldn't use all of my +1 maintenance time to work on packages directly related to my daily work
19:24 <rafaeldtinoco> thanks for saying that (that is where I was going)
19:24 <rafaeldtinoco> I liked the nodejs annotation in the application page
19:24 <oSoMoN> I also used popcon to get a sense of what popular packages might benefit from fixes
19:28 <sil2100> No more questions from me
19:28 <teward> if there are no more questions, then we can vote.  give me 2 seconds to grab the right meetingology command (I don't have it memorized LOL)
19:29 <teward> #vote Olivier Tilloy CoreDev
19:29 <meetingology> Please vote on: Olivier Tilloy CoreDev
19:29 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:29 <teward> #voters sil2100 rafaeldtinoco teward ddstreet
19:29 <meetingology> Current voters: ddstreet rafaeldtinoco sil2100 teward
19:29 <sil2100> +1 LONG OVERDUE
19:29 <meetingology> +1 LONG OVERDUE received from sil2100
19:29 <teward> +1
19:29 <meetingology> +1 received from teward
19:30 <rafaeldtinoco> +1 (Sebastien's and Iain's endorsements are no brainer)
19:30 <meetingology> +1 (Sebastien's and Iain's endorsements are no brainer) received from rafaeldtinoco
19:30 <ddstreet> +1 excellent endorsements as well as what looks like a lot of good work so far
19:30 <meetingology> +1 excellent endorsements as well as what looks like a lot of good work so far received from ddstreet
19:30 <teward> #endvote
19:30 <meetingology> Voting ended on: Olivier Tilloy CoreDev
19:30 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:30 <meetingology> Motion carried
19:31 <teward> that's quorum, congrats to you oSoMoN on a successful CoreDev application
19:31 <rafaeldtinoco> Congrats oSoMoN =)
19:31 <oSoMoN> thanks all!
19:31 <sergiodj> congrats oSoMoN :)
19:31 <ddstreet> congrats!
19:31 <teward> who wants to take care of assigning perms and announcing the successful application for me? (I can't, i'm solidly chaotically filled with dev stuff for my main job today)
19:31 <seb128> oSoMoN, congrats!
19:31 <rafaeldtinoco> its a holiday here today
19:31 <rafaeldtinoco> ill ask someone else to
19:32 <rafaeldtinoco> #)
19:32 <sil2100> I can o/
19:32 <sil2100> oSoMoN: congrats!
19:32 <teward> #action sil2100 to assign permissions and announce successful coredev application from Olivier Tilloy
19:32 * meetingology sil2100 to assign permissions and announce successful coredev application from Olivier Tilloy
19:32 <teward> Congrats, oSoMoN!
19:32 <teward> we have one more coredev application to review today, though we'll likely have to move it to
19:33 <teward> email I believe?
19:33 <teward> BAH broken keyboard
19:33 <rafaeldtinoco> teward: i can vote
19:33 <rafaeldtinoco> but only if all others are +1
19:33 <rafaeldtinoco> orelse I wont
19:33 <rafaeldtinoco> (just to make the quorum)
19:33 <teward> cool cool
19:33 <teward> #subtopic Sergio Durigan Junior
19:33 <teward> #link https://wiki.ubuntu.com/SergioDuriganJunior/CoreDevApplication
19:33 <teward> sergiodj: say hello and introduce yourself!  :)
19:34 <sergiodj> hey folks!  thanks for considering my application today.  I'm Sergio, I am part of the Ubuntu Server team at Canonical (therefore, I'm a Canonical employee ;-))
19:34 <sergiodj> I am a Debian Developer, and have been a Debian contributor since 2014
19:35 <sergiodj> as part of the Ubuntu Server team, I worked with several packages, mostly in main.  I also helped with +1 maintenance sometimes
19:36 <sergiodj> I would like to become a CoreDev because I've been pestering my team (rafael included!) to sponsor packages for me
19:36 <sergiodj> and also to retrigger autopkgtests ;)
19:37 <sil2100> sergiodj: while working on Ubuntu packages, did you ever work on any transitions? Can you tell us what that is and how such things are handled?
19:38 <sergiodj> sil2100: I have not worked on any transitions yet, but a transition is when you are going to upload a new version of a package which has the possibility of breaking reverse dependencies
19:38 <sergiodj> for example, when there is a major soname bump
19:38 <sergiodj> so we have to first request a transition slot to the release team, which will generate a new entry here: https://people.canonical.com/~ubuntu-archive/transitions/
19:39 <sergiodj> from there, we have to work with the maintainers of the reverse deps of our package and make sure that they are updated in order to handle the new version of our package
19:40 <sergiodj> of course, this can be as simple as rebuilding the reverse dep is uploaded, or can involve complex scenarios where you will have to do a major update in the revdep
19:41 <sil2100> sergiodj: ok, thanks o/
19:41 <sergiodj> interesting scenarios can occur when the revdep itself is a library (for example) and requires its own transition process
19:41 <sergiodj> heh
19:41 <sergiodj> sil2100: np!
19:43 <teward> any more questions for sergiodj?
19:43 <sil2100> sergiodj: another, less technical! You are applying for core-dev (which is very good!), but was wondering - what is the reason why you apply straight for core-dev and not for ubuntu-server PPU?
19:45 <teward> #chair rafaeldtinoco sil2100 ddstreet teward
19:45 <meetingology> Current chairs: ddstreet rafaeldtinoco sil2100 teward
19:45 <teward> (for reasons intermally explained)
19:45 <sergiodj> sil2100: I can cite a few things here.  the first one is that my whole team really encouraged me to apply straight to CoreDev, because (according to them) the quality of my work.  I can also mention the fact that my day-to-day work involves maintaining a lot of packages, so I'd have to file PPUs for several o fhtem
19:45 <ddstreet> sergiodj i don't have any questions, but debuginfod sounds super interesting, i hope you can get that going with ubuntu packages, it would be extremely helpful; mapping coredump buildid back to a specific package version has been elusive for me so far
19:45 <sergiodj> of them*
19:46 <sergiodj> there's also the fact that, being a DD, I'm confident I can "hit the ground running" by being a CoreDev as well
19:46 <sil2100> sergiodj: certainly having core-dev rights makes things much easier for general +1 maintenance! Ok, thanks!
19:46 <sil2100> No further questions
19:46 <sergiodj> ddstreet: thanks!  yeah, that's a very interesting project that is starting to attract a lot of attention!
19:46 <sergiodj> I'm also excited by it :)
19:48 <teward> any more questions from DMB members, or shall we vote?
19:48 <ddstreet> nothing else from me
19:48 <teward> #vote Sergio Durigan Junior CoreDev
19:48 <meetingology> Please vote on: Sergio Durigan Junior CoreDev
19:48 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:49 <teward> #voters sil2100 rafaeldtinoco teward ddstreet
19:49 <meetingology> Current voters: ddstreet rafaeldtinoco sil2100 teward
19:49 <teward> +1
19:49 <meetingology> +1 received from teward
19:49 <sil2100> +1 solid application, Sergio knows what he's doing - and I already had quite some exposure to his work, so yes
19:49 <meetingology> +1 solid application, Sergio knows what he's doing - and I already had quite some exposure to his work, so yes received from sil2100
19:49 <ddstreet> +1 great to see long list of endorsements, and all his work looks good
19:49 <meetingology> +1 great to see long list of endorsements, and all his work looks good received from ddstreet
19:50 <rafaeldtinoco> +1 because everybody else was already +1
19:50 <meetingology> +1 because everybody else was already +1 received from rafaeldtinoco
19:50 <teward> #endvote
19:50 <meetingology> Voting ended on: Sergio Durigan Junior CoreDev
19:50 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:50 <meetingology> Motion carried
19:50 <sil2100> sergiodj: congrats!
19:50 <rafaeldtinoco> sergiodj: congrats!
19:50 <teward> congrats, sergiodj!
19:50 <oSoMoN> congrats sergiodj !
19:50 <ddstreet> congrats!
19:50 <sergiodj> sil2100: rafaeldtinoco: teward: oSoMoN: thanks!
19:50 <teward> sil2100: another one for you to do if you want it, or should i give it to another?
19:50 <sergiodj> ddstreet: thanks!  :)
19:50 <sil2100> teward: I can do it as well o/
19:51 <sil2100> I'll pick it up a bit later today or (in worst case) tomorrow
19:51 <sil2100> But it will be done
19:51 <teward> #action sil2100 to assign permissions and announce successful coredev application from Sergio Durigan Junior
19:51 * meetingology sil2100 to assign permissions and announce successful coredev application from Sergio Durigan Junior
19:51 <teward> no worries :)
19:51 <teward> #topic Select a chair for next meeting
19:51 <teward> Once again, gonna be me, because I have a backlog of chair dates to fill
19:51 <rafaeldtinoco> lol
19:51 <teward> #action teward to chair next meeting
19:51 * meetingology teward to chair next meeting
19:51 <teward> #topic Any other business
19:52 <teward> i got one
19:52 <teward> #subtopic December Meetings
19:52 <teward> The second meeting of the DMB in december is scheduled for December 28th, which falls on the weekend that happens *directly* after the 25th of December, which is Christmas Day.
19:52 <teward> Meaning, 25, 26, 27, 28 technically fall on the Christmas weekend.
19:53 <teward> do we want to skip that meeting given the timing of that holiday vs. the meeting itself?
19:53 <rafaeldtinoco> I think it would be okay in skipping (as usually there are not many reqs during that time of the year)
19:53 <rafaeldtinoco> and judging by our history of quorum lately
19:54 <ddstreet> yeah i'm +1 to skip that one as well
19:54 <teward> true.  I'm all for skipping the Dec. 28 meeting that'd normally ahppen (and will document on the Agenda) if we're in agreement.  myself, rafaeldtinoco, and ddstreet makes 3, sil2100 any objections?
19:54 <teward> i know it's November but it's sometimes best to decide this stuff early ;)
19:55 <rafaeldtinoco> nah its good (applicants have to know the future schedule as well)
19:56 <rafaeldtinoco> sil2100: ^
19:57 <teward> i mean, I could unilaterally make the call but I think it's best for us to agree on things, and I'm pretty sure nobody will object.
19:57 <rafaeldtinoco> teward: if Lucasz is already gone, we can get his +1 on an email thread as well
19:57 <teward> yep I'll bring it up but when I edit the agenda I'll mark it as 'tentatively agreed' and then update that once we get a solid vote.
19:57 <rafaeldtinoco> sounds good
19:58 <teward> #action teward to email DMB ml regarding skipping of December 28th normally-scheduled meeting, mark Agenda as Tentatively Agreed to Skip
19:58 * meetingology teward to email DMB ml regarding skipping of December 28th normally-scheduled meeting, mark Agenda as Tentatively Agreed to Skip
19:58 <teward> Any other business for the DMB today?
19:58 <rafaeldtinoco> nope.. thanks a lot for chairing
19:58 <rafaeldtinoco> and congrats to both applicants!
19:58 <teward> happy to :)
19:58 <Odd_Bloke> sergiodj: Congrats!
19:58 <teward> indeed, congrats to oSoMoN and sergiodj :)
19:58 <sergiodj> Odd_Bloke: thanks!
19:58 <teward> #topic Next Meeting Date/Time
19:59 <teward> Just so it's in the record, the next meeting is 2020-11-16 at 15:00 UTC.
19:59 <teward> #info Next meeting scheduled for 2020-11-16 15:00 UTC
19:59 <teward> #endmeeting