19:17 <rbasak> #startmeeting
19:17 <meetingology> Meeting started Mon Oct  5 19:17:14 2020 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:17 <meetingology> 
19:17 <meetingology> Available commands: action commands idea info link nick
19:17 <rbasak> #topic Review of previous action items
19:17 <rbasak> rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
19:17 <rbasak> slashd to add Yaru to the desktop set for focal (carried over)
19:17 <rbasak> ddstreet edubuntu seed <-> pkgset (carried over)
19:17 <rbasak> rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:18 <rbasak> For those here, could you update us on your action items please?
19:18 <rafaeldtinoco> carry over again unfort
19:18 <ddstreet> unfortunately i need mine carried over again also
19:18 <rbasak> My action item needs to be carried over. There has been some further progress; I need to reply to the list with a summary.
19:18 <rbasak> #action rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
19:18 * meetingology rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
19:18 <rbasak> #action slashd to add Yaru to the desktop set for focal (carried over)
19:18 * meetingology slashd to add Yaru to the desktop set for focal (carried over)
19:18 <rbasak> #action ddstreet edubuntu seed <-> pkgset (carried over)
19:18 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
19:18 <rbasak> #action rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:18 * meetingology rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
19:19 <rbasak> #topic Package Set/Per Package Uploader Applications
19:19 <rbasak> #subtopic Chris MacNaughton (icey) - OpenStack package set
19:19 * icey waves
19:20 <rbasak> I'm going to break from tradition and not bother to ask icey to introduce his application since that's all clearly laid out on his wiki page
19:20 <rbasak> #link https://wiki.ubuntu.com/ChrisMacNaughton/OpenStackDeveloperApplication
19:20 <rbasak> Welcome icey :)
19:20 <rbasak> Does anyone have any questions for icey?
19:20 <icey> thanks rbasak!
19:20 <rafaeldtinoco> need a mom
19:20 <rafaeldtinoco> (ent) ?
19:20 <rafaeldtinoco> =)
19:21 <rbasak> icey: which previous meeting did you attend that failed to get quorum, OOI? I only see one devel-permissions@ post scheduling your application for just this meeting?
19:22 <icey> I didn't attend the previous one, but I did read some of the meeting logs
19:22 <rbasak> Ah OK
19:22 <icey> I iwas just being sad that there was seeming trouble getting to quorum previously as well
19:22 <icey> s/iwas/was
19:22 <rbasak> Got it, thanks.
19:22 <rbasak> Sorry I misunderstood you earlier.
19:23 <rbasak> I have a question to get us started.
19:24 <rbasak> What's the current situation with OpenStack's release schedule and its alignment with Ubuntu, and where would I find more information about that?
19:25 <icey> For both the current and next releases, they are scheduled for just before the corresponding OpenStack releases. Victoria is scheduled for next week, and Wallaby is scheduled fairly close to the Ubuntu H release
19:26 <rbasak> Sorry, I phrased that poorly. Let me try again. I mean with respect to Ubuntu's release schedule specifically, in terms of freeze and freeze exceptions.
19:26 <icey> I'm apparently having trouble loading the pages but those are generally published at https://releases.openstack.org/victoria/schedule.html and https://releases.openstack.org/wallaby/schedule.html
19:27 <icey> Ok - The OpenStack releases generally are fairly close to an Ubuntu release by release date, and generally have a freeze exception to cover the release
19:27 <rbasak> In other words what changes can you upload Openstack package updates in the development release of Ubuntu and when?
19:28 <rbasak> Do you know how this is coordinated in Ubuntu with respect to the release schedule, the freeze timeline and the release team?
19:29 <icey> As I currently understand it, the OpenStack packages get updates to the development release untili the final OpenStack release. Last release (Focal + OpenStack Ussuri), OpenStack shipped the final release after the release which required a lot of coordination and discussion with the release team to ship the final release
19:30 <icey> In terms of coordination, Corey generally starts a conversation with release timings to the release team via mailing list
19:30 <ddstreet> as an example, let's say you wanted to have a new feature included in qemu in victora; how would you do that, if possible (assuming you start work on it today)?
19:30 <icey> Broadly, I wouldn't.
19:32 <icey> If there were something compelling enough to not do the general thing, I would try to start a discussion about the feasibility of a freeze exception in #ubuntu-release as well as on the mailing list
19:32 <ddstreet> ok thanks
19:33 <slashd> o/
19:33 <ddstreet> hello, we have quorum! o/
19:33 <icey> \o/
19:33 <rafaeldtinoco> icey: and after uploading to devel, where would you check DEP8 issues if any ?
19:34 <rafaeldtinoco> how would you know issue is intermittent ?
19:34 * slashd catching up on the discusion (give me a moment to read)
19:35 <icey> Whenever I get a notification about a build failure (or an autopkgtest failure), my first step is to attemp to reproduce it locally. If I cannot reproduce it locally, then I'd re-run the failing build / test
19:36 <rafaeldtinoco> icey: do you know where to check if your failure is holding other packages migrations ?
19:37 <icey> I would generally go look in https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html (recently)
19:37 <rafaeldtinoco> cool, tku
19:39 <rafaeldtinoco> slashd: do you have any questions for icey ?
19:39 <ddstreet> icey as an administrative question, just to be sure, you're applying for upload rights to the 'openstack' packageset, correct? https://people.canonical.com/~ubuntu-archive/packagesets/groovy/openstack
19:40 <ddstreet> i only ask to clarify, as it currently has no team, so we would need to create a team to add you to
19:40 <icey> ddstreet: If that's the best option? I've been working with coreycb and jamespage on OpenStack packaging, but has generally included a lot larger set than just those packages
19:40 <slashd> rafaeldtinoco: I'm good with the questionned already asked, I have nothing to add for now
19:41 <ddstreet> icey yeah, i wonder if the 'openstack' packageset needs to be expanded
19:42 <icey> ddstreet: I wonder if there's a better packageset to represent ubuntu-openstack (as referenced from a recent test rebuild: https://people.canonical.com/~doko/ftbfs-report/test-rebuild-20200728-groovy-groovy.html#ubuntu-openstack)
19:42 <rbasak> Any more questions for icey?
19:42 <rbasak> icey: that's the team package subscriber list I think, which is distinctly different from the packageset
19:42 <rbasak> It's managed by the team, so I don't think it would be appropriate to drive ACLs from it.
19:43 <icey> rbasak: indeed
19:43 <rbasak> We need a DMB-managed list and that's the packageset.
19:43 <rafaeldtinoco> (or seed changes ?)
19:43 <rbasak> I don't think this packageset is automatic is it?
19:44 <rbasak> We can carry on discussing the technicalities, but if there are no more questions, shall we move on to a vote?
19:44 <rafaeldtinoco> rbasak: yes
19:44 <ddstreet> no more q from me
19:44 <ddstreet> slashd ready for vote?
19:44 <rbasak> #vote Add icey to the list of uploaders for the openstack packageset
19:44 <meetingology> Please vote on: Add icey to the list of uploaders for the openstack packageset
19:44 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:46 <ddstreet> +1 i'm happy with icey's responses and have full faith in his abilities from james and corey endorsements
19:46 <meetingology> +1 i'm happy with icey's responses and have full faith in his abilities from james and corey endorsements received from ddstreet
19:46 <slashd> +1 for the same reasons ^
19:46 <meetingology> +1 for the same reasons ^ received from slashd
19:47 <rafaeldtinoco> +1 and would like icey to help us/openstack team in sorting out seed (or just the pkgset) packages and update it
19:47 <meetingology> +1 and would like icey to help us/openstack team in sorting out seed (or just the pkgset) packages and update it received from rafaeldtinoco
19:48 <rbasak> +1
19:48 <meetingology> +1 received from rbasak
19:49 <rbasak> #endvote
19:49 <meetingology> Voting ended on: Add icey to the list of uploaders for the openstack packageset
19:49 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:49 <meetingology> Motion carried
19:49 <ddstreet> congrats icey!
19:49 <icey> thanks!
19:49 <icey> and I'm excited to help with getting the seed / packageset updated :)
19:50 <rbasak> Any volunteers to announce icey's successful application and to get the ACL changes made?
19:50 <slashd> Congrats icey ;)
19:50 <rafaeldtinoco> congrats!
19:50 <rbasak> Is there any clarification on the ACL changes required in this case?
19:50 <icey> thanks again :)
19:50 <ddstreet> i can handle the acl and announcement
19:50 <Bashing-om> ddstreet: For UWN: Do not ovelook to promulgamate the new addition to the mailing list :D
19:50 <rbasak> Looks like we'll need to create a team, ask the TB to add that to the ACL, etc.
19:50 <rbasak> Thanks ddstreet!
19:51 <ddstreet> yep, i'll create the team and add him, then open a TB request
19:51 <icey> I think (and Corey agrees) that the OpenStack packageset could definitely use some updating, and I'm happy to help with getting that done
19:51 <rbasak> #action ddstreet to announce icey's successful application
19:51 * meetingology ddstreet to announce icey's successful application
19:51 <ddstreet> Bashing-om i'll be sure to announce to devel-permissions
19:51 <ddstreet> i assume that's the list you mean
19:51 <rbasak> #action ddstreet to add icey to the ACL as needed for the openstack packageset
19:51 * meetingology ddstreet to add icey to the ACL as needed for the openstack packageset
19:52 <rbasak> ddstreet: it's https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application
19:52 <rbasak> ddstreet: ubuntu-news-team@
19:52 <ddstreet> ah ok i'll run down the checklist, yep
19:52 <rbasak> #topic Outstanding mailing list requests to assign
19:54 <rbasak> I don't see anything outstanding
19:54 <Bashing-om> ddstreet: I generally follow https://lists.ubuntu.com/archives/ubuntu-news-team/; but I will find the notice where ever you post it - thanks :D
19:54 <rbasak> #info Nothing outstanding
19:54 <rbasak> #topic Open TB bugs
19:54 <rbasak> #info Nothing outstanding
19:55 <rbasak> #topic Select a chair for the next meeting (following alphabetical order of first names)
19:55 <rbasak> It'll be teward
19:55 <rbasak> #info Next chair will be teward
19:55 <rbasak> #topic Any other business
19:55 <rbasak> Anything else?
19:55 <rafaeldtinoco> not here
19:55 <rafaeldtinoco> and thanks for chairing this
19:55 <ddstreet> nothing from me, and thanks for chairing!
19:56 <rbasak> #info No other business
19:56 <rbasak> Thanks all!
19:56 <rbasak> #endmeeting