19:02 <rbasak> #startmeeting Developer Membership Board
19:02 <meetingology> Meeting started Mon Mar 23 19:02:55 2020 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:02 <meetingology> 
19:02 <meetingology> Available commands: action commands idea info link nick
19:03 <rbasak> #topic Review of previous action items
19:03 <rbasak> tsimonq2 to better document what we expect applicants to know (carried over)
19:03 <rbasak> cyphermox to build report for expiry from dev teams (carried over)
19:03 <rbasak> rbasak to announce/implement : Expiry policy for flavor developer team membership (https://lists.ubuntu.com/archives/technical-board/2019-July/002451.html)
19:03 <rbasak> teward to handle permission granting and announcements for rcj
19:03 <teward> mine is done.
19:03 <rbasak> On my action, I will do that soon, now that the new DMB is settled.
19:04 <rbasak> Can someone take over cyphermox's previous action please?
19:04 <sil2100> o/
19:04 <sil2100> (just now arrived)
19:04 <rbasak> It's related to dealing with requiring expiry of flavour developers without explicit renewal, as requested by the TB, I think?
19:04 <rbasak> Thanks teward!
19:04 <rbasak> I don't see tsimonq2 here.
19:05 <rbasak> Any volunteers for cyphermox's previous action?
19:05 <ddstreet> is there any details on what exactly it involves?
19:05 <tsimonq2> Thanks to teward for blowing up notifications. :P
19:05 <tsimonq2> Hello.
19:06 <rbasak> ddstreet: if it is what I think it is, it's https://lists.ubuntu.com/archives/technical-board/2019-July/002451.html
19:07 <rbasak> I think there has been some discussion in previous meetings - we'd need to look at IRC logs.
19:07 <rbasak> But as people have changed, I don't think anyone should be held to any previous thoughts we had on this.
19:07 <rbasak> Just that it remains pending for us to implement for the TB>
19:07 <rbasak> .
19:08 <rbasak> tsimonq2: any news on your action please, or should I carry it forward?
19:08 <ddstreet> so, that email sounds like all that is being asked is to enable team expiry for the per-flavor teams, is that your understanding also?  the action item is talking about 'build report'
19:09 <rbasak> ddstreet: I remember a question (probably from me) on what exactly a "flavor team" is - for example is cloud or server included?
19:09 <tsimonq2> rbasak: Please do.
19:09 <rbasak> We need a list of them. But otherwise, yes.
19:09 <tsimonq2> (Carry it forward, that is.)
19:09 <rbasak> #action tsimonq2 to better document what we expect applicants to know (carried over)
19:09 * meetingology tsimonq2 to better document what we expect applicants to know (carried over)
19:09 <ddstreet> rbasak agreed, is that something the TB shoudl answer or is that something for us to define?
19:09 <rbasak> ddstreet: IMHO, the TB wouldn't mind if we just defined it
19:10 <rbasak> I don't remember how that turned into an action for a report
19:10 <rbasak> I'd have to look at old IRC logs
19:10 <rbasak> But IMHO, forget that, let's just get it done if we can find a volunteer.
19:10 <ddstreet> ok so we should probably have action item 1) define list of 'flavor teams' and 2) implement membership expiry for those teams
19:10 <rbasak> ddstreet: are you volunteering? :)
19:11 <cyphermox> o/
19:11 <cyphermox> so my action was to enable expiry, that's all
19:11 <ddstreet> cyphermox o/ hello!
19:11 <cyphermox> probably to notify everyone first, because it'll need people to help with setting the expiry when they add people for the delegated teams
19:11 <ddstreet> cyphermox did you have a list of specific teams to enable expiry for?
19:12 <rafaeldtinoco> o/
19:12 <ddstreet> full dmb house! \o/ party time
19:13 <teward> ddstreet: *turns on the rave lights and music*  :P
19:13 <rafaeldtinoco> is there any homework left for me ?
19:13 <rafaeldtinoco> or was it all taken ?
19:13 <ddstreet> rbasak i can at least take the action item to define an initial list of 'flavor teams' for review next dmb
19:13 <rbasak> ddstreet: thank you!
19:13 <ddstreet> unless rafaeldtinoco wants to take it :)
19:13 <rafaeldtinoco> no, its yours
19:13 <rbasak> #action ddstreet to define an initial list of 'flavor teams'
19:13 * meetingology ddstreet to define an initial list of 'flavor teams'
19:14 <rbasak> rbasak to announce/implement : Expiry policy for flavor developer team membership (https://lists.ubuntu.com/archives/technical-board/2019-July/002451.html) (carried over)
19:14 <rbasak> #info teward to handle permission granting and announcements for rcj: done
19:14 <rbasak> #topic DMB elections for the expired 2 members
19:14 <rbasak> #info Elections are now complete
19:14 <rbasak> No applications, so
19:14 <rbasak> #topic Outstanding mailing list requests to assign
19:15 <rbasak> Looks like these go back quite a way
19:16 <rbasak> Adding lubuntu-update-notifier to the Lubuntu package set
19:16 <rbasak> From 8 Jan
19:16 <rbasak> Expired MOTU membership
19:16 <rbasak> From 17 Feb
19:16 <rbasak> Please add new printing-related packages to my upload rights into main
19:16 <rbasak> From 20 Feb
19:16 <rbasak> Requesting upload rights for ltsp
19:16 <rbasak> From 18 Mar
19:16 <rbasak> That's all the outstanding requests I can see.
19:17 <rbasak> Can I suggest that we nominate one DMB member to look into each, and ask if you need help?
19:17 <teward> re: lubuntu-update-notifier I'll take that one, and make sure that gets added to teh packageset - this wwas discussed separately with the Lubuntu Team in the past that this is a reasonable request (at least from me as a coredev)
19:17 <teward> i'll take that one
19:17 <rbasak> Thanks
19:17 <teward> re: ltsp request, that needs a separate PPU upload IMO
19:17 <teward> the request expands BEYOND LTSP when reading it further
19:17 <rbasak> For each one, determine if you can act alone, or if you need the DMB to vote, and if the latter, bring that up next meeting?
19:17 <teward> i already dug in LTSP so i'll take that one
19:17 <teward> as well
19:18 <rbasak> #action teward to handle request "Adding lubuntu-update-notifier to the Lubuntu package set"
19:18 * meetingology teward to handle request "Adding lubuntu-update-notifier to the Lubuntu package set"
19:18 <rbasak> #action teward to handle request "Requesting upload rights for ltsp"
19:18 * meetingology teward to handle request "Requesting upload rights for ltsp"
19:18 <rbasak> Volunteers for the other two please?
19:18 <rafaeldtinoco> let me have one
19:18 <teward> i have an opinion re: the printing rights request
19:18 <teward> but i won't take it :p
19:18 <teward> rafaeldtinoco: two for the taking :)
19:19 <rbasak> rafaeldtinoco: any preference? :)
19:19 <rafaeldtinoco> nope
19:19 <rbasak> #action rafaeldtinoco to handle request "Expired MOTU membership"
19:19 * meetingology rafaeldtinoco to handle request "Expired MOTU membership"
19:19 <rbasak> One more volunteer for the printing request please.
19:19 <rbasak> Does anyone have no action?
19:20 <rbasak> slashd maybe please?
19:20 <slashd> rbasak: sure
19:20 <rbasak> Thanks!
19:20 <rbasak> #action slashd to handle request "Please add new printing-related packages to my upload rights into main"
19:20 * meetingology slashd to handle request "Please add new printing-related packages to my upload rights into main"
19:21 <rbasak> That's all of them I think.
19:21 <rbasak> Can anyone see anything I've missed?
19:21 <rbasak> FWIW, this is an unusually large number of outstanding requests. Usually there's zero or one.
19:21 <teward> i have a few things that as a member of the Studio dev team i want to get into the studio packagesets
19:21 <rbasak> I guess it's just the backlog during the elction etc.
19:22 <teward> but that can wait as they have me (as coredev sponsoring contact) on their team so I can handle those uploads for them
19:22 <teward> and i really want Eickmeyer (whos PoC on the Studio Dev Team) to request those
19:22 <rbasak> OK
19:22 <teward> so just something to keep in mind but no action item needed for now
19:22 <ddstreet> if we've moved on to AOB I have one topic to discuss
19:22 <rbasak> The flavor packagesets are "fun".
19:22 <rbasak> They're automatically generated from a script.
19:22 <teward> yes they are rbasak xD
19:22 <rbasak> So you can't just add something - you have to modify the script, etc.
19:23 <rbasak> (or, in theory, rerunning the script should suffice, but I'm not sure it's ever been that simple)
19:23 <rbasak> #topic Select a chair for the next meeting (following alphabetical order of first names)
19:23 <rbasak> We never did this in the past because attendance was so unreliable. Should we start this now?
19:24 <rbasak> Any objections?
19:24 <rafaeldtinoco> no objs
19:24 <ddstreet> sounds good to me
19:24 <rbasak> If not, tsimonq2 can start by chairing the next meeting as someone has already put together the list and he's first.
19:24 <rbasak> #info tsimonq2 will chair the next meeting
19:24 <rbasak> #topic Any other business
19:24 <rbasak> ddstreet: you're up!
19:25 <ddstreet> I wanted to bring up the topic of general team expirations
19:25 <tsimonq2> Sure, I can chair. :P
19:25 <rbasak> tsimonq2: thanks!
19:25 <ddstreet> i know MOTU and coredev, etc. have expirations enabled, but my thought was perhaps we should 'retire' people from coredev/motu/etc after X years of no uploads
19:26 <ddstreet> i suspect even people who have no intention of ever uploading again will still click the 'renew' button once every few years when their membership is reaching expiration
19:26 <ddstreet> bringing the topic up for thoughts from the dmb
19:26 <rbasak> I'm curious to know what other similar projects do.
19:27 <teward> I'm generally for the idea, but I'd like to see a report showing who has rights and who has exercised them
19:27 <teward> including PPU rights.
19:27 <ddstreet> rbasak similar projects meaning like freedesktop or fedora or github, etc?
19:27 <rbasak> Also, we sometimes get people whose memberships have expired ask for renewal. What do you propose to do if we get such a request after someone gets removed for having no uploads?
19:28 <teward> I think we need specifically to look at MOTU and CoreDev and specialized groups separately
19:28 <rbasak> ddstreet: like freedesktop and fedora. Community projects with a large number of "committers".
19:28 <teward> if they have a Launchpad group and we expire them from upload rights they aslo need to be removed / deactivated from the team at the same time
19:28 <ddstreet> that's an excellent point to consider, i personally would suggest anyone who is expired due to no uploads should re-apply, but it should be a policy (if we do 'retire' people)
19:28 <ddstreet> teward i like the report idea, that would be good info to have
19:29 <rafaeldtinoco> i'm in favor of re-apply idea if we ever start to demote devs
19:29 <rbasak> One thing that has happened recently is some people accidentally expire ("missed the email") so IIRC what we've done that is be fairly lax with readding them.
19:29 <rafaeldtinoco> rbasak: we could have an acceptable period
19:29 <teward> rbasak: With some exceptions, I think we should be more strict on enforcement
19:29 <rbasak> By "lax" I mean just re-add them if it's only been a month or so
19:29 <rafaeldtinoco> +1 on lax
19:29 <teward> or have a 'grace' period where they can be readded BUT have to have evidence of actually using those permissions
19:29 <teward> agreed +1
19:30 <ddstreet> yep, maybe if we enable a 'no upload retirement' policy, we could just disable the 'renew' emails
19:30 <ddstreet> but we would need a new email sent, saying 'you need to upload' instead of just 'you need to click this button' to stay in the group
19:30 <rbasak> Unfortunately to implement this I think we'd have to write some scripting ourselves
19:30 <teward> indeed
19:30 <ddstreet> yep
19:30 <ddstreet> ok probably no action to take now, but at least we're thinking about it
19:31 <rbasak> The Launchpad membership expiry doesn't stretch far enough for this proposal. To be clear: that's not intended to mean I'm opposed to this.
19:31 <rbasak> OK. Thank you for bringing this up.
19:31 <rbasak> I suggest that to make more progress someone writes a concrete proposal to the ML?
19:31 <rbasak> devel-permissions@ is probably the appropriate venue.
19:31 <rbasak> Any other AOB?
19:31 <rafaeldtinoco> +1 on proposal, with examples from other communities
19:32 <rafaeldtinoco> i liked the examples idea
19:32 <rafaeldtinoco> so we dont reinvent the wheel
19:32 <teward> +1 to sending to the ML (with a CC to the developer membership board list as well so it's alos listed htere)
19:32 <ddstreet> agreed from me also, as i brought it up i'll first see if i can get a report together as teward suggested
19:33 <ddstreet> and then email the list once the report is ready
19:33 <teward> rbasak: let's at least assign an action item to ddstreet for now re: getting together a report of:
19:33 <rafaeldtinoco> ddstreet: i'd write this as a small RFC so we grow it through the mail thread
19:33 <rbasak> ddstreet: do you want that as an action?
19:33 <teward> (1) who currently has upload rights, and (2) who has used them or not in the past year+
19:33 <teward> my two cents
19:33 <ddstreet> sure yep i'll take the action
19:34 <rbasak> #action ddstreet to write up a proposal for upload access expiry following some period of disuse
19:34 * meetingology ddstreet to write up a proposal for upload access expiry following some period of disuse
19:34 <rbasak> Anything further to discuss?
19:35 <rbasak> I guess we're done then.
19:35 <rbasak> Thanks all!
19:35 <rbasak> #endmeeting