15:00 <cyphermox> #startmeeting Developer Membership Board
15:00 <meetingology> Meeting started Mon Oct 21 15:00:38 2019 UTC.  The chair is cyphermox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00 <meetingology> 
15:00 <meetingology> Available commands: action commands idea info link nick
15:01 <cyphermox> #topic Review of previous action items
15:01 <cyphermox> tsimonq2 to better document what we expect applicants to know
15:01 <cyphermox> oh, and I was forgetting
15:01 <cyphermox> #votesrequired 4
15:01 <meetingology> votes now need 4 to be passed
15:01 <cyphermox> #voters cyphermox slashd rbasak sil2100 tsimonq2 jbicha micahg
15:01 <meetingology> Warning: Nick not in channel: jbicha
15:01 <meetingology> Warning: Nick not in channel: micahg
15:01 <meetingology> Current voters: cyphermox jbicha micahg rbasak sil2100 slashd tsimonq2
15:02 <cyphermox> tsimonq2: you around?
15:02 <slashd> o/
15:02 <sil2100> uh oh
15:02 <cyphermox> ok; carrying over I guess
15:02 <sil2100> Yeah
15:02 <cyphermox> slashd to make ACL changes for xtrusia's successful contributing developer application
15:02 <cyphermox> reportedly done
15:02 <slashd> it is indeed done ^
15:03 <cyphermox> slashd to announce xtrusia's successful contributing developer application (done)
15:03 <cyphermox> cool, so all done; I'll update the agenda afterwards
15:03 <sil2100> \o/
15:03 <marcustomlinson> :(
15:04 <cyphermox> Expiry policy for flavor developer team membership
15:04 <cyphermox> oops
15:04 <cyphermox> marcustomlinson: what's wrong?
15:04 <marcustomlinson> won't meet quorum today?
15:04 <cyphermox> so far we're not quorate, no
15:04 <cyphermox> but there's a chance
15:04 <cyphermox> #topic Expiry policy for flavor developer team membership
15:04 <sil2100> Well, so we have votes from Robie
15:04 <sil2100> So we can vote I think
15:04 <cyphermox> ah, good
15:04 <marcustomlinson> ah I see, I misread "cool, so all done"
15:04 <cyphermox> well, postpone expiry though?
15:05 <slashd> cyphermox, sil2100 : we are good to proceed with vote today
15:05 <cyphermox> yes okay
15:05 <cyphermox> but not quorate to discuss expiry policy?
15:05 <slashd> right
15:05 <sil2100> cyphermox: yeah, let's postpone the expiry
15:05 <cyphermox> and also, is there much to discuss or is it just implementing
15:05 <cyphermox> I think it's actually just implementing
15:06 <cyphermox> I'll take an action to actually start looking into a report for this at the very least
15:06 <cyphermox> #action cyphermox to build report for expiry from dev teams
15:06 * meetingology cyphermox to build report for expiry from dev teams
15:06 <cyphermox> #topic DMB elections for the expired 2 members
15:07 <cyphermox> so; me and jbicha had expired, because technically our term is over
15:07 <cyphermox> but I've asked the TB to reinstate us so we could be useful long enough to get voting done
15:07 <cyphermox> any one of us familiar enough with condorcet to set this up?
15:07 <cyphermox> otherwise I'll ask Laney for how to do it ^
15:09 <cyphermox> I'll take that as a no ;)
15:09 <cyphermox> #action cyphermox to setup nominations, voting for new DMB members
15:09 * meetingology cyphermox to setup nominations, voting for new DMB members
15:09 <cyphermox> #topic Package Set/Per Package Uploader Applications
15:10 <cyphermox> #subtopic GunnarHj ibus-avro PPU
15:10 <cyphermox> GunnarHj doesn't seem to be around
15:10 <sil2100> hmm
15:11 <sil2100> Since it's just addition to the PPU, should we maybe just do it?
15:11 <sil2100> I can't remember the procedures for this
15:12 <cyphermox> if it's consistent, if it was a pacakgeset
15:12 <cyphermox> but this is PPU
15:12 <cyphermox> depends on whether he can upload things to Debian
15:13 <cyphermox> I think we at least need more than just an email
15:13 <Laney> "This way, any DMB member may update the glob expansions for Gunnar (by relying on their existing definition) without needing to refer to the full DMB for agreement or the TB to make the change. "
15:13 <Laney> since I got highlighted :-)
15:13 <sil2100> Laney: ;)
15:13 <cyphermox> ah, I didn't remember this one ;)
15:13 <cyphermox> Laney: thanks!
15:13 <sil2100> \o/
15:13 <cyphermox> #agreed
15:13 <cyphermox> so, JFDI
15:13 <cyphermox> sil2100: you want to do the honours?
15:15 <sil2100> cyphermox: sure o/
15:16 <cyphermox> cool
15:16 <cyphermox> #action sil2100 to update PPU for Gunnar, adding ibus-avro
15:16 * meetingology sil2100 to update PPU for Gunnar, adding ibus-avro
15:16 <sil2100> wheee
15:16 <cyphermox> #subtopic marcustomlinson - LibreOffice PPU
15:16 <cyphermox> marcustomlinson: hey hey
15:16 <marcustomlinson> o/
15:17 <cyphermox> marcustomlinson: Would you like to summarize why you're here today, and what your work has been on Ubuntu? We do have the wiki page but it's nice to hear anyway :)
15:18 <marcustomlinson> sure, I’ve been contributing to Ubuntu since late 2013
15:18 <marcustomlinson> much of the first 4 years was Unity heavy
15:18 <marcustomlinson> in the last year I've been deeply involved in snap integration on Desktop and LibreOffice
15:18 <marcustomlinson> Since starting on Libreoffice we've gone from over 800 open bugs to under 400 :)
15:19 <marcustomlinson> and I've prepared probably around 15 or so releases
15:19 <marcustomlinson> that's the short version :)
15:19 <cyphermox> awesome :)
15:20 <cyphermox> sil2100: rbasak: slashd: tsimonq2: any questions for marcustomlinson ?
15:22 <marcustomlinson> oh I see I've done 26 releases ;)
15:22 <slashd> marcustomlinson, at which point in the devel release you stop introducing new features ?
15:23 <marcustomlinson> feature freeze
15:23 <slashd> and how do you know when is the specific date ?
15:24 <marcustomlinson> Good question, I trust my team calendar at the mo
15:24 <slashd> F is not out yet, by here's the one for eoan: https://wiki.ubuntu.com/EoanErmine/ReleaseSchedule
15:24 <marcustomlinson> https://wiki.ubuntu.com/EoanErmine/ReleaseSchedule
15:24 <marcustomlinson> ah too slow
15:25 <slashd> ;p
15:25 <sil2100> marcustomlinson: let's say you uploaded a new libreoffice to focal but it seems to be stuck in -proposed - what and where would you look for reasons 'why'?
15:25 <sil2100> How would you proceed?
15:25 <marcustomlinson> I'd ping a vanguard on #ubuntu-release
15:27 <sil2100> What vanguard would you ping?
15:27 <sil2100> And isn't there something you could investigate by yourself?
15:27 <marcustomlinson> I usually use the list here: https://wiki.ubuntu.com/StableReleaseUpdates
15:27 <marcustomlinson> depending on day
15:27 <slashd> marcustomlinson, before pinging the vanguard, what can be done by yourself ?
15:28 <sil2100> marcustomlinson: this is a focal upload, so for the development release - the SRU team doesn't really take care of the devel release ;)
15:29 <marcustomlinson> slashd: to be honest I don't know
15:29 <sil2100> marcustomlinson: what about update_excuses?
15:29 <marcustomlinson> ah ok
15:29 <sil2100> marcustomlinson: did you have any experience with update_excuses so far?
15:29 <marcustomlinson> right, I always run all my autopkgtests before upload, but yes how it effects others
15:30 <marcustomlinson> sil2100: yes https://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html#nspr
15:30 <marcustomlinson> I fixed a funk s390x issue recently in fact
15:31 <cyphermox> <3
15:31 <marcustomlinson> https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1832360
15:31 <ubottu> Launchpad bug 1832360 in libreoffice (Ubuntu) "autopkgtests flaky on s390x" [Medium,Fix released]
15:31 <sil2100> marcustomlinson: ok, just remember to always make sure to look at update_excuses for the uploads you make
15:31 <sil2100> Anyway, I have no other questions
15:31 <marcustomlinson> sil2100: indeed, brain fart
15:31 <slashd> no more questions as well
15:32 <cyphermox> okay
15:32 <cyphermox> #vote marcustomlinson  to gain Per-package upload rights for libreoffice
15:32 <meetingology> Please vote on: marcustomlinson  to gain Per-package upload rights for libreoffice
15:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:32 <cyphermox> humm
15:32 <cyphermox> actually, is that wrong? because there are some satellite packages to libreoffice?
15:33 <marcustomlinson> such as? libreoffice-l10n?
15:33 <slashd> cyphermox, should we also vote for contribution developer ? I see 2 application from marcustomlinson
15:33 <slashd> ppu + contrib developer
15:34 <cyphermox> contrib developer is irrelevant if this vote passes :)
15:34 <cyphermox> marcustomlinson: yes, libreoffice-l10n
15:35 <marcustomlinson> libreoffice-l10n at least is not a thing anymore from Eoan (thanks to me - he says hinting at more votes :P)
15:35 <cyphermox> and IIRC some of your predecessors had once requested PPU for some other things
15:35 <marcustomlinson> but yes for SRUs from D back I'll need that
15:35 <cyphermox> ah, cool
15:35 <cyphermox> well, let's vote on libreoffice first, and then we can (maybe) vote on adding l10n, if the rest of the board agrees to it
15:36 <cyphermox> voting is already open; please cast your votes :)
15:36 <cyphermox> +1
15:36 <meetingology> +1 received from cyphermox
15:37 <slashd> +1
15:37 <meetingology> +1 received from slashd
15:42 <slashd> sil2100, ?
15:43 <sil2100> +1
15:43 <meetingology> +1 received from sil2100
15:43 <sil2100> (apologies, got pulled into a meeting)
15:43 <slashd> We also got an anticipated vote from rbasak (+1)
15:44 <cyphermox> that's a +4
15:44 <marcustomlinson> \o/
15:44 <cyphermox> #endvote
15:44 <meetingology> Voting ended on: marcustomlinson  to gain Per-package upload rights for libreoffice
15:44 <meetingology> Votes for:3 Votes against:0 Abstentions:0
15:44 <meetingology> Motion denied
15:44 <marcustomlinson> XD
15:44 <cyphermox> #agreed Motion carried; meetingology is drunk
15:45 <slashd> Congrats marcustomlinson !
15:45 <cyphermox> Now; why I said that contributing dev is irrelevant is because all it really gives you is Ubuntu Membership, which you get by being PPU unless you really didn't qualify
15:45 <marcustomlinson> will I be added to ubuntu-developer-members?
15:45 <cyphermox> and a little wrench badge on Launchpad
15:45 <cyphermox> yep
15:45 <cyphermox> well
15:45 <cyphermox> that was my point
15:45 <cyphermox> you'd be added to ~ubuntu-dev, which gets you membership
15:46 <slashd> ok
15:46 <marcustomlinson> cool :)
15:46 <cyphermox> the only thing the other team gives you is the wrench badge
15:46 <cyphermox> I'm not opposed to adding that too if you really care ;)
15:46 <marcustomlinson> I like badges
15:46 <marcustomlinson> :D
15:46 <cyphermox> but really, it's just one more thing to renew membership for
15:46 <cyphermox> ok
15:46 <cyphermox> volunteers to do the team additions?
15:47 <slashd> cyphermox, I'll do it
15:47 <cyphermox> ~ubuntu-dev; and ~ubuntu-developer-members
15:47 <marcustomlinson> thanks guys
15:47 <RikMills> marcustomlinson: congrats
15:47 <cyphermox> I'm on purpose skipping voting on Contributing Developer, because as stated, marcustomlinson gets membership by having PPU rights.
15:47 <cyphermox> marcustomlinson: congrats!
15:48 <cyphermox> #topic MOTU Applications
15:48 <marcustomlinson> sorry to budge in, libreoffice-l10n?
15:49 <cyphermox> oh, right
15:49 <cyphermox> sil2100: slashd: do you care? do you think this really must be voted on?
15:49 <slashd> I'm good with it
15:50 <sil2100> +1 on that
15:51 <cyphermox> okay then
15:51 <cyphermox> #agreed Adding libreoffice-l10n to PPU for marcustomlinson as well, since it's a straightforward l10n satellite package to libreoffice
15:51 <marcustomlinson> awesome thanks
15:52 <cyphermox> oh, who does ACL? slashd you'll do it with teams?
15:52 <cyphermox> we might need TB help
15:52 <cyphermox> (I mean, alongside updating teams in LP)
15:52 <cyphermox> or I can deal with the ACL changes
15:53 <slashd> cyphermox, ok I'll deal with the team add
15:53 <cyphermox> #action slashd to add marcustomlinson to the right LP teams
15:53 * meetingology slashd to add marcustomlinson to the right LP teams
15:53 <cyphermox> #action cyphermox to update PPU for marcustomlinson, adding libreoffice and libreoffice-l10n
15:53 * meetingology cyphermox to update PPU for marcustomlinson, adding libreoffice and libreoffice-l10n
15:53 <cyphermox> okay; am I forgetting anything before we move on to the other requests?
15:54 <cyphermox> does everyone still have the time so we can vote?
15:54 <slashd> yeah I do
15:54 <slashd> let's take benefit of the quorum to do it
15:54 <cyphermox> yup
15:54 <cyphermox> #subtopic rafaeldtinoco - MOTU and Ubuntu Server Developer
15:54 <rafaeldtinoco> o/
15:55 <cyphermox> I'm a bit surprised that Ubuntu Server isn't a properly delegated team
15:56 <cpaelzer> cyphermox: I can only say this is as it was since before my time here and so far there never was a request/need to change it
15:56 <cpaelzer> all of us went through DMB to get server upload rights and somewhen later to core-dev
15:56 <cyphermox> well, I don't see any indication the DMB has rights to put people in ~ubuntu-server anyway
15:56 <cpaelzer> when rbasak is available on another day you might ask about the history of it
15:57 <cyphermox> oh, then upload rights wouldn't be synced with team though
15:57 <cpaelzer> but it shouldn't block the discussion of rafaeldtinoco today
15:57 <cyphermox> no, no, just trying to understand what we need to be voting for.
15:57 <Laney> It's ~ubuntu-server-dev
15:57 <sil2100> I guess this is just about the MOTU permissions here
15:57 <rafaeldtinoco> cyphermox: based on feedback - endorsements - I got from application, I'd like to to know if core-dev is also a possibility.
15:59 <cyphermox> well, rbasak probably only gave his vote formally for motu, not core-dev
15:59 <cyphermox> I wouldn't want to assume he's +1 on that, even though he might be
16:00 <sil2100> I think Robie said he had questions in case it was a core dev application
16:00 <cyphermox> okay
16:00 <cyphermox> then yeah, we wouldn't be quorate to vote for core-dev
16:00 <rafaeldtinoco> sounds good to me
16:00 <cyphermox> server or MOTU first?
16:02 <cyphermox> #vote rafaeldtinoco to gain MOTU upload rights
16:02 <meetingology> Please vote on: rafaeldtinoco to gain MOTU upload rights
16:02 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:03 <slashd> +1
16:03 <meetingology> +1 received from slashd
16:04 <cyphermox> Also, if there are questions, don't hesitate
16:04 <cyphermox> +1
16:04 <meetingology> +1 received from cyphermox
16:05 <sil2100> +1
16:05 <meetingology> +1 received from sil2100
16:05 <cyphermox> what vote did rbasak leave us?
16:05 <slashd> +1 from rbasak
16:05 <meetingology> +1 from rbasak received from slashd
16:05 <rafaeldtinoco> \o/
16:05 <cyphermox> alright; #envote
16:06 <cyphermox> #endvote
16:06 <meetingology> Voting ended on: rafaeldtinoco to gain MOTU upload rights
16:06 <meetingology> Votes for:3 Votes against:0 Abstentions:0
16:06 <meetingology> Motion denied
16:06 <cyphermox> #agreed Motion carried; rbasak left a vote +1
16:06 <cyphermox> meetingology: keep up.
16:06 <cyphermox> rafaeldtinoco: congrats
16:06 <RikMills> rafaeldtinoco: congratulations :)
16:06 <rafaeldtinoco> thx a lot!
16:06 <cyphermox> let's vote for Server now
16:06 <cyphermox> #vote rafaeldtinoco to gain Ubuntu Server upload rights
16:06 <meetingology> Please vote on: rafaeldtinoco to gain Ubuntu Server upload rights
16:06 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:07 <slashd> +1
16:07 <meetingology> +1 received from slashd
16:07 <cyphermox> +1
16:07 <meetingology> +1 received from cyphermox
16:09 <sil2100> +1 (seeing that ~4 people from server endorsed his application, makes sense!)
16:09 <meetingology> +1 (seeing that ~4 people from server endorsed his application, makes sense!) received from sil2100
16:10 <slashd> +1 from rbasak
16:10 <meetingology> +1 from rbasak received from slashd
16:10 <cyphermox> yup
16:10 <rafaeldtinoco> \o/
16:10 <cyphermox> #endvote
16:10 <meetingology> Voting ended on: rafaeldtinoco to gain Ubuntu Server upload rights
16:10 <meetingology> Votes for:3 Votes against:0 Abstentions:0
16:10 <meetingology> Motion denied
16:10 <cyphermox> #agreed motion carried!
16:10 <slashd> Congrats rafaeldtinoco
16:10 <sil2100> ;)
16:10 <rafaeldtinoco> thank you very much ! ill keep up with the work =)
16:10 <cyphermox> congrats rafaeldtinoco
16:10 <sil2100> rafaeldtinoco: congrats! Keep up the good work!
16:10 <rafaeldtinoco> thx!
16:10 <cyphermox> okay, volunteers to do team additions then?
16:10 <slashd> cyphermox, I'll do it
16:11 <cyphermox> #action  slashd to add rafaeldtinoco  to ~ubuntu-server-dev and ~motu
16:11 * meetingology slashd to add rafaeldtinoco  to ~ubuntu-server-dev and ~motu
16:11 <cyphermox> #topic Outstanding mailing list requests to assign
16:11 <cyphermox> are there any?
16:12 <cyphermox> looks like negative
16:12 <cyphermox> #topic Select a chair for the next meeting
16:12 <cyphermox> I nominate...
16:12 <cyphermox> rbasak; he's not around to say no! ;)
16:13 <cyphermox> (actually, trying to stick to the rotation)
16:13 <cyphermox> #topic Any other business
16:13 <cyphermox> anything else?
16:14 <cyphermox> I guess not
16:14 <slashd> I think we are good
16:15 <cyphermox> #endmeeting