19:10 <cyphermox> #startmeeting Developer Membership Board
19:10 <meetingology> Meeting started Mon Feb 26 19:10:54 2018 UTC.  The chair is cyphermox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:10 <meetingology> 
19:10 <meetingology> Available commands: action commands idea info link nick
19:11 <cyphermox> #topic Review of previous action items
19:11 <cyphermox> sil2100: to add budgie-extras to fossfreedom's PPU set
19:11 <cyphermox> ^ that's done, cool
19:11 <cyphermox> bdmurray: to handle mapreri's PPU-addition request
19:12 <bdmurray> I submitted a bug report to that special project, let me have a look at it.
19:12 <bdmurray> bug 1747093
19:12 <ubottu> bug 1747093 in ubuntu-community " [TB/DMB] Additional PPU for mapreri" [Undecided,New] https://launchpad.net/bugs/1747093
19:12 <bdmurray> I'll ping a TB member about it.
19:13 <mapreri> bad TB :>
19:13 <tsimonq2> heh
19:13 <cyphermox> alrighty
19:13 <cyphermox> #topic Package Set/Per Package Uploader Applications
19:14 <cyphermox> tsimonq2: the one issue I see though is that typically we ask to have a week's lead time to be able to review the application before doing the DMB meeting
19:14 <tsimonq2> Yes, I understand.
19:14 <cyphermox> to be fair, let's make sure that's written down somewhere
19:15 <tsimonq2> It is, but it's a "should" ;)
19:15 <rbasak> It's documented already at https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
19:15 <rbasak> I don't think we need to have a strict policy on it, since we can vote with our...votes as needed.
19:16 <cyphermox> any DMB members here opposing the review today?
19:16 <micahg> I know there were some questions of viability of application by email already
19:16 <bdmurray> I thought rbasak had asked a question about the application.
19:16 <rbasak> I don't oppose, but I may end up being -1 subject to more information or time.
19:16 <rbasak> If indeed I'm here to vote.
19:16 <tsimonq2> bdmurray: That was solved I believe.
19:17 <rbasak> I am still struggling to understand exactly what is blocking on you not being able to upload these packages.
19:17 <bdmurray> tsimonq2: I think a response should have been sent to the original query even if it was addresed out of band.
19:17 <rbasak> I found three uploads. Are there any more?
19:17 <tsimonq2> There's four packages in main.
19:17 <tsimonq2> rbasak: Yes, there's quite a bit more.
19:18 <tsimonq2> bdmurray: Sure, apologies.
19:18 <rbasak> tsimonq2: your third table seems to have uploads that you performed without sponsorship.
19:18 <rbasak> Which is great for the DMB to review of course.
19:18 <rbasak> It's useful to have in the application.
19:18 <rbasak> But first I'd like to understand what you're being blocked in uploading.
19:19 <tsimonq2> I can't land the stack via the CI Train myself because four packages in the stack aree in main.
19:19 <rbasak> And the best way to demonstrate that is with a list of sponsored uploads, so we can see your work, what sorts of uploads they were, who sponsored them, etc.
19:19 <tsimonq2> Sure, I understand.
19:21 <tsimonq2> For uploads, mitya57 and LocutusOfBorg sponsor things for me nowadays.
19:21 <tsimonq2> (With Qt.)
19:21 <tsimonq2> It's a bit hard to see who pressed the button on Bileto but it's been one of them.
19:22 <rbasak> I found three uploads> FTR, I think three is fine for an experienced uploader helping with transitions etc.
19:23 <rbasak> I haven't decided how you fit with that for myself yet though, because I'm not sure I understand (yet) your existing contributions.
19:23 <tsimonq2> OK; ftr I helped with the 5.7.1, 5.9.0, 5.9.1, 5.9.2 transitions  in Debian and Ubuntu  and 5.9.3 and 5.9.4 in  Ubuntu only.
19:24 <tsimonq2> I did 5.9.3 and 5.9.4 myself, with 5.9.2 being mostly me
19:24 <tsimonq2> 5.9.0 was a joint effort.
19:24 <rbasak> OK, but what specifically did that involve for you in Ubuntu?
19:25 <tsimonq2> 5.9.2+ was merging from Debian or doing Ubuntu-specific uploads.
19:26 <tsimonq2> 5.9.2 was mostly syncs while 5.9.3+ is Ubuntu-only with the whole stack.
19:26 <tsimonq2> This also involved the normal transition stuff like no-change rebuilds, etc.
19:27 <tsimonq2> I did some work with 5.7 but that was *mostly* Mirv and mitya57, both of which have eendorsed my application.
19:27 <tsimonq2> Does that answer your questions?
19:28 <tsimonq2> For the record, this is 5.9.4: https://bileto.ubuntu.com/#/ticket/311
19:28 <tsimonq2> er
19:28 <tsimonq2> https://bileto.ubuntu.com/#/ticket/3113
19:28 <tsimonq2> With the exception of one qttools upload, that was all me.
19:30 <tsimonq2> I'm not done yet either, qtwebengine is building and should be ready to land tobnight, as well as qtwebview.
19:30 <tsimonq2> *tonight
19:31 <tsimonq2> Is that all for questions? :)
19:33 <tsimonq2> (Hello?)
19:33 <rbasak> Can I see some diffs of what you actually uploaded to Ubuntu with sponsorship? I'm not sure how to get that.
19:33 <rbasak> (apart from the three I found)
19:34 <tsimonq2> https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.9.3+dfsg-0ubuntu1
19:35 <tsimonq2> https://launchpad.net/ubuntu/+source/qtsvg-opensource-src/5.9.3-0ubuntu1
19:36 <tsimonq2> I'm on mobile so it's taking me a bit, but the 5.9.3 transition was sponsored via Bil
19:36 <tsimonq2> *Bileto
19:37 <tsimonq2> I believe LocutusOfBorg did the review and pressed the button.
19:37 <tsimonq2> 5.9.2 should be similar
19:38 <tsimonq2> https://launchpad.net/ubuntu/+source/qtbase-opensource-src/5.9.2+dfsg-4ubuntu1
19:38 <tsimonq2> etc.
19:38 <tsimonq2> Would you like me to find additional uploads?
19:39 <bdmurray> I personally need some more time to review specifically the diffs rbasak is requesting.
19:39 <tsimonq2> Sure, no problem.
19:39 * LocutusOfBorg is here in case you want some answer
19:40 <tsimonq2> You can also find a lot on the ubuntu+1 branches of  the packages here: https://salsa.debian.org/qt-kde-team/qt//
19:40 <bdmurray> To be clear I mean more time than I think we have in this meeting.
19:40 <tsimonq2> Alright, no problem at all.
19:41 <tsimonq2> Does the rest of the DMB concur?
19:41 <rbasak> I agree with bdmurray
19:41 <rbasak> Could you update your application so that we have a link to sponsored Ubuntu diffs please?
19:42 <tsimonq2> Alright. Can we continue this on the mailing list then? Thd d
19:42 <rbasak> Yeah
19:42 <rbasak> Continue on the ML, and we'll schedule another meeting when we're ready.
19:42 <tsimonq2> Sure.
19:42 <tsimonq2> Thanks everyone,
19:42 <rbasak> That diff is one of the three I had found :)
19:43 <tsimonq2> OK ;)
19:44 <cyphermox> bdmurray: alright
19:44 <bdmurray> tsimonq2: So to ease the process I think you could provide us specific links to diffs showing your work.
19:44 <cyphermox> there's a core dev app for next month, yikes
19:45 <cyphermox> let's go the rest of this review on the ML, though
19:45 <tsimonq2> bdmurray: Sure.
19:45 <cyphermox> #topic AOB?
19:45 <bdmurray> Going back in time - I goofed about the PPU request and didn't email the TB.
19:45 <bdmurray> I'll fix that today.
19:46 <mapreri> put an #action to review my ppu bug next time again?
19:46 <cyphermox> mapreri: alrady there.
19:46 <cyphermox> #action bdmurray to email the TB about mapreri's PPU.
19:46 * meetingology bdmurray to email the TB about mapreri's PPU.
19:46 <cyphermox> anything else?
19:46 <mapreri> ta :)
19:47 <bdmurray> I don't think so.
19:47 * rbasak has to run
19:47 <cyphermox> ok, let's wrap this up
19:47 <cyphermox> who's next chair?
19:47 <sil2100> I can
19:47 <cyphermox> ack
19:47 <cyphermox> #endmeeting