15:10 <jbicha> #startmeeting
15:10 <meetingology> Meeting started Mon Nov 20 15:10:48 2017 UTC.  The chair is jbicha. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:10 <meetingology> 
15:10 <meetingology> Available commands: action commands idea info link nick
15:11 <jbicha> [TOPIC] Review of previous action items
15:11 <jbicha> > bdmurray to handle the PPU role for fossfreedom (done)
15:13 <jbicha> ok, that's done, I believe cyphermox was going to follow up by working on a proposed ubuntu-budgie seed
15:13 <cyphermox> I sent the packageset list, but blocked on having the packageset created in the first place. I mentioned it to slang.asek last week.
15:14 <micahg> having a packageset being created shouldn't be a problem in and of itself
15:14 <cyphermox> no, just needs someone to push buttons
15:15 <rbasak> Is this a TB thing?
15:15 <cyphermox> yes
15:15 <jbicha> cyphermox: I saw a pastebin but not an email from you with the packageset
15:15 <rbasak> If so we have the file-a-bug-and-post-to-the-ML process
15:16 <micahg> the issue isn't the packageset but whether or not we wanted to give packageset VS PPU rights
15:16 <sil2100> The vote was for PPU rights
15:16 <sil2100> And this has been granted
15:16 <sil2100> It's a separate topic IMO
15:17 <sil2100> We want to create the packageset now for future people that want to contribute to budgie
15:17 <jbicha> for clarity, I wanted to see the proposed packageset and I dont think it's a problem to create the packageset before we have someone to use it
15:17 <micahg> that's fine
15:18 <jbicha> I think we agree that there would be a new application and vote required for anyone to have upload rights for that packageset
15:19 <jbicha> cyphermox: can I give you an action item to send the packageset email? and then we can move on to the next topic?
15:20 <sil2100> +1 on that
15:22 <jbicha> well we can come back to that if needed when we discuss Any Other Business later
15:22 <jbicha> > sil2100 to grant ddstreet SRU permissions (done)
15:22 <jbicha> and rbalint was granted Core Dev permissions
15:22 <jbicha> so no further action is needed there
15:23 <jbicha> #topic PPU Application for osomon
15:23 <oSoMoN> o/
15:23 <jbicha> Each applicant should introduce themselves (1-5 sentences) and provide links to their Ubuntu Wiki page. After the introduction the members of the Membership Review Board will review the pages and, if needed, ask the applicant further questions.
15:24 <jbicha> During this time it is encouraged for other members of the community to show their support for the applicant. Do not be alarmed if the members of the Developer Membership Board are quiet during this time; they are most likely reading wiki/launchpad/forum/other pages and deciding how they are going to vote.
15:25 <jbicha> oSoMoN: can you introduce yourself?
15:25 <oSoMoN> sure
15:25 <oSoMoN> I'm Olivier, I'm part of the Canonical desktop team
15:25 <oSoMoN> my main duties these days are the maintenance of chromium-browser and libreoffice
15:26 <oSoMoN> both ubuntu packages and snaps
15:26 <oSoMoN> my PPU application is at https://wiki.ubuntu.com/OlivierTilloy/PPUApplication
15:26 <oSoMoN> I work on chromium-browser on a daily basis, hopefully my application makes sense
15:26 <jbicha> I'm not familiar with how Ubuntu snap uploads work, do you currently need sponsorship for those?
15:27 <oSoMoN> no, no sponsorship needed for those
15:27 <oSoMoN> there's a shared account in the store for snaps maintained by canonical
15:27 <jbicha> hmm, that's interesting
15:27 <oSoMoN> and I'm a collaborator to that account, so I have upload rights for the LO and chromium snaps
15:29 <jbicha> interesting that snap upload rights don't go through the traditional upload rights application process, but I guess that's off-topic for right now
15:30 <jbicha> does anyone else on the DMB have any questions for the applicant?
15:30 <rbasak> o/
15:30 <rbasak> oSoMoN: could you give us an example of when it may not be appropriate to upload to the archive please?
15:31 <sil2100> oSoMoN: recently you have sent a libreoffice SRU through sponsors with a wrong version number (the same as for the devel series) - could you explain why that happened?
15:31 <oSoMoN> rbasak, for instance during a freeze
15:32 <oSoMoN> sil2100, the SRU had been prepared before the corresponding version was in bionic
15:32 <oSoMoN> that was a mistake of course
15:33 <rbasak> oSoMoN: OK, and if during a freeze you felt an exception was warranted, what would you do? Feel free to choose an illustrative example rather than trying to exhaustively cover every possibility.
15:34 <oSoMoN> I would first question whether that exception is really needed, if e.g. it can't be made a 0day SRU
15:34 <oSoMoN> if not I would seek confirmation with the release team
15:35 <oSoMoN> and I would be particularly watchful of possible regressions
15:36 <rbasak> OK. Do you know where the documentation is that will tell you if we are in a freeze, and for the (formal; not necessarily required) process to seek an exception from the release team?
15:37 <oSoMoN> https://wiki.ubuntu.com/BionicBeaver/ReleaseSchedule for the release schedule and freezes
15:37 <oSoMoN> and https://wiki.ubuntu.com/FreezeExceptionProcess
15:38 <rbasak> OK thanks you. One final question. After a particular upload, can you summarise your subsequent responsibilities?
15:39 <oSoMoN> test out of -proposed, and once the package migrates monitor closely bug/crash reports
15:40 <oSoMoN> and act on them asap
15:40 <oSoMoN> monitor autopkgtest runs, too
15:40 <oSoMoN> and before all that, verify that the package builds fine in -proposed
15:41 <jbicha> In your experience, are all chromium-browser SRUs treated as security updates?
15:41 <rbasak> OK thanks. I'm ready to vote.
15:42 <rbasak> FTR, I don't expect anyone to test from devel -proposed specifically. Just take responsibility for it migrating and for any regressions.
15:42 <micahg> oSoMoN: can you please explain why chromium has unusual versioning in the suffix?
15:43 <oSoMoN> jbicha, yes, all major chromium updates contain security fixes, and as such go through a validation process by the security team
15:43 <oSoMoN> micahg, the last number in the versioning is the bzr revision number in the packaging branch
15:43 <micahg> oSoMoN: is there a reason for that?
15:44 <oSoMoN> micahg, I took over chromium packaging back in April and that was like that already, didn't feel a need to change/question it
15:45 <oSoMoN> I'm certainly open to suggestions
15:45 * micahg wonders who did that...
15:45 <oSoMoN> I can imagine using the bzr revision number makes it easy to script the changelog generation for a batch of series
15:46 <jbicha> I see that you maintain several chromium PPAs under your own name. I am a bit concerned that they are not maintained with a team
15:46 <oSoMoN> it's a cheap way to ensure you always bump the version, no matter what the major version number is
15:47 <jbicha> because it doesn't allow anyone else to make uploads to those PPAs, and it's a problem if the primary Ubuntu Chromium maintainer changes (like happened earlier this year)
15:47 <oSoMoN> jbicha, right, I've meant to transfer ownership of those PPAs to a team but never got around to doing it
15:47 <micahg> oSoMoN: that's what the packaging version: XubuntuY(.Z)
15:47 <jbicha> I see there is an existing team: https://launchpad.net/~chromium-daily
15:47 <oSoMoN> jbicha, I'm making a note to do that this week
15:47 <jbicha> thanks
15:47 <oSoMoN> https://launchpad.net/~chromium-team too
15:48 <jbicha> ok, that one is probably better :)
15:49 <jbicha> I'd like to try to wrap up this meeting this hour, so… last call for questions
15:50 <micahg> oSoMoN: I would encourage you to use standard versioning, I but I can imagine as well someone scripting with that version
15:51 <oSoMoN> micahg, ack, I made a note to do that, I'll use the standard versioning scheme starting with the next upload
15:51 <rbasak> FWIW, the git-ubuntu work attempts to encourage standardisation on this type of thing using the "lint" tool. It calculates the expected version, and complains if it is anything different. Which means that it has the code necessary for scripting to determine the expected version in a way that meets general Ubuntu developer expectations. We could expose that.
15:52 <rbasak> I'm not sure it covers all the edge cases yet, but it's pure Python and has tests so it shouldn't be too difficult to add more esoteric cases.
15:52 <oSoMoN> I'll need to migrate the packaging branches to git, too
15:52 <jbicha> #voters cyphermox jbicha micahg rbasak sil2100
15:52 <meetingology> Current voters: cyphermox jbicha micahg rbasak sil2100
15:53 <jbicha> #vote osomon to be granted PPU upload rights for chromium-browser
15:53 <meetingology> Please vote on: osomon to be granted PPU upload rights for chromium-browser
15:53 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:53 <rbasak> +1
15:53 <meetingology> +1 received from rbasak
15:53 <micahg> +1
15:53 <meetingology> +1 received from micahg
15:53 <jbicha> +1
15:53 <meetingology> +1 received from jbicha
15:53 <sil2100> +1
15:53 <meetingology> +1 received from sil2100
15:54 <jbicha> cyphermox: are you still here?
15:55 <sil2100> I think we can anyway close the vote as the minimum number of positive votes has been reached
15:55 <jbicha> #endvote
15:55 <meetingology> Voting ended on: osomon to be granted PPU upload rights for chromium-browser
15:55 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:55 <meetingology> Motion carried
15:56 <sil2100> oSoMoN: congratulations!
15:56 <oSoMoN> thanks!
15:56 <jbicha> oSoMoN: congratulations!
15:56 <jbicha> thank you for your work on Chromium and LibreOffice
15:57 <jbicha> [TOPIC] Any Other Business
15:57 <oSoMoN> some good suggestions emerged from that conversation, thanks for the questions
15:57 <rbasak> jbicha: can you assign actions to sort out oSoMoN please
15:58 <rbasak> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application
15:58 <rbasak> I'm happy to take them if you like.
15:59 <jbicha> I can send the announcement email this evening
15:59 <jbicha> rbasak: could you take care of the ACL? I guess we need to file a bug with the Tech Board?
16:00 <oSoMoN> shall I remove myself from the agenda?
16:00 <jbicha> oSoMoN: I can take care of that, thanks
16:00 <oSoMoN> cheers
16:01 <jbicha> [ACTION] jbicha to send out announcement email
16:01 * meetingology jbicha to send out announcement email
16:01 <rbasak> ack
16:01 <jbicha> [ACTION] rbasak to handle ACL for osomon's chromium-browser upload rights
16:01 * meetingology rbasak to handle ACL for osomon's chromium-browser upload rights
16:02 <jbicha> The next Developer Membership Board meeting is scheduled for Monday, December 4 at 19:00 UTC
16:02 <jbicha> thanks everyone!
16:02 <jbicha> #endmeeting