16:01 <cpaelzer> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue Jul 11 16:01:23 2017 UTC.  The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:01 <nacc> o/
16:01 <cpaelzer> #topic Review ACTION points from previous meeting
16:01 <cpaelzer> I won't again quote all we had and summarize
16:01 <cpaelzer> nacc: ipv6 ?
16:01 <cpaelzer> rharper: v2 yaml ?
16:01 <nacc> cpaelzer: carry
16:02 * slashd be back in 2 minutes
16:02 <cpaelzer> rbasak: mysql maintainership?
16:02 <rbasak> carry forward, sorry
16:03 <dpb1> o/
16:03 <cpaelzer> ok rharpermight be away carrying that as well
16:03 <cpaelzer> take an example on powersj he cleared his action the first week
16:03 <cpaelzer> speaking of that, one more
16:03 <cpaelzer> dpb look into why this is stalled https://github.com/lxc/pylxd/issues/232
16:03 <cpaelzer> how about that?
16:04 <dpb1> hm
16:04 <dpb1> I did
16:04 <dpb1> and they released a new release now
16:04 <dpb1> that was the reason
16:04 <dpb1> I'll poke again
16:04 <cpaelzer> ok any follow up by anyone needed?
16:04 <dpb1> oh no
16:04 <dpb1> it's closed now
16:04 <dpb1> action DONE
16:04 <cpaelzer> thank
16:05 <teward> o/ (i'm late)
16:05 <cpaelzer> hi teward
16:05 <cpaelzer> clearing one carrying 5 then
16:05 <cpaelzer> #action nacc to write a release notes entry on ipv6 netboot (carried over)
16:05 * meetingology nacc to write a release notes entry on ipv6 netboot (carried over)
16:05 <cpaelzer> #action nacc to write a server guide entry on ipv6 netboot (carried over)
16:05 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:05 <cpaelzer> #action rbasak to add maintainership info to mysql triage page (carried over)
16:05 * meetingology rbasak to add maintainership info to mysql triage page (carried over)
16:05 <cpaelzer> #action rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 * meetingology rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 <cpaelzer> #action rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:05 * meetingology rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:05 <cpaelzer> #topic Artful Development
16:05 <cpaelzer> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:05 <cpaelzer> #subtopic Current Work
16:05 <cpaelzer> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:05 <cpaelzer> Any current work other than bugs (which will follow) worth to discuss in a group?
16:05 <teward> just for awareness:
16:06 <cpaelzer> any bigger changes coming that should be made known
16:06 <cpaelzer> ok teward go
16:06 <teward> nginx 1.12.1 released todah - it's a headache because i already started 1.12 - delays my tasks another week
16:06 <teward> (builds, etc.)
16:06 <teward> 1.12.0 merge*
16:06 <cpaelzer> teward: do you plan to go 1.12.0 first and then 1.12.1 then?
16:06 <cpaelzer> or will go move to .1 before uploading the merge?
16:06 <teward> cpaelzer: we're already 1.12.0 i have to finish merging in Debian's packaging changes
16:07 <teward> probably going to finish testing that then jump to 1.12.1 direct.
16:07 <cpaelzer> ok
16:07 <cpaelzer> thanks
16:07 <teward> yep.
16:07 <teward> *returns to the shadows*
16:07 <cpaelzer> #subtopic Release Bugs
16:07 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:07 <cpaelzer> now more bug centric - anything high profile to share?
16:07 <ahasenack> I don't
16:08 <cpaelzer> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd, ddstreet)
16:08 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:08 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:08 <slashd> Business as usual for us this week so far --> http://pastebin.ubuntu.com/25068655/
16:08 <slashd> Note that we are still working on the MIR of pcp + libpapi (dependency of pcp) : Looking at implementing autopkgtest, ...
16:08 <slashd> #info SRU pending for : percona-xtradb-cluster-5.5 percona-xtradb-cluster-5.6, cups, sssd, open-iscsi, rsyslog, ksh, neutron
16:08 <cpaelzer> in addition for those who wonder on yakkety, stricly speaking that has a remaining lifecycle of two days left https://wiki.ubuntu.com/Releases
16:09 <cpaelzer> thanks slashd, anybody else SRUs to share?
16:09 <slashd> cpaelzer, everything is under control on our hand with regard to SRU
16:10 <cpaelzer> If not *special* you don't need to list all as the weekly summary will include them automatically
16:10 <cpaelzer> #link https://lists.ubuntu.com/archives/ubuntu-server/2017-July/007559.html
16:10 <slashd> cpaelzer, ack
16:10 <cpaelzer> and for example the SRUs I had are non-special - e.g. fiixing libvirt in zesty for spice
16:10 <cpaelzer> there are more by more people
16:11 <slashd> cpaelzer, ok I'll make sure I only share the special one for now one, thanks
16:11 <cpaelzer> it is mostly on listing so that people are aware that their work collide
16:11 <cpaelzer> since your Teams work somewhat separate we might collide on that
16:12 <cpaelzer> ok I don't here on more SRUs queued up and heard nobody complain on the ones listed by slashd to cause any trouble
16:12 <cpaelzer> #topic Weekly Updates & Questions for the QA Team (powersj)
16:12 <cpaelzer> #link https://jenkins.ubuntu.com/server/
16:12 <cpaelzer> he is not here
16:12 <cpaelzer> dpb1: is he off?
16:12 <dpb1> hm
16:12 <dpb1> powersj?
16:13 <cpaelzer> he is coming
16:13 <dpb1> he's here
16:13 <dpb1> k
16:13 <powersj> o/
16:13 <cpaelzer> you are right on powersj
16:13 <powersj> sorry for being late
16:13 <cpaelzer> qa status please
16:13 <dpb1> he's just being lazy
16:13 <dpb1> :)
16:13 <slashd> cpaelzer, that was mainly why I list everything, sometime it may raise a flag on your side
16:13 <cpaelzer> slashd: perfect slashd - I have a proposal to that in the open discussion
16:14 <cpaelzer> but now lets report powersj first on QA
16:14 <powersj> Last week I worked on resolving some test failures with cloud-init and otherwise spent time on KPI related activities.
16:14 <powersj> This week I am working on kvm-backed cloud-init integration testing.
16:14 <powersj> I do have to bring up that the artful ISO is now over 700mb
16:15 <powersj> I know this was being looked at as the seeds changed, but didn't get resolved, so I need to get status
16:15 <cpaelzer> I didn't see a related seeds change when working on ubuntu-virt seeds changes
16:15 <cpaelzer> you wil llet us know next wek
16:16 <cpaelzer> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:16 <smb> Latest info I heard is that we are close to move to 4.11 in artful. There are very few dkms issues left (2 to fix and one to potentially remove (blktap-dkms)). To my knowledge blktap was only ever used by XCP/XAPI/open-xenserver and that is gone.
16:16 <smb> Apart from that (not kernel related at all), doing my special kind of debootstrap installs which are adding "server^ ubuntu-server" later, I got netplan/systemd-networkd without libnss-resolve installed. Which is not too well working. Not sure but maybe libnss-resolve needs adding to either the server task or meta-package.
16:17 <cpaelzer> that is interesting smb
16:17 <cpaelzer> dpb1: should we forward that to cyphermox_ ?
16:17 <cpaelzer> dpb1: or is ryan pre-handling those netplan related things?
16:17 <cpaelzer> rharper I should say
16:17 <dpb1> interesting
16:17 <cpaelzer> smb: is cyphermox_ involved in your netplan findings already
16:18 <smb> cpaelzer, not with libnss one but with my ipv6 ra issues
16:18 <cpaelzer> ok good, because that ipv6 ra was the one I knew about
16:18 <dpb1> smb: have a bug for that?
16:18 <cpaelzer> the libnss you mean dpb1?
16:18 <dpb1> yes
16:18 <smb> not yet for that
16:19 <cpaelzer> smb: please do so once you happen to open one up
16:19 <smb> cpaelzer, ck
16:19 <cpaelzer> dpb1: do you want to be sucscirbed to reroute as applicable?
16:20 <cpaelzer> or even "subscribed"
16:20 <dpb1> yes please
16:20 <smb> ok
16:20 <cpaelzer> great, and 4.11 sounds good
16:20 <cpaelzer> smb: will 4.11 stay the aa kernel then?
16:20 <cpaelzer> or 4.12
16:20 <cpaelzer> or not commited to either?
16:21 <smb> at least 4.12
16:21 <cpaelzer> ok
16:21 <cpaelzer> #topic Upcoming Call For Papers
16:21 <cpaelzer> #link https://lwn.net/Calendar/Monthly/cfp/
16:21 <ahasenack> I think I added a link to a lxd conference
16:21 <cpaelzer> Openstack CFPs ahead - anybody heading there?
16:21 <cpaelzer> there are more ahasenack
16:22 <cpaelzer> I wanted the generic - are there any beofre listing those
16:22 <ahasenack> ok
16:22 <cpaelzer> ok, on the agenda as ahasenack mentioned are also
16:22 <cpaelzer> #link http://www.open-zfs.org/wiki/OpenZFS_Developer_Summit
16:22 <cpaelzer> #link https://discuss.linuxcontainers.org/t/containers-micro-conference-at-linux-plumbers-2017/262
16:22 <cpaelzer> ahasenack: do you have background on those?
16:22 <ahasenack> just that there is still time, and the lxd one was sent by stgraber to a list and I copied it to the agenda
16:23 <ahasenack> I wasn't sure if they were listed in the lwn.net calendar
16:23 <cpaelzer> they are not
16:23 <ahasenack> the zfs one is short, just one day
16:23 <cpaelzer> intending to go anybody?
16:24 <cpaelzer> ok not go from here, continuing
16:24 <cpaelzer> #topic Ubuntu Server Team Events
16:24 <cpaelzer> none that I know of
16:24 <dpb1> nothing to announce yet
16:24 <cpaelzer> #topic Open Discussion
16:25 <cpaelzer> I have two tihngs here, anybody els?
16:25 <ahasenack> I don't
16:25 <cpaelzer> First of all libvirt/qemu daily builds are out now
16:25 <cpaelzer> we will have to see how easy (or not) they are to maintain
16:25 <cpaelzer> but for now you got very easy verification/test packages from upstream master
16:25 <cpaelzer> #info Daily builds on libvirt and qemu master available
16:25 <cpaelzer> #link https://launchpad.net/~ubuntu-virt/+archive/ubuntu/virt-daily-upstream
16:26 <cpaelzer> The other topic I have is for slashd and powersj (and everybdoy actually)
16:26 <cpaelzer> on the mentioning of SRUs
16:26 <cpaelzer> the intention for that is to not step on each others toes
16:26 <cpaelzer> powersj: could the report David is sending get a list like https://launchpad.net/ubuntu/xenial/+queue?queue_state=1
16:26 <cpaelzer> filtered by "uploaded this week" and only server subset?
16:26 <cpaelzer> That would make sure people know what is about to come - a bit like slashd reports us what STS is working on.
16:27 <powersj> cpaelzer: so essentially report what is in proposed?
16:27 <slashd> cpaelzer, and can we be added to this email ?
16:27 <cpaelzer> powersj: almost - what is in proposed is kind of "too late"
16:27 <dpb1> slashd: ubuntu-server@lists.c.c
16:27 <cpaelzer> I'd like to see what is in unapproved even
16:27 <slashd> dbp1, thanks
16:28 <cpaelzer> that is about 2-10 days earlier
16:28 <dpb1> slashd: errr
16:28 <dpb1> ubuntu-server@lists.ubuntu.com
16:28 <cpaelzer> so an earlier heads up for those plannign a new one
16:28 <cpaelzer> powersj: just take a note, if it is doable that might be a good info
16:28 <cpaelzer> if not it is not worth to invest too much
16:29 <cpaelzer> surely everybody could check the link, and I know me and others do
16:29 <powersj> cpaelzer: I like the idea, I'll add a card and circle back
16:29 <cpaelzer> but you know pushing the info out might be useful
16:29 <cpaelzer> ok great powersj
16:29 <cpaelzer> #topic Announce next meeting date, time and chair
16:29 <cpaelzer> ahasenack: forgot to remove himself after last week, I'll be so kind to do that
16:30 <cpaelzer> I also remove myself which makes rharper next weeks chair
16:30 <ahasenack> thank you
16:30 <dpb1> rharper is away next week
16:30 <dpb1> shuffle him back one week please
16:30 <dpb1> oh
16:30 <dpb1> n/m
16:30 <dpb1> he's away this week!
16:30 <cpaelzer> thats whyt I thought
16:30 <dpb1> carry on
16:30 <cpaelzer> ok, we elect him then
16:30 * dpb1 disappears back into shadows
16:30 <cpaelzer> thanks everybody
16:31 <cpaelzer> #endmeeting