16:06 <cpaelzer> #startmeeting ubuntu-server-team
16:06 <meetingology> Meeting started Tue May 30 16:06:00 2017 UTC.  The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:06 <meetingology> 
16:06 <meetingology> Available commands: action commands idea info link nick
16:06 <cpaelzer> #topic Review ACTION points from previous meeting
16:06 <cpaelzer> we have plenty this time
16:06 <cpaelzer> lets check how much we postpone again
16:06 * cpaelzer rbasak to add maintainership info to mysql triage page (carried over)
16:06 <cpaelzer> well - not here so carry over
16:06 <cpaelzer> #ACTION: rbasak to add maintainership info to mysql triage page (carried over)
16:06 * meetingology : rbasak to add maintainership info to mysql triage page (carried over)
16:06 * cpaelzer nacc to write a release notes entry on ipv6 netboot (carried over)
16:06 * cpaelzer nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 <cpaelzer> nacc: how about those?
16:07 <nacc> cpaelzer: carrying on until next week
16:07 <cpaelzer> #ACTION: nacc to write a release notes entry on ipv6 netboot (carried over)
16:07 * meetingology : nacc to write a release notes entry on ipv6 netboot (carried over)
16:07 <cpaelzer> #ACTION: nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 * meetingology : nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 <powersj> FYI we have a sprint agenda item to do all of these ;)
16:07 <rharper> ack
16:07 <cpaelzer> oh I see
16:08 <cpaelzer> so I carry rharper's as well
16:08 <cpaelzer> #ACTION: rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:08 * meetingology : rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:08 <rharper> yes
16:08 <cpaelzer> #ACTION: rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:08 * meetingology : rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:08 * cpaelzer teward to add release notes blurb for nginx (1.10.x -> 1.12.x) (carried over)
16:08 <teward> https://wiki.ubuntu.com/NGINX/ReleaseNotes/Artful
16:08 <teward> probably needs improvement and needs a once-over from someone OTHER than me, but at least started there.
16:08 <teward> (I had no computer, so I dropped it in a sublocation under the NGINX pages)
16:08 <cpaelzer> see guys, this is how things are done
16:09 <cpaelzer> dpb1: could you add to review and move this to the real release notes to our sprint?
16:09 <nacc> tewards puts us all to shame
16:09 <cpaelzer> teward: has done the base work, if we need we can reach out to him
16:09 <cpaelzer> otherwise we can review polish and edit the reelase notes on the sprint
16:09 <dpb1> cpaelzer: ok
16:09 <teward> nacc: i'mma remember you said that :P
16:09 <cpaelzer> dpb1: you don't need an action here to take that into the sprint notes right?
16:10 <dpb1> cpaelzer: add an action
16:10 <dpb1> that way we can get one done!
16:10 <cpaelzer> #ACTION dpb1 to add the review of https://wiki.ubuntu.com/NGINX/ReleaseNotes/Artful to the sprint agenda
16:10 * meetingology dpb1 to add the review of https://wiki.ubuntu.com/NGINX/ReleaseNotes/Artful to the sprint agenda
16:10 <cpaelzer> #link https://wiki.ubuntu.com/NGINX/ReleaseNotes/Artful
16:11 <cpaelzer> ok one done, thanks teward
16:11 <cpaelzer> dpb1: while we are at it how about
16:11 <teward> cpaelzer: yep!
16:11 * cpaelzer dpb to look into a few open issues around automatic updates that were pointed out by the doc team (carried over)
16:11 <ahasenack> hm
16:11 <ahasenack> that is the one the doc team mentioned to me
16:11 <dpb1> cpaelzer: will add that one too
16:11 <dpb1> good idea
16:11 <ahasenack> that they were waiting for before publishing a new server guide relase
16:12 <ahasenack> with my samba/ldap/kerberos fixes
16:12 <ahasenack> so dpb1 is blocking my fixes from landing! :)
16:12 <cpaelzer> I remember the reply ahasenack
16:12 <dpb1> ahasenack: you want to take it?
16:12 <cpaelzer> but they are unrelated - doc about kernel upgrades vs samba fixes
16:12 <cpaelzer> should not block each other right?
16:12 <ahasenack> indeed, they just wanted to take the opportunity
16:13 <ahasenack> ah, it was the /boot being filled up controversy?
16:13 <cpaelzer> yes
16:13 <ahasenack> what exactly are we supposed to do there?
16:13 <cpaelzer> so get your doc changes landed is #1
16:13 <ahasenack> document best practices?
16:13 <cpaelzer> and #2 is unrelated which is dpb1 taking care to clarify on these kernel things
16:13 <cpaelzer> I'll carry the action, then we can talk about doc ok ahasenack
16:14 <ahasenack> ok
16:14 <cpaelzer> #ACTION: dpb to look into a few open issues around automatic updates that were pointed out by the doc team (carried over, into sprint)
16:14 * meetingology : dpb to look into a few open issues around automatic updates that were pointed out by the doc team (carried over, into sprint)
16:14 <cpaelzer> ahasenack: do you want to wait for the open discussion with the doc things?
16:14 <cpaelzer> ahasenack: but I'm fine here if you want
16:14 <ahasenack> what's next?
16:15 <ahasenack> let's do it in the open discussion section
16:15 <cpaelzer> Dev Release -> bugs -> sru- kernel -> open discussion
16:15 <cpaelzer> ok
16:15 <cpaelzer> #topic Artful Development
16:15 <cpaelzer> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:15 <cpaelzer> #subtopic blueprints
16:15 <cpaelzer> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-aa-server-core
16:16 <cpaelzer> on merges I heard nacc is power-farming merges
16:16 <cpaelzer> thanks a lot nacc
16:16 <cpaelzer> anything on the general Artful before going into artful bugs?
16:16 <teward> yeah i have work to do on nginx
16:16 <teward> merging from Debian by hand
16:16 <ahasenack> the merge report is now up-to-date, right?
16:16 <teward> but that'll be done by end-of-week
16:16 <ahasenack> I mean, it's running
16:17 <ahasenack> http://reqorts.qa.ubuntu.com/reports/ubuntu-server/merges.html ?
16:17 <ahasenack> imagemagick is server?
16:17 <cpaelzer> rbasak updated it and it generates things with recent updates
16:17 <cpaelzer> ahasenack: I think it is tied to php
16:17 <ahasenack> ah, could be
16:18 <ahasenack> I might try some of the simpler ones, and related to services I know
16:19 <cpaelzer> yeah doing most before the Debian release will be wise
16:19 <cpaelzer> as after Debian releases all weird experiments will land and be sorted out
16:19 <cpaelzer> merging then might be more stressful than intended
16:19 <cpaelzer> a cycle later things will have settled a bit
16:20 <cpaelzer> there are excuses like myself with qemu/libvirt intentionally waiting until the new versions appear after the release
16:20 <cpaelzer> anyway going on to bugs in AA
16:20 <cpaelzer> #subtopic Release Bugs
16:20 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:20 <ahasenack> hey, that list has gone down :)
16:20 <cpaelzer> nish is on the merge assigned so I consider that handled
16:21 <cpaelzer> sosreport is assigned to the reporter
16:21 <nacc> cpaelzer: django?
16:21 <cpaelzer> is that STS driven?
16:21 <nacc> cpaelzer: yeah, i'm waiting for confirmation from openstack still
16:21 <cpaelzer> nacc: yeah django
16:21 <ahasenack> how is that cloud-init one fix committed but the artful task is not?
16:21 <cpaelzer> nacc: you are on it which is enough to know it is not forgotten
16:21 <ahasenack> isn't the main task == artful at this time?
16:21 <cpaelzer> rharper: ^^?
16:22 <ahasenack> https://bugs.launchpad.net/cloud-init/+bug/1692028
16:22 <ubottu> Launchpad bug 1692028 in cloud-init (Ubuntu Artful) "duplicate mac address during config-drive configuration with LXD container on openstack" [Medium,Confirmed]
16:22 <ahasenack> ah
16:22 <ahasenack> committed is upstream/code
16:22 <cpaelzer> I think if it is an ubuntu owned thing then Devel and Artful can differ
16:22 <ahasenack> package task is separate
16:22 <cpaelzer> ahasenack: see upstream vs "status tracked in artful"
16:22 <ahasenack> right
16:22 <cpaelzer> exactly
16:22 <ahasenack> I missed that
16:22 <ahasenack> n/m
16:22 <cpaelzer> slashd: hey is the sosreport from STS?
16:23 <cpaelzer> David Coronel is assigned to all of them
16:23 <cpaelzer> and the reporter
16:23 <cpaelzer> well if he is around he can share in the next section since the bug goes back to all other releases as well
16:23 <cpaelzer> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd)
16:23 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:23 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:24 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:24 <cpaelzer> slashd: around?
16:24 <ahasenack> http://launchpad.net/bugs/1677329 needs a look (libpam-winbind sponsorship)
16:24 <ubottu> Launchpad bug 1677329 in samba (Ubuntu Zesty) "libpam-winbind: unable to dlopen" [High,In progress]
16:24 <cpaelzer> and while waiting any other SRUs worth to mention completed or inthe pipe?
16:24 <cpaelzer> I completed libvirt (apparmor rules) last week
16:24 <cpaelzer> also postrges MRE fully passed X,Y,Z
16:25 <cpaelzer> Trusty was accepted late, so it has to wait a few days in proposed - but test sare good
16:25 <cpaelzer> ahasenack: what is it that you need on that one ahasenack?
16:25 <ahasenack> cpaelzer: sponsorship for artful
16:26 <ahasenack> and then I can proceed with sru'ing it to the other releases where it just doesn't work
16:26 <ahasenack> I have a ppa with the fix for people to test: https://launchpad.net/~ahasenack/+archive/ubuntu/samba-1677329/+packages
16:26 <ahasenack> builds with the appropriate ~ppa1 suffix ;)
16:26 <cpaelzer> ahasenack: I need to tell you about bileto on the sprint
16:27 <ahasenack> do tell
16:27 <cpaelzer> which would make this a one-button action
16:27 <cpaelzer> it is a repetition for the others so not on the agenda, but please remind me
16:27 <cpaelzer> nacc: you did samba things in the past - could you sponsor the upload ?
16:28 <nacc> cpaelzer: i can -- isa it ready to sponsor?
16:28 <nacc> reading the backscroll
16:28 <nacc> ahasenack: ping me in #ubuntu-server after this and i'll review it
16:28 <cpaelzer> nacc: it is, if you want it in a different way then let ahasenack know
16:28 <ahasenack> ok, thanks
16:28 <cpaelzer> #ACTION: nacc to review and sponsor ahasenack work on bug 1677329
16:28 * meetingology : nacc to review and sponsor ahasenack work on bug 1677329
16:29 <ubottu> bug 1677329 in samba (Ubuntu Zesty) "libpam-winbind: unable to dlopen" [High,In progress] https://launchpad.net/bugs/1677329
16:29 <cpaelzer> #topic Weekly Updates & Questions for the QA Team (powersj)
16:29 <cpaelzer> #link https://jenkins.ubuntu.com/server/
16:29 <cpaelzer> copy and paste please
16:29 <powersj> Last week involved getting the initial collection metrics setup and into Prometheus. Also started on the proposed automation testing and was able to get a jenkins job setup with nightly checks for uploads and determine what tests, if any, need to be ran.
16:29 <powersj> This week the focus is on getting cloud-init/curtin CI pipeline setup to extend our merge request testing past unit tests and include integration, build, etc. testing. Also hoping to get my proposed automation testing further working to demo next week.
16:30 <powersj> #info continue work on proposed automation testing
16:30 <powersj> questions?
16:30 <cpaelzer> proposed automation testing is based on https://launchpad.net/qa-regression-testing right?
16:30 <powersj> cpaelzer: ys
16:30 <powersj> yes*
16:30 <cpaelzer> just as my qemu/libvirt tests
16:30 <cpaelzer> nice
16:30 <cpaelzer> I used more of them looking forward to discuss and help in case
16:30 <cpaelzer> e.g. strongswan I used
16:31 <cpaelzer> interested how you wrapped that to work in jenkins
16:31 <cpaelzer> #link https://launchpad.net/qa-regression-testing
16:31 <cpaelzer> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:31 <smb> No news (those are said to be the good ones I hear). Are there questions/remarks/requests?
16:32 <ahasenack> smb: do we carry a big apparmor delta regarding the upstream kernel?
16:33 <smb> ahasenack, it can vary but I can tell from the top of my head how big that is in each kernel
16:33 <ahasenack> ok
16:33 <cpaelzer> thanks smb, I assume s/can/can't/ above
16:34 <cpaelzer> otherwise I'd be extra impressed
16:34 <ahasenack> same :)
16:34 <smb> indeed
16:34 <cpaelzer> #topic Upcoming Call For Papers
16:34 <cpaelzer> #link https://lwn.net/Calendar/Monthly/cfp/
16:34 <cpaelzer> nothing on my radar that is important - anybody?
16:34 <cpaelzer> 3
16:34 <cpaelzer> 2
16:34 <cpaelzer> 1
16:34 <cpaelzer> #topic Ubuntu Server Team Events
16:35 <cpaelzer> we sprint internally next week as you have seen on some actions we moved there
16:35 <cpaelzer> anything on top we should consider/discuss there?
16:35 <cpaelzer> silence = no
16:35 <cpaelzer> #topic Open Discussion
16:35 <cpaelzer> ahasenack: could you outline the doc thing you wanted to discuss
16:35 <cpaelzer> I remember the discussion about 3 weeks ago
16:35 <ahasenack> ah, right
16:36 <cpaelzer> you wanted to get stuff into serverguide (and I read you have/are on the way)
16:36 <ahasenack> so tl;dr, I merged many fixes to the serverguide
16:36 <ahasenack> and that's ready for release/publishing
16:36 <cpaelzer> ok thats is a +1 for you
16:36 <cpaelzer> \o/
16:36 <ahasenack> the doc team then told me they will proceed with that, but first they wanted to check on something about unattended upgrades that was brought up elsewhere
16:36 <ahasenack> (not by me)
16:37 <ahasenack> and I didn't remembe that, until I saw that action here before
16:37 <cpaelzer> hrm - still sounds as one should not block th eother
16:37 <cpaelzer> was that update on the merge proposal?
16:37 <ahasenack> no
16:37 <ahasenack> the MPs have all been merged
16:37 <cpaelzer> ah you mean before the point release they want to check
16:37 <ahasenack> it was brought up in ubuntu-doc, in the reply to my publishing request
16:37 <ahasenack> right
16:37 <ahasenack> they wanted to try to include those changes in the point release as well
16:37 <cpaelzer> maybe they have another change in flight which they'd like to include
16:37 <cpaelzer> ah ok, now things make sense
16:38 <ahasenack> and after seeing that action item
16:38 <cpaelzer> do you happen to know if that is (or not) related to this kernel cleanup thing which is a task for dpb1?
16:38 <ahasenack> I wondered if we were blocking that for them
16:38 <cpaelzer> ok, so wondering not knowing if it IS the same item
16:38 <ahasenack> I *think* it is related, but it's vague to me
16:38 <cpaelzer> ok, dpb1 on that item could you do a few prechecks before next week so we know what to do onthat?
16:38 <cpaelzer> part of the action you already have
16:39 <ahasenack> I can paste the reply here
16:39 <cpaelzer> yeah please
16:39 <ahasenack> paste incoming (short)
16:39 <ahasenack> "However, over on the Ubuntu-server e-mail list and meeting reports there was some stuff
16:39 <ahasenack> about getting help addressing the unattended upgrades issues, and someone took the action
16:39 <ahasenack> item. I'm going to try to kick that list and get some help, towards the objective of
16:39 <ahasenack> including those fixes in this same point release cycle. So, there will be a delay before
16:39 <ahasenack> string freeze is declared for this point release cycle."
16:39 <dpb1> cpaelzer: I might not have time this week.
16:39 <ahasenack> might that "someone" be dpb1?
16:39 <cpaelzer> ok, ahasenack is next week early enough?
16:39 <cpaelzer> I guess yes
16:39 <ahasenack> sure
16:39 <cpaelzer> #topic Announce next meeting date, time and chair
16:40 <cpaelzer> we will be around same time (from the sprint)
16:40 <cpaelzer> chait will again be rbasak
16:40 <cpaelzer> who will do the mail/wiki updates today for me covering him I hope
16:40 <cpaelzer> as I have to run to a parent teacher conference now :-)
16:40 <cpaelzer> #chair rbasak
16:40 <meetingology> Current chairs: cpaelzer rbasak
16:40 <cpaelzer> you can close rbasak, so you get the link
16:41 <rbasak> #endmeeting