16:00 <rbasak> #startmeeting ubuntu-server-team
16:00 <meetingology> Meeting started Tue Jan 17 16:00:24 2017 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:00 <meetingology> 
16:00 <meetingology> Available commands: action commands idea info link nick
16:00 <cpaelzer> o/
16:00 <rbasak> o/
16:00 <powersj> o/
16:00 <jgrimm> o/
16:00 <rbasak> caribou isn't around for long, so let's start with his item.
16:00 <rbasak> #topic Server & Cloud Bugs & SRU/Pending Uploads (caribou)
16:00 <rbasak> caribou: over to you!
16:01 <caribou> wow that was quick
16:01 <jgrimm> heh
16:01 <caribou> let me break the list so I don't flood the channel :
16:01 <cpaelzer> that sounds like a lot going on
16:01 <caribou> LP: #1298061 - (nova) nova should allow evacuate for an instance in the Error state
16:01 <caribou> LP: #1356211 - (sosreport) cannot collect rotated syslog.1
16:01 <caribou> LP: #1366103 - (sosreport) sosreport doesn't collect all data from /etc/apparmor.d/
16:01 <caribou> LP: #1447695 - (sosreport) sosreport 3.2 does not collect systemd information
16:01 <caribou> LP: #1447715 - (ifupdown) dhclient -6: Can't bind to dhcp address: Cannot assign requested address
16:01 <ubottu> Launchpad bug 1298061 in nova (Ubuntu Trusty) "nova should allow evacuate for an instance in the Error state" [Medium,In progress] https://launchpad.net/bugs/1298061
16:02 <caribou> LP: #1579609 - (os-prober) os-prober bug resulting in possible FS corruption
16:02 <caribou> LP: #1605243 - (sosreport) iscsi initiator related configs and logs are not recorded
16:02 <caribou> LP: #1614052 - (sosreport) SOSREPORT need to collect OPAL msglog
16:02 <caribou> LP: #1621340 - (multipath-tools) [SRU]'multipath -r' causes /dev/mapper/<wwid> being removed
16:02 <ubottu> Launchpad bug 1356211 in sosreport (Ubuntu Trusty) "cannot collect rotated syslog.1" [Medium,In progress] https://launchpad.net/bugs/1356211
16:02 <caribou> LP: #1640382 - (qemu) Segfault event notifier because of race condition
16:02 <caribou> LP: #1640676 - (libvirt) [SRU] libvirt 1.2.12 live-migration corrupts some instances
16:02 <caribou> LP: #1642903 - (systemd) introduce disk/by-id (model_serial) symlinks for NVMe drives
16:02 <caribou> LP: #1647485 - (systemd) NVMe symlinks broken by devices with spaces in model or serial strings
16:02 <caribou> LP: #1648901 - (krb5) SPNEGO crash on mechanism failure
16:02 <ubottu> Launchpad bug 1366103 in sosreport (Ubuntu Trusty) "sosreport doesn't collect all data from /etc/apparmor.d/" [Medium,In progress] https://launchpad.net/bugs/1366103
16:02 <ubottu> Launchpad bug 1447695 in sosreport (Ubuntu Trusty) "sosreport 3.2 does not collect systemd information" [Medium,In progress] https://launchpad.net/bugs/1447695
16:02 <ubottu> Launchpad bug 1447715 in ifupdown (Ubuntu Xenial) "dhclient -6: Can't bind to dhcp address: Cannot assign requested address" [Medium,In progress] https://launchpad.net/bugs/1447715
16:02 <caribou> The first nova SRU does't really belong here though
16:02 <ubottu> Launchpad bug 1579609 in os-prober (Ubuntu Xenial) "os-prober bug resulting in possible FS corruption" [Critical,Fix committed] https://launchpad.net/bugs/1579609
16:02 <ubottu> Launchpad bug 1605243 in sosreport (Ubuntu Yakkety) "iscsi initiator related configs and logs are not recorded" [Medium,In progress] https://launchpad.net/bugs/1605243
16:02 <ubottu> Launchpad bug 1614052 in sosreport (Ubuntu Yakkety) "SOSREPORT need to collect OPAL msglog" [Medium,In progress] https://launchpad.net/bugs/1614052
16:02 <ubottu> Launchpad bug 1621340 in multipath-tools (Ubuntu Xenial) "[SRU]'multipath -r' causes /dev/mapper/<wwid> being removed" [Medium,In progress] https://launchpad.net/bugs/1621340
16:02 <ubottu> Launchpad bug 1640382 in qemu (Ubuntu Trusty) "Segfault event notifier because of race condition" [Medium,Fix committed] https://launchpad.net/bugs/1640382
16:02 <ubottu> Launchpad bug 1640676 in libvirt (Ubuntu Trusty) "[SRU] libvirt 1.2.12 live-migration corrupts some instances" [High,Incomplete] https://launchpad.net/bugs/1640676
16:02 <ubottu> Launchpad bug 1642903 in systemd (Ubuntu Trusty) "introduce disk/by-id (model_serial) symlinks for NVMe drives" [Wishlist,Fix committed] https://launchpad.net/bugs/1642903
16:02 <ubottu> Launchpad bug 1647485 in systemd (Ubuntu Trusty) "NVMe symlinks broken by devices with spaces in model or serial strings" [High,Confirmed] https://launchpad.net/bugs/1647485
16:02 <ubottu> Launchpad bug 1648901 in krb5 (Ubuntu Xenial) "SPNEGO crash on mechanism failure" [Medium,In progress] https://launchpad.net/bugs/1648901
16:02 <caribou> been doing some work on sosreport today to catch up with old issues
16:03 <caribou> that's about it
16:03 <cpaelzer> I heard that coreycb looks into sponsoring the nova one
16:04 <rbasak> Thanks caribou!
16:04 <rbasak> Does anyone have any questions?
16:04 <jgrimm> nope
16:04 <cpaelzer> checking on bugs
16:04 <cpaelzer> I think I heard of all I'm affected already
16:04 <cpaelzer> here
16:04 <cpaelzer> bug 1640676
16:04 <ubottu> bug 1640676 in libvirt (Ubuntu Trusty) "[SRU] libvirt 1.2.12 live-migration corrupts some instances" [High,Incomplete] https://launchpad.net/bugs/1640676
16:04 <cpaelzer> caribou: what is left to do there
16:05 <cpaelzer> it is rather unclear on this one
16:05 <caribou> cpaelzer: I will have to check on this one
16:05 <cpaelzer> It was targetted for kilo UCA
16:05 <cpaelzer> TBC is if that should go to trusty
16:06 <cpaelzer> if so let Hua calrify and prep a debdiff I can review test and sponsor
16:06 <cpaelzer> otherwise et him set the incomplete trusty to won't fix if that is ok
16:06 <caribou> cpaelzer: the Trusty target might be there only to allow for UCA SRU; I'll check with him
16:07 <cpaelzer> great
16:07 <caribou> rbasak: can you please add an action for me on this ?
16:07 <cpaelzer> rbasak: caribou: bug 1640382 was sponsored and verified, wait migration
16:07 <ubottu> bug 1640382 in qemu (Ubuntu Trusty) "Segfault event notifier because of race condition" [Medium,Fix committed] https://launchpad.net/bugs/1640382
16:07 <caribou> rbasak: ok, I'll clear the tag
16:07 <cpaelzer> anything caribou or xtrusia can do to track or speed up migration?
16:07 <rbasak> caribou: sure. What should it say exactly? I'm not sure I follow.
16:08 <caribou> rbasak: [ACTION] caribou to verify with Huang if the Trusty Target is still required for bug 1640676
16:08 <ubottu> bug 1640676 in libvirt (Ubuntu Trusty) "[SRU] libvirt 1.2.12 live-migration corrupts some instances" [High,Incomplete] https://launchpad.net/bugs/1640676
16:08 <rbasak> #action caribou to verify with Huang if the Trusty Target is still required for bug 1640676
16:08 * meetingology caribou to verify with Huang if the Trusty Target is still required for bug 1640676
16:09 <cpaelzer> caribou: and finally for bug 1621340 I'll upload multipath in about 1.5 weeks from now as-is - or with some tweaks - depends if rbasak or cyphermox can find time for a deeper review
16:09 <ubottu> bug 1621340 in multipath-tools (Ubuntu Xenial) "[SRU]'multipath -r' causes /dev/mapper/<wwid> being removed" [Medium,In progress] https://launchpad.net/bugs/1621340
16:09 <caribou> cpaelzer: good to know, thanks!
16:10 * cpaelzer stops stalling this now
16:10 <cpaelzer> but I wanted to help syncing on that
16:10 <caribou> :)
16:10 <caribou> tbh, this is what this list is for
16:11 <rbasak> #info cpaelzer will upload multipath in about 1.5 weeks from now
16:11 <rbasak> #topic Review ACTION points from previous meeting
16:11 <rbasak> #info There were no action points from the previous meeting.
16:11 <rbasak> #topic Development Release
16:11 <rbasak> #link https://wiki.ubuntu.com/ZestyZapus/ReleaseSchedule
16:12 <rbasak> #info About a month to feature freeze now. I know we still have a bunch of outstanding work items for feature freeze, including merges.
16:12 <jgrimm> cpaelzer is working on qemu
16:12 <rbasak> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:12 <rbasak> Any comments?
16:12 <jgrimm> actively
16:12 <rbasak> I'm nearly done with squid.
16:12 <jgrimm> \o/
16:13 <rbasak> I've been working with Lars upstream and we've merged mysql-5.7 and mysql-defaults now. They're not migrated yet - big dep8 backlog.
16:13 <jgrimm> we've gotten a bunch of the more complicated ones done, or in progress. that's a very nice place to be one month out
16:14 <rbasak> #topic Weekly Updates & Questions for the QA Team (powersj)
16:14 <rbasak> powersj: o/
16:14 <cpaelzer> just marked dovecot (done) and removed the duplicate on tgt 8done as well)
16:14 <powersj> Last week lots of cloud-init work in the form of getting ready to add the KVM backend to the integration tests (thanks again for the input on that), reviewing Wes' merge request, and working on unit tests.
16:14 <powersj> This week is a short one for me so the plan is to review Wesley's latest merge request, review some jenkins failures, and spend more time on unit tests and trying to wrap up bug triage of 2016.
16:14 <powersj> questions? comments?
16:15 <jgrimm> powersj, ppc64el smoketest gating?
16:15 <cpaelzer> powersj: just FYI to everybody I was hacking a bit on the ppc qmeu migration tests
16:15 <powersj> jgrimm: no still waiting on RT to gain access to jenkins
16:15 <cpaelzer> not yet fully functioning, will work with powersj on it but at low/medium prio for now
16:15 <powersj> cpaelzer: yeah saw, but haven't read, your email yet :P
16:15 <jgrimm> powersj, ok, you may want to ping that RT
16:15 <powersj> jgrimm: will do (did once last week) I think I need to get thepriority raised again
16:15 <jgrimm> thanks
16:16 <rbasak> #info ppc64el smoketest gating is blocked on infrastructure
16:16 <rbasak> #info cpaelzer has been working on the ppc qmeu migration tests
16:16 <rbasak> Thanks powersj!
16:16 <rbasak> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:16 <smb> Nothing to report (guess kernel version 4.9 in zesty is old news, target for zesty is 4.10). Are there any questions?
16:16 <rbasak> #info Target for zesty is 4.10
16:17 <caribou> smb: would be good to find someone to look after the crash pkg
16:17 <smb> caribou, Oh right
16:17 <caribou> smb: current version fails to open 4.8 & newer kernels
16:17 <caribou> smb: I got a debdiff ready for this, but it still needs some loving care
16:18 <smb> caribou, Point me to the debdiff and I look who could handle it
16:18 <caribou> LP: #1655625
16:18 <ubottu> Launchpad bug 1655625 in makedumpfile (Ubuntu Xenial) "ISST-LTE:pVM:roselp4:ubuntu 16.04.2: vmcore cannot be analysed by crash" [High,Confirmed] https://launchpad.net/bugs/1655625
16:19 <caribou> smb: I'll wave at you once I get everything ready
16:19 <smb> caribou, ok, thanks
16:19 <caribou> smb: newer crash will still need merging in zesty otherwise it'll bite us
16:20 <smb> yeah, I can believe that
16:21 <rbasak> OK, thanks all!
16:21 <rbasak> #topic Upcoming Call For Papers
16:21 <rbasak> #link https://lwn.net/Calendar/Monthly/cfp/
16:21 <rbasak> Anything to mention?
16:21 <rbasak> #topic Ubuntu Server Team Events
16:21 <rbasak> Anything to mention?
16:22 <rbasak> I know FOSDEM is coming up. Anyone going?
16:22 <jgrimm> lxd team
16:23 <rbasak> Great. Thanks jgrimm!
16:23 <rbasak> #topic Open Discussion
16:23 <jgrimm> https://lists.ubuntu.com/archives/ubuntu-devel/2017-January/039643.html
16:24 <jgrimm> anyone give this any thought yet? ^^
16:24 <rbasak> #info RFC: proposal to remove net-tools from ubuntu-minimal
16:24 <rbasak> #link https://lists.ubuntu.com/archives/ubuntu-devel/2017-January/039643.html
16:24 <rbasak> I don't see any issue with it.
16:25 <rbasak> I'm sure we'll have users complaining ifconfig doesn't work come the next LTS, but they will still be able to install it manually.
16:25 <jgrimm> may have to double check our packages for correct dependencies
16:26 <cpaelzer> what would you think of a ifconfig semi-compat wrapper
16:26 <cpaelzer> as an alternative when net-tools are not installed
16:26 <rbasak> That's basically what ifconfig already is, no?
16:26 <cpaelzer> hehe
16:26 <jgrimm> heh
16:26 <cpaelzer> I thought a <1k script that makes "please use this instead" or so
16:26 <cpaelzer> maybe not worth the effort
16:27 <rbasak> command-not-found should still work.
16:27 <rbasak> $ sudo ifconfig ...
16:27 <cpaelzer> just came to my mind reading (and I agree) "we'll have users complaining ifconfig doesn't work come the next LTS"
16:27 <jgrimm> right
16:27 <rbasak> "Please install net-tools"
16:27 <cpaelzer> that is the problem
16:27 <cpaelzer> I'd like to see
16:27 <cpaelzer> $ sudo ifconfig
16:27 <cpaelzer> "Please install net-tools or better ise the ip suite see XYZ"
16:27 <jgrimm> cpaelzer, command-not-found not sufficient?
16:28 <cpaelzer> for deprecated things it lacks a way to "announce" the successor
16:28 <rbasak> I wonder if cnf can handle custom messages.
16:28 <rbasak> If not, perhaps that's a feature request for it?
16:28 <jgrimm> ah
16:28 <rbasak> A similar thing for /usr/bin/python might be appropriate too.
16:29 <smoser> i think a deprecated message might be better placed in the thing itself
16:29 <smoser> rather than in some thing unrelated
16:29 <smoser> ie
16:29 <smoser> $ sudo ifconfiug
16:29 <smoser> $ sudo ifconfig
16:29 <smoser> <cnf says 'install ifconfig witih net-tools'>
16:29 <rbasak> Let's take this to the ubuntu-devel ML.
16:29 <smoser> $ sudo apt-get install net-tools
16:30 <jgrimm> +1
16:30 <jgrimm> rbasak, ^^
16:30 <smoser> $ ifconfig
16:30 <smoser> <stderr>: this is deprecated
16:30 <smoser> ...
16:30 <smoser> i'm fine to take to ml, just finishing my thought,.
16:30 <jgrimm> yep! all good
16:31 <rbasak> smoser: I agree with your proposed UX; I just think that the implementation could be inside cnf.
16:31 <rbasak> Anyway.
16:31 * rbasak loses the agenda
16:31 <rbasak> Ah
16:31 <rbasak> #topic Announce next meeting date, time and chair
16:32 <rbasak> #info Next meeting: Tue Jan 24 16:00:00 UTC 2017
16:32 <rbasak> #info Next chair: jamespage
16:32 <rbasak> (says the rota)
16:32 <rbasak> Thanks all!
16:32 <rbasak> #endmeeting