16:04 <jgrimm> #startmeeting ubuntu-server-team
16:04 <meetingology> Meeting started Tue Nov  8 16:04:20 2016 UTC.  The chair is jgrimm. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:04 <meetingology> 
16:04 <meetingology> Available commands: action commands idea info link nick
16:04 <nacc> o/
16:05 <jgrimm> hi folks, sorry for slow start
16:05 <jgrimm> #topic Review ACTION points from previous meeting
16:05 <jgrimm> (jamespage) checkin with old iscsitarget users on relevancy with new kernels
16:06 <jgrimm> jamespage, around ^^
16:07 <jgrimm> seems not, i'll take action to follow-up in email, this has sat around in actions for a long while
16:07 <nacc> jgrimm: thanks
16:08 <jgrimm> #action jgrimm: send jamespage email about iscsitarget
16:08 * meetingology jgrimm: send jamespage email about iscsitarget
16:08 <jgrimm> that looks to be only thing from last week
16:09 <jgrimm> #topic Zesty Development
16:09 <jgrimm> #link https://wiki.ubuntu.com/ZestyZapus/ReleaseSchedule
16:09 <jgrimm> anyone want to discuss something wrt Zesty?
16:09 <teward> *raises hand* I broke nginx for a short while in Zesty two weeks ago... fixed now, but we can thank Debian's security fix patch and a small mistake on my part for that.
16:10 <teward> there's going to be an nginx merge I'd like some spot checking on and testing when I finish prepping it, i'll send a mail to the list for the call for testing
16:10 <jgrimm> cool, thanks for being on top of that teward
16:10 <teward> yep
16:10 <jgrimm> i know cpaelzer is working through gnarly strongswan merge..
16:11 <cpaelzer> yeah and dovecot just donw
16:11 <rbasak> I'm still trying to land mysql-5.7 5.7.16.
16:11 <jgrimm> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:11 <powersj> jgrimm: from last week we should email server list re: powerpc + debian
16:12 <jgrimm> powersj, thanks for the reminder
16:12 <jgrimm> so what powersj is is referring to is that debian is dropping powerpc arch
16:13 <jgrimm> so i'm planning to send an email to ubuntu mls on the future (or possibly lack of) future for that arch in  ubuntu
16:13 <jgrimm> #action jgrimm: email ubuntu dev mailing lists about powerpc arch
16:13 * meetingology jgrimm: email ubuntu dev mailing lists about powerpc arch
16:14 <jgrimm> if you have capacity to help with merges feel free to sign yourself up in the blueprint; but i'll probably do some active recruitment shortly too
16:15 <jgrimm> nacc, i have general agreement from maas team with python-django moving forward
16:15 <nacc> jgrimm: great
16:15 <nacc> importer changes are almost done, working on `usd ` today and I will pivot to merges
16:16 <jgrimm> i talked to that team last week and they asked that we do it early in cycle if possible
16:16 <nacc> ack
16:16 <jgrimm> nacc, cool. thanks
16:16 <nacc> i'll sync with them before upload
16:16 <jgrimm> thanks, you may also want to check with the debian openstack folks, looks like they are planning an even newer django soon.
16:17 <nacc> ack
16:17 <jgrimm> found the bug
16:17 <jgrimm> #link https://bugs.launchpad.net/ubuntu/+source/python-django/+bug/1605278
16:17 <ubottu> Launchpad bug 1605278 in MAAS "Merge python-django 1:1.9.8-1 (main) from Debian unstable (main)" [Wishlist,Triaged]
16:18 <jgrimm> https://bugs.launchpad.net/ubuntu/+source/python-django/+bug/1605278/comments/10
16:18 <jgrimm> ok, anything else zesty related?
16:19 <jgrimm> #subtopic Release Bugs
16:19 <jgrimm> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:19 <powersj> fyi for those doing triage, if you haven't noticed each of us has an assigned day Tuesday-Friday and rotate Monday now.
16:19 <jgrimm> we should switch that to z now. :)
16:19 <jgrimm> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:20 <jgrimm> thanks powersj
16:20 <jgrimm> ok, nothing critical in the z-tracking report
16:21 <jgrimm> moving on
16:21 <jgrimm> #topic Server & Cloud Bugs & SRU/Pending Uploads (caribou)
16:21 <caribou> Active SRU list :
16:21 <caribou> LP: #1626258 [SRU] AttributeError: 'Requirement' object has no attribute 'project_name'
16:21 <caribou> - Uploaded to Z; X & Y to follow
16:21 <ubottu> Launchpad bug 1626258 in python-pip (Ubuntu Yakkety) "[SRU] AttributeError: 'Requirement' object has no attribute 'project_name'" [High,Triaged] https://launchpad.net/bugs/1626258
16:21 <caribou> LP: #1584485 Upgrading samba to latest security fixes together with winbind in nsswitch.conf can harm entire OS
16:21 <caribou> - Uploaded to Z, X & Y to follow
16:21 <ubottu> Launchpad bug 1584485 in samba (Ubuntu Yakkety) "Upgrading samba to latest security fixes together with winbind in nsswitch.conf can harm entire OS" [High,In progress] https://launchpad.net/bugs/1584485
16:21 <caribou> LP: #1447715 dhclient -6: Can't bind to dhcp address: Cannot assign requested address
16:21 <caribou> - Need to be uploaded to Xenial
16:21 <ubottu> Launchpad bug 1447715 in ifupdown (Ubuntu Xenial) "dhclient -6: Can't bind to dhcp address: Cannot assign requested address" [Medium,In progress] https://launchpad.net/bugs/1447715
16:22 <caribou> other : makedumpfile is finally fixed for kernel 4.8 & uploaded to Z
16:22 <caribou> SRU for Y & X to follow
16:22 <caribou> (done)
16:22 <jgrimm> thanks caribou
16:22 <jgrimm> any questions?
16:23 <jgrimm> any other SRU work in progress that folks should highlight?
16:23 <jgrimm> cpaelzer, ^^
16:23 <jgrimm> dovecot?
16:24 <tinoco> jgrimm: im fixing qemu+libvirt live migration
16:24 <tinoco> jgrimm: live migration is broken using mitaka cloud-archives and trusty kernel
16:25 <tinoco> thats worth to mention (apparmor blocks live migration)
16:25 <cpaelzer> dovecot had a crash on huge mails filtering that I'm working on
16:25 <jgrimm> tinoco, do you have a link for us?
16:25 <cpaelzer> tinoco: thanks - for your work on this - so this is kernel dependent then?
16:26 <tinoco> upstrema: https://bugs.launchpad.net/qemu/+bug/1626972
16:26 <ubottu> Launchpad bug 1626972 in QEMU "QEMU memfd_create fallback mechanism change for security drivers" [Undecided,In progress]
16:26 <tinoco> ours: https://bugs.launchpad.net/nova/+bug/1613423
16:26 <ubottu> Error: launchpad bug 1613423 not found
16:26 <tinoco> (its a security fix, its closed)
16:26 <cpaelzer> tinoco: once you have a proposed upload e.g. in a ppa please let me know, I have some extra tests I'd liek to run over with -or-for-you
16:26 <tinoco> cpaelzer: definitely.
16:26 <jgrimm> cpaelzer, tinoco: thanks. yes please work together
16:27 <jgrimm> another in progress bug worth mentioning:
16:27 <jgrimm> #link https://bugs.launchpad.net/ubuntu/+source/klibc/+bug/1621507
16:27 <ubottu> Launchpad bug 1621507 in open-iscsi (Ubuntu Yakkety) "initramfs-tools configure_networking() fails to dhcp ipv6 addresses" [High,In progress]
16:28 <jgrimm> just for awareness or if anyone else wants to join in the review
16:28 <jgrimm> ok, that's all I can think of off top of my head atm
16:29 <jgrimm> #topic Weekly Updates & Questions for the QA Team (powersj)
16:29 <powersj> Back from sprint. Started running automated zesty ISO tests with positive results and made a few Jenkinks changes to QEMU/live migration (thanks cpaelzer).
16:29 <powersj> Short week with Friday being holiday, gotta chatch up on cloud-init integration. /done
16:31 <jgrimm> thanks powersj
16:31 <jgrimm> oops forgot the CI link
16:31 <jgrimm> #link https://jenkins.ubuntu.com/server/
16:32 <jgrimm> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:32 <jgrimm> any  kernel folks around?
16:33 <jgrimm> ok, moving on
16:33 <jgrimm> #topic Upcoming Call For Papers
16:33 <jgrimm> #link https://lwn.net/Calendar/Monthly/cfp/
16:34 <jgrimm> not seeing anything interesting
16:34 <jgrimm> #topic Ubuntu Server Team Events
16:35 <jgrimm> Plumbers and ODS happened in last couple weeks. I haven't caught up on trip reports or articles yet
16:35 <jgrimm> anyone have anything to bring up?
16:35 <jgrimm> #topic Open Discussion
16:36 <jgrimm> I took a TODO to get a formal SRU exception for cloud-init processed.  We've been behaving as such without having anything really formal in place with conditions/testing needed.
16:37 <jgrimm> really something we should have had in place long ago, so time to clean this up as well help with SRU team processing
16:37 <jgrimm> that's all i have.  anyone else?
16:38 <jgrimm> #topic Announce next meeting date, time and chair
16:38 <nacc> jgrimm: that sounds commendable :)
16:38 <jgrimm> :)
16:38 <jgrimm> same place and time next week.   beisner still up as chair
16:38 <tinoco> o/
16:39 <jgrimm> #endmeeting