15:01 <slangasek> #startmeeting
15:01 <meetingology> Meeting started Thu Oct  6 15:01:46 2016 UTC.  The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:01 <meetingology> 
15:01 <meetingology> Available commands: action commands idea info link nick
15:02 <slangasek> [TOPIC] Lightning round
15:02 <slangasek> $ echo $(shuf -e barry doko bdmurray slangasek caribou infinity sil2100 robru cyphermox pitti tdaitx xnox chiluk mwhudson)
15:02 <slangasek> doko caribou bdmurray sil2100 slangasek infinity xnox cyphermox chiluk tdaitx mwhudson pitti robru barry
15:02 <slangasek> doko_: hullo!
15:02 <barry> win!
15:03 <doko_> - last week Linaro Connect, Monday bank holiday
15:03 <doko_> - cross toolchain updates
15:03 <xnox> ah
15:03 <doko_> - lintian update, makedumpfile for arm64
15:04 <caribou> doko_: makedumpfile fix is in the upcoming debian pkg
15:04 <doko_> - "final" GCC update, seeing timeouts on arm64 with new kernels
15:04 <doko_> (done)
15:04 <caribou> Bugfix:
15:04 <caribou> /etc/multipath/wwids not updated upon restart (LP: #1621835)
15:04 <caribou> Blocked by potential regression with .14 (LP: #1629644)
15:04 <caribou> Request to backport rsyslog Xenial to trusty
15:04 <caribou> NAK, dependancy problems.
15:04 <caribou> Slow SSH login
15:04 <caribou> - Could be the same as LP: #1591411
15:04 <ubottu> Launchpad bug 1621835 in multipath-tools (Ubuntu Trusty) "multipathd reconfigure does not update /etc/multipath/wwids file on trusty" [Medium,In progress] https://launchpad.net/bugs/1621835
15:04 <ubottu> Launchpad bug 1629644 in multipath-tools (Ubuntu) "Trusty: failure to detect device with 0.4.9-3ubuntu7.14" [High,Incomplete] https://launchpad.net/bugs/1629644
15:04 <caribou> - Asked to test sil2100 PPA fix
15:04 <ubottu> Launchpad bug 1591411 in dbus (Ubuntu Xenial) "systemd-logind must be restarted every ~1000 SSH logins to prevent a ~25 second delay" [Medium,Confirmed] https://launchpad.net/bugs/1591411
15:04 <caribou> Development :
15:05 <caribou> Working on a sosreport charm :
15:05 <caribou> - Submitted for review & inclusion in the charm store
15:05 <caribou> tomsfastpath MIR :
15:05 <caribou> - clamav fixed to use 'in package' library
15:05 <caribou> - upload blocked on llvm-toolchain-3.6 FTBS
15:05 <caribou> makedumpfile not working on kernel 4.8 (LP: #1626269)
15:05 <ubottu> Error: Could not gather data from Launchpad for bug #1626269 (https://launchpad.net/bugs/1626269). The error has been logged
15:05 <caribou> - Still under investigation, waiting on upstream
15:05 <caribou> Working on a sosreport and gtimelog snap
15:05 <caribou> Misc
15:05 <caribou> meeting
15:05 <caribou> & some makedumpfile work
15:05 <caribou> ☑ Done
15:05 <bdmurray> phased-updater changes to look at release pocket for regression comparisons
15:05 <bdmurray> investigation into LP: #1574193, uploaded SRUs for it
15:05 <ubottu> Launchpad bug 1574193 in update-manager (Ubuntu Xenial) "ubuntu-support-status lists end-of-support packages (after EOL) as supported" [Medium,Fix committed] https://launchpad.net/bugs/1574193
15:05 <bdmurray> investigation into LP: #1614576, uploaded Y fix for it
15:05 <ubottu> Launchpad bug 1614576 in ubuntu-release-upgrader (Ubuntu) "Upgrade from xenial to yakkety fails due to a UnicodeDecodeError" [High,In progress] https://launchpad.net/bugs/1614576
15:05 <bdmurray> uploaded Yakkety, Xenial fix of LP:  #1619188
15:05 <ubottu> Launchpad bug 1619188 in casper (Ubuntu Xenial) "Unattended upgrades can break persistent live media" [Medium,Fix committed] https://launchpad.net/bugs/1619188
15:05 <bdmurray> reported software-properties bug LP: #1630731
15:05 <bdmurray> bug triage of LP: #1444682
15:05 <bdmurray> upload update-manager fix for LP: #1629900 to Yakkety
15:05 <bdmurray> SRU training with rbasak
15:05 <ubottu> Launchpad bug 1630731 in software-properties (Ubuntu) "autodownload check in get_update_automation_level doesn't check hard enough" [Medium,Triaged] https://launchpad.net/bugs/1630731
15:05 <ubottu> Launchpad bug 1444682 in software-properties (Ubuntu) "Software properties gtk implies my cpu is unknown and not working. " [Medium,Triaged] https://launchpad.net/bugs/1444682
15:05 <ubottu> Launchpad bug 1629900 in update-manager (Ubuntu Yakkety) "update-manager crashed with ValueError in require_version(): Namespace Unity not available" [Medium,Fix released] https://launchpad.net/bugs/1629900
15:06 <bdmurray> irc discussion with nuclearbob re upgrade testing
15:06 <bdmurray> foundations, iso-testing bug triage
15:06 <sil2100> caribou: yeah, from what people said this fix didn't really work though, will try another one from the proposals in the upstream bug
15:06 <bdmurray> unattended-upgrades bug triage
15:06 <bdmurray> ✔ done
15:06 <caribou> sil2100: ok, keeping an eye on it
15:06 <sil2100> - Landing team work, silo coordination, preparing landing e-mails
15:06 <sil2100> - RTM status meetings
15:06 <sil2100> - xenial arm64: * Reviewing all xenial touch systemd merge requests * Prepare and test lxc-android-config silo with all changes * Poke about upstart getting released * Filling in RT for an arm64 scalingstack node for the custom tarball jenkins * Importing first arm64 frieza custom tarball * Building and importing first systemd enabled touch rootfs image
15:06 <sil2100> - Fixing xenial i386 builds, yakkety armhf builds
15:06 <sil2100> - Improve the instrumentation sync scripts to allow remote patch management
15:06 <sil2100> - More work on the landing-team-tools snap - dealing with some minor issues now
15:06 <sil2100> - Look into the s390x pyzmq unit test failure, attempt building a workaround
15:06 <slangasek> caribou: why are you using llvm-toolchain-3.6 instead of llvm-toolchain-3.8?  (I think I saw this question asked on #ubuntu-devel the other day...)
15:06 <sil2100> - Promote emulator OTA-13 images
15:07 <sil2100> - Fix small breakage in commitlog generation
15:07 <sil2100> - Help out with ubuntu-push dead-dependencies removal for MIR
15:07 <sil2100> - Work on documenting the new landing process for snaps
15:07 <sil2100> (done)
15:07 <pitti> sil2100: did I read "emulator"?
15:07 <caribou> slangasek: higher than 3.6 requires sensible modification of the package & debian is not done yet
15:07 <sil2100> pitti: yeah, the ubuntu-emulator images ;)
15:07 <pitti> sil2100: *\o/* !
15:08 <caribou> slangasek: https://www.mail-archive.com/pkg-clamav-devel@lists.alioth.debian.org/msg04458.html
15:09 <slangasek> doko_, xnox: could one of you help caribou with his clamav vs. llvm problem, so we can un-stick this for release?
15:09 <xnox> ok.
15:10 <caribou> slangasek: right now, debian has the same problem as they are transitioning to llvm-3.8 and clamav no longer builds there either
15:11 <slangasek> * releasey stuff - lots of queue reviews and update_excuses prodding
15:11 <slangasek> * finished landing unity8 session on the desktop ISO \o/
15:11 <slangasek> * fixed a few unaligned access SIGBUSes on armhf, exposed by the change to launchpad builder config; these cause previously-working packages to FTBFS and sometimes now fail autopkgtests (python-xmp-toolkit) and are reproducible on porter-arm64 but not porter-armhf
15:11 <slangasek> (done)
15:11 <slangasek> -infinity
15:11 <slangasek> xnox:
15:13 <xnox> fixing bridge_role attribute race in s390-tools (in a silo)
15:13 <xnox> adding apt-key support to ubuntu-release-upgrader
15:13 <xnox> merge proposal for archive signing for next series
15:13 <xnox> upstart review/merge for systemd bridge support
15:13 <xnox> d-i version stamp fixes for automated testing
15:13 <xnox> testing zfcpdump kernel for apw
15:13 <xnox> done
15:13 <cyphermox> xenial:
15:13 <cyphermox> - grub2 ipv6 fixes SRU (bug LP: #1229458)
15:13 <cyphermox> yakkety:
15:13 <cyphermox> - hw-detect modprobe fix (bug LP: #1602717)
15:13 <cyphermox> - shim revert to 0.8
15:13 <ubottu> Launchpad bug 1229458 in MAAS "grubnetx64.efi tftp client does not work over ipv6" [High,Triaged] https://launchpad.net/bugs/1229458
15:13 <ubottu> Launchpad bug 1602717 in hw-detect (Ubuntu Xenial) "hw-detect modprobes blindly, ignoring blacklists" [Low,Fix committed] https://launchpad.net/bugs/1602717
15:13 <cyphermox> - davmor2 caught a fail there because MokManager.
15:13 <cyphermox> - d-i respin for shim fix
15:13 <cyphermox> - open-iscsi autopkgtest debugging
15:14 <cyphermox> - more open-iscsi autopkgtest debugging
15:14 <cyphermox> - ppc64el issue partitioning with JFS (bug LP: #1630017)
15:14 <cyphermox> - sync e2fsprogs for segfault fix (bug LP: #1627608)
15:14 <cyphermox> - upload ubiquity 16.10.12
15:14 <cyphermox> - ubiquity kde frontend porting to pyqt5
15:14 <cyphermox> - to unbreak the slideshow...
15:14 <cyphermox> - zomg ubiquity icon and UI fixes
15:14 <ubottu> Launchpad bug 1630017 in partman-prep (Ubuntu) "Ubuntu 16.10 installation with root as JFS file system fails" [High,Incomplete] https://launchpad.net/bugs/1630017
15:14 <ubottu> Launchpad bug 1627608 in e2fsprogs (Ubuntu) "resize2fs crashed with SIGSEGV in ext2fs_extent_translate()" [Medium,Fix released] https://launchpad.net/bugs/1627608
15:14 <cyphermox> ±other stuff:
15:14 <cyphermox> - coordinating with juju team
15:14 <cyphermox> - netcfg hostname magic (bug LP: #1452202)
15:14 <cyphermox> - review probert PR: read NM leases in networkd format
15:14 <cyphermox> - review subiquity/probert pull requests
15:14 <ubottu> Launchpad bug 1452202 in preseed (Ubuntu Xenial) "ubuntu preseed install fails to set a hostname" [Medium,In progress] https://launchpad.net/bugs/1452202
15:14 <cyphermox> (done)
15:15 <slangasek> cyphermox: so on the shim revert... best idea I can think of is to rescue the MokManager binary from the original 0.8 package and pass it through.  We still have all the source for it, we just wouldn't use the one we're building because $reasons
15:15 <cyphermox> slangasek: that was my plan too
15:15 <cyphermox> no other way about it anyway
15:15 <cyphermox> just *omg it's still borken*
15:16 <slangasek> ok
15:16 <slangasek> chiluk: hi
15:18 <slangasek> tdaitx is having Internet problems today
15:18 <slangasek> pitti:
15:18 <pitti> just a 3-day week (conference days Thu/Fri and national holiday Mon)
15:18 <pitti> autopkgtest:
15:18 <pitti> - Debug endless retry loop with broken kernel (#1630578)
15:18 <pitti> - Fix autopkgtest.u.c. navbar in mobile mode
15:18 <pitti> - Fix virt-qemu for user/password logins on ttyS0 [ongoing] (#1630963)
15:19 <pitti> - Investigate and fix missing/hidden test requests
15:19 <pitti> - Various generalizations for running system-image tests from GitHub, barry's system-image tests are now in place
15:19 <pitti> distro:
15:19 <pitti> - cloud-init: Investigate DNS resolution deadlock in early boot (#1629797)
15:19 <pitti> - glibc: Debug/fix locale-related crash (#1577460)
15:19 <pitti> - gnome-keyring: Fix dependency loop
15:19 <pitti> - systemd: Fix the previous security patch for notify assertion (#1628687)
15:19 <pitti> - systemd, gnome-session: Robustify and simplify run-systemd-session, no shell polling loops any more
15:19 <pitti> lots of yakkety archive admin/reviews and SRU processing
15:19 <pitti> 🔚
15:19 <barry> s/system-image/ubuntu-image
15:20 <pitti> "project"
15:20 <slangasek> :)
15:20 <slangasek> robru:
15:20 <barry> btw, it works great (modulo hopefully a minor issue) - thanks pitti!  so much better than travis+docker
15:21 <pitti> robru: haven't forgotten your britney branch review, just swamped; will still get to it this week
15:22 <slangasek> barry: and now you can use it for testing s390x all-snap images!
15:22 <barry> \o/
15:23 <slangasek> barry: no sign of robru, go ahead?
15:23 <pitti> no nested qemu for s390x yet, needs scalingstack
15:23 <barry> ubuntu-image: LP: #1617445 (coverage branch)
15:23 <ubottu> Launchpad bug 1617445 in Ubuntu Image "Pay down coverage tech debt" [High,In progress] https://launchpad.net/bugs/1617445
15:23 <barry> debuntu: python-pluggy 0.4.0-1; unfutz debian machine; testing gpg-agent/upstart problem this morning
15:23 <barry> misc: kiwi pycon trip report
15:23 <barry> ✔ done
15:23 <slangasek> alrighty
15:23 <slangasek> any questions?
15:23 <slangasek> one week to release
15:23 <slangasek> I think you maybe all know what to do :)
15:24 <pitti> I think it's time for an early 4.9 kernel!
15:24 <xnox> AOB: why did she not choose Bernie as VP? Also, only 80 sleeps until Christmas. Regent Street decorations are going up.
15:24 <barry> pitti: yes, because bisecting kernel failures for 4.8 was so much fun!
15:25 <pitti> "if it's hard, do it more often"
15:25 <xnox> i still see a few bugs w.r.t. 4.8 kernel filed for ppc64el....
15:25 <pitti> barry: "was" → "is"
15:25 <pitti> also on x86
15:25 <pitti> https://bugs.launchpad.net/ubuntu/+source/linux/+bugs?field.tag=kernel-4.8
15:25 * xnox doesn't use legacy architecutres
15:25 <barry> awesome
15:25 <slangasek> xnox: because politics is complicated and political advisors all have their own bias when it comes to deciphering what will win an election :)
15:25 * pitti wants to see xnox's s390x phone
15:25 <cyphermox> xnox: for you legacy == !s390x?
15:26 <xnox> cyphermox, not made by IBM =)
15:26 <slangasek> [TOPIC] AOB
15:26 <slangasek> anything else, for realsies?
15:26 <cyphermox> you know, people could argue the other way around...
15:26 <cyphermox> not from me ;)
15:26 <cyphermox> oh actually
15:26 <slangasek> Monday is nat hol in the US
15:26 <pitti> any OMGcritical installer bugs known that are in foundation land?
15:26 <xnox> perfect timing
15:26 <cyphermox> also thanksgiving in Canada
15:26 <xnox> pitti, well just the last minute port from Qt4 to Qt5.
15:26 <slangasek> oh indeed
15:27 <slangasek> so a few of us will be snoozing Monday
15:27 <cyphermox> pitti: other icon stuff
15:27 <cyphermox> (for ubiquity)
15:27 <bdmurray> what's the status of bug 1626622?
15:27 <ubottu> bug 1626622 in debian-installer (Ubuntu Yakkety) "yakkety server: fails to detect and mount CD-ROM" [Critical,Incomplete] https://launchpad.net/bugs/1626622
15:27 <xnox> are both cyphermox & infinity going to celebrate extended thanksgiving? is that on a thursday?
15:27 <cyphermox> but I've finished the pyqt5 porting, and the icons I will fix in a bit
15:27 * xnox googles when is canadian thanksgiving
15:27 <cyphermox> monday
15:27 <xnox> ah monday.
15:28 <slangasek> yes, Canadian is at a higher latitude, so the harvest comes earlier, therefore it's on a Monday instead of a Thursday
15:28 * cyphermox read altitude
15:28 <xnox> slangasek, right......
15:29 <bdmurray> xnox: Are you still looking at bug 1611256?
15:29 <ubottu> bug 1611256 in ubuntu-release-upgrader (Ubuntu) "X to Y upgrade fails with gconf2 depends on python3:any; however: Package python3 is not configured yet." [Critical,Confirmed] https://launchpad.net/bugs/1611256
15:29 <xnox> you could have fooled me
15:29 <bdmurray> Oh, bug 1626622 seems fixed so don't worry about that.
15:29 <ubottu> bug 1626622 in debian-installer (Ubuntu Yakkety) "yakkety server: fails to detect and mount CD-ROM" [Critical,Incomplete] https://launchpad.net/bugs/1626622
15:33 <slangasek> seems like that's everything
15:34 <slangasek> unless robru or chiluk have anything to add
15:34 <bdmurray> xnox: Are you still looking at bug 1611256?
15:34 <ubottu> bug 1611256 in ubuntu-release-upgrader (Ubuntu) "X to Y upgrade fails with gconf2 depends on python3:any; however: Package python3 is not configured yet." [Critical,Confirmed] https://launchpad.net/bugs/1611256
15:34 <chiluk> sorry slangasek.. not much from me this week.. just tracking down kernel bugs.
15:34 <xnox> bdmurray, no.
15:35 <bdmurray> xnox: Do you have time to?
15:35 <slangasek> chiluk: ok
15:35 <xnox> bdmurray, i really should.
15:35 <xnox> it was trivial to reproduce, cause my laptop hit it
15:36 <slangasek> [ACTION] xnox to investigate bug #1611256
15:36 * meetingology xnox to investigate bug #1611256
15:36 <ubottu> bug 1611256 in ubuntu-release-upgrader (Ubuntu) "X to Y upgrade fails with gconf2 depends on python3:any; however: Package python3 is not configured yet." [Critical,Confirmed] https://launchpad.net/bugs/1611256
15:36 <slangasek> #endmeeting