16:02 <rharper> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Oct  4 16:02:27 2016 UTC.  The chair is rharper. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <rharper> #topic Review ACTION points from previous meeting
16:02 <jgrimm> thanks rhaper
16:02 <jgrimm> rharper even!
16:03 <rharper> jgrimm: sure
16:03 <rharper> jgrimm: Add a url for server release bugs to irc commands for meetings ?
16:03 <smoser> o/
16:04 <jgrimm> rharper, bah.. i just need to add the rls-x url in again
16:04 <jgrimm> rharper, leave it, i'll do right after meeting
16:04 <rharper> ok, we'll keep that
16:04 <rharper> jamespage checking with old iscsitarget users on relevancy with new kernels
16:04 <jamespage> oh boy
16:05 <jamespage> better carry that - I need to figure out who to ask
16:05 <rharper> sure
16:05 <rharper> powersj to put together iso testing signup sheet
16:05 <jgrimm> hmm.. that's old
16:05 <jgrimm> rharper, where are you looking at agenda from
16:05 <powersj> rharper, yeah - done a while ago ;)
16:05 <rharper> https://wiki.ubuntu.com/MeetingLogs/Server/20160927
16:06 <jgrimm> ok, should have been marked done last time. not on wiki at least
16:06 <rharper> #done powersj to put together iso testing signup sheet
16:07 <jgrimm> rharper, you are looking at the agenda of last week
16:07 <jgrimm> by looking at the minutes. :)
16:07 <rharper> but I was successful, 2/3 still need doing =)
16:07 <jgrimm> heheheh. indeed!
16:08 <rharper> ok, I don't see any other actions to review
16:08 <rharper> #topic Yakkety Development
16:08 <rharper> #link https://wiki.ubuntu.com/YakketyYak/ReleaseSchedule
16:08 <rharper> just up to Final Freeze
16:08 <jgrimm> rush to the finish line
16:08 <rharper> very much
16:08 <rharper> #subtopic Release Bugs
16:09 <jgrimm> anything to discuss wrt urgent/critical for freeze?
16:09 <rharper> maybe, smoser re: the nss/cloud-init/dbus.socket stuff
16:09 <nacc> down to 4 ftbfs in the test rebuild
16:09 <jgrimm> cpaelzer got a new upload in today (already in archive) for dpdk, he has some cleanups to do with respect to latest ovs
16:10 <smoser> bug 1629868
16:10 <ubottu> bug 1629868 in cloud-init (Ubuntu) "times out because of no dbus" [Undecided,New] https://launchpad.net/bugs/1629868
16:10 <smoser> and bug 1629797
16:10 <ubottu> bug 1629797 in systemd (Ubuntu) "resolve service in nsswitch.conf adds 25 seconds to failed lookups before systemd-resolved is up" [Undecided,Triaged] https://launchpad.net/bugs/1629797
16:10 <smoser> are the fun
16:10 <smoser> they're a result of 2 changes... a.) cloud-init.service now running 'Before=basic.target'
16:10 <smoser> b.) adding of 'resolv' to /etc/nsswitch.conf in yakkety
16:11 <smoser> sorry, spelling. resolve
16:11 <jgrimm> smoser, fix in hand? need help?
16:11 <rharper> smoser: and (a) was required to ensure cloud-init can mount/unmount devices
16:11 <rharper> before systemd.mount does
16:11 <smoser> i'd say *a* fix is possible, but everyone agrees that while being least-intrusive of the options, it seems yucky
16:12 <smoser> (that fix is to put 'Before=dbus.service' in cloud-init.service, which seems quite counter obvious at first glance)
16:12 <rharper> indeed
16:12 <smoser> so, continuing to work that. the good news is it is fairly easily recreatable.
16:13 <rharper> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-y-tracking-bug-tasks.html#ubuntu-server
16:13 <jgrimm> ok, i just read the dbus one.
16:14 <rharper> any other release items/issues ?
16:14 <jgrimm> rls-y looks fine
16:14 <rharper> k
16:14 <rharper> #topic Server & Cloud Bugs (caribou)
16:14 <caribou> Hi,
16:14 <caribou> sosreport up for review, removed the clamav tomsfastmath Universe dependancy
16:14 <smoser> i'm hoping to fix bug 1630274 shortly
16:14 <ubottu> bug 1630274 in cloud-utils (Ubuntu) "mount-image-callback may not mount overlay when it could" [High,In progress] https://launchpad.net/bugs/1630274
16:14 <caribou> that's about it
16:14 <smoser> i need odd_bloke to verify that it works for him, but i expect it to
16:15 <rharper> any questions for caribou
16:16 <rharper> thanks caribou
16:16 <jgrimm> nope, but on the topic, i'm currently working through bugs that have xenial, trusty tasks still in some sort of in-progress state to nudge them along
16:16 <jgrimm> get owners as needed, etc
16:16 <jgrimm> that's all
16:16 <rharper> thanks
16:17 <rharper> #topic Weekly Updates & Questions for the QA Team (powersj)
16:17 <powersj> Spent last week at QA sprint with folks from other areas, learned lots. Focusing this week on triage, gathering cloud-init integration test cases, qemu/kvm live migration tests running.
16:17 <powersj> Server ISO kernel issues got resolved last week (yea!) and size is decreasing nicely. Only waiting on GCC 6 reductions to hopefully get us down below 703 MB (amd64 is at 743 MB today). Post-release will continue analysis of ISO size and contents. /qa_update
16:17 <rharper> #link https://jenkins.ubuntu.com/server/
16:17 <rharper> powersj: thanks for the summary from the sprint, that was super helpful
16:18 <nacc> +1
16:18 <powersj> good to hear :)
16:18 <rharper> should be an interesting discussion with the team later this week
16:19 <rharper> any questions for powersj ?
16:19 <jgrimm> :) heh. josh already had to hear a few rants from me.
16:19 <rharper> haha
16:19 <rharper> yeah, I was resisting the urge to poke the messenger
16:19 <jgrimm> :)
16:20 <rharper> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:22 <rharper> nothing from kernel team
16:22 <rharper> #topic Upcoming Call For Papers
16:22 <rharper> any new CfPs to think about ?
16:23 <jgrimm> fosdem 2017 has end of Oct CFP deadline
16:23 <jgrimm> otherwise october looking pretty empty for CFPs (according to LWN)
16:23 <rharper> y
16:24 <rharper> #topic Ubuntu Server Team Events
16:25 <jgrimm> LinuxCon Europe / ContainerCon Europe: stgraber & brauner are there for LXD/LXC
16:25 <jgrimm> this week
16:25 <rharper> ODS is in a few too
16:25 <jgrimm> indeed that time o year
16:25 <rharper> #topic Open Discussion
16:25 <rharper> floor's open
16:26 <jgrimm> i'll bring up the z blueprint again just for awareness
16:26 <jgrimm> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:26 <rharper> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-z-server-core
16:26 <jgrimm> open for business
16:26 <jgrimm> thanks!
16:26 <jgrimm> that's all from me
16:26 <rharper> ok
16:27 <rharper> #topic Assigned merges/bugwork (rbasak)
16:27 <rbasak> Nothing from me this week. Carry on as normal I think! Any questions or issues to raise?
16:27 <rharper> ok
16:28 <rharper> #topic Announce next meeting date, time and chair
16:28 <rharper> Next meeting will be same time a week from now, chair will be rharper (I shall taunt you a second time!)
16:29 <jgrimm> :)
16:29 <rharper> #action jgrimm Add a url for server release bugs to irc commands for meetings
16:29 * meetingology jgrimm Add a url for server release bugs to irc commands for meetings
16:29 <rharper> #action jamespage checking with old iscsitarget users on relevancy with new kernels
16:29 * meetingology jamespage checking with old iscsitarget users on relevancy with new kernels
16:29 <rharper> adding those for next time since we carry them
16:29 <rharper> and that's it folks
16:29 <jgrimm> thanks rharper
16:29 <rharper> #endmeeting