15:16 <rbasak> #startmeeting DMB
15:16 <meetingology> Meeting started Mon Aug  1 15:16:00 2016 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:16 <meetingology> 
15:16 <meetingology> Available commands: action commands idea info link nick
15:16 <rbasak> There, I did it.
15:16 <infinity> So we can stop being confused.
15:16 <micahg> it should be whoever is after me
15:16 <infinity> Or that. :P
15:16 <rbasak> #topic Review of previous action items
15:16 <rbasak> cyphremox Update Mate packages per Iain Laney's suggestions
15:16 <rbasak> everyone to review rbasak's question on devel-permissions and give feedback
15:16 <cyphermox> in progress, it will be done today
15:16 <rbasak> rbasak to make permission changes for new PPU packages for GunnarHj (blocked on previous)
15:16 <rbasak> My action is with infinity
15:16 <rbasak> infinity: any news on that please?
15:17 <rbasak> #action Update Mate packages per Iain Laney's suggestions (carried over)
15:17 * meetingology Update Mate packages per Iain Laney's suggestions (carried over)
15:17 <infinity> rbasak: Derp.  I've been swamped with stuff.  I'll sort it today.
15:17 <cyphermox> rbasak: in progress, it will be done today
15:17 <rbasak> #action infinity  to make permission changes for new PPU packages for GunnarHj
15:17 * meetingology infinity  to make permission changes for new PPU packages for GunnarHj
15:18 <rbasak> cyphermox: thanks. I just wanted to carry it over so it doesn't get lost in the next meeting in case you get distracted.
15:18 <cyphermox> yes
15:18 <rbasak> #topic Package Set/Per Package Uploader Applications
15:18 <rbasak> #subtopic Otto Kekäläinen (Aug 1st, 2016)
15:18 <rbasak> I don't think otto is here.
15:18 <rbasak> So let's move on.
15:18 <rbasak> #subtopic Extend the ubuntu-mate package set to include mate-hud (Jul 18th, 2016)
15:19 <rbasak> I think we concluded that there's nothing to do here until mate-hud is seeded, and then one of us can just regenerate the packageset.
15:19 <sil2100> I agree
15:19 <rbasak> Looks like it is seeded now.
15:20 <sil2100> Oh, indeed
15:20 <sil2100> I can do that, since I never regenerated packagesets before
15:21 <rbasak> Thanks!
15:21 <sil2100> If you could put an action item for me for that
15:21 <sil2100> I'll do that in a moment
15:21 <rbasak> #action sil2100 to regenerate ubuntu-mate packageset to add new seeded package mate-hud for flexiondotorg
15:21 * meetingology sil2100 to regenerate ubuntu-mate packageset to add new seeded package mate-hud for flexiondotorg
15:21 <sil2100> Thanks :)
15:21 <rbasak> #topic Ubuntu Contributing Developer Applications
15:21 <rbasak> #subtopic Ross Gammon (Aug 1, 2016)
15:22 <rbasak> Rosco2: you're on!
15:22 <Rosco2> Hi there all
15:22 <rbasak> Rosco2: would you like to introduce yourself?
15:22 <Rosco2> I am the Test Team lead for Ubuntu Studio
15:23 <Rosco2> Debian Maintainer for a few packages
15:23 <infinity> Rosco2: Excellent, I'll have ISOs for you to test today. :P
15:23 <Rosco2> :-)
15:23 <infinity> Oh look, it's otto.  Fashionably late.
15:23 <rbasak> I think otto was expecting the meeting to be in #ubuntu-devel. Our Agenda page doens't seem to state venue. I should add it.
15:24 <Rosco2> Have done a small number of bits in Ubuntu that were sponsored
15:24 <otto> Sorry, I only read the first part of https://wiki.ubuntu.com/DeveloperMembershipBoard and did not notice #ubuntu-meeting
15:24 <sil2100> otto: ok, no worries, good that you're here today
15:24 <infinity> Rosco2: Yeah, I was about to ask about the "small number".  The Ubuntu Contributing Thingee description mentions "significant and sustained contributions".
15:25 <sil2100> We'll take care of your application once we're done with Rosco2
15:25 <infinity> Rosco2: That said, if we add up Debian and Ubuntu involvement together, I suspect it counts.
15:26 <Rosco2> Basically just stating an intention to begin getting serious in Ubuntu
15:26 <Rosco2> Ubuntu Studio is short on regular developers
15:26 <infinity> They are indeed.
15:27 <rbasak> Rosco2: had you asked anyone for endorsements on your application?
15:27 <Rosco2> Yes - I asked the small number of sponsors
15:27 <Rosco2> Only 2 responded saying they needed to see more
15:28 <Rosco2> But I am not expecting upload rights straight away
15:28 <infinity> Rosco2: You seem to have a lot of old ITP bugs open in Debian.  Is the plan to get those done and uploaded, and maintain them in both Debian and Ubuntu?
15:28 <Rosco2> Just want to work towards it
15:28 <Rosco2> Yes
15:29 <sil2100> Rosco2: I see that in your application plans for the future you mentioned you want make sure all ubuntu studio packages have autopkgtests - do you have experience in writing those?
15:29 <Rosco2> Need to try and get it done before the freeze
15:29 <Rosco2> I have only written the one autopkgtest
15:29 <Rosco2> But I watch the video from the last debconf
15:30 <Rosco2> and promised myself to do better
15:30 <sil2100> Ok
15:30 <Rosco2> watched
15:31 <Rosco2> We have been concentratiing on manual tests in Studio
15:31 <Rosco2> Trying to have one for each priority package for us
15:37 <rbasak> OK, any other questions for Rosco2?
15:37 * rbasak forgot he was chairing for a minute there, sorry!
15:37 * sil2100 has no more questions
15:37 <rbasak> OK, let's vote
15:38 <rbasak> #vote Rosco2 for contributing developer
15:38 <meetingology> Please vote on: Rosco2 for contributing developer
15:38 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:38 <infinity> -1
15:38 <meetingology> -1 received from infinity
15:39 <infinity> Rosco2: FWIW, that's not an opinion on you or your work, but rather just the limited contribution so far.  I don't think you meet the bar for "significant and sustained".
15:39 <infinity> Rosco2: Get a bunch more sponsored uploads under your belt, and I'll be happy to change that.
15:39 <rbasak> cyphermox, sil2100, micahg: please vote
15:39 <bdmurray> -1
15:39 <meetingology> -1 received from bdmurray
15:39 <cyphermox> yeah, thinking about it
15:39 <cyphermox> +0
15:39 <meetingology> +0 received from cyphermox
15:39 <micahg> +0 would be nice to have some endorsements of the dev work that's been done and see more of it (significant and sustained)
15:39 <meetingology> +0 would be nice to have some endorsements of the dev work that's been done and see more of it (significant and sustained) received from micahg
15:39 <rbasak> +0
15:39 <meetingology> +0 received from rbasak
15:40 <sil2100> +0 (good direction, but need to demonstrate a bit more ubuntu involvement)
15:40 <meetingology> +0 (good direction, but need to demonstrate a bit more ubuntu involvement) received from sil2100
15:40 <rbasak> It certainly sounds like your contributions exceed the picture given by comments and endorsements on your application. So it sounds like your contributions may meet the requirements for contributing developer, but I feel that I should base any decision on endorsements, and unfortunately you have none. I appreciate your contributions and I hope to see you continue, but I don't feel that it's
15:40 <rbasak> appropriate to proceed without endorsements.
15:40 <rbasak> #endvote
15:40 <meetingology> Voting ended on: Rosco2 for contributing developer
15:40 <meetingology> Votes for:0 Votes against:2 Abstentions:4
15:40 <meetingology> Motion denied
15:40 <Rosco2> No problems. Thanks guys
15:41 <Rosco2> I will keep plugging away :-)
15:41 <micahg> Rosco2: might help also if you're specific when you ask for endorsements that it's not for upload rights right now
15:41 <micahg> most devs when approached for endorsements think upload rights
15:41 <Rosco2> I thought I said that - but point taken
15:41 <rbasak> Rosco2: thank you for your contributions. I'm sorry we couldn't endorse your application right now, but I hope we can do so in the future. I hope you'll consider reapplying as soon as you've addressed the comments we made.
15:41 <infinity> Rosco2: Yeah.  Just get a bunch more uploads in, and as micahg mentions, ask some of your sponsors to basically say that the work you're doing is useful.
15:42 <rbasak> Now that otto's here, let's go back to him.
15:42 <infinity> Rosco2: (Or if all your stuff goes through zequence, that's fine if he's your only real endorsement, just make sure he has a lot of work to base it on)
15:42 <rbasak> #topic Package Set/Per Package Uploader Applications
15:42 <rbasak> #subtopic Otto Kekäläinen (Aug 1st, 2016)
15:42 <rbasak> otto: hello!
15:43 <otto> o/
15:43 <rbasak> otto: please introduce yourself, and we'll see if anyone has any questions.
15:43 <rbasak> I have endorsed otto myself, and so I have no questions for him.
15:44 <otto> I have been a Linux advocate ever since I was introduced to it around 1998-1999
15:44 <otto> I've been using and working with both RPM and DEB based distros
15:44 <otto> I started using Ubuntu around 2005
15:45 <otto> Currently I work for Seravo Oy and the MariaDB Foundation, and enjoy working with FOSS full time
15:45 <infinity> otto: I assume the three packages you're asking for upload rights to are all ones you upload in Debian?
15:45 <otto> Yes
15:46 <infinity> Yeah.  I've no real questions about competence and the like, then.  We consume your packaging anyway.
15:46 <infinity> So, the only real questions are if you know and understand Ubuntu release cycles/schedules and all that.
15:46 <micahg> and everything is in sync with Debian, nice :)
15:46 <otto> the link in my application shows an overview of my packages in Debian: https://qa.debian.org/developer.php?login=otto%40debian.org
15:47 <infinity> otto: Yeah, it's all team maintained, though, so hard to tell what you actually upload, and asking you was easier than parsing changelogs. ;)
15:48 <infinity> otto: Anyhow, I'm more than satisfied with your Debian creds on this front.
15:48 <otto> I actually upload all of those that have otto@debian.org as uploader
15:48 <infinity> otto: So, it's just down to Ubuntu nit-picking.  Are you aware of where we keep our release schedule, what feature freeze means, how to plead with the release team to break feature freeze, etc? :P
15:49 <infinity> I know you're aware of the SRU/security processes, because you already deal with those.
15:49 <otto> Note that I am currently the only active DD in the pkg-mysql team in Debian. Robie is in the team too but only as DM (but that should change soon)
15:49 <otto> I have been looking at pages like https://wiki.ubuntu.com/YakketyYak/ReleaseSchedule since 2005
15:49 <infinity> otto: Yeah, a lot of us have fallen by the wayside over the years.  Sorry about that. :P
15:50 <otto> Though I have to admit I run only LTS releases on my own machines since some years
15:50 <cyphermox> I'd like to vote but I'm going to need to run away for a bit; I'm +1
15:50 <infinity> otto: Knowing the URL is already miles ahead of half the people who have upload rights.
15:50 <otto> But I do all of my Debian packaging so that I upload to Launchpad PPA in parallel
15:50 <rbasak> cyphermox: noted, thanks.
15:50 <infinity> cyphermox: I'll spoof your vote.
15:50 <cyphermox> sorry about that
15:52 * sil2100 doesn't have any particular questions here
15:52 <rbasak> Any other questions for otto?
15:52 <bdmurray> Not from me
15:52 <infinity> I'm good, I think.
15:52 <rbasak> #vote otto for PPU to mariadb-10.0, mariadb-client-lgpl, galera-3
15:52 <meetingology> Please vote on: otto for PPU to mariadb-10.0, mariadb-client-lgpl, galera-3
15:52 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:53 <cyphermix> +1
15:53 <meetingology> +1 received from cyphermix
15:53 <rbasak> +1
15:53 <meetingology> +1 received from rbasak
15:53 <infinity> +1
15:53 <meetingology> +1 received from infinity
15:53 <micahg> +1
15:53 <meetingology> +1 received from micahg
15:53 <bdmurray> +1
15:53 <meetingology> +1 received from bdmurray
15:53 <rbasak> sil2100: would you like to vote?
15:53 <sil2100> +1
15:53 <meetingology> +1 received from sil2100
15:53 <sil2100> !
15:53 <sil2100> Got disctracted, sorry about that ;)
15:53 <rbasak> #endvote
15:53 <meetingology> Voting ended on: otto for PPU to mariadb-10.0, mariadb-client-lgpl, galera-3
15:53 <meetingology> Votes for:6 Votes against:0 Abstentions:0
15:53 <meetingology> Motion carried
15:54 <rbasak> No problem :)
15:54 <otto> thanks :)
15:54 <rbasak> otto: congratulations, and thank you for your contributions to Ubuntu!
15:54 <sil2100> otto: happy per-package-uploading!
15:54 <sil2100> rbasak: will you send out an announcement?
15:54 <infinity> rbasak: I'm going to forget my actions immediately after the meeting because 14.04.5 is driving me batty.  Can you send me a mail with all the TB-necessary things I need to do?
15:54 <rbasak> infinity: can you take an action to add otto please?
15:54 <infinity> Jinx.
15:55 <rbasak> Yes, I can do the announcement.
15:55 <rbasak> infinity: will do
15:55 <infinity> Ta.
15:55 <rbasak> #action infinity to add Otto PPU access to mariadb-10.0, mariadb-client-lgpl, and galera-3
15:55 * meetingology infinity to add Otto PPU access to mariadb-10.0, mariadb-client-lgpl, and galera-3
15:55 <rbasak> #action rbasak to summarise all TB-necessary DMB tasks to infinity
15:55 * meetingology rbasak to summarise all TB-necessary DMB tasks to infinity
15:56 <rbasak> #action rbasak to add otto to ~ubuntu-dev
15:56 * meetingology rbasak to add otto to ~ubuntu-dev
15:56 <rbasak> #action rbasak to announce otto's successful application
15:56 * meetingology rbasak to announce otto's successful application
15:57 <rbasak> #topic Decide on how to implement suggestions from the CC meeting
15:57 <rbasak> So we had our catchup with the CC last week.
15:57 <rbasak> One comment from them was a concern that announcements were getting lost. I said we'd sort something out.
15:59 <sil2100> I guess we all need to just follow all 'After the meeting' steps in the agenda
15:59 <infinity> I know I forgot to announce juliank's core-dev thing cause he and I both got sucked back into Debconf right after the meeting.
15:59 <rbasak> I propose that we make sure to add explicit meeting actions for successful applicants, including the announcement to the news team, etc. We seem to be quite good at following up meeting actions (in the end) with meetingology's help.
15:59 <rbasak> So then we'd be using something we're fairly good at doing to make sure we get stuff done.
15:59 <rbasak> (which is why I added a bunch of actions above)
16:00 <sil2100> rbasak: fair enough
16:00 <rbasak> So the only change is that the chair needs to make sure to add actions immediately after an applicant is approved. Then hopefully we won't forget.
16:01 <rbasak> An alternative suggestion from the CC was using a Kanban style thing somewhere, but I prefer just using meetingology.
16:01 <rbasak> Any other alternative suggestions, or objections to my proposal?
16:02 <rbasak> I'll assume we're agreed then?
16:02 <bdmurray> works for me
16:02 <rbasak> #agreed Future meeting chairs will individual actions for approved applicants to make sure they don't get missed, including to inform the news team of successful applicants.
16:02 <rbasak> #topic Select a chair for the next meeting (following alphabetical order of first names)
16:03 <rbasak> How do we want to proceed with chair selection?
16:03 <infinity> Just go alpha from you, and we'll fix this.
16:03 <rbasak> OK.
16:03 <rbasak> So that means infinity is next
16:03 <rbasak> :-)
16:03 <rbasak> #topic Any other business
16:03 <infinity> And from now on, if someone misses, the next in line (who's present) chairs, and on the wiki, mark "next: (jerk who skipped), backup: (next alpha from today's)"
16:04 <infinity> If that makes sense?
16:04 <rbasak> Yes, until we have multiple outstanding skips ;-)
16:04 <rbasak> But that's certainly a start so is fine.
16:04 <rbasak> So BenC is the backup for now I guess?
16:05 <infinity> Wait, we're doing alpha by... What?
16:05 <infinity> TB, we do "LP sort order".
16:05 <rbasak> By first name apparently. That's how it is in the wiki currently.
16:05 <infinity> Which would be sil, then me, then ben.
16:05 <infinity> Oh.
16:05 <infinity> Whacky.
16:05 <infinity> Kay.
16:05 <sil2100> Yeah, I always saw it being alpha by first-name
16:05 <rbasak> I think it's easy enough just to not bother changing it.
16:05 <infinity> Works for me.
16:05 <rbasak> OK
16:05 <infinity> Just can't use LP as my dictionary. ;)
16:06 <rbasak> Any other AOB?
16:06 <infinity> I NEED TO SING THE ALPHABET SONG.
16:06 <rbasak> :-)
16:06 * doko mutes
16:06 <rbasak> OK then. Thanks all!
16:06 <rbasak> #endmeeting