15:01 <BenC> #startmeeting DMB meeting
15:01 <meetingology> Meeting started Mon May  9 15:01:23 2016 UTC.  The chair is BenC. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:01 <meetingology> 
15:01 <meetingology> Available commands: action commands idea info link nick
15:02 <BenC> I’m going to be a little slow getting started. First time using meetingology
15:02 <cyphermox> no worries
15:02 <BenC> I see 4 present, including myself.
15:02 <BenC> 5
15:03 <BenC> Guess that’s enough to get started
15:03 <BenC> #topic Review of previous action items
15:03 <BenC> infinity: If you’re here...
15:04 <BenC> I believe membership changes were done.
15:04 <BenC> Can anyone else confirm?
15:04 <sil2100> I updated the agenda last week since it was a bit chaotic
15:04 <rbasak> I think lamont had some suggestions for us in https://lists.ubuntu.com/archives/devel-permissions/2016-May/000922.html in relation to this?
15:04 <rbasak> Sorry, I meant Laney.
15:04 <BenC> rbasak: I saw that as well
15:05 <cyphermox> I don't think that has been done, but you can add an action for me to fix this
15:05 <lamont> whew
15:05 <BenC> I’m guessing no one has done that changes. Anyone want to volunteer to take care of them?
15:05 <cyphermox> o/
15:05 <rbasak> Thanks cyphermox
15:05 <BenC> #action cyphremox Update Mate packages per Iain Lane’s suggestions
15:05 * meetingology cyphremox Update Mate packages per Iain Lane’s suggestions
15:06 <rbasak> flexiondotorg: FYI ^. AIUI, this won't affect your actual uploadaccess.
15:06 <BenC> Basically a house keeping action, right?
15:06 <rbasak> I believe so, yes. Paves the way for more MATE uploaders.
15:07 <Laney> Well
15:07 <Laney> The other half of it was that you should merge my branch and make it an automatically generated set
15:07 <rbasak> I think there is a question for flexiondotorg here though.
15:07 <Laney> that's how flavour ones normally work
15:07 <Laney> but up to you of course
15:07 <rbasak> Does he want to seed those packages that Laney mentioned?
15:07 <rbasak> Laney: ah, I assumed BenC's action covered your entire email.
15:08 <Laney> Maybe so
15:08 <BenC> I had assumed that as well
15:08 <flexiondotorg> I can answer questions if need be.
15:08 <Laney> OK, I think that the second part is housekeeping but the first part not
15:08 <Laney> no bother if you want to define it differently :)
15:08 * Laney goes away
15:08 <rbasak> flexiondotorg: are you happy to seed the packages Laney mentioned?
15:08 <BenC> Thanks, Laney
15:09 <BenC> flexiondotorg: It’s in the devel-permissions email in the above URL
15:09 <flexiondotorg> Ummm, do you mean the expanded packages I requested PPU for?
15:09 * flexiondotorg reads...
15:09 <flexiondotorg> caja-actions
15:09 <flexiondotorg> caja-dropbox
15:09 <flexiondotorg> mate-accountsdialog
15:09 <flexiondotorg> mate-common
15:09 <flexiondotorg> mate-user-share
15:10 <flexiondotorg> So, The above are not seeded.
15:10 <rbasak> I think so, yes. Because then we'll make it an automatically managed packageset instead. So rather than individual PPU, you'd be able to upload MATE-seeded stuff that isn't seeded elsewhere.
15:10 <rbasak> (I think)
15:10 <flexiondotorg> But are part of the MATE packageset in the Debian pkg-mate team.
15:10 <flexiondotorg> I would like to be able to upload fixes for those packages.
15:11 <rbasak> The suggestion is that you do seed them.
15:11 <cyphermox> flexiondotorg: indeed, they should be in the mate supported seed, probably. we can discuss this after the meeting, but it's very much a jfdi thing
15:11 <flexiondotorg> If by seed, you mean, include in the images.
15:11 <cyphermox> not really
15:11 <flexiondotorg> Then no, I don't want to seed them.
15:11 <rbasak> They don't have to be in the images.
15:11 <cyphermox> they will be in a seed that doesn't make it into the images :)
15:11 <rbasak> You can seed them in a "supported" seed which basically means that you claim support for them but without them being in the images.
15:11 <flexiondotorg> OK, then yes :-)
15:11 <rbasak> Great, thanks :)
15:12 <flexiondotorg> If those packages go in a seed that is not part of the images, that is fine with me.
15:12 <BenC> Ok, so I think we’re in agreement that the action stands and the suggestions in Laney’s email will be performed.
15:13 <BenC> #topic Package Set/Per Package Uploader Applications
15:13 <BenC> #subtopic Martin Wimpress / Ubuntu MATE Packages
15:13 <BenC> I think this is sort of done, right?
15:13 <rbasak> I think this is moot now then? I do have another question but I'll take it up with flexiondotorg in #ubuntu-devel.
15:14 <BenC> #agreed Martin Wimpress / MATE Packages already handled.
15:14 <BenC> #topic Ubuntu Core Developer Applications
15:14 <BenC> #subtopic Phillip Susi https://wiki.ubuntu.com/PhillipSusi/DeveloperApplication2
15:14 <psusi> o/
15:14 <sil2100> o/
15:14 <rbasak> Hi psusi
15:14 <sil2100> Hello
15:15 <rbasak> We deferred you last time because you weren't online and we didn't see any endorsements.
15:15 <BenC> psusi: Thanks for joingin. Care to give us some background and information you’d like to say?
15:15 <psusi> well, I have been using Ubunutu since 6.06 was in development... and now I feel old...
15:15 <rbasak> psusi: I see that you're still missing endorsements. Do you need more time?
15:15 <BenC> Yeah, noticing that as well.
15:15 <psusi> I do a ton of bug triaging, and fix bugs whenever I can, though my time for that has been a bit limited lately due to busy schedule at work and a second kiddo at the end of last year
15:16 <psusi> I've been a contributing developer for a few years now and decided it's time to stop pestering others to upload for me
15:17 <psusi> not sure about the endorsements... I've been askiing in -devel every now and then for a good 5 months now
15:17 <psusi> I'm also the upstream develeoper for GNU parted, and contribute to upstream gparted, and am the debian maintainer for gparted
15:18 <BenC> I see you focus mainly on partition/disk/bootloader type packages. Is there any reason not to do per-package upload permissions instead of coredev?
15:19 <psusi> my attention sometimes wanders ;)
15:19 <psusi> but I suppose that would probably cover most of my work, yes
15:20 <rbasak> https://launchpad.net/~psusi/+uploaded-packages says that your last sponsored upload was in 2014?
15:21 <psusi> wow... I guess lately I've been getting more of them in thorugh Debian
15:21 <psusi> though I have at least one upload that has been waiting for sponsorship for months... a fix go grub to finally use dpkg-triggers for update-grub
15:22 <BenC> The grub spam on my screen during some apt operations would agree to that being a good feature…
15:22 <rbasak> Is that https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1250109?
15:22 <ubottu> Launchpad bug 1250109 in linux (Ubuntu) "Please use dpkg-triggers" [Wishlist,Triaged]
15:22 <sil2100> http://ubuntu-dev.alioth.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor_search=name&sponsoree=*Susi*&sponsoree_search=name <- it seems there was one more in 2015
15:24 <psusi> I try to keep gparted just auto syncing from debian as I'm the dm there so I just upload there and let it auto sync to ubuntu
15:25 <psusi> of course, during debian freeze, that can be a bit problematic when I want to update ubuntu for its release schedule
15:26 <BenC> Anyone have any other questions or comments for psusi?
15:26 <rbasak> o/
15:26 <rbasak> > that can e a bit problematic
15:26 <rbasak> Can you give us a recent example?
15:27 <psusi> hrm... I don't recall exactly what it was now, but the last time debian had a freeze ( which has been some time now ), there was a crash bug fix of some sort that I wanted to get into Ubuntu
15:27 <psusi> let me check the change log
15:28 <psusi> pretty sure I ended up just filing a sync request bug and having someone else sync from debian experimental
15:29 <psusi> after uploading it there
15:29 <BenC> psusi: Thanks for answering our questions.
15:29 <BenC> If there’s nothing further, I’ll call for a vote…
15:30 <BenC> #vote Phillip Susi for Ubuntu Core Dev
15:30 <meetingology> Please vote on: Phillip Susi for Ubuntu Core Dev
15:30 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:30 <BenC> -1
15:30 <meetingology> -1 received from BenC
15:30 <rbasak> -1
15:30 <meetingology> -1 received from rbasak
15:30 <sil2100> +0
15:30 <meetingology> +0 received from sil2100
15:31 <cyphermox> -1, there are no endorsements, not much in terms of recent uploads; we really ought to gate core-dev on someone actively needing the permissions / wasting reviewers' time with perfect uploads.
15:31 <meetingology> -1, there are no endorsements, not much in terms of recent uploads; we really ought to gate core-dev on someone actively needing the permissions / wasting reviewers' time with perfect uploads. received from cyphermox
15:31 <bdmurray> +0
15:31 <meetingology> +0 received from bdmurray
15:31 <rbasak> I don't think it's appropriate to grant upload access without any endorsements from fellow developers.
15:31 <BenC> #endvote
15:31 <meetingology> Voting ended on: Phillip Susi for Ubuntu Core Dev
15:31 <meetingology> Votes for:0 Votes against:3 Abstentions:2
15:31 <meetingology> Motion denied
15:31 <BenC> psusi: I suggest applying for per-package, and getting some endorsements as well.
15:32 <sil2100> I must agree with cyphermox here a bit, even though I see that the uploads you did were fairly good, I didn't also see any more challenging uploads set for sponsoring
15:32 <BenC> Thanks for your time and contributions, they are definitely appreciated.
15:32 <psusi> guess I need to pester cjwatson some more... he sponsored me for contrib back when I didn't feel comfortable enough to have core
15:32 <rbasak> I'd also like to see a demonstrated need for upload access.
15:32 <rbasak> Especially for core dev.
15:32 <psusi> ppu might work also
15:33 <cyphermox> sil2100: it's not just the challenge level, but showing that one can do unsupervised upload to any part of the archive, etc.
15:33 <BenC> Ok, moving on
15:33 <BenC> #topic AOB
15:33 <cyphermox> sil2100: so as we discussed last week, "X is wasting reviewers' time by asking for sponsoring for otherwise perfect uploads" is a great gate for core-dev access
15:33 <BenC> Anything from any one?
15:34 <sil2100> I would also really recommend PPU right now
15:34 <cyphermox> BenC: nothing from me
15:34 <sil2100> cyphermox: right
15:34 * sil2100 is good
15:34 <BenC> Ok
15:34 <BenC> #endmeeting