15:11 <bdmurray> #startmeeting 2016-04-11
15:11 <meetingology> Meeting started Mon Apr 11 15:11:15 2016 UTC.  The chair is bdmurray. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:11 <meetingology> 
15:11 <meetingology> Available commands: action commands idea info link nick
15:11 <sil2100> I guess it's been a while
15:11 <sil2100> :)
15:12 <bdmurray> So we have a new DMB, welcome everyone!
15:12 <BenC> Cheers all
15:12 <bdmurray> The agenda is still influx due to it not having been updated recently.
15:12 <cyphermox> o/
15:12 <bdmurray> sil2100: you'd mentioned you were going to look at the candidate list. Did you get a chance to do that?
15:13 <sil2100> bdmurray: didn't do it throughly sadly, but so far we had two candidates willing to participate in today's meeting: Mirv and FourDollars
15:13 <rbasak> slashd is here too I think?
15:14 <slashd> yes, am I
15:14 <bdmurray> Right, I see slashd and FourDollars on the agenda for today.
15:15 <sil2100> Mirv is also here, his application was postponed a bit
15:15 <Mirv> there are four applications to meetings that were cancelled in February and March
15:16 <sil2100> Mirv: yes, but some of them already have core-dev privilages, so the list is not really up-to-date
15:16 <Mirv> sil2100: ah correct I think 2016-02-29 was held and some of them were handled. then mine 2016-03-14 was the meeting that got cancelled.
15:17 <sil2100> From the core-dev field there's you and psusi left
15:17 <BenC> Are there people on the current agenda that are already handled and can be removed?
15:17 <bdmurray> Let's start with Mirv then since he's been waiting a while and circle back to Ubuntu Contributing Developer.
15:17 <sil2100> Agreed
15:17 <bdmurray> BenC: Yes, that was mentioned via email. I did remove some.
15:17 <BenC> Ok
15:18 <bdmurray> #topic Ubuntu Core Developer applications
15:18 <bdmurray> #subtopic Timo Jyrunki's application for core-dev
15:18 <bdmurray> Mirv: Could you please introduce yourself?
15:19 <Mirv> Hi. So I'm Ubuntu user since 2004, and currently a MOTU and have rights to two PPU package sets. I'm working for Canonical for four years now, and as part of that have maintained for example the Qt packages and their migrations, and various other things as part of the phone efforts.
15:20 <Mirv> My special interests tend to have been the "consumer" parts of Ubuntu, including desktop, phone and the different flavors of Ubuntu (where I'm glad to help, while I use Unity myself).
15:21 <bdmurray> Does anybody have any questions for Mirv?
15:21 <BenC> o/
15:22 <bdmurray> BenC: feel free to just ask
15:22 <BenC> Mirv: In what way would becoming a core-dev help you to contribute to Ubuntu further. What about not being a core-dev hinders your contributions?
15:24 <Mirv> BenC: I can't currently do packaging reviews of main packages that go through CI Train. As a landing team member, it hurts a bit to not be able to help other teams in that, while they tend to ask me for packaging help often. I could have more PPU:s, but I already have quite some. I'm also nowadays familiar with most things that happen in the archives, and I'd be glad to help where I can with eg releas
15:24 <Mirv> e pocket migrations more often than I currently can.
15:25 <Mirv> Likewise, my patch pilot is currently limited to universe packages, while I do see things on the sponsoring list occasionally where I'd be familiar with the package but don't have upload rights.
15:26 <bdmurray> Mirv: What kinds of feedback have you provided when reviewing packages that go through the CI Train?
15:27 <sil2100> Mirv: regarding that actually - since I see you have a lot of main experience through the Qt stack and do patch-piloting sessions, did you work on some lot of other package work from main?
15:27 <sil2100> s/lot of//
15:28 <Mirv> bdmurray: the most common feedback (if something is needed) has to do with handling moved files, where people tend to not use Breaks/Replaces etc correctly.
15:29 <Mirv> sil2100: well in the past we handled the unity/compiz SRU:s, but most of the time I've found it easier to just contribute within my MOTU rights where there is also work to be done. I mean, I've not done much of eg sponsoring where I'd do review but ask then actual core-dev to sponsor it, after I got MOTU rights.
15:30 <BenC> Mirv: I guess I’m not familiar enough with the CI Train. Just for my own education, what about providing feedback to main packagers requires core-dev access?
15:30 <Mirv> sil2100: well of course I've libvoikko, suomi-malaga/voikko-fi, libreoffice-voikko etc in main from Debian that I work on but can't upload myself in Ubuntu
15:30 <sil2100> Mirv: ACK
15:30 <Mirv> BenC: I can provide feedback and I usually do, but then if I get the fixes from the developers I can't approve them since it requires a core-dev to ack them.
15:31 <Mirv> BenC: so then I need to spend some other core-dev's time and he also needs to look through the changes since he's essentially taking the responsibility (since I'm not core-dev)
15:31 <BenC> Mirv: That makes more sense, thanks.
15:31 <bdmurray> micahg, cyphermox: any questions?
15:32 <sil2100> BenC: usually when there's a package from main that Mirv reviews he forwards his concerns/opinion to me or someone else that's around, but it's still a bit duplicating work
15:32 <micahg> Mirv: out of curiosity, do the CI Train rules change as the cycle progresses?
15:32 <BenC> sil2100: Your endorsement speaks well to him. Thanks for the additonal info.
15:33 <Mirv> micahg: not much, other than by the final freeze we will not land anymore to archives but to overlay PPA, from where packages will be copied to +1 when it opens
15:34 <micahg> so, is it up to the reviewers to decide whether or not to approve something based on feature freeze?
15:34 <cyphermox> no questions from me
15:35 <sil2100> micahg: yes
15:36 <Mirv> micahg: yes otherwise, but actually if there are no packaging changes (debian/), any lander can essentially land anything. which has of course been a bit hot topic regarding traditional processes.
15:36 <Mirv> we've had standing FFe:s for touch related packages for that reason, and those have not been considered optimal from all people either.
15:36 <micahg> ah
15:37 <bdmurray> Any more questions?
15:37 <Mirv> it's a bit tough with touch being essentially rolling release releasing to traditional half year Ubuntu cycle archives.
15:37 <sil2100> No questions from me, all good here
15:37 <micahg> I think that's it from me
15:38 <BenC> Me as well
15:38 <bdmurray> #vote Mirv to be granted membership to core-dev
15:38 <meetingology> Please vote on: Mirv to be granted membership to core-dev
15:38 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:38 <BenC> +1
15:38 <meetingology> +1 received from BenC
15:38 <micahg> +1
15:38 <meetingology> +1 received from micahg
15:39 <cyphermox> +1
15:39 <meetingology> +1 received from cyphermox
15:39 <rbasak> +1
15:39 <meetingology> +1 received from rbasak
15:39 <sil2100> +1
15:39 <meetingology> +1 received from sil2100
15:39 <bdmurray> +1
15:39 <meetingology> +1 received from bdmurray
15:40 <bdmurray> #endvote
15:40 <meetingology> Voting ended on: Mirv to be granted membership to core-dev
15:40 <meetingology> Votes for:6 Votes against:0 Abstentions:0
15:40 <meetingology> Motion carried
15:40 <bdmurray> Mirv: congratulations!
15:40 <BenC> Mirv: Congrats
15:40 <sil2100> Mirv: congratulations :)
15:40 <Mirv> thank you! :)
15:42 <bdmurray> Based off the wiki history it looks like FourDollars signed up first.
15:43 <bdmurray> FourDollars: Are you available / ready?
15:43 <FourDollars> bdmurray: yes
15:43 <bdmurray> #topic MOTU Applications
15:43 <bdmurray> #subtopic Shih-Yuan Lee
15:44 <bdmurray> FourDollars: Could you please introduce yourself?
15:44 <FourDollars> OK
15:44 <FourDollars> Hi, I am Ubuntu user since 6.04. I am working for Canonical for six years now.
15:45 <FourDollars> I am a free software developer and contributor, a Debian Maintainer.
15:46 <FourDollars> I host the physical community http://www.tossug.org at https://moztw.org/space/.
15:47 <FourDollars> I am also the member of some different communities in Taiwan, such as Ubuntu Taiwan, Linux Taiwan, Debian Taiwan.
15:48 <bdmurray> FourDollars: How much of your work is for the development release?
15:48 <FourDollars> I contributed to efibootmgr, dell-recovery, gnome-screenshot and upower.
15:48 <FourDollars> bdmurray: Most of my work is about LTS.
15:49 <FourDollars> I takes care of the issues directly from the OEM/ODM.
15:49 <FourDollars> If the issue is not kernel related, I will try to fix them.
15:50 <FourDollars> So I will provide the patch to the upstream and then backport to Ubuntu.
15:50 <bdmurray> FourDollars: What do you do if the fix is not in the development release?
15:50 <sil2100> FourDollars: let's say you publish a package to the archives, but you see it doesn't migrate from the -proposed pocket - where would you look for clues?
15:52 <FourDollars> I don't understand the question.  :(
15:53 <sil2100> FourDollars: which one? bdmurray's or mine? I'm happy to provide more context if needed
15:53 <FourDollars> bdmurray: I will search for the upstream source control system if the fix is not in the development release.
15:54 <FourDollars> bdmurray: If I can not find the fix, I will open a bug on upstream bug tracking system and provide the details.
15:54 <FourDollars> bdmurray: Then if I have time, I will try it fix it directly.
15:54 <FourDollars> sil2100: I don't understand yours.
15:55 <sil2100> FourDollars: so, let's say you have a package that you prepare with a fix and upload it to the Ubuntu archive using dput
15:56 <sil2100> FourDollars: you see that the upload succeeded and that the packages built correctly - looking, for instance, through Launchpad
15:56 <sil2100> FourDollars: but the package you uploaded is stuck in the proposed pocket, not migrating to the release pocket for some reason
15:57 <sil2100> FourDollars: what steps would you perform to check why it doesn't migrate from, let's say, xenial-proposed to xenial?
15:57 <FourDollars> sil2100: I remember there are some days delay about 1~2 weeks from -proposed to -updates.
15:58 <sil2100> FourDollars: ah, yes, that's the case for SRUs
15:58 <sil2100> FourDollars: but let's say it doesn't migrate even after this time, or doesn't migrate when you upload the package to the current development series
15:58 <sil2100> (which shouldn't have any specific delays)
15:59 <FourDollars> sil2100: I will ask for the help from the mailing list or IRC channels.
16:00 <sil2100> FourDollars: ok, that's always an option - did you have any experience with the output_excuses page?
16:01 <bdmurray> FourDollars: Looking at the "My involvement" section of your application, I'm a bit confused as I see some bugs where it isn't clear to me how you were invovled. For example bug 1452238, bug 1042231.
16:01 <ubottu> bug 1452238 in apt (Ubuntu) "Failed to upgrade system from 14.04" [Medium,Confirmed] https://launchpad.net/bugs/1452238
16:01 <ubottu> bug 1042231 in Session Installer "InstallPackageNames should not return until the package has been installed" [Undecided,New] https://launchpad.net/bugs/1042231
16:02 <FourDollars> sil2100: I will check if there is any freezing date.
16:02 <sil2100> FourDollars: also an option, yes, but a place worth remembering whenever things like this happen is http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html (for latest development series)
16:02 <FourDollars> sil2100: If I can not make it, I will wait.
16:04 <FourDollars> sil2100: I didn't deal with it before, but I knows it.
16:06 <rbasak> FourDollars: you said in your application that you're looking go get MOTU so that you can do package relative works for the Ubuntu community in Taiwan. Could you give us an example of a sponsored upload with this sort of work?
16:06 <rbasak> *to get
16:06 <FourDollars> bdmurray: Regarding https://launchpad.net/bugs/1452238, I test it in the beginning and I was trying to fix it. But there are other tasks so Tim helps me to deal with it.
16:06 <ubottu> Launchpad bug 1452238 in apt (Ubuntu) "Failed to upgrade system from 14.04" [Medium,Confirmed]
16:06 <rbasak> Sorry, I forgot about that outstanding question. Take your time.
16:06 <FourDollars> rbasak: ibus-chewing
16:07 <sil2100> Ok
16:08 <FourDollars> bdmurray: Regarding https://launchpad.net/bugs/1042231, I help to verify the fix.
16:08 <ubottu> Launchpad bug 1042231 in Session Installer "InstallPackageNames should not return until the package has been installed" [Undecided,New]
16:08 <FourDollars> rbasak: I knows a Debian developer and he is active dealing with all Chinese input related packages in Debian.
16:08 <bdmurray> FourDollars: While verifying is helpful to the process it does not demonstrate development work.
16:09 <FourDollars> rbasak: So I am wondering if I can help him to do the similar works in Ubuntu.
16:09 <FourDollars> rbasak: You can check https://github.com/fourdollars. There are some development work.
16:10 <FourDollars> bdmurray: You can check https://github.com/fourdollars. There are some development work.
16:10 <rbasak> FourDollars: I understand that with work done in Debian you wouldn't expect to upload much to the development release in Ubuntu. So I presume you're looking at SRUs mainly, is that right? Are there any other packages in particular that you expect to want to upload with MOTU?
16:10 <FourDollars> rbasak: Sorry. I replied to wrong person.
16:10 <rbasak> np
16:12 <FourDollars> rbasak: I am not looking at SRU only.
16:14 <FourDollars> rbasak: I would like to also join the development work.
16:15 <rbasak> FourDollars: have you been hindered by not having MOTU?
16:16 <FourDollars> rbasak: In fact, my goal is to become a core developer because most packages I want to fix is in main.
16:16 <FourDollars> rbasak: So that I can fix them quicker.
16:17 <rbasak> OK
16:17 <FourDollars> rbasak: However I am not familiar with the process yet so I apply MOTU first.
16:18 <bdmurray> We are a bit over time now, are there any more questions? cyphermox, micahg, BenC?
16:18 <FourDollars> rbasak: My plan is to practice the process of MOTU and help to fix some universe/multiverse packages.
16:18 <FourDollars> rbasak: My own Debian packages are in universe/multiverse.
16:19 <micahg> FourDollars: usually people do that before they apply, to demonstrate mastery
16:19 <FourDollars> micahg: I see.
16:21 <sil2100> No more questions from me
16:22 <bdmurray> #vote FourDollars to be granted membership in motu
16:22 <meetingology> Please vote on: FourDollars to be granted membership in motu
16:22 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:24 <bdmurray> -1
16:24 <meetingology> -1 received from bdmurray
16:25 <rbasak> -1
16:25 <meetingology> -1 received from rbasak
16:25 <rbasak> I'll explain after the vote has ended.
16:25 <sil2100> +0 (I do see potential, but I suppose you'd need to gain a bit more experience)
16:25 <meetingology> +0 (I do see potential, but I suppose you'd need to gain a bit more experience) received from sil2100
16:25 <bdmurray> While your work on SRUs has been great, that is a double gated process (sponsor / SRU team member) and follows a very strict process. I'd like you to be more involved / experienced with Ubuntu development before granting you membership in motu.
16:25 <cyphermox> +0
16:25 <meetingology> +0 received from cyphermox
16:27 <micahg> +0 good intentions, good work so far, but hasn't displayed mastery of MOTU style work (library transitions, helping proposed-migration in devel release, merges from Debian)
16:27 <meetingology> +0 good intentions, good work so far, but hasn't displayed mastery of MOTU style work (library transitions, helping proposed-migration in devel release, merges from Debian) received from micahg
16:27 <cyphermox> I've seen (and in fact sponsored) some good uploads after some back and forth, but I would like to see more sponsored uploads (in main or otherwise)
16:27 <bdmurray> BenC: still about, care to vote?
16:28 <bdmurray> #endvote
16:28 <meetingology> Voting ended on: FourDollars to be granted membership in motu
16:28 <meetingology> Votes for:0 Votes against:2 Abstentions:3
16:28 <meetingology> Motion denied
16:29 <bdmurray> rbasak: did you want to say something?
16:29 <rbasak> I appreciate the good work you have been doing, but it doesn't seem to have that much relevance for MOTU specifically. I'd expect to see more sponsored uploads to universe.
16:29 <rbasak> You mentioned wanting to becoming familiar with the process. I believe it's more appropriate to do that under the guidance of sponsors, and then apply again for MOTU when you have some experience exercising the process.
16:29 <rbasak> I'm a little torn because I appreciate that doing the right thing in Debian means fewer uploads to Ubuntu, which hinders getting a good track record for Ubuntu uploads. But if that is the case, then getting the odd sponsored universe upload shouldn't be a problem either.
16:30 <BenC> +1
16:30 <BenC> Sorry
16:30 <rbasak> FourDollars: your sponsored upload history does look good though. So can I suggest a vote to give you Ubuntu Contributing Developer in recognition of that, if you're interested in that?
16:30 <BenC> Actually, I meant +0
16:30 <FourDollars> rbasak: OK
16:31 <jjohansen> \o
16:32 <rbasak> bdmurray: #vote FourDollars for Ubuntu Contributing Developer please?
16:32 <sil2100> FourDollars: I would recommend joining the patch-piloting initiative to gain experience and additional upload history :)
16:32 <sil2100> FourDollars: https://wiki.ubuntu.com/UbuntuDevelopment/CodeReviews
16:32 <bdmurray> #vote FourDollars for Ubuntu Contributing Developer
16:32 <meetingology> Please vote on: FourDollars for Ubuntu Contributing Developer
16:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:32 <rbasak> +1
16:32 <meetingology> +1 received from rbasak
16:33 <micahg> +1
16:33 <meetingology> +1 received from micahg
16:33 <sil2100> +1
16:33 <meetingology> +1 received from sil2100
16:33 <bdmurray> +1
16:33 <meetingology> +1 received from bdmurray
16:34 <bdmurray> that's enough so in the interest of time...
16:34 <bdmurray> #endvote
16:34 <meetingology> Voting ended on: FourDollars for Ubuntu Contributing Developer
16:34 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:34 <meetingology> Motion carried
16:35 <rbasak> FourDollars: sorry we couldn't give you MOTU. But please pretend you have it, stick the uploads you would have made to universe into the sponsorship queue, and re-apply once you have a few of these.
16:35 <FourDollars> rbasak: OK. Thx.
16:35 <bdmurray> FourDollars: the patch piloting queue frequently has incomplete items in it, so isn't just stuff that needs sponsoring
16:35 <bdmurray> #topci AOB
16:35 <bdmurray> #topic AOB
16:36 <bdmurray> #action bdmurray to summarize the meeting / send annoucements
16:36 * meetingology bdmurray to summarize the meeting / send annoucements
16:36 <bdmurray> #action cyphermox to make membership changes
16:36 * meetingology cyphermox to make membership changes
16:36 <bdmurray> #action bdmurray to update agenda
16:36 * meetingology bdmurray to update agenda
16:37 <rbasak> So we didn't get to slashd :-(
16:37 <bdmurray> sil2100: are you still willing to review the status of applicants on the agenda?
16:38 <rbasak> He was down for today. Is there anyone else in the backlog?
16:38 <bdmurray> rbasak: ah right, I feel like an hour isn't long enough
16:38 <sil2100> bdmurray: yes, please add an action item for that for me :)
16:38 <bdmurray> #action sil2100 to review status of applicants on the agenda
16:38 * meetingology sil2100 to review status of applicants on the agenda
16:38 <sil2100> I'll make sure to review the list this week
16:39 <slashd> Do I need to reschedule my application for next meeting ?
16:39 <bdmurray> We could review it by email I think, right micahg?
16:39 <sil2100> slashd: no worries, we'll reschedule you to the next one - if it's ok with you
16:40 <sil2100> Or that
16:40 <micahg> we could do by email
16:40 <sil2100> Fine with me as well
16:40 <rbasak> I endorsed slashd, so there's an implicit +1 from me already.
16:40 <micahg> or now if no one needs to channel and DMB members are still around
16:41 <rbasak> jjohansen: did you need the channel?
16:42 <jjohansen> rbasak: nah, sorry for hoping into your meeting, we moved to meeting-2 when we saw your meeting was still going
16:43 <rbasak> jjohansen: ah OK. Thanks!
16:43 <bdmurray> Okay, I guess there are still four of us.
16:44 <bdmurray> #topic Eric Desrochers for Ubuntu Contributing Developer
16:44 <bdmurray> lets just skip the intro part and move to questions
16:45 <micahg> link?
16:45 <bdmurray> https://wiki.ubuntu.com/slashd/ContributingDeveloperApplication
16:46 <micahg> #link https://wiki.ubuntu.com/slashd/ContributingDeveloperApplication
16:46 <bdmurray> slashd: What needs to happen next with bug 1546735?
16:46 <ubottu> bug 1546735 in openipmi (Ubuntu) "openipmi package compile without SSL" [Undecided,Fix released] https://launchpad.net/bugs/1546735
16:46 <slashd> bdmurray, I need to change my plan and focus on the solterm issue (debian bug) more than the entreprise impact with zabbix
16:47 <slashd> the patch is now available in xenial but need to work on justification for Trusty surrounding solterm more than Zabbix
16:49 <bdmurray> slashd: I'd consider justification as the impact, so the Test Case section is also missing.
16:49 <bdmurray> any questions from the DMB members?
16:50 <slashd> bdmurray, I'm my defense I did it in the private bug, since there was sensible informations about UA customer, but yes I agree, I should also put it on the public bug
16:50 <slashd> without UA customer reference
16:52 <rbasak> Hmm. openipmi is in part GPL. Is it even compatible with openssl's license?
16:52 <rbasak> Anyway, offtopic, sorry.
16:53 <bdmurray> slashd: You put information about how to verify the bug using a third party package not supported by Ubuntu, which as I've mentioned before isn't SRU worthy.
16:53 <slashd> bdmurray, yeah this is why I need to re-work the justification around the debian bug (solterm)
16:54 <micahg> slashd: you mention attending local networking events as something you can do better.  Have you ever been to an Ubuntu meetup?
16:54 <micahg> or and Ubuntu LoCo event?
16:56 <slashd> micahg, I'm attending a few devops meetings (as an organizer) where we talked about different techno and represent Ubuntu in those one such as montreal devops, the community in montreal doesn't seems to be very strong, but yes my goal is to attend more event in Montreal
16:58 <slashd> it's not very active except for the mailing list
17:00 <bdmurray> #vote slashd for Ubuntu Contributing Developer
17:00 <meetingology> Please vote on: slashd for Ubuntu Contributing Developer
17:00 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
17:01 <micahg> +1 bug fixes + dev event representation, keep up the good work!
17:01 <meetingology> +1 bug fixes + dev event representation, keep up the good work! received from micahg
17:02 <BenC> +1 sustained effort
17:02 <meetingology> +1 sustained effort received from BenC
17:02 <sil2100> +1
17:02 <meetingology> +1 received from sil2100
17:02 <bdmurray> +1
17:02 <meetingology> +1 received from bdmurray
17:02 <rbasak> +1
17:02 <meetingology> +1 received from rbasak
17:03 <bdmurray> #end vote
17:03 <bdmurray> #endvote
17:03 <meetingology> Voting ended on: slashd for Ubuntu Contributing Developer
17:03 <meetingology> Votes for:5 Votes against:0 Abstentions:0
17:03 <meetingology> Motion carried
17:03 <bdmurray> #topic AOB
17:03 <slashd> thanks everyone
17:03 <bdmurray> Anything other business x2?
17:05 <bdmurray> Alright! Thanks everyone.
17:05 <bdmurray> #endmeeting