16:02 <jgrimm> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Mar 29 16:02:42 2016 UTC.  The chair is jgrimm. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:03 <jgrimm> hi all, crazy busy last week for beta2. thanks for all the hard work
16:03 <jgrimm> #topic Review ACTION points from previous meeting
16:03 <jgrimm> jgrimm to update/clean up blueprint
16:04 <jgrimm> Done. Updated it this morning
16:04 <jgrimm> and updated by teward. thanks!
16:04 <teward> updated by me due to things I have to do heh :P
16:04 <teward> you're welcome.
16:04 <jgrimm> caribou to investigate if kickin's clamav merge should land
16:05 <jgrimm> caribou around?
16:05 <caribou> jgrimm: yep
16:05 <caribou> jgrimm: Debian have put out a new 0.99.1
16:05 <caribou> I feel like we might just want to wait for the next merge window
16:06 <jgrimm> caribou, yes. i agree
16:06 <caribou> the only major thing is LLVM3.6
16:06 <jgrimm> too late and we need to move to bugs
16:06 <caribou> jgrimm: agree
16:06 <jgrimm> thanks caribou
16:06 <caribou> np
16:06 <jgrimm> #topic Xenial Development
16:07 <jgrimm> #link https://wiki.ubuntu.com/XenialXerus/ReleaseSchedule
16:07 <jgrimm> Final Beta is out.  Bug hunting mode now for most part
16:08 <caribou> don't need to hunt for them, they seem to come at me rather easily :)
16:08 <jgrimm> a few things hanging stuck in proposed atm..
16:08 <jgrimm> squid3 -> rharper is looking at it
16:08 <cpaelzer> https://launchpad.net/ubuntu/xenial/+queue?queue_state=1
16:09 <cpaelzer> also hanging in case one looks for his uploadas
16:09 <jgrimm> :)
16:09 <jgrimm> and vsftpd been stuck there for >40 days and needs someone to look at it yet
16:09 <jgrimm> #link http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses.html
16:10 <jgrimm> #action jgrimm find owner for vsftpd test failures
16:10 * meetingology jgrimm find owner for vsftpd test failures
16:11 <jgrimm> cpaelzer, how is dpdk testing going?
16:11 * jgrimm knows the answer, but giving cpaelzer a chance to share
16:12 <jgrimm> cpaelzer?
16:12 <caribou> jgrimm: I'll do a pass at vsftpd test failure & try to help
16:12 <jgrimm> caribou, you rock!
16:13 <jgrimm> thanks
16:13 <cpaelzer> jgrimm: tests good
16:13 <cpaelzer> jgrimm: finally a running openvswitch-dpdk
16:13 <cpaelzer> jgrimm: I'm convinced to get something reasly usable over this week into my test automation
16:14 <cpaelzer> jgrimm: already prepared for performance comparisons of ovs vs ovs-dpdk one day
16:14 <jgrimm> cpaelzer, very nice.  Have you given thought to documentation? ServerGuide?
16:14 <cpaelzer> jgrimm: thought yes, time not yet
16:15 <jgrimm> :) no worries. just wanted to remind.
16:15 <cpaelzer> jgrimm: but I wanted to create a how-to-use-dpdk anyway for a blog post - can as well go to server doc
16:15 <jgrimm> excellent. tx!
16:15 <cpaelzer> jgrimm: what was the deadline on the server guide contributions?
16:16 <jgrimm> #link https://lists.ubuntu.com/archives/ubuntu-server/2016-March/007195.html
16:16 <jgrimm> #link https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/UbuntuServerGuide
16:17 <cpaelzer> yeah I saw the mail thread, I'll just give it a try - thanks
16:17 <jgrimm> cpaelzer, yeah, i don't recall the timeline, i need to look that up too.
16:18 <jgrimm> #action jgrimm understand timeline/process around serverguide
16:18 * meetingology jgrimm understand timeline/process around serverguide
16:18 <cpaelzer> does that apply ? https://wiki.ubuntu.com/DocumentationStringFreeze
16:18 <cpaelzer> that would be in the past (17th March)
16:18 <jgrimm> cpaelzer, not sure
16:18 <cpaelzer> well you will calrify via your action item
16:18 <jgrimm> heh. of course
16:19 <jgrimm> more xenial topics? anything to share?
16:19 <teward> nginx 1.9.13 released today upstream, i'm going to hunt getting that into Xenial, but i won't be able to start on that until April 1 (hence why it's in that section of the work items on the blueprint); it'll need an FFe, but I'll work with the Release team on that.
16:19 <caribou> jgrimm: you might want to ping pmatulis over this
16:19 <caribou> this = server guide
16:19 <jgrimm> caribou, ack
16:19 <teward> jgrimm: just giving the note on that item for nginx, it's on my list of things :)
16:19 <teward> hopefully it gets reviewed before FinalFreeze, though the 1.10.x item is going to be... more tricky...
16:20 <jgrimm> teward,  indeed, I was going to ask you what sort of reality would be around 1.10
16:20 <jgrimm> is there a date in mind for that being released?
16:20 <teward> jgrimm: good question, i'm working with both Release and Security on multiple issues surrounding nginx in Xenial right now
16:20 <teward> jgrimm: when nginx tells me a firm date, I'll be able to give you a clear answer.
16:20 <jgrimm> teward, ack. thanks for the update
16:21 <teward> Last time I checked right before Easter, there was no firm date set, but predicted time is a couple days before, or after, we release
16:21 <jgrimm> ok, i won't hold out much hope for it then
16:21 <teward> hence looping Release and Security in together, given that post-release if it ends up SRU'd, it'd be important enough for Security to include an update possibly.  I'll coordinate with sarnold and the rest of the Security team when that's closer.
16:21 <jgrimm> teward, excellent. tx
16:21 <teward> jgrimm: we had touched base with the TB initially on this, before the SRU policy changes
16:22 <jgrimm> k
16:22 <teward> and it had been considered post-release SRU of 1.10.x in, or right before we release include 1.10.x depending on nginx release date
16:22 <jgrimm> k
16:22 <teward> either way, it'd be available 'somewhere' in Xenial.
16:22 <jgrimm> :)
16:22 <teward> until i hear otherwise, that's what I assume is going to be the case
16:23 <jgrimm> gotcha
16:23 <teward> HTTP/2 is sooner on my radar than 1.10.x though, and I'm coordinating with Security Team on that discussion (attn: sarnold)
16:23 <jgrimm> that would be great
16:24 <teward> I'd love to turn that on before FinalFreeze, but like 1.10.x, it may get in post-release.  rbasak I think was on the list of people in that discussion, but ultimately I'm going to keep coordinating with the SEcurity Team on that (they're the ones that have to remove the "Don't enable HTTP/2" restriction in place now)
16:24 <jgrimm> k
16:24 <jgrimm> anyone else?
16:25 <jgrimm> i know nacc is continuing to plug away at removing php5. probably at least a week of work yet
16:25 <jgrimm> moving on
16:25 <jgrimm> #subtopic Release Bugs
16:26 <jgrimm> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-w-tracking-bug-tasks.html#ubuntu-server
16:27 <jgrimm> anyone have anything to discuss or point out there?
16:27 <nacc> jgrimm: ack, < 300 packages left at this point :)
16:28 <jgrimm> nacc, \o/
16:28 <jgrimm> #topic Server & Cloud Bugs (caribou)
16:29 <caribou> not much to talk about; trying to enable zfcpdump on s390x
16:29 <caribou> & now looking at vsftpd DEP8 tests ;-)
16:29 <jgrimm> :) much appreciated!
16:29 <jgrimm> moving on
16:30 <jgrimm> #topic Weekly Updates & Questions for the QA Team (matsubara)
16:30 <matsubara> jgrimm, cyphermox is working on the installer bug that was raised last week
16:30 <matsubara> jgrimm, bug 1559507
16:30 <ubottu> bug 1549529 in console-setup (Ubuntu) "duplicate for #1559507 The keyboard is still installed as US-English even if another language is selected during the installation" [High,In progress] https://launchpad.net/bugs/1549529
16:31 <matsubara> that's all I have to report
16:31 <jgrimm> matsubara, thanks!
16:31 <jgrimm> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:31 <smb> Nothing to report from kernel.
16:31 <jgrimm> thanks smb
16:31 <jgrimm> #topic Upcoming Call For Papers
16:32 <cyphermox> matsubara: jgrimm: that was fixed last week
16:32 <jgrimm> cyphermox, excellent. thanks!
16:33 <jgrimm> i don't see any interesting CFP on LWN calendar
16:34 <jgrimm> #topic Ubuntu Server Team Events
16:34 <jgrimm> Anyone
16:34 <matsubara> thanks cyphermox
16:34 <jgrimm> #topic Open Discussion
16:34 <jgrimm> rharper, since you just popped on. can you update on recap and update on tgt & squid3
16:35 <jgrimm> err. recap and update on tgt & squid3
16:37 <rharper> sure
16:37 <jgrimm> tx
16:37 <rharper> I'm not ready to say that AIO is something we're ready to support
16:37 <rharper> so, I'll drop the FFE, I have a new debdiff with the new source from debian (allowing us to drop a patch that's already upstream)
16:37 <rharper> and not enable AIO (delta from debian)
16:38 <rharper> I'll update the BZ today and then search for a sponser (it'll be a really small diff)
16:38 <jgrimm> perfect.
16:38 <rharper> on squid3, there was an issue during dist-upgrade of squid in xenial proposed where the postinst scripts would not complete without error
16:39 <rharper> the cause is the script (From upstream) checks for /etc/squid3 and then assumes that the /etc/init.d/<service> is named the same (squid3); this is not the case in our package;
16:39 <jgrimm> #link https://bugs.launchpad.net/ubuntu/+source/squid3/+bug/1473691/comments/18
16:39 <ubottu> Launchpad bug 1473691 in squid3 (Ubuntu) "[FFe] squid: Update to latest upstream release (3.5)" [Wishlist,Fix committed]
16:39 <rharper> adding some logic to find the right service file name in that case, resolves the issue, the upgrade completes and I verified that both squid-deb-proxy and squid-guard, configured in 14.04, continue to work in Xenial
16:40 <rharper> I'm not 100% certain about why the init script has the case it does;  it seems like debian should have the same bug then; I've not verified that
16:40 <caribou> rharper: last I checked, debian went from squid3 to squid, that might explain it
16:40 <rharper> caribou: we did the same
16:41 <caribou> oh right
16:41 <rharper> I'm guessing that if we did the same dist-upgrade test in debian (from a squid3 to squid) it'll fail the same way; I can confirm
16:41 <rharper> in which case, we can push a fix into debian;
16:41 <jgrimm> cool.
16:42 <rharper> I can regen the debdiff for squid if no one else is going to; would like some other ubuntu-dev eyes to check that it's a sane thing to do
16:42 <rharper> one other topic on squid3
16:43 <rharper> the maas team raised a concern about the new squid package service now being named squid (/etc/init.d/squid) vs (/etc/init.d/squid3) and wanted an alias to help transition
16:43 <rharper> I did a minimal search and asked in #ubuntu-devel, but I've not found any existing/prior cases of including an alias for service names
16:43 <rharper> does anyone here know of one, or a policy that would apply
16:44 <rharper> rbasak replied to the bug indicating that it's understable to break in the transition to a new LTS;  I tend to agree with that;  maas team which depends upon squid was concerned given the lateness in the cycle;  but without prior example, I worry more about long term support of including the alias
16:44 <rharper> if anyone knows more, please comment in the bug
16:44 <rharper> jgrimm: ok, I think that covers those two
16:45 <jgrimm> rharper, cool. you might try the ml too (small turnout here)
16:45 <jgrimm> thank you very much
16:46 <rharper> gotcha
16:46 <jgrimm> and for the quick sleuthing, really need new squid3 to get real world testing on it and this has hung out for a long time
16:46 <jgrimm> ok, anything else?
16:46 <caribou> rharper: by alias, do you mean a transitional package ?
16:47 <nacc> caribou: an init-script alias (as the service has changed name from squid3 -> squid)
16:47 <caribou> nacc: ak gotcha
16:47 <jgrimm> thanks
16:47 <jgrimm> i think we are done for today
16:47 <jgrimm> #topic Announce next meeting date, time and chair
16:48 <jgrimm> Tuesday 2016-04-05 at 1600 UTC - #ubuntu-meeting  and gaughen will be the next chair
16:48 <jgrimm> #endmeeting