15:20 <stgraber> #startmeeting DMB meeting
15:20 <meetingology> Meeting started Mon Nov 23 15:20:04 2015 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:20 <meetingology> 
15:20 <meetingology> Available commands: action commands idea info link nick
15:20 <cyphermox> 4 DMB members, as I recall
15:20 <xnox> cyphermox, cool.
15:21 <stgraber> #topic Review of previous action items
15:21 <stgraber> Laney to start an onboarding page for new dmb members
15:21 <stgraber> Laney: has that been done or should we carry this one over?
15:22 <Laney> I did it
15:22 <Laney> I mailed a link to the list asking for comments
15:22 <Laney> didn't get any
15:22 <cyphermox> can you share the link here for the minutes/
15:22 * xnox does not recall.... =(
15:23 <Laney> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase
15:23 * cyphermox searches
15:23 <stgraber> oh yeah, just found the e-mail
15:23 <Laney> Date: Fri, 2 Oct 2015 17:52:51 +0100
15:23 <stgraber> DMB members who didn't consent to fill in feedback to Noskcaj
15:26 * xnox ducks
15:26 <stgraber> I think we need to keep this one as I'm not seeing evidence that this happened :)
15:26 <cyphermox> yes
15:26 <stgraber> #topic Confirm whether we grant membership for uploaders by default
15:26 <xnox> last meeting we converged to the following: if one wants membership one should apply as contributing developer, motu, or core-dev.
15:27 <xnox> per-package(set) uploaders do not assume membership.
15:27 <Laney> erm
15:27 <cyphermox> Laney: we had some discussion about this at the last meeting but it seemed like we couldn't quite get to an agreement
15:27 <Laney> you decided to change the criteria?
15:27 <xnox> if one wants PPU + membership, one should explicitely apply for PPU+contributing developer.
15:27 <Laney> oh geez
15:27 <xnox> Laney, yeah, this is summary of a (new) opinion, some board members had.
15:28 <xnox> i.e. myself and (micahg?!) can't remember now.
15:28 <cyphermox> could we perhaps move ahead to voting on this proposition, or decide to amend it?
15:28 <stgraber> yeah, we can vote but by the sounds of it, it won't pass
15:29 <cyphermox> which won't pass? ;)
15:29 <stgraber> we're only 4 around, if we don't get 4 +1s it'll fail
15:29 <cyphermox> right
15:29 <xnox> we can vote as is. I will vote -1 on "grant membership for uploaders by default". And say that there is already mechanism for that -> contributing developer.
15:29 <xnox> i can be convinced that i'm being illogical =)
15:29 <stgraber> the proposal on the agenda is to by default assume that PPU means membership unless we decide otherwise
15:29 <cyphermox> well, then it needs to be amended, and we probably should take this to email instead so everyone can bring up their points
15:29 <xnox> and that e.g. contributing member -> is membership without any upload rights, and that membership is needed for uploading anything.
15:30 <Laney> It's too much of a burden to assume that people will understand this, and doesn't make sense to make the DMB explicitly make this determination fro every application
15:30 <Laney> whatever
15:30 <cyphermox> doesn't it kind of involve sustained contributions at least to even be considered for PPU?
15:30 <stgraber> I agree with Laney, it's way easier for us to determine when someone shouldn't be getting membership and make it clear then rather than require EVERYONE to request both
15:31 <cyphermox> in which case Laney's proposition is simple and straightforward
15:31 <xnox> oh, if we grant it when people are eligble, that makes sense.
15:32 <xnox> and it's up to us to be diligent, and say "yeah cool you can upload but no membership yet, come back for it" that sounds sensible.
15:32 <cyphermox> xnox: sounds to me like that is what Laney means :)
15:32 <xnox> i guess at each PPU grant, we do a second mini-vote whether or not to grant membership too?
15:32 <Laney> No
15:32 <xnox> why would we do that, instead of granting contributing developer?
15:33 <cyphermox> I wouldn't even bother
15:33 <Laney> You just have the vote in the negative case
15:33 <Laney> in most cases it is implied
15:33 <xnox> to PPUs, when PPUs apply, and are eligible for membership?
15:33 <Laney> it really hardly ever comes up in practie
15:33 <Laney> practice
15:33 <Laney> so it's not sensible to put the burden on the normal case
15:33 <xnox> "This does not happen automatically - they must be added to the ~ubuntu-dev team." -> can we not add people to contributing developer instead?
15:34 * xnox ponders if we should move on to email.
15:34 <Laney> ucd isn't in ubuntu-dev
15:36 <Laney> I'm only happy moving to email if people will actually reply. :)
15:36 <stgraber> ubuntu-dev is only for Ubuntu members who have upload rights, so being in UCD doesn't get you that
15:36 <xnox> stgraber, ack.
15:36 <Laney> it gets you bug control and other teams that UCD doesn't
15:37 <Laney> because UCD is just membership
15:37 <xnox> i see.
15:37 <stgraber> we can also vote for it now and then you can get the rest of the members to vote on the list, may be enough to have this pass
15:38 <Laney> OK
15:38 <stgraber> #vote Do we grant Ubuntu membership by default for PPUs (see https://lists.ubuntu.com/archives/devel-permissions/2015-August/000815.html)?
15:38 <meetingology> Please vote on: Do we grant Ubuntu membership by default for PPUs (see https://lists.ubuntu.com/archives/devel-permissions/2015-August/000815.html)?
15:38 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:38 <xnox> +1
15:38 <meetingology> +1 received from xnox
15:38 <stgraber> +1
15:38 <meetingology> +1 received from stgraber
15:38 <cyphermox> +1
15:38 <meetingology> +1 received from cyphermox
15:38 <Laney> +1
15:38 <meetingology> +1 received from Laney
15:38 <Laney> nice
15:38 <stgraber> #endvote
15:38 <meetingology> Voting ended on: Do we grant Ubuntu membership by default for PPUs (see https://lists.ubuntu.com/archives/devel-permissions/2015-August/000815.html)?
15:38 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:38 <meetingology> Motion carried
15:38 <stgraber> there, done :)
15:39 <stgraber> Laney: is there any documentation we need updating?
15:39 <Laney> well, it's the status quo, so no
15:39 <Laney> in theory
15:39 <xnox> stgraber, i guess XXX needs removal from https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase under teams to add uploaders to
15:39 <Laney> ah
15:39 <Laney> I was just going to say that I should add this somewhere
15:40 <Laney> OK let me edit that
15:40 <stgraber> cool
15:40 <stgraber> #topic Package Set/Per Package Uploader Applications
15:40 <Laney> that ubuntu-uploaders sentence is utter lies
15:40 * Laney fixes that too
15:41 <stgraber> https://lists.ubuntu.com/archives/devel-permissions/2015-October/000856.html
15:42 <stgraber> Laney: ok, so this item is just about adding a new package set for the ubuntu qt stuff and adding a few more packages to the existing qt set?
15:43 <stgraber> qt5 set today: http://people.canonical.com/~ubuntu-archive/packagesets/xenial/qt5
15:43 <Laney> I think so
15:43 <Laney> because they don't fit the description there
15:44 <stgraber> ok, should we just vote on this then, seems pretty straightforward to me
15:44 <Laney> Probably, just want to know what a Qt package is
15:44 <Laney> anything which build-depends on qt at all?
15:45 <cyphermox> seems wrong
15:45 * xnox 'd just update qt5 packageset description to include all qt5* base stuff, irrespective of origin.
15:45 <cyphermox> plus it probably should be unity8-desktop as a name or something to the effect that it's unity8 things, not necessarily qt
15:45 <stgraber> proposed description is:
15:45 <stgraber> Qt packages used by Ubuntu not originating from the
15:45 <stgraber> upstream Qt project but using Qt private headers
15:46 <cyphermox> right
15:46 <stgraber> so not all rdepends of qt, more like tight version rdepends (due to private symbols)
15:46 <xnox> sounds good. and just stick that as ".. and" into qt5 package set, and update the lot.
15:46 <stgraber> proposed set of package is:
15:46 <stgraber> appmenu-qt5 ciborium fcitx-qt5 gsettings-qt maliit-framework oxide-qt
15:46 <stgraber> qtmir qtmir-gles qtubuntu qtubuntu-gles qtvideo-node ubuntu-ui-toolkit
15:46 <stgraber> ubuntu-ui-toolkit-gles unity8 webbrowser-app
15:46 <cyphermox> except I can see more people wanting to upload these packages in the future, and things being added that might not be qt5
15:47 <xnox> existing uploaders know how to upload those, as far as I remember. Or have been co-operating with "private ubuntu qt5" uploads in the past (~kubuntu-dev)
15:47 <cyphermox> on top of that, all these packages usually go through the CI train, not usually direct uploads
15:48 <cyphermox> (or, at least most of them, possibly exception being fcitx-qt5 and gsettings-qt
15:48 * xnox sides at making timo core-dev, and stop adding new qt packagesets or packages, and then timo can be go to person for ci landing of those components ;-)
15:48 <stgraber> the proposed set name and description don't specifically mention qt5, just says ubuntu specific stuff using private qt symbols, so typically ubuntu sdk and related libs, with unity8 being a special one
15:49 <cyphermox> stgraber: there's lots of stuff surrounding that current set that are make with go, and so don't have any qt symbols
15:49 <cyphermox> or at least, that was my understanding
15:50 <cyphermox> I mostly just don't like the qt/using qt headers being a criteria for a packageset, I guess
15:50 <sil2100> Mirv wants to try for core-dev, but said he'll do it after I become a core-dev first
15:50 <sil2100> Soooo... just saying.. you know...
15:50 <sil2100> ;)
15:50 <cyphermox> vote or not, and then move on?
15:50 <xnox> sil2100, i shall not be peer pressured.
15:51 * Laney watches money slide under the table
15:51 <sil2100> I'm not implying anything! My intentions are as clear as mountain water
15:51 * sil2100 goes quiet now
15:52 <Laney> I'm happy to vote this
15:52 <stgraber> cyphermox: the static go stuff would never be in that set because if statically built (instead of using cgo), you won't need rebuild/changing when private symbols change in the archive, since it bundles its own copy
15:52 <stgraber> #vote Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:52 <meetingology> Please vote on: Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:52 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:52 <cyphermox> stgraber: I'm saying by this that it feels to specific
15:52 <stgraber> +1
15:52 <meetingology> +1 received from stgraber
15:52 <Laney> I'd be happy to amend this by mail
15:52 <Laney> it's not the best
15:52 <Laney> +1
15:52 <meetingology> +1 received from Laney
15:52 <cyphermox> +0. seems to specific to me, but I won't block if everyone agrees already.
15:52 <meetingology> +0. seems to specific to me, but I won't block if everyone agrees already. received from cyphermox
15:52 <stgraber> cyphermox: I like too specific, it's easier to make it less specific than more specific later :)
15:53 <xnox> +1
15:53 <meetingology> +1 received from xnox
15:53 <cyphermox> I'd rather fewer random packagesets for random things
15:53 <stgraber> #endvote
15:53 <meetingology> Voting ended on: Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:53 <meetingology> Votes for:3 Votes against:0 Abstentions:1
15:53 <meetingology> Motion carried
15:53 <cyphermox> ^ motion carried
15:53 <Laney> false
15:53 <stgraber> yeah, that's wrong
15:53 <Laney> deferred to email
15:53 <xnox> true.
15:53 <cyphermox> no, consider it fine for me tbh
15:53 <Laney> or next meeting
15:53 <Laney> then you need to vote +1 :P
15:54 <cyphermox> did you not read what was next to +0? ;)
15:54 <xnox> we have quorum, and we only need to have possitive outcome.
15:54 <cyphermox> let's move on
15:54 <Laney> ffs
15:54 <stgraber> we need quorum and 4 +1s to have a motion pass, this wasn't the case here
15:55 <stgraber> so if cyphermox feels like +1ing instead, we can re-vote, otherwise this is moving to ML to get the remaining votes
15:55 <cyphermox> arf
15:55 <cyphermox> sure, let's quickly revote
15:55 <stgraber> #vote Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:55 <meetingology> Please vote on: Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:55 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:55 <stgraber> +1
15:55 <meetingology> +1 received from stgraber
15:55 <cyphermox> +1
15:55 <meetingology> +1 received from cyphermox
15:55 <xnox> +1
15:55 <meetingology> +1 received from xnox
15:55 <Laney> +1
15:55 <meetingology> +1 received from Laney
15:56 <Laney> haha
15:56 <stgraber> #endvote
15:56 <meetingology> Voting ended on: Create a new ubuntu-qt-packages packageset with description "Qt packages used by Ubuntu not originating from the upstream Qt project but using Qt private headers"
15:56 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:56 <meetingology> Motion carried
15:56 <Laney> thanks!
15:56 <stgraber> there we go :)
15:56 <cyphermox> thar.
15:56 <stgraber> #action stgraber to implement changes listed in https://lists.ubuntu.com/archives/devel-permissions/2015-October/000856.html
15:56 * meetingology stgraber to implement changes listed in https://lists.ubuntu.com/archives/devel-permissions/2015-October/000856.html
15:56 <stgraber> #topic Ubuntu Contributing Developer Applications
15:56 <stgraber> https://wiki.ubuntu.com/chiluk
15:56 <stgraber> chiluk: still around?
15:57 <chiluk> yes..
15:57 <stgraber> can you give us a quick intro on who you are and what you've been doing?
15:57 <cyphermox> I know chiluk, he definitely did not bribe me to +1.
15:57 <chiluk> hah.
15:57 <xnox> I know chiluk, he definitely did not bribe me to +1.
15:57 <chiluk> Alright, well I work for Canonical on sustaining old releases.
15:58 <chiluk> mostly for paying customers, but I do my best to get out on public launchpad as often as I can.
15:58 <chiluk> as such my work is very scatter-brained and unfocussed.
15:58 <chiluk> I'm not requesting PPU for that reason.
15:58 <stgraber> sounds like everyone's ready to vote already so let's do it then :)
15:59 <chiluk> there are very few packages that I will ever touch twice.
15:59 <chiluk> hah.
15:59 <stgraber> #startvote UCD for chiluk
15:59 <chiluk> alright guys.
15:59 <stgraber> #vote UCD for chiluk
15:59 <meetingology> Please vote on: UCD for chiluk
15:59 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:59 <stgraber> +1
15:59 <meetingology> +1 received from stgraber
15:59 <cyphermox> +1
15:59 <meetingology> +1 received from cyphermox
15:59 <Laney> +!
15:59 <Laney> 1!!
15:59 <Laney> +1
15:59 <meetingology> +1 received from Laney
15:59 <xnox> +1
15:59 <meetingology> +1 received from xnox
15:59 <Laney> PLUS BANG
15:59 <chiluk> someone should -1 for infinity
15:59 <stgraber> #endvote
15:59 <meetingology> Voting ended on: UCD for chiluk
15:59 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:59 <meetingology> Motion carried
15:59 <sil2100> Man, I should have brought screwdrivers with me to the sprint too...
15:59 <chiluk> sil2100: why when, I live in town.
16:00 <cyphermox> chiluk: my only request would be for you to fix https://launchpad.net/ubuntu/+source/coreutils/8.21-1ubuntu5.2
16:00 <stgraber> oh, is that how you bribed cyphermox? :)
16:00 <chiluk> cyphermox, yeah I'm on that.
16:00 <chiluk> cyphermox, the test never ran before my upload.
16:00 <cyphermox> stgraber: nah, there was no alcohol, just tools.
16:00 <chiluk> now it's being run and failing
16:00 <xnox> chiluk, fyi have you seen https://launchpad.net/ubuntu/+source/coreutils/8.21-1ubuntu5.2 ? =)
16:00 <chiluk> although it only fails ont eh buildds.
16:01 <chiluk> yeah I've been looking into it.
16:01 <xnox> rightyoh.
16:01 <chiluk> the test that fails was never getting run before because df couldn't read the mount table, and would thus skip the test.
16:01 <stgraber> #topic Ubuntu Core Developer application for Łukasz Zemczak
16:01 <chiluk> so it works better.
16:01 <xnox> chiluk, "Kernel version: Linux lgw01-46 3.19.0-33-generic #38~14.04.1-Ubuntu SMP Fri Nov 6 18:17:28 UTC 2015 x86_64" =)
16:01 <stgraber> https://wiki.ubuntu.com/LukaszZemczak/CoreDeveloperApplication
16:01 <sil2100> o/
16:01 <stgraber> good, you're still around :)
16:02 * chiluk goes to figure out how to get ubuntu business cards for conferences.
16:02 <stgraber> sil2100: can you introduce yourself, what you're working on and why you'd like to become a core developer?
16:02 <sil2100> Sure!
16:03 <sil2100> I'm Łukasz, working for Canonical for quite a while, currently the semi release-manager for Ubuntu Touch, one of the co-maintainers of the infameous CI Train and current co-maintainer of system-image
16:03 <sil2100> I'm also a MOTU since over a year
16:04 <sil2100> Been doing two +1 maintenance sessions, with the most recent one a bit more fruitful than the first
16:05 <sil2100> I have worked a bit more on main packages recently and decided to re-apply - becoming a core-dev would make my development work much easier, not only from the CI Train side, but also during my patch-pilot and +1 maintenance sessions
16:06 <sil2100> I'm also the maintainer of the ubuntu-touch seeds and even though the package itself is in universe, the owner of the branches is ubuntu-core-dev, so well ;) I would like to stop bothering people all the time
16:07 <sil2100> And I think that's basically it, becoming a core-dev is my long-standing goal
16:08 <Laney> so this isn't your first application
16:08 <Laney> what's changed since last time? :)
16:08 <sil2100> No, last time I applied I basically didn't have too much main experience as during all my piloting sessions and archive work I was concentrating on universe, the place where I had power
16:08 <Mirv> (thanks for the Qt PPU additions. with those I'd manage through Qt 5.5 before applying for core-dev)
16:09 <sil2100> So since that time I started actually working on main packages as advised by xnox, helping out in the wily FTBFS from the test-rebuilds right before release
16:09 * xnox notices abi transitions work from sil as well
16:09 <sil2100> Then I wanted to help out and resolve the ocaml transition, but sadly most of the packages there were in universe
16:10 <sil2100> And just now noticed that I have some leftovers in NBS from the transition, ouch! But resolving those now inbetween things
16:10 <xnox> sil2100, which tools did you use to assist you with ocaml transition?
16:11 <sil2100> xnox: reverse-depends, a xenial-proposed chroot, I used chdist for checking installability on different platforms (at first I used the porterboxes, but chdist was faster)
16:11 <xnox> sil2100, any websites at all? e.g. launchpad...?
16:11 <sil2100> I created a few scripts that were helping me in the no-change rebuilds, checking for installability problems first and then outputting dependencies etc.
16:12 <sil2100> xnox: used launchpad too, but my scripts were fetching the most required information using LP API
16:12 <sil2100> Like which archs FTBFS, what binaries are provided by the packages
16:13 <sil2100> At first I was checking those manually through launchpad, but seeing ~100 packages in the transition, I got tired and wrote some stupid-helpers
16:13 <xnox> sil2100, have you used transition tracker at all?
16:13 <sil2100> Of course
16:14 <xnox> cool.
16:14 <sil2100> http://people.canonical.com/~ubuntu-archive/transitions/html/ocaml.html
16:14 <sil2100> That was the main page I was using for the transition
16:14 <sil2100> (e.g. which packages needed my attention)
16:17 <sil2100> I see that something causes now ocaml to have installability issues, will look at that later
16:17 <Laney> any more?
16:19 <stgraber> #vote Ubuntu Core Developer membership for sil2100
16:19 <meetingology> Please vote on: Ubuntu Core Developer membership for sil2100
16:19 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:21 <xnox> +1
16:21 <meetingology> +1 received from xnox
16:21 <cyphermox> +1
16:21 <meetingology> +1 received from cyphermox
16:21 <Laney> +1
16:21 <meetingology> +1 received from Laney
16:21 <stgraber> +1
16:21 <meetingology> +1 received from stgraber
16:21 <stgraber> #endvote
16:21 <meetingology> Voting ended on: Ubuntu Core Developer membership for sil2100
16:21 <meetingology> Votes for:4 Votes against:0 Abstentions:0
16:21 <meetingology> Motion carried
16:21 <sil2100> \o/ Thank you!
16:22 <Na3iL> congrats sil2100 :)
16:22 <Mirv> congrats sil2100!
16:22 <cyphermox> thanks sil2100
16:23 <cyphermox> I hope that doesn't mean I hear less from you for citrain silo reviews ;)
16:23 <sil2100> hah ;)
16:24 <sil2100> Interesting, all ocaml binaries look installable here, maybe I'll have to dig a bit deeper
16:24 * xnox /o\ what have we done. anway, i shall have sil2100 on speed dial for any ci train issues =)
16:24 <sil2100> But I noticed that the ben is not to be trusted in 100%
16:25 <stgraber> #topic Select a chair for the next meeting (following alphabetical order of first names)
16:25 <sil2100> No worries! I'll get bad karma if I publish too many bad packages through the train
16:25 <stgraber> that will be micahg, I'll move my name last in the list
16:25 * sil2100 only likes good karma
16:25 <stgraber> #topic AOB
16:25 <stgraber> anything?
16:26 <cyphermox> I don't know
16:26 <stgraber> I've already done the packageset changes we agreed on, added chiluk to UCD and sil2100 to core-dev, so we should be good action-wise.
16:26 <sil2100> stgraber: thanks!
16:26 <cyphermox> I responded to Timo by email to say the pkgset was done
16:26 <stgraber> thanks!
16:27 <chiluk> thanks stgraber, cyphermox, Laney, xnox
16:27 <cyphermox> chiluk: looking forward to sponsoring requests from you to eventually +1 a core-dev application
16:28 <chiluk> that's the goal.
16:28 <stgraber> agenda updated too
16:29 <Laney> thanks
16:29 <stgraber> and replied to the applications saying they've been approved and Cced the news-team
16:29 <stgraber> so I think we're all done
16:29 <stgraber> #endmeeting