16:02 <arosales> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Jun 16 16:02:18 2015 UTC.  The chair is arosales. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <beisner> o/
16:02 <arosales> #topic Review ACTION points from previous meeting
16:02 * arosales doesn't see any action items from the previous meeting
16:02 <arosales> #topic Vivid Development
16:03 <arosales> #link https://wiki.ubuntu.com/WilyWerewolf/ReleaseSchedule
16:03 <arosales> #info Alpha 1 coming up June 25
16:03 <coreycb> o/
16:03 <arosales> #subtopic Release Bugs
16:04 <arosales> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-w-tracking-bug-tasks.html#ubuntu-server
16:04 * arosales trying to pull up http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-w-tracking-bug-tasks.html#ubuntu-server . . .
16:04 <arosales> is that URL working for others?
16:04 <teward> arosales: site death perhaps, the white page of death
16:04 <teward> oh wait
16:05 <rharper> \o
16:05 <teward> nope
16:05 <teward> wpod, still, arosales
16:05 <teward> i think it's down
16:05 <arosales> just whit page for me
16:05 <caribou> wpod for me
16:05 <arosales> *white
16:05 <beisner> :-/  0k file
16:05 <teward> arosales: codenamed: "White Page Of Death" - WPOD
16:05 <teward> contact canonical sysadmins for fixing?
16:05 <rharper> beisner: indeed
16:05 <arosales> teward, ack, WPOD it seems
16:05 <arosales> rharper, can you take that action?
16:06 <rharper> arosales: sure
16:06 <arosales> #action rharper to follow up with canonical sysadmins on  http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-w-tracking-bug-tasks.html#ubuntu-server WPOD
16:06 * meetingology rharper to follow up with canonical sysadmins on  http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-w-tracking-bug-tasks.html#ubuntu-server WPOD
16:06 <arosales> thanks rharper
16:06 <arosales> any bugs folks would like to discuss before moving on
16:07 <arosales> I'll take it folks are ready for BPs then
16:07 <arosales> . . .
16:07 <arosales> #subtopic Blueprints
16:07 <arosales> #link http://status.ubuntu.com/ubuntu-w/group/topic-w-server.html
16:07 <arosales> http://status.ubuntu.com/ubuntu-w/group/topic-w-server.html   not working for me either today
16:08 <teward> arosales: confirmed, 404.
16:08 <arosales> we have http://status.ubuntu.com/ubuntu-w/group/topic-w-openstack.html
16:08 <arosales> but not server
16:08 <arosales> rharper, smoser: do you guys have a topic BP?
16:09 <smoser> checking. i dont think we probably do.
16:10 <smoser> or i do not think we do
16:10 <matsubara> arosales, http://status.ubuntu.com/ubuntu-w/canonical-server.html and http://status.ubuntu.com/ubuntu-w/ubuntu-server.html might give a better overview of server BPs
16:10 <matsubara> since the topic url is not working...
16:11 <arosales> matsubara, ok, do folks agree here we should update the meeting commands to these links?
16:11 * matsubara doesn't really know what's more appropriate in this case
16:11 <arosales> #action smoser update Topic blueprint URLs, if necessary
16:11 * meetingology smoser update Topic blueprint URLs, if necessary
16:12 <arosales> #link http://status.ubuntu.com/ubuntu-w/canonical-server.html
16:12 <arosales> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-w-openstack-liberty progressing
16:13 <arosales> sorry
16:13 <arosales> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-w-openstack-liberty
16:13 <arosales> #link http://status.ubuntu.com/ubuntu-w/ubuntu-server.html
16:13 <arosales> same blueprint there
16:14 <arosales> and as said before servercloud-w-openstack-liberty is progressing
16:14 <arosales> but seems there should be some other BPs there . .  .
16:14 <arosales> smoser, jamespage need to follow up if the correct BPs are linked  ^
16:15 <arosales> perhaps because https://blueprints.launchpad.net/ubuntu/+spec/topic-w-server is blank atm ?
16:15 <arosales> #link https://blueprints.launchpad.net/ubuntu/+spec/topic-w-server
16:15 <arosales> in any case an action item is made to follow up.
16:16 <arosales> Ping here if folks have any BPs items they would like to surface
16:16 <arosales> . . .
16:16 <arosales> moving on
16:16 <arosales> #topic Server & Cloud Bugs (caribou)
16:16 <caribou> nothing major to me; mostly done with rsyslog merge
16:16 <arosales> caribou, thanks for the update
16:16 <arosales> #topic Weekly Updates & Questions for the QA Team (matsubara)
16:16 <matsubara> arosales, nothing new to report
16:17 <arosales> matsubara, ok, thanks
16:17 <arosales> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee, arges)
16:17 <smb> I have nothing today if nobody else has anything.
16:17 <arosales> any questions for smb (kernel)?
16:17 <arosales> . . .
16:17 <arosales> #topic Ubuntu Server Team Events
16:18 <arosales> If any folks are interested in Spark. I am currently at Spark Summit and we'll be hosting an even tonight
16:18 <arosales> https://insights.ubuntu.com/event/big-data-mine-and-mingle/
16:18 <arosales> sorry
16:18 <arosales> #link https://insights.ubuntu.com/event/big-data-mine-and-mingle/
16:18 <arosales> any others?
16:18 <arosales> . . .
16:18 <arosales> #topic Open Discussion
16:18 <arosales> other items?
16:18 <teward> i think there's a missing item
16:19 <teward> which agenda page are you using, the ServerTeam/Meeting one?
16:19 <arosales> teward, using https://wiki.ubuntu.com/ServerTeam/Meeting/IRCCommands
16:19 <arosales> linked from https://wiki.ubuntu.com/ServerTeam/Meeting
16:19 <arosales> teward, was there another topic?
16:19 <teward> arosales: there's an item on the Agenda page added by me, and I'd like Server Team input on the course of action
16:19 <teward> arosales: https://wiki.ubuntu.com/ServerTeam/Meeting - NGINX in Ubuntu: Course of Action discussion (teward)
16:20 <teward> popped on in the middle of last week
16:20 <arosales> teward, ahh, sorry for missing that
16:20 <teward> perhaps it was missed?
16:20 <teward> no problem :)
16:20 <arosales> #link https://lists.ubuntu.com/archives/ubuntu-server/2015-June/007072.html
16:21 <teward> Previously, up until now, Debian was using a Stable branch of the NGINX web server's code as the package base.
16:21 <teward> Recently, based on what they do with Debian release times as far as I can gather, they're now using an NGINX Mainline branch, which is their feature-development branch.
16:22 <teward> Further questions on that branch can be directed to LinuxJedi who is here currently, and is a Senior Developer Advocate for the nginx upstream people
16:22 <LinuxJedi> o/
16:22 <teward> Currently, as of 15.04, we are using the Stable branch of NGINX in Ubuntu, which is mirroring Debian's choice of package versions.  However, following them will have Wily get 1.9.1 currently, which will likely remain that way through next LTS
16:23 <teward> While both versions are 'stable' enough to be used in production environments, and indeed I do have a couple Mainline nginx versions running in production, that is a changing development branch, replete with new features.
16:23 <teward> 1.8.x is the NGINX Stable branch, which receives critical bug fixes and security updates but forgoes the additional features.
16:24 <hallyn> you expect a stable branch of the current devel branch by 16.02 ?
16:24 <teward> hallyn: from what LinuxJedi has told me, such release (1.10.x) will be very near or after FinalFreeze or release date for LTS
16:24 <hallyn> that's unfortunate :)
16:25 <LinuxJedi> but there shouldn't be much change from 1.9.x to 1.10.0 at that stage
16:25 <teward> they release the 'mainline' as stable in April, and judging by the last release date, April 21, on or near that date would put us really close to release date
16:25 <hallyn> but if we could get a 1.10.alpha1 that might be good.  i assume the stable releases will be supported much longer than devel
16:25 <hallyn> i think it's worth asking the release time for best option there
16:26 <teward> To finish my initial thought stream: I'd like the Server Team to provide some guidance for Wily, as to how we proceed
16:26 <hallyn> hm, no rbasak today
16:26 <teward> A merge of 1.9.1 wouldn't take too long.  Merging in changes from Debian's packaging and merging that with 1.8.x is doable by myself, but would diverge from the standard process of getting packaging from Debian
16:27 <hallyn> you already emailed ubntu-server about this right?
16:27 <teward> hallyn: indeed.  I did ask Seth Arnold (sarnold) for his opinions, he responded to the email thread on the server mailing list
16:27 <smoser> teward, well, the questions hallyn asked apply for wily as well as x (16.04)
16:27 <hallyn> right,
16:27 <teward> hallyn: the email link that arosales posted.
16:27 <teward> smoser: indeed.
16:27 <teward> https://lists.ubuntu.com/archives/ubuntu-server/2015-June/007072.html
16:27 <smoser> we dont want to move forward in wily if we would then have to move back.
16:27 <hallyn> i'd follow sarnold's guidance :)
16:27 <hallyn> teward: how long do you expect 1.9 to be supported?
16:27 <LinuxJedi> it is worth noting that useful LTS features such as HTTP/2 will be in 1.10
16:27 <teward> hallyn: doing so would place us on 1.9.x.
16:28 <teward> hallyn: until 1.10.x release in April, I believe.  LinuxJedi: that's the upstream support period, if I'm not mistaken?
16:28 <LinuxJedi> correct
16:28 <hallyn> teward: i'm wondering whehter we can put things in place now to take 1.9 now, and have process ready to take 1.10 as an exceptional sru in 16.05
16:28 <hallyn> or, again,
16:29 <hallyn> ask upstream for a alpha or beta release in feb or march of 2016
16:29 <smoser> hallyn is right. this is not significantly different then what we do for openstack.
16:29 <smoser> or at least possibly not much different
16:29 <rharper> if 1.9.x isn't far apart from 1.10.0, why wouldn't 1.9 have the http2 and other features we'd want in the LTS?
16:29 <LinuxJedi> it will
16:29 <hallyn> not htat we want it to become the norm :)  but in 2019 we'll likely be wishing we'd done it
16:30 <hallyn> rharper: it's just that 1.9 likely won't be supported for 5 years upstream, so a stable would be nicer for 16.04
16:30 <teward> rharper: provided Debian has it uploaded and available, I'd rather *not* have to do manual source version merges by hand, although I do so for the PPAs already provided under ~nginx on Launchpad
16:30 <LinuxJedi> 1.9.x is mainline where new features are added. 1.10.0 will be the end release of the 1.9.x series
16:30 <rharper> right, the support from upstream
16:30 <rharper> teward: and the package maint;
16:31 <hallyn> teward: ok, let's see if rbasak is willing to take this to release team, if not i'll volunteer ,t ocome up with options
16:31 <LinuxJedi> we have odd numbers for mainline and even numbers for stable. And only one odd and one even maintained at any time (so currently 1.8 and 1.9 are maintained)
16:31 <hallyn> ok how long will 1.10 be supported?
16:31 <LinuxJedi> until 1.12
16:31 <hallyn> which is when
16:31 <teward> hallyn: ack
16:31 <teward> hallyn: april 2017
16:31 <hallyn> nyears
16:31 <hallyn> hm
16:31 <LinuxJedi> 1 year
16:31 <hallyn> so tha'ts not much of an extra cushion
16:32 <hallyn> so we really want an MRE here or something
16:32 <teward> hallyn: MRE was considered in the past but we have a weird exception:
16:32 <teward> nginx-core is in main, the other flavors are in Universe, because of third party modules
16:32 <teward> and security team suggestions/recommendations during the MIR
16:32 <teward> (back for 14.04)
16:32 <hallyn> ok i'll need to go read the MIR comments then
16:33 <hallyn> (assuming rbasak doesn't handle it :)
16:33 <teward> hallyn: i think the MRE discussion wasn't on the MIR, and was handled after the fact
16:33 <hallyn> teward: do you have links?  can you send them in a reply to sarnold's email?
16:33 <hallyn> (bc i haven't got the thread to reply to)
16:33 <teward> hallyn: to the discussions?  I could try and find the irclogs links, but I think my discussions with rbasak on that were in private
16:33 <hallyn> oh, ok
16:33 <hallyn> np
16:34 <teward> the MIR was https://bugs.launchpad.net/ubuntu/+source/nginx/+bug/1262710
16:34 <ubottu> Ubuntu bug 1262710 in nginx (Ubuntu) "[MIR] nginx" [Undecided,Fix released]
16:34 <hallyn> arosales: can you post an action for me to follow up (email rbasak etc)?
16:34 <arosales> #action hallyn to see if rbasak is willing to take this (nginx version in 15.10 and looking to 16.04)  to release team, if not hallyn to volunteer, to come up with options
16:34 * meetingology hallyn to see if rbasak is willing to take this (nginx version in 15.10 and looking to 16.04)  to release team, if not hallyn to volunteer, to come up with options
16:34 <hallyn> thx
16:34 <arosales> thanks hallyn
16:34 <smoser> thank you teward
16:34 <teward> you're welcome, and thank you all for your time on this :)
16:34 <arosales> teward, and LinuxJedi thanks for bringing up this topic
16:35 <LinuxJedi> no problem
16:35 <arosales> any other items to discuss?
16:35 <teward> arosales: you're welcome, thank you to the Server Team for taking the time to discuss.
16:35 <arosales> teward, np thats what this meeting is for. Sorry for missing your agenda item :-/
16:35 <teward> arosales: mistakes happen, no worries :0
16:35 <teward> :) *
16:36 <arosales> #topic Announce next meeting date, time and chair
16:36 <arosales> #info chair = hallyn per the list
16:36 <hallyn> woohoo
16:36 <arosales> #info NEXT MEETING: Tuesday 2015-06-23 at 1600 UTC
16:36 <arosales> thanks everyone
16:36 <arosales> #endmeeting