19:20 <bdmurray> #startmeeting DMB
19:20 <meetingology> Meeting started Mon Dec  1 19:20:03 2014 UTC.  The chair is bdmurray. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:20 <meetingology> 
19:20 <meetingology> Available commands: action commands idea info link nick
19:20 <bdmurray> #topic Review of previous action items
19:21 <bdmurray> Colin King was on the agenda still but I removed that as he was granted upload privileges
19:21 <bdmurray> What about "Extend DD PPU to cover DM too (Laney)
19:21 <ScottK> I think we decided that last time (yes).
19:21 <ScottK> Just needs writing up and doing.
19:22 <bdmurray> okay, I'll leave that there
19:22 <bdmurray> #topic MOTU Applications
19:22 <bdmurray> Let's try to review Jackson's application today / tomorrow please.
19:23 <ScottK> Noted.
19:23 <Noskcaj> :)
19:23 <bdmurray> #topic Ubuntu Core Developer Applications
19:24 <bdmurray> rbasak: Can you tell us a bit about yourelf and why you are applying for Core Dev?
19:24 <rbasak> o/
19:24 <rbasak> I'm a long time Ubuntu user. I started working full time for Canonical on Ubuntu server.
19:24 <Laney> (bdmurray: #action me to write it up please)
19:24 <rbasak> I was granted ubuntu-server-dev last year.
19:24 <Laney> (not really here, bye!)
19:25 <bdmurray> #action Laney to write up "Extend DD PPU to cover DM"
19:25 * meetingology Laney to write up "Extend DD PPU to cover DM"
19:25 <rbasak> One thing that holds us up quite a bit is waiting on SRU team or release team action. When we asked internally on what we could do to resolve this, it was suggested that we volunteer our time on the release and SRU teams.
19:26 <rbasak> By helping with the queue on non-server stuff, it was suggested that the queue would be emptier for others to look at our own server stuff.
19:26 * bdrung arrives
19:26 <rbasak> I was nominated, but I'm not a core dev, and working in that direction would need me to be a core dev first.
19:26 <rbasak> There are also some packages I'd like to be able to upload, but cannot, for example bind.
19:27 <rbasak> (the DMB has refused bind for ubuntu-server-dev previously)
19:27 <stgraber> (to clarify, "nominated" here means that infinity, I and probably a few other folks thought that rbasak is the best candidate for that)
19:27 <ScottK> rbasak: Here's a question for you...  You're looking at the sponsor queue, and you see bug #583216.  What do you think you should do with it?
19:27 <ubottu> bug 583216 in postfix (Ubuntu) "inet_protocols can't be preseeded" [Medium,In progress] https://launchpad.net/bugs/583216
19:28 <rbasak> Good choice of bug! I looked at that while triaging earlier :)
19:28 <rbasak> I found I couldn't upload postfix so decided to defer any action until after this meeting, but I can talk about my thoughts on it.
19:28 <rbasak> First, I looked at the linked Debian bug.
19:29 <rbasak> On the surface (I haven't looked deeper at this stage) it looks like the bug is valid and the core of the patch is good.
19:29 <rbasak> I don't want to introduce an Ubuntu delta, particularly as postfix doesn't have one right now.
19:29 <rbasak> So I'd ask lamont first if he's around.
19:30 <ScottK> Wjat
19:30 <rbasak> Failing that, I think it's fair to introduce a delta in Ubuntu temporarily (especially as jessie is in freeze right now, but also because the bug has been in Debian with a patch long enough)
19:30 <ScottK> What're the chances of that getting fixed in Debian and sync'ed into Ubuntu right now?
19:30 <ScottK> Ah, you anticipated the question...
19:31 <rbasak> I noted a couple of minor issues in the debdiffs.
19:31 <rbasak> From memory, I think the version for the SRU wasn't right, and I think the changelog message could be improved.
19:31 <ScottK> OK.
19:32 <rbasak> I wouldn't hold up sponsoring on that basis - I'd try to ping the person to verify the change is OK with them, but failing that I'd just upload.
19:32 <ScottK> Postfix also has an MRE, but I haven't had time to update it.
19:32 <ScottK> OK.
19:32 <rbasak> (and be clear in the bug and in the changelog comment what I changed from the submitted debdiff)
19:33 <rbasak> THis all assumes that I'm happy with the patch - I haven't actually reviewed it in detail
19:33 <ScottK> Right.
19:34 <ScottK> How about the patch for Bug #1366104 shows up in the sponsor queue?
19:34 <ubottu> bug 1366104 in psycopg2 (Ubuntu) "[FFe] OperationError when large object greater than 2gb" [Wishlist,New] https://launchpad.net/bugs/1366104
19:34 <rbasak> I've seen this bug before, but let me just remind myself of it.
19:35 <ScottK> That's fine.
19:36 <rbasak> So to clarify your question, what's the timing of it hypothetically showing up in the sponsorship queue? Do you mean feature freeze as I think it did?
19:36 <rbasak> (...during feature freeze as I think it did?)
19:38 <ScottK> How about if it shows up now.
19:38 <ScottK> If it shows up during freeze, as the release team is the easy answer.
19:38 <ScottK> Now you have to decide if it's a reasonable thing to patch into our psycopg2.
19:39 <rbasak> OK, so I'll talk you through what I'm thinking. Please stop or direct me if I diverge too far from what you're asking.
19:40 <rbasak> My first thought is to where we are right now with psycopg2 in Vivid, whether this is fixed in an upstream release or not, and where Debian is up to.
19:40 <rbasak> I'll look that up now.
19:41 <rbasak> Looks like it's still in a feature branch.
19:42 <rbasak> What I don't like about this situation is that it's an API change. Pulling that into Ubuntu before an upstream release can get really ugly in terms of future API breakage if upstream end up releasing something slightly different.
19:43 <rbasak> I'd push for work upstream here. I'd be far more comfortable cherry-picking this into Ubuntu if upstream at least commit to their main development branch.
19:44 <rbasak> I'd explain this in the bug. I'd want at least an effort or explanation why this can't get landed upstream first.
19:44 <ScottK> Thanks.
19:45 <ScottK> I think that's a very reasonable answer.
19:45 <ScottK> That's all for me.
19:45 <bdrung> I would have come to the same resolution
19:45 <rbasak> Nice to know :)
19:47 <bdrung> rbasak: back to bug #583216, how would your changelog entry look like? you said you would tweak it
19:47 <ubottu> bug 583216 in postfix (Ubuntu) "inet_protocols can't be preseeded" [Medium,In progress] https://launchpad.net/bugs/583216
19:48 <rbasak> bdrung: something like "d/postfix.postinst: correctly mark postfix/protocols debconf setting as changed so that it preseeds correctly (LP: #583216)."
19:48 <ubottu> Launchpad bug 583216 in postfix (Ubuntu) "inet_protocols can't be preseeded" [Medium,In progress] https://launchpad.net/bugs/583216
19:48 <rbasak> Assuming that I've understood the fix, and it is what I assume it to be (as I haven't actually reviewed it in detail).
19:49 <bdrung> i miss "closes: #671235" in there, but otherwise it's good
19:49 <rbasak> I wish there were a better way to note this correctly though. I don't want it to look like those are Seyeong's words in the changelog without his agreement, but I do want to attribute the work to him.
19:50 <rbasak> I've never considered closing Debian's bugs in Ubuntu's changelogs. I appreciate it when it's done the other way round by Debian maintainers though, so I guess it makes sense, thanks.
19:51 <stgraber> rbasak: do you know how to check if a given package is included in one of our published images (ubuntu or flavours)?
19:51 <bdrung> it makes sense to have a reference to the Debian bug. When you do the merge, you can easily check if the change was applied to the Debian package.
19:51 <ScottK> It's particularly useful for postfix since the Debian postfix maintainer has been known to just grab the Ubuntu postfix package and upload to Debian.
19:52 <rbasak> Yeah, it does sound useful, and I intend to do it now. I just hadn't ever considered it before.
19:52 <rbasak> stgraber: seeded-in-ubuntu.
19:52 <rbasak> I think it has a -b option for binaries too.
19:52 <stgraber> it does
19:52 <rbasak> I often look at germinate-output too.
19:52 <stgraber> that's slightly harder to read though ;)
19:52 <rbasak> And just search in there. Since I often want to know what is pulling it in.
19:53 <rbasak> It does get a little complex when multiple things pull things in though. I miss a tool that does a better analysis of it all.
19:54 <bdmurray> while we started a bit late we are running short on time
19:54 <stgraber> rbasak: can you tell me why ruby-arel is stuck in vivid-proposed?
19:54 * rbasak looks
19:55 <rbasak> Looks like it makes a bunch of packages uninstallable.
19:56 <rbasak> rails3, etc.
19:56 <rbasak> Want me to go deeper?
19:56 <stgraber> nope, that's deep enough, thanks
19:57 <bdmurray> are there any other questions?
19:57 <ScottK> rails3 is completely removed in Debian (FYI), so there's a transition someone serverish ought to superintend.
19:57 <ScottK> Not from me.
19:57 <rbasak> That's probably my department then :)
19:58 <ScottK> Handy you're here.
19:58 <rbasak> I've not really done much work this cycle yet. Been away for sprints, vacation, etc.
19:58 * ScottK did the last of the removals recently with his Debian FTP Team hat on.
20:00 <bdmurray> let's vote then
20:00 <bdmurray> #vote rbasak for core-dev
20:00 <meetingology> Please vote on: rbasak for core-dev
20:00 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:00 <ScottK> +1
20:00 <meetingology> +1 received from ScottK
20:00 <bdmurray> +1
20:00 <meetingology> +1 received from bdmurray
20:01 <bdrung> +1
20:01 <meetingology> +1 received from bdrung
20:01 <ScottK> Laney registered a +1 offline.
20:01 <stgraber> +1
20:01 <meetingology> +1 received from stgraber
20:01 <stgraber> +1 (proxy for Laney)
20:01 <meetingology> +1 (proxy for Laney) received from stgraber
20:01 <bdmurray> #endvote
20:01 <meetingology> Voting ended on: rbasak for core-dev
20:01 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:01 <meetingology> Motion carried
20:02 <rbasak> \o/
20:02 <rbasak> Thanks all.
20:02 <ScottK> Actually 5.
20:02 <ScottK> Congrats.
20:02 <bdmurray> Congratulations
20:02 <stgraber> rbasak: finally! :)
20:02 <rbasak> :)
20:03 <bdmurray> #topic AOB
20:03 <bdmurray> I was looking at the meeting schedule and believe a fair number of people will be off on December 29th.
20:04 <bdmurray> I was wondering if we should make the next meeting the 5th of January (3 weeks after the 15th) or the 12th of January (4 weeks).
20:04 <ScottK> I'm OK with either.
20:04 <bdmurray> I was leaning towards the 5th so its not as long of a gap.
20:05 <ScottK> Reasonable.
20:05 <stgraber> sounds fine
20:05 <bdrung> that's okay for me
20:05 <bdmurray> Okay, I'll put down the 5th. Thanks everyone.
20:05 <stgraber> I'll also be missing our next meeting (15th) as I'll be on a plane somewhere above the atlantic at the time
20:06 <bdmurray> #endmeeting