17:05 <dholbach> #startmeeting
17:05 <meetingology> Meeting started Thu Aug  7 17:05:11 2014 UTC.  The chair is dholbach. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
17:05 <meetingology> 
17:05 <meetingology> Available commands: action commands idea info link nick
17:05 <dholbach> #chair elfy mhall119
17:05 <meetingology> Current chairs: dholbach elfy mhall119
17:05 <dholbach> #topic Catching up with the Xubuntu team
17:05 <dholbach> knome, how's life? how's Xubuntu? how was the last release? :)
17:06 <knome> life is good but busy, xubuntu is good even if i'm not leading anymore ;)
17:06 <elfy> lol
17:06 <knome> so yeah, as some of you might know, we have a new project lead since the 14.04 release
17:07 <dholbach> knome, did you bring anyone else from the team? :)
17:07 <knome> 14.04 was great, got a lot of long-planned stuff in
17:07 <knome> well, elfy is kind of here...;)
17:07 <mhall119> knome: who is the new lead?
17:07 <knome> mhall119, Simon Steinbeiß (ochosi)
17:07 <knome> i guess we could have announced that in the CC list
17:07 <dholbach> ah, brilliant
17:07 <knome> i can get him send a mail to the list.
17:07 <mhall119> I recall seeing an announcement, just couldn't remember who
17:08 <dholbach> sure, a quick intro should be nice :)
17:08 <dholbach> elfy, so about the hats you're wearing today? :)
17:08 <knome> yep, i'll pass on the message
17:08 <elfy> dholbach: heh
17:08 <dholbach> excellent
17:08 <dholbach> do you feel you got everything done for the last release as you expected?
17:08 <elfy> QA for xubuntu during the last cycle was awesome
17:09 <knome> fwiw, from my point of view, everything is going well with simon leading, but there are maybe a few things here and there to pass on :)
17:09 <dholbach> what do you feel could work even better? :)
17:09 <knome> i'll be around, and we're documenting our process in the wiki, so pretty much *anybody* could take the leader hat in the future
17:10 <dholbach> that's brilliant
17:10 <dholbach> nothing better than having it all documented
17:10 <knome> it's mostly that simon leads in a different way and some minor details just need to be iron out
17:10 <knome> and he isn't on top of all the bureaucratic things he needs to handle
17:10 <dholbach> ah ok, so nothing in terms of the xubuntu project itself?
17:10 <knome> no, nothing is *wrong* :)
17:10 <mhall119> elfy: knome: who is this dev cycle going?
17:11 <mhall119> s/who/how/
17:11 <knome> mhall119, you mean "how"? :)
17:11 <knome> hehe, yeah
17:11 <knome> a bit slow, as always after an LTS release
17:11 <knome> we have a developer with uploader rights to the xubuntu package set now (Sean Davis aka bluesabre), so in that respect, we're much better!
17:12 <knome> dholbach, thanks for the help on that btw :)
17:12 <dholbach> anytime :)
17:12 <dholbach> I hope other folks will follow Sean :)
17:12 <elfy> so do I :)
17:12 <knome> me too
17:13 <dholbach> were you able to recruit some new folks as well in the last time?
17:13 <knome> sean was also nominated the xubuntu technical lead, so some sustainability is expected
17:13 <dholbach> wow, nice
17:14 <knome> during the whole LTS cycle (2 years), we got some new contributors, but (i think) also were able to get other people commit more
17:14 <knome> so while the numbers aren't up by dozens, the team feels more solid and has learned how to work together
17:15 <elfy> knome: I'd agree with that :)
17:15 <knome> i've no reason to expect a change in this movement.
17:15 <mhall119> knome: Global Jam is coming up again in September, that might be an opportunity to get some people involved if xubuntu has any specific tasks that need to be done and can be done at that point in time
17:16 <knome> mhall119, mmh, maybe... though as i said, things are relatively quiet this cycle
17:16 <dholbach> elfy, you mentioned QA - did you make any changes to the processes there for things to turn awesome, or how would you describe what changed?
17:16 <knome> it's summer, and everybody has given all they have to finalize the LTS release :)
17:16 <elfy> dholbach: I think mostly it was having someone just tracking that and pushing it - constantly
17:16 <elfy> I probably got a bit boring ;)
17:17 <knome> yep, elfy has done fantastic job ;)
17:17 <knome> it's unfortunately too easy to forget QA
17:17 <elfy> dholbach: the best bit was "found and reported 50 bugs during the cycle, that is more than for Ubuntu Desktop, Kylin Desktop, Lubuntu Desktop, Ubuntu Gnome and Common Desktop combined"
17:17 <elfy> http://xubuntu.org/news/xubuntu-14-04-qa-recap/
17:17 <elfy> I was really pleased with the response
17:18 <knome> getting the ISO/package tests in good shape has helped a lot!
17:18 <dholbach> wow, nice
17:18 <knome> now we have something concrete we can point people at when they ask how they can help with xubuntu QA
17:18 <elfy> yea - we did an awful lot of work getting the package tracker working
17:18 <elfy> well worth it in the end
17:18 <knome> definitely
17:19 <elfy> we made a new LP team so that people just doing QA for us had a concrete route into the Xubuntu team
17:19 <knome> i guess getting them done is just another sign that the team is wroking well together...
17:19 <elfy> :)
17:20 <knome> ^ yep, in addition to xubuntu-testers which is an open team which membership list isn't very accurate/up-to-date
17:20 <dholbach> is there anything you took on for this cycle which might interest new contributors?
17:20 <knome> even if xubuntu-qa doesn't come with any (technical) privilege/access, i think it's proven to be an important social team
17:21 <dholbach> yeah
17:21 <elfy> dholbach: it's mostly a cycle of consolidation and experimentation with apps I'd say
17:21 <dholbach> what's going to change?
17:21 <knome> and slowly continuing to improve stuff
17:22 <knome> we're dropping xchat
17:22 <knome> since it's unmaintained and all
17:22 <dholbach> and replace it with what?
17:22 <knome> nothing.
17:23 <knome> we have pidgin for people who need to join IRC occasionally
17:23 <dholbach> ok
17:23 <dholbach> right
17:23 <knome> and xubuntu.org/irc/
17:23 <knome> which is also linked from our installation slideshow
17:23 <knome> we want to see what kind of feedback we get with this experiment
17:24 <dholbach> how is the feedback generally? how do people let you know about their experience? (apart from filing bugs ... :-))
17:25 <elfy> we get people in the support channel and on the mailing lists, social media (which pleia2 looks after)
17:25 <knome> dholbach, nothing specific has been planned yet, but we have active social media outlets, so probably at least the feedback from there
17:25 <knome> i'd imagine we're going to talk about more applications to drop/change in the future, so let's see how this goes ;)
17:26 <dholbach> yeah, that's always an interesting subject :)
17:26 <elfy> :)
17:27 <dholbach> is there anything you're concerned or worried about? anything the CC could help with?
17:27 <knome> to sum it up, i think we're doing pretty good
17:28 <knome> if there's something the CC thinks the xubuntu team can help with (like describing our processes or sth), you can always ask
17:28 <dholbach> sure
17:28 <dholbach> and the other way around :)
17:29 <knome> yep
17:29 <knome> #nick ochosi
17:29 <dholbach> thanks a lot for your hard work - it's great to hear that you're all happy in the team and happy with the results of your work
17:29 <dholbach> and thanks a bunch for making time today!
17:29 <knome> #action ochosi to send an imtroducing mail to the CC list
17:29 * meetingology ochosi to send an imtroducing mail to the CC list
17:29 <dholbach> mhall119, elfy: any more questions?
17:29 <knome> introducing, but whatever ;)
17:29 <elfy> not from me dholbach
17:29 <dholbach> elfy, I realise that last question was sort of assuming you were schizophrenic, but I thought it'd be polite to ask anyway ;-)
17:30 <elfy> ha ha ha
17:30 <mhall119> knome: elfy: you guys are doing a fantastic job, I love seeing the xubuntu project so energized
17:30 <elfy> it feels good to be part of it mhall119 :)
17:30 <dholbach> rock and roll! :)
17:30 <dholbach> #topic Catching up with the Ubuntu Studio team
17:31 <dholbach> hello cub, zequence and everyone else who made it here today :)
17:31 <dholbach> how are you all doing? :)
17:31 <knome> mhall119, thanks *bows*
17:31 <elfy> hi zequence cub
17:31 <zequence> Hi
17:31 <cub> Hello
17:32 <dholbach> how are things in the Ubuntu Studio project?
17:32 <zequence> Stable, I would say :)
17:33 <dholbach> so the last cycle was more about maintenance rather than developing new things?
17:33 <dholbach> or could you maybe explain a bit?
17:33 <zequence> Well, development hasn't always hit the releases
17:34 <dholbach> meaning that some bits came in too late?
17:35 <zequence> was having a bit of a slow connection there
17:35 <zequence> ok, better
17:35 <zequence> We are few, so naturally, things go slowly
17:36 <zequence> And not all the work we do is for the actual ISO
17:36 <zequence> I've been studying the process of developing an Ubuntu flavor, and done some documentation on that
17:36 <dholbach> awesome - were you in touch with other flavour developers as well?
17:37 <zequence> We get a lot of help from the Xubuntu guys
17:37 <dholbach> that's great :)
17:38 <zequence> Right now, I'm mostly working on rewriting ubuntustudio-controls, while keeping the boat afloat
17:38 <zequence> Our desktop is to be fully synced with Xubuntus, just adding our multimedia packages on top of it, and in the future we will support the installation of more DEs
17:38 <dholbach> wow
17:39 <dholbach> this should make the maintenance a lot easier for you, I guess
17:39 <zequence> I would say we are about 3 guys now who can do some packaging work, though we don't do much of it
17:39 <zequence> None of us have much time, sadly
17:40 <zequence> Yes, since we don't really worry too much about the desktop, it makes sense to not focus too much on that
17:40 <cub> yes, that's a bit hard to get time, and with few people
17:41 <dholbach> do you have a list of things you would like to do, if there were more packaging folks around?
17:41 <zequence> I did get upload rights to the set of packages that we maintain, directly (not the package set)
17:41 <zequence> I guess we don't really need to do a lot of packaging
17:42 <zequence> We could however help shape the whole landscape of multimedia in some respects, audio especially
17:42 <dholbach> ok, sorry... I read the above as if you have more packaging tasks than hands on deck :)
17:43 <zequence> I'm sure there are plenty of bugs to fix, but we don't do a lot of testing
17:43 <zequence> elfy has helped us a bit on that
17:44 <elfy> or tried to at least :)
17:44 <zequence> and, the plan is we get more people helping out with QA
17:44 <elfy> early days
17:45 <zequence> The big goal now is 16.04. I feel farily confident that we can achieve everything we want by then
17:46 <dholbach> are there other things in the plans apart from making maintenance easier and add the ability to install different DEs?
17:47 <zequence> We're working on freedesktop and debtag categories, to make it easier to find and sort applications
17:47 <dholbach> nice
17:48 <zequence> The way we achieve realtime privilege for jack needs to change, so that its the same way on all Debian derived
17:48 <zequence> And, that will mean we need to sort it out in Debian as well
17:48 <zequence> That would make audio production on other UBuntu flavors much less painful to set up
17:49 <mhall119> have you spoken with the jack maintainer in debian?
17:49 <zequence> mhall119: not for a while
17:49 <zequence> It's been something I've been putting off for a long time, but I will absolutely have it done before 16.04
17:50 <dholbach> is there a bug tracking this work or something?
17:50 <zequence> Not directly. But, the issue with using audio group has been discussed
17:51 <dholbach> ok
17:51 <zequence> ubuntustudio-controls, when finished with all the features we have planned, would possibly become a preffered tool for audio newbies who want to use all the different audio servers that Debian derived has
17:52 <zequence> A first version will only administer realtime, and I will soon be SRUing it to trusty
17:52 <zequence> That will greatly simplify audio setup for newbies
17:52 <zequence> (who don't use Ubuntu Studio, that is)
17:53 <mhall119> zequence: will this work impact any other DEs or flavors?
17:53 <dholbach> oh yeah, that sounds like it
17:53 <zequence> mhall119: It will mostly be helpful on other flavors than Ubuntu Studio
17:54 <zequence> On Ubuntu Studio, the first user is in audio group, and thus gets realtime
17:54 <mhall119> zequence: but it won't break anything or cause them to need to change anything?
17:54 <zequence> No
17:54 <mhall119> ok
17:54 <dholbach> are you in touch with ubuntu studio users? do you have meetings?
17:55 <zequence> We haven'd had meeting for a long while. We don't have much user interaction, other than on our G+, fb, mail list, and so on
17:55 <zequence> Would be great if we had someone who only did that part
17:55 <zequence> I think I will want to do that, if we have more to offer, trying to shine a light on the distro
17:56 <dholbach> mhall119, ^ are you thinking what I'm thinking?
17:57 <dholbach> since we're doing these community q&a hangouts every week, I thought it might be a good idea to invite you folks to one, so you can show off some of the good work you've been doing
17:57 <dholbach> and maybe give a list of things to think about and see if they'd be willing to help out in the team
17:57 <cub> I have had hopes to get more involved in the community work, but time has been short.
17:57 <dholbach> sure
17:58 <cub> I had some contact with Jono before, but have not attended the Q&A for months
17:58 * dholbach nods
17:58 <mhall119> dholbach: I think so brain, but where are we going to find rubber pants our size?
17:58 <elfy> zequence: cub I've unfortunately gtg - good to see you both, look forward to seeing what comes of it all
17:58 <dholbach> mhall119, narf!
17:58 <elfy> and keep in touch re QA :)
17:59 <zequence> elfy: alright
17:59 <mhall119> dholbach: do we have anybody for next week's Q&A?
17:59 <dholbach> yeah, let's have a chat and see when we can get together and bring some ubuntu studio action to the airwaves
17:59 <cub> just to add to the contact with users, there are some activity on the ubuntu forum as well
17:59 <dholbach> mhall119, I don't know
18:00 <mhall119> cub: who had access to the social media accounts/pages for ubuntu studio?
18:00 <cub> Is that only you now zequence?
18:00 <zequence> me, and a couple of other people.
18:00 <zequence> madeinkobaia, so he can do the artwork himself
18:00 <zequence> holstein, I think
18:01 <mhall119> ok, as long as it's not just one person, that can often cause a bottleneck
18:01 <zequence> I could give you the rights, cub
18:01 <cub> sure
18:01 <dholbach> awesome :-D
18:01 <zequence> Oh, yeah, we had plans on doing youtube videos, tutorials on how to do different type of multimedia production
18:02 <zequence> cub has been involved in that as well
18:02 <dholbach> that sounds like a great people could get involved with
18:02 <dholbach> sounds like there's no shortage of good ideas :)
18:02 <cub> nope, mostly just time. :)
18:02 <dholbach> that's all the questions I had - anyone else? mhall119, elfy?
18:03 <mhall119> nothing else from me, but anything the CC or Community Team can do to help you promote your work we'll be happy to do
18:03 <zequence> That's usually not the big problem :)
18:05 <dholbach> ok
18:05 <dholbach> thanks a lot making time
18:05 <dholbach> and thanks for your hard work!
18:05 <zequence> Thanks
18:05 <dholbach> :)
18:05 <dholbach> #topic Any other business?
18:05 <dholbach> does anyone have any other business?
18:06 <cub> thanks
18:07 <dholbach> looks like that's it
18:07 <dholbach> thanks a lot everyone!
18:07 <dholbach> #endmeeting