15:03 <stgraber> #startmeeting Ubuntu DMB
15:03 <meetingology> Meeting started Mon Mar 10 15:03:53 2014 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:04 <stgraber> apparently I'm the chair, though I just realized it so give me a minute to actually go look at the agenda :)
15:04 <tumbleweed> o/
15:04 <stgraber> #topic Review of previous action items
15:04 <stgraber> Add Daniel Pocock's upload rights, waiting on reply from Daniel (stgraber).
15:05 <stgraber> done
15:05 <stgraber> #topic Confirm election results (Laney)
15:05 <stgraber> Laney: you're up
15:05 <Laney> ok
15:05 <Laney> thanks to all the candidates and outgoing board members :-)
15:05 * Laney goes to press the big butan
15:05 <Laney> Ok, there we go
15:05 <Laney> prospective new members are micahg, xnox and bdmurray
15:06 <Laney> congratulations!
15:06 <tumbleweed> indeed
15:06 <barry> congrats!
15:06 <Laney> #vote Confirm the nominations of micahg, xnox and bdmurray to the DMB
15:06 <Laney> stgraber: do that please
15:06 <stgraber> #vote Confirm the nominations of micahg, xnox and bdmurray to the DMB
15:06 <meetingology> Please vote on: Confirm the nominations of micahg, xnox and bdmurray to the DMB
15:06 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:06 <Laney> +1
15:06 <meetingology> +1 received from Laney
15:06 <barry> +1
15:06 <meetingology> +1 received from barry
15:06 <stgraber> +1
15:06 <meetingology> +1 received from stgraber
15:06 <tumbleweed> +1
15:06 <meetingology> +1 received from tumbleweed
15:07 <micahg-work> +1
15:07 <meetingology> +1 received from micahg-work
15:07 <stgraber> is that everyone?
15:07 <Laney> everyone who is here, anyway
15:08 <micahg-work> wait, should I abstain?
15:08 <stgraber> good enough
15:08 <Laney> and it seems to be beyond doubt
15:08 <stgraber> #endvote
15:08 <meetingology> Voting ended on: Confirm the nominations of micahg, xnox and bdmurray to the DMB
15:08 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:08 <meetingology> Motion carried
15:08 <Laney> welcome
15:08 <stgraber> micahg-work: wouldn't make a difference really ;)
15:08 <Laney> So the new terms start tomorrow
15:08 <micahg-work> congrats bdmurray and xnox
15:08 <Laney> stgraber: can you take an action to add them then?
15:09 <Laney> or in 8 hours when the current ones expire
15:09 <stgraber> #action stgraber to add the new DMB members, update the IRC bot, wiki, mailing-list subscriptions, IRC ACLs, ...
15:09 * meetingology stgraber to add the new DMB members, update the IRC bot, wiki, mailing-list subscriptions, IRC ACLs, ...
15:09 <Laney> I have been planning to send some kind of update of things we should do and think about
15:09 <Laney> to start the new term off
15:09 <Laney> Will try to do it tomorrow, but I'm off the rest of the week after today so we'll see
15:10 <Laney> anyway, that's that
15:10 * xnox yeah, thanks =)
15:10 <stgraber> Laney: I'll send an e-mail to the list once the new members have been added, the old ones removed, ... feel free to reply to that one
15:10 <stgraber> #topic Ubuntu Core dev application: Adam Stokes
15:10 <Laney> ok
15:10 <stgraber> stokachu: around?
15:11 <micahg-work> I think he said he'd have trouble making this meeting
15:11 <stgraber> ah, ok, then we can start with hallyn and see if he shows up later
15:12 <hallyn> hi
15:12 <stgraber> #topic Ubuntu Core dev application: Serge Hallyn
15:12 <stgraber> hallyn: hey there
15:14 <stgraber> sorry, IRC was a bit laggy here, apparently I'm back :)
15:14 <stgraber> hallyn: can you introduce yourself, your work and your application please?
15:14 <hallyn> Sure,
15:14 <hallyn> I'm a member of the ubuntu server team.  I generally babysit the virt stack - lxc, qemu, libvirt, netcf ,and the like.
15:14 <hallyn> my application is at https://wiki.ubuntu.com/SergeHallyn/CoreDevApplication
15:14 <hallyn> I've been generally happy with the package upload rights that I have,
15:15 <hallyn> but am applying for coredev in the hopes of being more generally helpful.
15:15 <hallyn> (without always being a burden to someone to sponsor)
15:17 <barry> hallyn: how's qemu 2.0 looking? :)
15:17 <hallyn> it's looking good!
15:18 <hallyn> now we have to hope upstream sticks to its schedule
15:18 * barry has been meaning to try it to see if it fixes the crashes with certain builds
15:18 <hallyn> the new trusty kernel also may fix some crashs fwiw
15:20 <stgraber> since nobody's asking questions, let's start with the usual ones
15:20 <tumbleweed> hallyn: so, what are you wanting to maintain in Debian?
15:20 <stgraber> are you subscribed to ubuntu-devel-announce@lists.ubuntu.com?
15:20 <hallyn> stgraber: I am
15:20 <hallyn> tumbleweed: I currently maintain netcf.  would like to have upload rights for that. want to ITP vimprobable2;
15:21 <hallyn> would like to help out eventually with shadow, libcap2, lxc,
15:21 <hallyn> i'm on the maint team for qemu
15:21 <stgraber> probably get cgmanager into Debian too?
15:21 <tumbleweed> I would hope DM is only going to be a stepping stone towards DD, then
15:21 <tumbleweed> :)
15:21 <hallyn> that too :)
15:21 <hallyn> tumbleweed: yup
15:21 <stgraber> (the lack of both cgroup-lite and cgmanager in Debian and the usually broken state of LXC in there is really annoying...)
15:22 <hallyn> stgraber: that will of course force the systemd+cgmanager issue, but yes.
15:22 <hallyn> it needs to be addressed anyway :)
15:22 <stgraber> yep
15:24 <barry> hallyn: i'm glad to see LP: #1284793.  in the packages you maintain, do you have any other FFes?
15:24 <ubottu> Launchpad bug 1284793 in qemu (Ubuntu) "[FFE] Merge qemu 2.0" [Undecided,Triaged] https://launchpad.net/bugs/1284793
15:24 <hallyn> barry: I don't.  zul has an FFE for libvirt for 1.2.0.
15:25 <hallyn> (I had an ffe for cgmanger, but it is fix released now)
15:25 <hallyn> oh wait,
15:25 <hallyn> there may be one for lxc for stacked apparmor profiles, if the core support goes into kernel int ime
15:26 <barry> hallyn: k, thanks
15:26 * Laney needs to bug you both about lxc /dev/{console,tty*} handling that he noticed breaks user switching today :-)
15:26 <Laney> about your UDD complaints in the "What I like least" section --- do you see anything that can be done about it?
15:27 <hallyn> Laney: well on a project by  project basis, simply agreeing on whether to use the bzr tree for staging fixes in advance;
15:27 <hallyn> i'd personally prefer it if dput refused if the lp tree had changes
15:27 <Laney> One of the main benefits was having a standard way to work with source package
15:28 <Laney> but given that there's no engineering happening on UDD it's hard to see any of the wishlist items being addressed
15:28 <hallyn> right, and right now there are two standard ways (or more)
15:28 <Laney> or even any of the bugs
15:28 <hallyn> yeah :(
15:28 <Laney> so, short of someone free software-ing up a fix, I wonder what can be done
15:28 <hallyn> for my own side, i may just need to whip up a script that does that checking for me
15:29 <hallyn> in lxc, i always fear i'll wipe a change by stgraber;  in vmguider, it goes the other way bc i work from lp:vmbuilder, but for isntance xnox had recently made a package-onlychange
15:29 <Laney> yeah
15:29 <Laney> the importer certainly used to propose back merge proposals if the archive overwrote something
15:29 <Laney> I'm not sure if that still works
15:30 <hallyn> that *would* be neat.
15:30 <Laney> xnox might know
15:30 <stgraber> yeah, for LXC I always stage and keep lp:~ubuntu-branches/ubuntu/trusty/lxc/trusty in sync but the importer is just completely broken, ubuntu:lxc doesn't work and auto-imports don't either...
15:30 <barry> at least bzr branch ubuntu:foo complains if the source branch is out of date now.  when i see that, i fallback to apt-get source
15:30 <hallyn> for years, qemu and libvirt would fail to auto-import every time.
15:31 <barry> (then import the .dsc an viola! a bzr branch)
15:31 <hallyn> in my ideal world, we could tag a bzr ttree to say "publish this as pkg" :)
15:31 <Laney> It's a bit sad that we've not gotten over the line with UDD
15:31 <hallyn> but i know that won't happen at this point
15:31 <stgraber> barry: sort of, try branching ubuntu:lxc for fun ;)
15:32 <Laney> ScottK was quite prescient when we started writing the 'packaging guide' a couple of years ago
15:32 <stgraber> barry: we have a UDD branch, but the ubuntu:lxc alias is broken for whatever reason
15:32 <Laney> he pushed back on it being as UDD-heavy as it is
15:32 <barry> stgraber: yay
15:32 <Laney> but sadly wasn't listened to so it's turned out to be a bit split brained
15:32 <hallyn> stgraber: oh i thought i was misuing the ubuntu: shortcut :)
15:33 <stgraber> hallyn: nope, it's just UDD being horribly broken with LXC, you need to use the full path (lp:~ubuntu-branches/ubuntu/trusty/lxc/trusty)
15:33 <xnox> Laney: hallyn: since importer doesn't look at "trunk" branches, e.g. lp:vmbuilder, it wouldn't help in the case hallyn mentioned.
15:33 * barry cries a little inside
15:33 <micahg-work> hallyn, I notice that most of your endorsements come from teammates or former teammates, I know that you're engaged with other developers in the community as well, I was wondering if you approached anyone else for testimonials outside of that list (no need to name names) and if you got any other feedback
15:33 <Laney> I'm asking about the merge-backfeature
15:33 <hallyn> xnox: yes.
15:33 <Laney> s/back/back /
15:34 <Laney> I don't remember seeing that stuff in the queue, but it could just be because nobody pushes to UDD any more
15:34 <xnox> Laney: it generates some branches still, but i don't think it proposed to merge them any more.
15:34 <stgraber> micahg-work: he did approach me (we're not on the same team technically) but I sort of forgot to write a testimonial ;)
15:34 <hallyn> micahg-work: hm, i'd have to look at the list;  there was one, who said he only saw one pkg he had sponsored for me so felt he could only do a personal endorsement
15:35 <micahg-work> ok, right :), that probably would've preempted by question :)
15:35 <micahg-work> s/by/my/
15:35 <stgraber> so btw, I've been working with hallyn a long time, been reviewing quite a lot of his packaging changes (he always asks when unsure), been sponsoring quite a few of his changes and they're usually of great quality. It'd be nice having him be able to touch the rest of the archive (outside of the ubuntuserver package set) especially given his interest in +1 maintenance.
15:36 <stgraber> ^ there you go :) sorry for being late
15:36 <micahg-work> wfm
15:36 * Laney is all outta Qs
15:39 <stgraber> #vote Serge Hallyn for Ubuntu Coredev
15:39 <meetingology> Please vote on: Serge Hallyn for Ubuntu Coredev
15:39 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:39 <stgraber> +1
15:39 <meetingology> +1 received from stgraber
15:39 <tumbleweed> +1
15:39 <meetingology> +1 received from tumbleweed
15:39 <micahg-work> +1
15:39 <meetingology> +1 received from micahg-work
15:39 <Laney> +1
15:39 <meetingology> +1 received from Laney
15:40 <barry> +1
15:40 <meetingology> +1 received from barry
15:40 <stgraber> #endvote
15:40 <meetingology> Voting ended on: Serge Hallyn for Ubuntu Coredev
15:40 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:40 <meetingology> Motion carried
15:40 <stgraber> hallyn: congrats!
15:40 <Laney> w00t
15:40 <hallyn> thanks :)
15:40 <stgraber> added to ~ubuntu-core-dev
15:41 <stgraber> #topic AOB
15:41 <tumbleweed> yeah, one thing
15:41 <tumbleweed> who wants to take over the membership-monitor cronjob?
15:41 <tumbleweed> I can give you a tarball of the current state
15:42 <stgraber> tumbleweed: send it to me, I'll get it running somewhere
15:42 <tumbleweed> cool
15:42 <tumbleweed> ah, I see the bzr repo already belongs to be board
15:43 <Laney> oh god, I really ought to figure out that packageset script
15:43 <Laney> I re-ran it the other day and it confused me even more by giving mozjs24 to edubuntu
15:43 <micahg-work> I've been wanting to poke at that for a couple years now
15:43 <stgraber> blame cjwatson ;)
15:44 <Laney> :P
15:45 <stgraber> so before we wrap, I'd just like to say a big thank you to barry and tumbleweed for serving on the DMB for so long (2 years and 2 years and 2 months respectively), all the best!
15:45 * cjwatson hides
15:46 <tumbleweed> thanks, it's been a pleasure
15:46 <stgraber> and again congratulations to the new members, xnox and bdmurray. And to micahg-work for sticking with us for another term!
15:46 <barry> stgraber: thanks!  it's been a great experience, thanks largely to the other fantastic members on the board.  congrats to the new members.
15:46 <Laney> \o/
15:46 <Laney> thanks chaps
15:47 * Laney goes to hassle stgraber and hallyn in another channel
15:47 <stgraber> :)
15:48 <stgraber> ok, so I think that's a wrap. It'll take me a while to do all the paperwork (picked the wrong meeting to chair...) but I'll send an e-mail to the private list once it's all done and the announcements to u-d-a as I'm done with the changes.
15:48 <stgraber> thanks everyone!
15:48 <stgraber> #endmeeting