15:06 <Laney> #startmeeting DMB
15:06 <meetingology> Meeting started Mon Feb 10 15:06:04 2014 UTC.  The chair is Laney. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:06 <meetingology> 
15:06 <meetingology> Available commands: action commands idea info link nick
15:06 <Laney> #topic Review of previous action items
15:06 <barry> Laney: thanks
15:06 <Laney> #subtopic micahg to update documentation on PPU team restructuring.
15:06 <Laney> micahg_mobile: ?
15:07 <Laney> let's come back to that ...
15:07 <Laney> #subtopic Add upload rights for pocock and hyperair
15:07 <Laney> stgraber: you happy to do that?
15:08 <Laney> ¬_¬
15:08 <Laney> stop playing portal!
15:08 <stgraber> Laney: sure
15:09 <Laney> thanks
15:09 <Laney> #action stgraber to add upload rights for pocock and hyperair
15:09 * meetingology stgraber to add upload rights for pocock and hyperair
15:09 <Laney> #topic MOTU Application - Artur Rona
15:09 <Laney> ari-tczew: hi, could you introduce yourself please
15:10 <ari-tczew> sure.  My name is Artur, nickname ari-tczew, I was MOTU already and I'd like to rejoin again
15:10 <Laney> #link https://wiki.ubuntu.com/ArturRona/MOTUApplicationNEW
15:11 <Laney> are there specific areas you focus on / would like to focus on?
15:11 <bdrung_work> sorry, i am busy
15:11 <ari-tczew> yes, I'd like to focus on reducing delta between Debian and Ubuntu
15:11 <ari-tczew> so, merges, syncs, forwarding changes, etc.
15:12 <Laney> yay
15:12 <Laney> in any specific area? do you have any commit / upload access in Debian or do you intend on getting that?
15:13 <ari-tczew> no, i don't. I have already uploaded a few packages als NMU in Debian. http://qa.debian.org/developer.php?login=ari-tczew@tlen.pl
15:14 <ari-tczew> anyway, I'm writing a submit@debian.org if changes are forwardable, then  I hope maintainer will upload Ubuntu changes
15:14 <Laney> good, that's what we like to see
15:15 <Laney> @bugs.debian.org, hopefully :P
15:15 <meetingology> Laney: Error: "bugs.debian.org," is not a valid command.
15:15 * Laney slaps
15:15 <barry> ari-tczew: i often see changes made in ubuntu packages which should probably be upstreamed in debian.  but ubuntu devs don't always have the knowledge or permission to upload to debian.  i'd like to see steps taken to help make debian the first stop for patches when possible
15:15 <ari-tczew> yes, I write direct from my head :P
15:15 <Laney> so, since you've been out for a while - do you remember how the second half of the cycle works?
15:17 <ari-tczew> barry: ok, like above - if changes are forwardable, I'm sending them to maintainers
15:17 <ari-tczew> Laney: I think so.
15:19 <tumbleweed> ari-tczew: hi. so, let's talk about the things you like least in ubuntu
15:19 <Laney> maybe you could expand on that a little bit :P
15:19 <tumbleweed> do you think we can improve sponsorship?
15:20 <ari-tczew> tumbleweed: yes, we can!
15:20 <tumbleweed> how?
15:22 <ari-tczew> tumbleweed: so, I think we need to keep a small size of sponsoring overview and don't keep requests hanging on since a few months or more.
15:23 <tumbleweed> that's the result, but how do we get there?
15:23 <ari-tczew> if requests is related to main section, MOTUs can review them, as well. although, from packaging knowledge.
15:23 <ari-tczew> if requests are*
15:24 <barry> ari-tczew: we have patch piloting, which is supposed to help keep queue small.  in my experience though, it can sometimes be tough to consume a lot of items during a pp session.  if one merge/patch takes a long time to verify, it can eat up a lot of time.  can we improve the patch pilot program to help with big queues?
15:25 <ari-tczew> we can help contributors to get patches uploaded, if someone is fresh, we don't need to write "please update your d/changelog, there's no * in line X", we can make it done themselve and upload patch/debdiff
15:25 <Laney> we still get hard sponsorships being ignored :(
15:25 <barry> Laney: yep
15:26 <Laney> doesn't look awful in that respect currently though
15:26 <tumbleweed> ari-tczew: you subscribed to ubuntu-devel-announce?
15:27 <ari-tczew> barry: I have noticed that patch pilots make in the first queue syncs, merges, what are comparatively easy as SRUs or requests hanging on since 2 months
15:28 <ari-tczew> barry: so, maybe patch pilots will make in the first shot the old requests
15:28 <ari-tczew> tumbleweed: yes, I am
15:29 <Laney> imo it's a bit focused on sponsoring and not so much on piloting as was the original mission
15:29 <barry> ari-tczew: yes, that's been my experience and observation too.  it's a trade-off between trying to get a lot of easy things done, or just a couple of hard things.  any thoughts on how to make the process (either sru or patch piloting) easier to take on the hard tasks?
15:29 <Laney> which was to try and help patches along even if you don't upload them
15:30 <Laney> let's vote after this reply so that we have time for zequence, unless anyone has anything burning
15:31 <ari-tczew> barry: I think just patch pilots should take care of the most forgotten requests (last is 2013-05-14). if sponsoring overview is clear, then can we think about another ideas
15:31 <ari-tczew> so: just take the work in hands
15:32 <Laney> thanks, now to the voting chamber
15:32 * Laney enrobes
15:32 <barry> ari-tczew: i'm skeptical the queue will ever be clear ;)  but anyway
15:32 <Laney> #vote Should ari-tczew join ~motu?
15:32 <meetingology> Please vote on: Should ari-tczew join ~motu?
15:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:32 <Laney> +1
15:32 <meetingology> +1 received from Laney
15:33 <barry> +1
15:33 <meetingology> +1 received from barry
15:33 <tumbleweed> +1 [ welcome back ]
15:33 <meetingology> +1 [ welcome back ] received from tumbleweed
15:34 <micahg_mobile> +1
15:34 <meetingology> +1 received from micahg_mobile
15:34 <stgraber> +1
15:34 <meetingology> +1 received from stgraber
15:34 <Laney> bdrung_work: here?
15:35 <Laney> #endvote
15:35 <meetingology> Voting ended on: Should ari-tczew join ~motu?
15:35 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:35 <meetingology> Motion carried
15:36 <Laney> ari-tczew: welcome back!
15:36 <barry> ari-tczew: congrats!
15:36 <ari-tczew> Thank you for your trust.
15:36 <Laney> #topic Per Package Uploader Application - zequence
15:36 <Laney> hi zequence, please could you briefly introduce yourself
15:37 <zequence> Hi. I'm the project lead for Ubuntu Studio, musician first, coder/packager second, so to speak
15:37 <zequence> I've been involved in Ubuntu Studio development for a few years now. Maybe 3-4
15:37 <zequence> Not so much packagin though, until the last year or so
15:38 <zequence> I was hoping that micahg_mobile would show up, as he's done most of the sponsoring :)
15:38 <micahg_mobile> I'm here
15:38 <zequence> I'm applying for upload rights for the ubuntustudio-* packages at this point, but will like to extend to the whole Ubuntu Studio package set in the future
15:39 <barry> zequence: hi.  i'm only seeing one endorsement on your application, but you've worked extensively with many members of ubuntu.  did you ask any of them to add endorsements to your page?
15:39 <zequence> Aside from doing only a small amount of changes myself to ubuntustudio-* packages, I've fixed a couple of bugs, and been maintaining linux-lowlatency now for a good while
15:40 <zequence> Well, I've asked a few, but none have written anything on the page
15:40 <zequence> diwic and dholbach both were involved in a couple of bugs I had fixed
15:40 <zequence> They might not even remember
15:41 <zequence> apw and infinity have both been involved in linux-lowlatency, but I'm not doing anything complicated there
15:41 <dholbach> I do, vaguely :)
15:41 <zequence> Cool :)
15:42 <zequence> The studio packages are fairly simple to maintain. Most of the work is just in updating our meta package, and our default settings
15:42 <zequence> We have a couple of our own projects too, -installer and -controls (which I'm rewriting from scratch atm)
15:43 <zequence> I know my way around a debian package, but I haven't had extensive practical experience from diverse packaging and getting stuff sponsored
15:44 <micahg_mobile> Zequence: do you review the diff of the VCS versions before requesting sponsorship to ensure that everything in there is good?
15:45 <zequence> micahg_mobile: So far, I havent't packaged anything that is an update of something upstream
15:46 <zequence> We are the upstream for our own packages, and in the case with the bugs, I just added patches consisting of the particular code that fixed the bugs
15:46 <micahg_mobile> No,I'm referring to packages maintained in a VCS like ubuntustudio-default-settings
15:47 <zequence> micahg_mobile: If I am to upload a package, then I will of course make sure what changed was something useful.
15:50 <micahg_mobile> Can i direct you to version 0.48 of ubuntustudio-default-settings, please take a look at the diff, do you notice anything out of the ordinary?
15:50 <micahg_mobile> (Sorry, can't give a link from here easily)
15:51 <zequence> just a moment..
15:51 <Laney> https://launchpadlibrarian.net/150692403/ubuntustudio-default-settings_0.47_0.48.diff.gz
15:52 <micahg_mobile> Thanks Laney
15:55 <Laney> I think we need to speed this along a bit; time is almost up
15:55 <zequence> Yeah, looks like change itself for the wallpaper doesn't show
15:55 <Laney> I think micahg_mobile is trying to get at the fact that this postinst performs a rm -f on a file which the package doesn't own
15:56 <Laney> which isn't really going to work properly, like if the user ever reinstalls the owning package or if it is SRUed
15:56 <Laney> that wasn't a change /introduced/ in this version, but it certainly raises some flags to me when I see this diff
15:57 <zequence> I haven't followed Lens changes a lot
15:57 <Laney> ideally that would be looked at
15:57 <Laney> does anybody else have any questions
15:58 <zequence> (since I haven't been the one uploading them, or reviewing them)
15:58 <Laney> ?
15:58 <Laney> I think it's just something that came up in course of reviewing your stuff :-)
15:59 <Laney> zequence: looks like linux-lowlatency got absorbed into the main kernel
15:59 <Laney> I guess that's nice for you :-)
15:59 <Laney> okay, let's vote
16:00 <Laney> #vote Should zequence get upload rights to the packges listed in https://wiki.ubuntu.com/zequence/DeveloperApplication ?
16:00 <meetingology> Please vote on: Should zequence get upload rights to the packges listed in https://wiki.ubuntu.com/zequence/DeveloperApplication ?
16:00 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:00 <Laney> too difficult to copy and paste that into a nice list :P
16:00 <Laney> also, that lowlatency thing is noted there I see now
16:00 <Laney> +1
16:00 <meetingology> +1 received from Laney
16:01 <barry> +0 [ would like to see more endorsements from folks you've worked with ]
16:01 <meetingology> +0 [ would like to see more endorsements from folks you've worked with ] received from barry
16:01 <tumbleweed> -1 [ that ubuntustudio-default-settings postinst doesn't inspire me with any confidence. And I'd like to see at least one endorsement from a sponsor ]
16:01 <meetingology> -1 [ that ubuntustudio-default-settings postinst doesn't inspire me with any confidence. And I'd like to see at least one endorsement from a sponsor ] received from tumbleweed
16:02 <stgraber> +0 [ would like to see some endorsements ]
16:02 <meetingology> +0 [ would like to see some endorsements ] received from stgraber
16:02 <micahg_mobile> +0 i would like to see an endorsement from a lowlatency sponsor
16:02 <meetingology> +0 i would like to see an endorsement from a lowlatency sponsor received from micahg_mobile
16:03 <micahg_mobile> Oh, is that not on the application anymore?
16:03 <Laney> nope
16:03 <zequence> No, linux-lowlatency is now merged with master :)
16:04 <zequence> I still maintain the config diff
16:04 <zequence> which is as trivial as it has always been
16:04 <zequence> But, I don't deal with the source
16:05 <tumbleweed> given the long involvement with that, I'm not so concerned about it, anyway. It's more general debian packaging that I'm worried about
16:05 <tumbleweed> (with that == the kernel bits)
16:06 <micahg_mobile> +0, a concerned with the postinst
16:06 <meetingology> +0, a concerned with the postinst received from micahg_mobile
16:06 <Laney> okay
16:06 <zequence> Who uploaded that?
16:07 <Laney> #endvote
16:07 <meetingology> Voting ended on: Should zequence get upload rights to the packges listed in https://wiki.ubuntu.com/zequence/DeveloperApplication ?
16:07 <meetingology> Votes for:1 Votes against:1 Abstentions:3
16:07 <meetingology> Deadlock, casting vote may be used
16:07 <Laney> wtf
16:07 <Laney> https://launchpad.net/ubuntu/+source/ubuntustudio-default-settings/0.48
16:07 <Laney> So, I'm sorry that this wasn't successful right now
16:08 <Laney> would people be happy to have a quick email vote if some endorsements come around? or back to IRC again?
16:08 <zequence> Ah, sorry dholbach. I should have looked into that change a bit more carefully :)
16:08 <Laney> or an IRC vote without this whole interview thing?
16:08 <barry> zequence: please do solicit those endorsements.  i'd be happy enough to take it to email.
16:09 <dholbach> zequence, sorry I didn't follow the meeting and am in a phone call right now
16:09 <zequence> dholbach: No problem.
16:09 <barry> *take a follow up vote on zequence's application to email
16:09 <Laney> okay
16:10 <Laney> zequence: if you can get two or three endorsements and then email devel-permissions I'll try to make sure we re-vote
16:10 <Laney> Assume you don't need to attend any meeting unless we tell you otherwise
16:10 <zequence> I think in this situation what I need to is get sponsors for the coming uploads of ubuntustudio-* packages before this release, and then apply again
16:11 <zequence> Also, go through all the packages for faults, like what was just described
16:11 <tumbleweed> yeah, that'd work
16:11 <zequence> Thanks everyone
16:11 * Laney hugs zequence
16:11 <Laney> thanks!
16:11 <Laney> #topic AOB
16:12 <micahg_mobile> Zequence: that would be great, you're doing great work
16:12 <zequence> micahg_mobile: Thanks
16:12 <Laney> so, micahg_mobile has promised to start a vote on Noskcaj
16:12 <Laney> please do that asap
16:12 <Laney> #action micahg_mobile to start a vote on Noskcaj on devel-permissions
16:12 * meetingology micahg_mobile to start a vote on Noskcaj on devel-permissions
16:12 <micahg_mobile> Ok
16:13 <Laney> anything else?
16:13 <Laney> Oh, I started looking at the packageset script and it threw up some odd things
16:13 <Laney> like adding sbuild to kubuntu
16:13 <Laney> need to see what's going on there, then we can start running it regularly / automatically
16:14 <Laney> going
16:14 <Laney> going
16:15 <Laney> gone
16:15 <Laney> #endmeeting