15:17 <stgraber> #startmeeting DMB
15:17 <meetingology> Meeting started Mon Dec 16 15:17:16 2013 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:17 <meetingology> 
15:17 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:17 <stgraber> #topic review of past action items
15:17 <stgraber> micahg to restructure PPU teams.
15:18 <stgraber> I'm assuming nothing changed there, carried to next meeting.
15:18 <stgraber> Discussion of skipping of Dec 30 2013 meeting on ML
15:18 <stgraber> this was discussed and the meeting of the 30th will be skipped.
15:18 <stgraber> #topic Per Package Uploader Applications
15:18 <bdrung_work> +1 for skipping the Dec 30 meeting
15:19 <barry> next meeting after today is 13 jan
15:19 <stgraber> #topic Dmitry Shachnev for PPU of: python-markdown, python-keyring, python-secretstorage, python-docutils, python-qt4, sip4, sphinx and the QT5 packageset
15:19 <mitya57> o/ again
15:20 <stgraber> hi mitya57, can you please introduce yourself and your application?
15:20 <mitya57> Of course
15:21 <mitya57> I am Dmitry Shachnev, user of Ubuntu since some ancient version, developing since ~Natty. I am interested in a big bunch of stuff, including Python, Qt, JS, GNOME and KDE.
15:22 <mitya57> For the packages listed (^), I am not the primary maintainer.
15:22 <mitya57> Most of them (except sphinx and sip4 I think) are now in sync with Debian.
15:22 <mitya57> s/not/now/
15:23 <mitya57> For some of them I am also upstream co-developer (i.e. for python-keyring)
15:23 <mitya57> And I also contribute to upstream Qt (have made ~13 commits)
15:24 <mitya57> Well, I think that will be enough, the details are in the application
15:24 <mitya57> https://wiki.ubuntu.com/DmitryShachnev/PPUApplication
15:25 <Riddell> mitya57: what have you done with sip4 and pyqt?
15:26 <mitya57> Riddell: ScottK asked me to help with maintaining them, I think I've done one sip4 upload and two python-qt4 uploads
15:26 <Laney> mitya57: thanks
15:26 <Laney> are you in the Debian teams for all of these things?
15:26 <mitya57> I am also maintaining pyqt5, but it is in universe, so I can already upload it in Ubuntu
15:26 <mitya57> Laney: yes
15:27 <barry> mitya57: why ppu and not core-dev yet?
15:27 <Laney> lolz, tumbleweed is your AM
15:27 <mitya57> barry: I don't know :)
15:27 <barry> :)
15:29 <barry> mitya57: for the record, i've been very happy with all your contributions to python.  thanks!
15:29 <Riddell> mitya57: any plan for sip 4.15.3?
15:29 <Laney> regarding your "Things I don't like" - not all of it is due to a lack of communication
15:29 <mitya57> Riddell: oh, it just needs a trivial merge
15:29 <mitya57> Will do when I get upload rights :)
15:29 <Riddell> groovy, mitya57 gets my +1 :)
15:29 <Laney> Riddell in joining the DMB shocker
15:30 <Laney> anyway, sometimes there are general technical / design differences
15:31 <Laney> and there are pockets of great collaboration even within communities like GNOME imo, but it's obviously quite a way from perfect
15:31 <Laney> what do you think we could do there?
15:31 <mitya57> Laney: actually, that what-i-dont-like-in-ubuntu section is quite difficult to fill in
15:31 <Laney> I do like what you put though
15:32 <Laney> as someone who calls out not-coordinated work and not-forwarded patches from time to time
15:32 <mitya57> I think we should get more people testing unstable GNOME and pointing out issues, and discussing these issues with upstream
15:33 <Laney> a lot of people are just resigned to the projects being different these days
15:33 <Laney> the collaboration on the library level is better
15:33 <Laney> but Ubuntu GNOME is good in this regard too
15:34 <mitya57> Yes, but the Gtk's CSDs stuff looks like nobody tested it under Unity before 3.10 was released
15:34 <mitya57> (Gtk is a library :P)
15:34 <Laney> yeah I was thinking of that
15:34 <Laney> quite a few changes came from the pre-upload testing
15:35 <Laney> still, the basic problem is that we were testing something after it was already baked
15:35 <Laney> ahem, I'll stop rambling
15:35 <Laney> anyone else?
15:36 <Laney> well, I'm ready to vote :-)
15:36 <bdrung_work_> no, everything is answered already.
15:36 <bdrung_work_> i am ready to vote.
15:36 * barry too
15:36 <Laney> stgraber:
15:38 <stgraber> Laney: 1sec
15:39 <stgraber> #vote Dmitry Shachnev for PPU of: python-markdown, python-keyring, python-secretstorage, python-docutils, python-qt4, sip4, sphinx and the QT5 packageset
15:39 <meetingology> Please vote on: Dmitry Shachnev for PPU of: python-markdown, python-keyring, python-secretstorage, python-docutils, python-qt4, sip4, sphinx and the QT5 packageset
15:39 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
15:39 <Laney> +1
15:39 <meetingology> +1 received from Laney
15:39 <bdrung_work_> +1
15:39 <meetingology> +1 received from bdrung_work_
15:40 <barry> +1 [keep going!  i hope to see core-dev app soon]
15:40 <meetingology> +1 [keep going!  i hope to see core-dev app soon] received from barry
15:40 <stgraber> +1
15:40 <meetingology> +1 received from stgraber
15:40 <stgraber> #endvote
15:40 <meetingology> Voting ended on: Dmitry Shachnev for PPU of: python-markdown, python-keyring, python-secretstorage, python-docutils, python-qt4, sip4, sphinx and the QT5 packageset
15:40 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:40 <meetingology> Motion carried
15:40 <stgraber> #action stgraber to get webops to add the new PPU and add qt5 membership
15:40 * meetingology stgraber to get webops to add the new PPU and add qt5 membership
15:40 <Laney> you can add the membership yourself
15:41 <Laney> unless I'm parsing that wrong
15:41 <Laney> mitya57: congrats!
15:41 <mitya57> barry: UCD application in my todo list after becoming a DD :)
15:41 <mitya57> Laney & everybody: thanks!
15:41 <barry> mitya57: \o/  hopefully it won't take you as long for DD as it did for me :)
15:41 <Laney> UCD is something else
15:42 <stgraber> Laney: right, I'll add the membership myself
15:42 <Laney> (contributing developer)
15:42 <Laney> beware of applying for that
15:42 <Laney> :P
15:42 <dholbach> mitya57, congratulations!
15:42 <mitya57> dholbach: danke!
15:42 <dholbach> :)
15:42 <mitya57> Laney: names conflict, that is
15:42 <Laney> everyone just says core-dev
15:42 <stgraber> #topic Graham Inggs for MOTU
15:43 <ginggs> hi
15:43 <stgraber> ginggs: hey there, can you introduce yourself and your application please?
15:43 <ginggs> I'm Graham Inggs, I've been an Ubuntu user since 2007/2008 and have been contributing since 2012
15:44 <dholbach> ginggs, sorry for not getting to update your application - just for the completeness' sake I'd like to point out that I was VERY happy with Graham's work, if there were ever issues, Graham was very quick to resolve them, coordinate with Debian and Upstreams, huge +1 from me
15:45 <mitya57> Let me also give a +1 to ginggs if you don't mind :)
15:46 <barry> ginggs: hi.  in your endorsements section, there is a criticism about "over-eagerness to sru".  what's your criteria for deciding whether to sru a fix or not?
15:47 <ginggs> If it affects a lot of users or the fix is trivial, I'll try for an SRU
15:49 <barry> ginggs: do you think the effort to sru fixes is too high, too low, or just right?
15:51 <ginggs> I would say it's just right; it's not so easy as to make one want to SRU everything, and it's not so difficult as to make one avoid it altogether
15:54 <Laney> Do you keep up with the testing status of things you have SRUed?
15:54 <Laney> Sometimes things can linger in -proposed
15:56 <ginggs> yes, I usually give other people a chance to test and if no responses after 7 days I will test again myself and change the verification status
15:56 <barry> ginggs: i notice the conflict regarding sru's between your endorsement feedback and your comment about "what i like least in ubuntu".  how do you resolve these two viewpoints?
16:01 <ginggs> I don't think it will make me want to SRU any less, but if I had upload rights at least my uploads wouldn't be taking up the sponsors team's time
16:01 <bdrung_work> ginggs: did your SRUs had any regressions?
16:02 <ginggs> i don't believe so
16:23 <dholbach> ginggs, congratulations! :)
16:23 <tumbleweed> ginggs: \o/
16:23 <stgraber> the chair for our next meeting (January 13th) will be tumbleweed
16:23 <stgraber> #topic AOB
16:23 <stgraber> anything?
16:23 <Laney> it should be ScottK since he missed this one
16:23 <stgraber> oh, good point
16:23 <stgraber> I'll just move myself at the back of the rotation, that should do it
16:23 <barry> stgraber: yep
16:24 <stgraber> #endmeeting