16:02 <hallyn_> #startmeeting
16:02 <meetingology> Meeting started Tue Sep  3 16:02:22 2013 UTC.  The chair is hallyn_. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02 <hallyn_> #topic Review ACTION points from previous meeting
16:02 <hallyn_> arosales to update Juju blueprints
16:03 <arosales> hallyn_, got some good updates during the sprint last week.
16:03 <hallyn_> and bp is updated?
16:03 <hallyn_> will assume yes :)
16:03 <hallyn_> hallyn_ to coordinate with zul and smb on testing xen 4.3 on nova
16:04 <hallyn_> done - tested fine
16:04 <hallyn_> zul to follow up on mariadb/percona making it into Saucy
16:04 <hallyn_> zul: done?
16:04 <jamespage> we have a catchup in +2 hrs about that with percona
16:04 <jamespage> mariadb is still in review in Debian
16:04 <hallyn_> cool, i'll count that as up-followed
16:05 <hallyn_> thx
16:05 <jamespage> and percona expect to work on it next month
16:05 <jamespage> saucy looking unlikely
16:05 <hallyn_> ok
16:05 <hallyn_> #topic Saucy Development
16:05 <hallyn_> #link http://reports.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:06 <hallyn_> looking through the high prio ones, not sure those pertain to us
16:06 <hallyn_> oh there we go
16:07 <arosales> hallyn_, yes sorry for the delay. Yes got some good BP updates
16:07 <hallyn_> bug 1208455 - we can talk about during smb's section
16:07 <ubottu> bug 1208455 in linux (Ubuntu Saucy) "general protection fault running apt-get inside double nested kvm VM" [High,In progress] https://launchpad.net/bugs/1208455
16:07 <hallyn_> arosales: great, thanks
16:07 <hallyn_> bug 1213915
16:07 <ubottu> bug 1213915 in ceph (Ubuntu Saucy) "Please demote ceph-mds and ceph-fs-common to universe" [High,New] https://launchpad.net/bugs/1213915
16:07 <hallyn_> jamespage: ?
16:07 <jamespage> with archive admins
16:07 <jamespage> no further action on our part required
16:08 <hallyn_> thx
16:08 <hallyn_> bug 1206872
16:08 <ubottu> bug 1206872 in samba (Ubuntu Saucy) "samba fails to unpack (behavior change in patch) and ftbfs on aarch64" [High,Incomplete] https://launchpad.net/bugs/1206872
16:08 <hallyn_> zul: ^ ?
16:08 <hallyn_> also bug 1156932
16:08 <ubottu> bug 1156932 in python-novaclient (Ubuntu Saucy) "User can't modify security-group-rule via nova-api if there are duplicated security group name" [High,Confirmed] https://launchpad.net/bugs/1156932
16:08 <jamespage> thats fixed
16:08 <zul> will look at it this week
16:08 <hallyn_> and bug 1199791
16:08 <ubottu> bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged] https://launchpad.net/bugs/1199791
16:08 <zul> jamespage:  the samba one/
16:08 <jamespage> yeah
16:08 <jamespage> nova security groups thing is not and probably won't be I guess
16:09 <zul> jamespage:  i was hoping for the nova security one ;)
16:09 <jamespage> nah
16:09 <hallyn_> jamespage: sorry, won't be what?
16:09 <jamespage> its not that of a biggy
16:09 <jamespage> won't be fixed
16:09 <hallyn_> ok
16:09 <hallyn_> last high prio one is bug 1214615
16:09 <ubottu> bug 1214615 in juju-core (Ubuntu Saucy) "package juju-core 1.13.1-0ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2" [High,Fix released] https://launchpad.net/bugs/1214615
16:09 <jamespage> I just closed that
16:10 <jamespage> I realized my mistake just after uploading but someone raised a bug Idid not spot
16:10 <hallyn_> i see that :)  thx
16:10 <hallyn_> ok, so moving on to blueprints
16:10 <jamespage> that horizon r/w on /usr/share is a pig as well
16:10 * jamespage bumps the priority
16:10 <hallyn_> jamespage: oh?
16:11 <jamespage> I hit is yesterday when testing a few updates for horizon
16:11 <hallyn_> bug 1216019
16:11 <jamespage> I'll have a look
16:11 <ubottu> bug 1216019 in horizon (Ubuntu Saucy) "Horizon default config assumes www-data has R/w on /usr/share... directory" [High,Confirmed] https://launchpad.net/bugs/1216019
16:11 <hallyn_> jamespage: thx
16:11 <jamespage> yeah - horizon tries to store/retrieve a secret
16:11 <jamespage> is horrid
16:11 <hallyn_> ok, so moving on -
16:11 <hallyn_> [LINK] http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:11 <hallyn_> arosales: jamespage: ^
16:11 * hallyn_ defers
16:12 <jamespage> good oh
16:12 <arosales> smoser, jamespage did vUDS allow for some good BP updates?
16:12 <jamespage> looks like everything might have had a good catchup after uds last week
16:12 <arosales> ah ok
16:12 <jamespage> roaksoax, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2
16:12 <jamespage> any updates?
16:13 <jamespage> bah - we are stuck on the hard stuff - active/active rabbitmq and active/active mysql
16:13 <roaksoax> jamespage: nope, I'll start this week to work on the charms (cause got distracted last week with toher stuff) right now in training
16:13 <jamespage> I started to look at charming percona/cluster using upstream repositories
16:13 <jamespage> it feel fragile still
16:13 <jamespage> anyway..
16:13 <smoser> arosales, i did a far amount of bp updates. if nothing else, vuds did give a reasonable time slot for that.
16:14 <jamespage> smoser, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-simplestreams
16:14 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-init
16:14 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-qa got a bit of a replan post vUDS
16:15 <jamespage> so s'ok
16:15 <smoser> jamespage, simplestreams is in correct state.
16:15 <jamespage> zul, please can you update and re-plan https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-havana against remaining milestones
16:15 <smoser> cloud-init i'm updating now.
16:15 <zul> ack
16:16 <zul> jamespage:  will do so this afternoon
16:16 <jamespage> I don't think mongodb will make main this cycle - https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-mongodb
16:16 <jamespage> but hopefully we can figure out something with upstream for 14.04
16:16 <zul> arrgh
16:16 <jamespage> that said we are now ship-shape on OpenSSL + AGPL linking exceptions
16:17 * jamespage thanks MongoDB for doing that
16:17 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms
16:17 <jamespage> adam_g, I think that needs an update post UDS session please; with milestones etc...
16:18 <adam_g> jamespage, ack
16:18 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-cloud-archive
16:18 <jamespage> replanned and OK
16:18 <jamespage> zul, smb, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-hypervisor  has some immediate work items that need attention
16:19 <jamespage> specifcally FFe's for openstack stuff
16:19 <zul> FFE filed for xen
16:19 <smb> https://bugs.launchpad.net/ubuntu/+source/xen/+bug/1218817
16:19 <ubottu> Launchpad bug 1218817 in xen (Ubuntu) "[FFE] Update to Xen-4.3 in Saucy" [High,New]
16:19 <jamespage> zul, please update the blueprint then
16:19 <zul> FFE filed for openstack-lxc coming today
16:19 <jamespage> thanks
16:19 <smb> jamespage, thought I did update the bp
16:19 <jamespage> smb; so you did - my mistake
16:20 <jamespage> arosales, want to touch on the juju blueprints?
16:20 <jamespage> I'm not so close to those...
16:21 <jamespage> nope -OK
16:21 <jamespage> looks like not to many issues anyway
16:21 <jamespage> hallyn_, back to you
16:21 <arosales> jamespage, I think we are good for this week
16:21 <hallyn_> jamespage: thanks, moving on,
16:21 <arosales> plus looks like I lost my chance :-)
16:21 <jamespage> arosales, lol
16:21 <jamespage> blink and you miss it
16:21 <hallyn_> :)
16:21 * arosales too slow
16:21 <hallyn_> #topic Ubuntu Server Team Events
16:22 <hallyn_> plumber's is comgin up with several mini-confs (lxc, virt, security...)
16:22 * smb will be there
16:22 <hallyn_> any more coming up?
16:22 <arosales> charm school this friday
16:22 <arosales> https://juju.ubuntu.com/events/
16:23 <arosales> How to use Charm Helpers
16:23 <arosales> 1700 UTC (1pm EDT) 6 September
16:23 <arosales> #juju on Freenode
16:23 <hallyn_> and maybe what charm helpers are? :)  /me should consider listening in
16:23 <hallyn_> ok, moving on,
16:23 <hallyn_> #topic Weekly Updates & Questions for the QA Team (plars)
16:23 <arosales> yes if you don't know what charms are please join us and find out :-)
16:23 <jamespage> charm helpers help you write charms in less code +10000
16:23 <zul> lol
16:24 <hallyn_> plars: psivaa: \o
16:24 <hallyn_> we can come back if need be,
16:24 <hallyn_> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:24 <psivaa> hello
16:24 <smb> too late ? :)
16:24 <psivaa> no updaes from us btw :)
16:24 <hallyn_> psivaa: ok thanks :)
16:24 <smb> So just for that kvm bug mentioned before...
16:24 <smb> I cannot say more than that is seems to be some regression with 3.11 (maybe 3.10 already). I just managed to write a lengthy email to the kvm mailing list this morning as I am not sure how to drill down further. Basing on 64bit Precise  and 64bit Saucy on level 1 for a level 2 should be mostly working but adding more saucy to deeper nesting is likely prone to fail.
16:25 <hallyn_> smb: so 3.9-under-3.9 wouldn't have had this problem?
16:25 <hallyn_> (I thought jodh was having trouble iwth earlier kernels, but maybe i mis-remember)
16:25 <smb> hallyn_, I think only 32bit user-space in level 1 seems to have been broken a bit longer
16:26 <hallyn_> oh. right.  we have multiple bugs?
16:26 <smb> Likely
16:26 <hallyn_> lovely
16:26 <hallyn_> ok so, we're waiting on community to jump in.  this can be rperoduced with fedora or some other distros i assume?
16:26 <smb> I hope but I have not tried
16:27 <hallyn_> ok.  (mahbe i'll try later this week)  any other questions for smb
16:27 <hallyn_> if not, we can move on to...
16:27 <hallyn_> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:27 <rbasak> Nothing new from me. Any questions?
16:28 <hallyn_> (waiting 30 secs for responses)
16:28 <hallyn_> great, let's move on to
16:28 <hallyn_> #topic Open Discussion
16:29 <hallyn_> anything?
16:29 <rbasak> In case anyone is unaware, http://status.qa.ubuntu.com/reports/ubuntu-server/triage-report.html needs some love.
16:29 <hallyn_> oh yeah - can we do any automated cleanup of the likewise-open bugs?
16:30 <hallyn_> jamespage: ^ that looks like yoru ba
16:30 <hallyn_> bag
16:30 <jamespage> golly
16:30 <jamespage> yes
16:30 <jamespage> I'll take a look
16:31 <jamespage> but if the rest of the team can have a dirge on bug triage this week/next that would be helpful
16:31 * jamespage holds up his hand for being a little neglegent on triage duty recently
16:31 <hallyn_> jamespage: ok, thanks :)  i looked at some by hand, and actually they looked like not all the same causes - but it's hard to tell bc i don't know the package that well
16:31 <hallyn_> i'd also like to consider taking all < 1000000 numbered likewise-open bugs and marking them all dups or something
16:32 <hallyn_> but ok, let's say
16:32 <hallyn_> [ACTION] everyone spend extra time triaging bugs this week
16:32 * meetingology everyone spend extra time triaging bugs this week
16:32 <hallyn_> so we can move on to
16:32 <hallyn_> #topic Announce next meeting date, time and chair
16:32 <hallyn_> Should be Tuesday Sep 10 at 16:00 UTC, with the magnificent roaksoax chairing
16:33 <hallyn_> thanks everyone \o
16:33 <hallyn_> #endmeeting