16:02 <jamespage> #startmeeting
16:02 <meetingology> Meeting started Tue Jul 23 16:02:00 2013 UTC.  The chair is jamespage. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:02 <jamespage> #topic review previous actions
16:02 <jamespage> rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:02 <jamespage> rbasak, Daviey- hows that going?
16:03 <jamespage> zul:
16:03 <jamespage> zul has willfully volunteered to review and document what is blocking server related saucy-proposed migration excuses, with joy.
16:03 <jamespage> I think thats all sorted now right
16:03 <jamespage> ?
16:03 <zul> bah
16:03 <zul> almost apache2 again i think
16:03 <zul> rbasak:  ^^^
16:04 <jamespage> anyone actually here?
16:04 <jamespage> lol
16:04 <jamespage> anyway
16:04 <jamespage> #action rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:04 * meetingology rbasak to land delta report to lp:ubuntu-reports, Daviey to deploy
16:04 <hallyn> my bot is...
16:04 <jamespage> carried forward in their absence
16:04 <jamespage> #topic Saucy Development
16:05 <jamespage> #link https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:05 <jamespage> Debian Import Freeze is on the 25th July - manual syncs after that point will be required
16:05 <jamespage> alpha2 same week - we will be opting out again
16:06 <jamespage> also worth noting that 12.04.3 is just under a month away
16:06 <jamespage> the QA team now have some dkms auto-testing setup
16:06 <jamespage> openvswitch and iscsitarget are going to need some attention in the next two weeks.
16:06 <hallyn> ?
16:06 <jamespage> (as are lots more I guess)
16:07 <jamespage> hallyn, hardware enablement kernels
16:07 <rbasak> Oops, sorry. ubuntu-reports is almost ready for an MP. apache2 is done. I'm preparing a merge with an upgrade path bug and SSL passphrase prompting fixed.
16:07 <jamespage> 12.04.3 will get rarings 3.8 kernel
16:07 <jamespage> rbasak, marvellous!
16:07 <hallyn> jamespage: gotcha
16:07 <jamespage> next
16:07 <jamespage> #subtopic Release Bugs
16:07 <jamespage> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:08 <jamespage> I still need to look at asm4 transitions
16:08 <jamespage> and quantum service respawns
16:09 * jamespage berates himself again
16:09 <yolanda> lua5.2 is pending from review
16:09 <jamespage> ack
16:09 <hallyn> there's a yucky memleak in libvirt i need to look into
16:09 <yolanda> rrdtool and rubyluabridge
16:09 <rbasak> bug 1202653 should be targetted for Saucy. It's in hand though - I just want to fix SSL certificate prompting at the same time, write a dep8 test for that, and in any case proposed migration will be blocked as it's seeded in alpha-2 opt-in flavours.
16:09 <jamespage> zul: https://bugs.launchpad.net/ubuntu/+source/nova/+bug/1199791
16:09 <ubottu> bug 1202653 in apache2 (Ubuntu) "apache2 2.4.4-6ubuntu4 failed to upgrade: Cannot load /usr/lib/apache2/modules/libphp5.so into server: undefined symbol: unixd_config" [High,In progress] https://launchpad.net/bugs/1202653
16:09 <ubottu> Ubuntu bug 1199791 in nova (Ubuntu Saucy) "nova-compute-xcp misses nova-compute.conf" [High,Triaged]
16:09 <jamespage> rbasak, done
16:09 <zul> in progrress
16:09 <rbasak> thanks
16:09 <jamespage> zul, great - thanks
16:10 <jamespage> looks like adam_g's cheetah fixup is almost done
16:11 <adam_g> yup, should make its way out today
16:12 <jamespage> rbasak, whats the latest on bug 1031680?
16:12 <ubottu> bug 1031680 in nagios-plugins (Ubuntu Raring) "check_apt always report 0 critical updates" [High,Triaged] https://launchpad.net/bugs/1031680
16:13 <jamespage> and that covers release bugs....
16:13 <jamespage> #subtopic Blueprints
16:13 <rbasak> No progress.
16:13 <jamespage> #link http://status.ubuntu.com/ubuntu-s/group/topic-s-servercloud-overview.html
16:13 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-mongodb
16:13 <jamespage> use of libv8 in the mongodb shell is causing some security concerns re supportability
16:13 <jamespage> which is understandable
16:14 <jamespage> looking at a shell disabled variant of the package - but I suspect thats worse than useless
16:14 <jamespage> so we might be inthe position where mongodb is not suitable for main inclusion
16:14 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-juju-2-delivery
16:14 <jamespage> juju2 release going much smoother now
16:14 <jamespage> two in the last week
16:15 <jamespage> (one for OSCON)
16:15 <jamespage> local provider has also landed if no-one noticed - works well (thanks thumper)
16:15 <jamespage> roaksoax, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms-ha-v2
16:15 <jamespage> whats happening with HA stack for saucy? I know we have had a few conversations?
16:16 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-ceph reappears
16:16 <jamespage> utlemming, https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-webscale
16:16 <jamespage> utlemming, are you likely to have capacity to work on this blueprint this release? its already a carry over from raring
16:17 <jamespage> zul: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-qa
16:17 <jamespage> needs some updates
16:18 <zul> jamespage:  ack
16:18 <jamespage> quite a few activities need to be worked on still this cycle there - might be work allocating out and postponing anything we know we won't get to this cycle
16:18 <jamespage> adam_g, ^^
16:19 <hallyn> s/work/worth/ ?
16:19 <adam_g> agree
16:19 <jamespage> hallyn, yes
16:19 <roaksoax> jamespage: sorry i'm supper lagged
16:19 <hallyn> k
16:19 <jamespage> roaksoax, ack
16:19 <jamespage> roaksoax, wanna update now?
16:19 * jamespage gives roaksoax a few to respond
16:20 <jamespage> zul: https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-havana
16:20 <jamespage> lots of things actually done there I think
16:20 <jamespage> good point to catchup now that havana2 is landing everywhere
16:20 <zul> ill upate it today
16:21 <jamespage> arosales, quite a few juju related ones with minimal progress - do you want to go through those now?
16:21 <jamespage> https://blueprints.launchpad.net/ubuntu/+spec/servercloud-s-openstack-charms
16:21 <jamespage> adam_g, roaksoax and I have been working on the python redux of the openstack charms
16:22 <jamespage> looking quite good now - hopefully we should have a full set of initial versions this week
16:22 <adam_g> im hoping to have all of the bash -> python rewrites ready for testing this week
16:22 <jamespage> \o/
16:23 <jamespage> OK - anyone got any other BP related stuff they wanted to raise/query?
16:23 <jamespage> ....
16:23 <jamespage> ...
16:23 <jamespage> ..
16:23 <yolanda> mine of server banners is stuck, working on other issues
16:23 <jamespage> .
16:24 <jamespage> yolanda, is that just pending sponsorship or are you getting blocked?
16:24 <arosales> jamespage, sorry I was in another window
16:24 <yolanda> jamespage, i stopped working on that for a while, working on syncs and merges, and now in charms
16:24 <jamespage> yolanda, OK
16:25 <jamespage> arosales, juju blueprints?
16:25 <yolanda> i got some of them uploaded, bind9 is pending on review
16:25 <arosales> jamespage, a couple of the owners are at OSCON so I can take an action to review juju related ones this week
16:25 <arosales> #action arosales to review Juju blueprints
16:25 * meetingology arosales to review Juju blueprints
16:25 <jamespage> #action arosales to review juju related blueprints with owners after OSCON
16:25 * meetingology arosales to review juju related blueprints with owners after OSCON
16:25 <jamespage> ooops
16:25 <jamespage> oh well - we will remember twice now!
16:25 <jamespage> lets move on
16:25 <jamespage> #topic Ubuntu Server Team Events
16:26 <jamespage> something called OSCON I think
16:26 <jamespage> anyone going?
16:26 <hallyn> i'm guessing if they are, they are there already
16:26 <jamespage> lol
16:26 <jamespage> yes
16:26 <jamespage> any other events folk want to raise now?
16:26 <arosales> m_3 and jcastro @ OSCON
16:26 <arosales> giveing a Charm School talk as we chat here
16:27 <jamespage> excellent - hope its packed....
16:27 <jamespage> #topic Weekly Updates & Questions for the QA Team (plars)
16:27 <jamespage> plars, floor is yours
16:27 <plars> hi, a couple of bugs are affecting server testing at the moment
16:27 <plars> both on the virtual host part
16:27 <plars> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1203694 and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1203211
16:28 <ubottu> Ubuntu bug 1203211 in linux (Ubuntu) "duplicate for #1203694 Modprobe doesn't recognize any parameters on 3.10.0-4" [Critical,Fix committed]
16:28 <ubottu> Ubuntu bug 1203211 in linux (Ubuntu) "Modprobe doesn't recognize any parameters on 3.10.0-4" [Critical,Fix committed]
16:28 <smb> should be fixed by -5 in proposed
16:28 <plars> bot seem to be well on their way though :)
16:28 <plars> ack
16:28 <rbasak> AIUI the release team are working on landing -5.
16:28 <jamespage> excellent
16:28 <plars> sounds good
16:28 <plars> that's it from me
16:28 <jamespage> thanks plars
16:28 <jamespage> anyone got anything else qa related while we are here? matsubara maybe?
16:29 <jamespage> ....
16:29 <jamespage> ...
16:29 <jamespage> ..
16:29 <jamespage> .
16:29 <matsubara> not really
16:29 <jamespage> ack
16:29 <jamespage> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:29 <smb> There seem also to be some problem with qemu and vmvga crashing the host which apw is working on.
16:30 <smb> The bug number slipped my brain though
16:30 <smb> ah
16:30 <smb> bug 1204005
16:30 <ubottu> bug 1204005 in linux (Ubuntu) "[saucy] kvm host hangs of guest boot with 3.10.0-5" [Critical,Triaged] https://launchpad.net/bugs/1204005
16:31 <smb> Apart from that I cannot think of anything hot right now (exccept the weather)
16:31 <smb> Are there questions?
16:31 <jamespage> smb, thanks
16:31 <jamespage> sound like a no for questions...
16:31 <jamespage> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:32 <rbasak> Nothing new to report. Any questions for me?
16:32 <jamespage> not from me
16:32 <jamespage> anyone else?
16:33 <jamespage> OK
16:33 <jamespage> #topic Open Discussion
16:33 <jamespage> anything anyone wants to raise?
16:33 <arosales> UDS fastly approaching
16:33 <jamespage> discuss or otherwise argue about?
16:33 <arosales> http://uds.ubuntu.com/
16:33 <zul> yeah i raised this
16:33 <roaksoax> jamespage: basically, I'm currently updating the cluster stack, which means the removal of 'redhat-cluster' from the archives. All cluster will be based on pacemaker+corosync2.0, gfs2 + dlm (a new package that needs to be uploaded)
16:33 <roaksoax> for distributed storage
16:33 <roaksoax> /filesystem
16:33 <jamespage> roaksoax, man - that is some lag - thanks for the update
16:34 <zul> https://bugs.launchpad.net/ubuntu/+source/quantum/+bug/1203766
16:34 <ubottu> Ubuntu bug 1203766 in quantum (Ubuntu) "Please remove from Ubuntu Archive" [Undecided,New]
16:34 <roaksoax> and all packages that used to depend on redhat-cluster related dependencies need to be update
16:34 <arosales> ah sorry for the dup zul
16:34 <jamespage> good point about UDS _ only a month away
16:34 <jamespage> good point to recheck on progress for saucy so far
16:34 <zul> that should be interesting
16:35 <jamespage> just to be clear - quantum is now called neutron if anyone missed that
16:35 <jamespage> its not another new core project in openstack
16:35 <jamespage> :-)
16:35 <jamespage> anyway
16:35 <jamespage> #topic Announce next meeting date and time
16:36 <jamespage> Tuesday 30th July - 1600 GMT
16:36 <jamespage> see you then
16:36 <jamespage> #endmeeting