16:01 <smoser> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue Jun  4 16:01:38 2013 UTC.  The chair is smoser. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01 <smoser> #topic Review ACTION points from previous meeting
16:01 <adam_g> o/
16:01 <arosales> smoser, I ~still~ need to contact norvald
16:02 <arosales> :-/
16:02 <arosales> sorry
16:02 <arosales> I _will_ send an email today
16:02 * smoser carried foward.     (carried forward)
16:02 <smoser> #ACTION arosales [carried forward] to follow up with Norvald regarding SRU
16:02 * meetingology arosales [carried forward] to follow up with Norvald regarding SRU
16:03 <smoser> there.
16:03 * smoser thanks arosales for the cut and paste commands at https://wiki.ubuntu.com/ServerTeam/Meeting/IRCCommands
16:03 <hallyn> +1
16:03 <smoser> #topic Raring Development
16:03 <smoser> #link https://wiki.ubuntu.com/RaringRingtail/ReleaseSchedule
16:04 <smoser> hm..
16:04 <smoser> where is our url for pretty graphs like https://wiki.ubuntu.com/RaringRingtail/ReleaseSchedule
16:04 <smoser> gah
16:04 <smoser> like
16:04 <roaksoax> o/
16:04 <smb> Sounds a tad outdated?
16:04 <smoser> http://status.ubuntu.com/ubuntu-s/
16:04 <arosales> I just updated them, I think another kind person originally made it.
16:04 <arosales> smoser, I think I need to make a topic url
16:04 <smoser> https://wiki.ubuntu.com/SaucySalamander/ReleaseSchedule
16:04 <arosales> sorry a topic blueprint
16:04 <smoser> can i action you for that ?
16:04 <arosales> #action arosales create a overview topic bp for servercloud
16:04 * meetingology arosales create a overview topic bp for servercloud
16:05 <smoser> good.
16:05 * arosales think I also volunteered for that last week, running behind on my todos :-(
16:05 <smoser> #subtopic Release Bugs
16:05 <smoser> http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:06 <smoser> i dont know how relevant that url is at this point in the cycle.
16:06 <smoser> (in addition to the fact that i posted a -r- url again)
16:06 <smoser> http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-s-tracking-bug-tasks.html#server
16:06 <smoser> #topic Blueprints
16:07 <smoser> we need some help from here from arosales, so next week we'll have a pretty graph.
16:07 * arosales will work on that _today_
16:07 <smoser> ok. so 2 things here.
16:08 <smoser> a.) if you have expected work for 13.04 that is not covered by a blueprint starting with 'servercloud-s-' at https://blueprints.launchpad.net/~davewalker/+specs?role=approver
16:08 <smoser> then please contact myself or jamespage to help you get on that list.
16:09 <smoser> b.) if you have something on that list in some state other than 'Approved', then you should make some effort to change that.
16:09 <smoser> (smoser looks in a mirror and says "I'm talking to you")
16:09 <smoser> other blueprints in such a state are:
16:09 <smoser> servercloud-s-cloud-kvm-on-arm: hallyn
16:10 <smoser> servercloud-s-enterprise-testing: jamespage
16:10 <smoser> servercloud-s-fastpath-install: smoser
16:10 * hallyn not sure what that means.
16:10 <smoser> servercloud-s-interlock: Daviey
16:10 <smoser> servercloud-s-maas-next-steps: roaksoax
16:10 <smoser> servercloud-s-openstack-hypervisor: zul
16:10 <smoser> servercloud-s-openstack-pkg: zul
16:11 <hallyn> smoser: can you please drop servercloud-s-cloud-kvm-on-arm ?
16:11 <smoser> one other one for zul and one for smoser.
16:11 <hallyn> or cani do that, hm
16:11 <zul> can you drop servercloud-s-oepnstack-pkg: its going to be folded into the main openstck blueprint
16:12 <smoser> hm..
16:12 <smoser> ok. we'll figure out what to do on those.
16:12 <hallyn> thx
16:12 <hallyn> i marked it deferred for now.
16:13 <smoser> just put both of them as 'definition: obsolete'
16:13 <smoser> zul, ^
16:13 <hallyn> ok
16:13 <zul> ok cool
16:13 <smoser> anyone have anything else here?
16:13 <smoser> #topic Ubuntu Server Team Events
16:14 <smoser> anyone have events coming up ?
16:14 <smoser> ok. i dont. so moving on.
16:14 <smoser> #topic Weekly Updates & Questions for the QA Team (plars)
16:14 <psivaa> i am in for plars today
16:15 <psivaa> nothing much from our side
16:15 <smoser> anyone have questions for psivaa ?
16:15 <smoser> k. moving on. thanks for coming p
16:15 <smoser> k. moving on. thanks for coming psivaa
16:15 <smoser> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:15 <smb> No kernel specific things to report (some user-space issues, though). Maybe I should remind anybody having kernel problems which I should (or am supposed to) be looking at, to remind me (again) if I have not been active on reports. Are there questions?
16:16 <smb> smoser, And I likely will try to talk to you about Xen stable (micro) updates and tech-board at some point later...
16:16 <smb> ...
16:16 <smoser> i dont have anything for you, smb.
16:16 <smoser> sometime, sooner than later, daviey or i or someone needs to look at "medium" sized kernel for server
16:17 <hallyn> smb: do you know if there are any overlayfs work items for kernel?
16:17 <smoser> (ie, one block net and other important-to-server modules, but not "desktop" like drivers)
16:17 <smb> hallyn, I thought apw was doing something
16:17 <hallyn> (there are some (well at least one) open bugs, wondering if fixing them is going to be actively done, or passively waited for)
16:17 <hallyn> if anyone was i assumed it was him :)
16:18 <hallyn> just wondering, i can looka round later
16:18 <smoser> hallyn, you have a list of said bugs ? it would be good to have them collected if nothing else.
16:18 <smoser> i'd be interested in seeing it.
16:18 * smoser has been bit by no inotify support
16:18 <smoser> bug 882147
16:18 <ubottu> bug 882147 in coreutils (Ubuntu) "overlayfs does not implement inotify interfaces correctly" [Undecided,In progress] https://launchpad.net/bugs/882147
16:18 <smb> smoser, The medium size package thing, you probably may be successful in replacing current virtual, but there was not much rejoice for having yet another type
16:18 <hallyn> no not really. and i just deleted the emails
16:19 <smoser> good thinking on deleting stuff, hallyn :)
16:19 <smb> never leave paper trail. :)
16:20 <smoser> smoser, on medium sized, the goal woudl be replace -virtual, but i could see me asking for small medium an large for 13.10, one of which to be dropped for 14.04
16:20 <smoser> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:20 <smoser> rbasak, howdy
16:20 <rbasak> Hi
16:20 <rbasak> Nothing to report. Any questions for me?
16:21 <rbasak> I'm looking at a golang FTBFS that affects saucy but not sid
16:21 <smoser> nice.
16:21 <rbasak> That's about all in the ARM world right now.
16:21 <smoser> #topic Open Discussion
16:21 <hallyn> smoser: smb: bug 1098378
16:21 <ubottu> bug 1098378 in linux (Ubuntu Raring) "chroot+overlayfs seems to cause umount mis-behavior" [High,Confirmed] https://launchpad.net/bugs/1098378
16:21 <hallyn> (and bug 1007089)
16:21 <ubottu> bug 1007089 in linux (Ubuntu) "overlayfs alters /proc/self/exe link(s), making result a dead link." [Medium,Confirmed] https://launchpad.net/bugs/1007089
16:21 <rbasak> I've applied for Ubuntu server dev upload rights.
16:22 <rbasak> Comments and/or endorsements appreciated: https://wiki.ubuntu.com/RobieBasak/ServerDeveloperApplication
16:22 <smoser> hallyn, https://bugs.launchpad.net/ubuntu/+source/linux/+bugs?field.tag=overlayfs
16:22 <smb> hallyn, I will fwd them
16:23 <smoser> i just tagged those 3 bugs with 'overlayfs'
16:23 <hallyn> smoser: cool, thanks
16:23 <smoser> oh.. as far as endorsements go...
16:23 * xnox wishes for 882147 (inotify) to be fixed =))))
16:24 <smoser> caribou, is also seeking contributing developer
16:24 <caribou> smoser: indeed I am
16:25 <smoser> so anyone who's seen his good work (myself included) should feel free/priviledge/expected to update https://wiki.ubuntu.com/LouisBouchard
16:25 * caribou would be honoured :-)
16:25 <smoser> anything else ?
16:26 <smoser> #topic Announce next meeting date and time
16:26 <smoser> this concludes our regularly scheduled program
16:26 <smoser> tune in next week for more exciting server team development
16:26 <rbasak> Thanks for chairing, smoser!
16:26 <smoser> next meeting Tuesday 2013-06-11 at 1600 UTC - #ubuntu-meeting
16:26 <smoser> #endmeeting