16:01:04 <hallyn> #startmeeting ubuntu-server-team
16:01:04 <meetingology> Meeting started Tue Feb 26 16:01:04 2013 UTC.  The chair is hallyn. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01:04 <meetingology> 
16:01:04 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
16:01:06 <hggdh> ~รด~
16:01:07 <jamespage> o/
16:01:14 <hallyn> #topic Review ACTION points from previous meeting
16:01:22 <hallyn> Daviey send call for alpha-2-ish testing
16:01:46 <hallyn> didn't see this?
16:02:06 <Daviey> Ugh. I thought we dropped that.
16:02:15 <hallyn> Daviey: last week it was re-added.  should we drop it?
16:02:28 <hallyn> wait for a beta to do CFT?
16:02:34 <Daviey> hallyn: Yes please.. but i will gladly send a reminder to ask people to test
16:02:50 <Daviey> matsurba has kidnly offered to help with dep-8 tests BTW.
16:02:58 <Daviey> kindly*
16:02:59 <hallyn> cool
16:03:08 <hallyn> (i have 2 i'm still supposed tow rite)
16:03:08 <jamespage> \o/
16:03:10 <hallyn> moving on,
16:03:11 <hallyn> jamespage to milesone documentation updates [carryover]
16:03:47 <jamespage> hallyn, I need to refresh my memory as to what that means
16:04:07 <jamespage> but please carryover for the time being
16:04:08 <hallyn> jamespage: i think it meant going through blueprints looking for doc updates, and adding milestones to them?
16:04:12 <hallyn> ok
16:04:15 <jamespage> hallyn, yeah - I think so
16:04:19 * hallyn jamespage to milesone documentation updates [carryover]
16:04:28 <hallyn> jamespage: though it was in the context of server guide, so not sure
16:04:34 <hallyn> jamespage discuss QA representation at Server TeamMeeting
16:04:55 <jamespage> yes - hggdh is here today and plars will be attending from now onwards...
16:04:58 <plars> hallyn: I'll be taking that over
16:05:17 <jamespage> plars, welcome!
16:05:28 <hallyn> cool, so i'll update that in the server meeting knowledgebase page
16:05:35 <hggdh> and I am disconnecting from representing QA :-)
16:05:38 <hallyn> #action serge update server meeting docs to reflect palrs representing qa
16:05:38 * meetingology serge update server meeting docs to reflect palrs representing qa
16:05:55 <hallyn> hggdh: :(
16:06:00 <plars> s/palrs/plars
16:06:00 <hallyn> plars: welcome :)
16:06:13 <plars> thanks!
16:06:14 <hallyn> plars: sorry, fingers cold, hard typing
16:06:17 <arosales> yes hggdh :-(
16:06:21 <arosales> but welcome plars :-)
16:06:21 <hallyn> ok moving on,
16:06:23 <hallyn> #topic Raring Development
16:06:41 <hallyn> Release Tracking Bug Tasks - http://reports.qa.ubuntu.com/reports/rls-mgr/rls-r-tracking-bug-tasks.html#server
16:06:54 <hallyn> jamespage: Daviey: one of you want to take th is, or should i go over them?
16:07:11 <hallyn> well i'll start,
16:07:12 <hallyn> bug 1092715
16:07:14 <ubottu> bug 1092715 in qemu-kvm (Ubuntu Raring) "udevadm trigger --action=change not working in quantal and raring" [High,Confirmed] https://launchpad.net/bugs/1092715
16:07:24 <hallyn> the kvm bug *should* be worked around now,
16:07:30 <hallyn> jamespage: can you confirm that?
16:07:35 <jamespage> hallyn, I'll check
16:07:38 <hallyn> or... is that only in 1.4.0 (which is still pending my pushing)
16:07:42 <hallyn> jamespage: thanks
16:07:54 <hallyn> bug 1044503
16:07:56 <ubottu> bug 1044503 in maas (Ubuntu Raring) "kernel command line is not easily customizable" [High,Triaged] https://launchpad.net/bugs/1044503
16:08:06 <Daviey> hmm, i thought that was fixed now
16:08:10 <hallyn> smoser: ?
16:08:24 <hallyn> fixed in the project but not the package, looks like
16:08:51 <Daviey> smoser: does bug 901600 not solve bug 1044503 ?
16:08:53 <ubottu> bug 901600 in grub2 (Ubuntu Quantal) "Allow /etc/default/grub overriding via /etc/default/grub.d/" [High,Fix released] https://launchpad.net/bugs/901600
16:09:10 <smoser> i think hally's assesment is correct wrt 1044503.
16:09:16 <Daviey> Oh, duh.. the bug title confused me
16:09:30 <hallyn> so that'll end up in the pkg before long?
16:10:04 <hallyn> will assume so.  bug 1064527 - roaksoax ?
16:10:05 <smoser> i'd hope we'll get something in raring... but most focus on maas has been on backport.
16:10:06 <ubottu> bug 1064527 in maas (Ubuntu Raring) "detect_ipmi needs improvement. detects non-existant device in nested kvm" [High,Triaged] https://launchpad.net/bugs/1064527
16:10:12 <hallyn> smoser: thx
16:10:47 <hallyn> roaksoax: around?
16:10:54 <roaksoax> hallyn: here
16:11:32 <hallyn> any progress on that bug?  seems to be stalled since october?
16:11:51 <roaksoax> hallyn: well we haven't really found a way to do it.. so there's no progress
16:12:10 <hallyn> ok, thanks...
16:12:19 <hallyn> bug 1073463
16:12:20 <ubottu> bug 1073463 in maas (Ubuntu Raring) "User-configurable files are not installed in /etc" [High,Triaged] https://launchpad.net/bugs/1073463
16:12:25 <hallyn> not owned by anyone,
16:12:50 <hallyn> anyone want to volunteer to look at it?
16:12:56 <roaksoax> i;ll take it
16:13:00 <hallyn> cool, thanks
16:13:17 <roaksoax> but I think that bug doesn't belong there
16:13:31 <roaksoax> that belongs upstream
16:13:43 <hallyn> ok - you can re-target?
16:13:57 <roaksoax> hallyn: yes, I'll catch up with bigjools about it first
16:14:10 <hallyn> great
16:14:11 <hallyn> bug 1122206
16:14:13 <ubottu> bug 1122206 in quantum (Ubuntu Raring) "l3_agent destroys all namespaces on init, even if router_id is set" [High,Triaged] https://launchpad.net/bugs/1122206
16:14:38 <hallyn> fix released in quantum project, not pkg...
16:14:48 <hallyn> i assume we're jsut waiting - moving on unless someone shouts
16:15:05 <hallyn> bug 1132302
16:15:07 <ubottu> bug 1132302 in drbd8 (Ubuntu Raring) "drbd8-utils are not compatible with kernel 3.8" [High,Triaged] https://launchpad.net/bugs/1132302
16:15:33 <hallyn> looks like rbasak has that handled :)  thanks rbasak
16:15:48 <rbasak> np. Just waiting on the reporter to test, and if it's OK then we can upload
16:15:52 <hallyn> two medium bugs, tempted to skip them,
16:16:08 <hallyn> well there is bug 1100920 whic his fix committed,
16:16:10 <ubottu> bug 1100920 in cloud-init (Ubuntu Raring) "In Ubuntu 12.10, the legacy 'user' cloud-config option is not handled properly" [Medium,Triaged] https://launchpad.net/bugs/1100920
16:16:33 <hallyn> and then bug 1113821 - zul or i just needs to fix that in libvirt (same fix as in lxc)
16:16:35 <ubottu> bug 1113821 in libvirt (Ubuntu Raring) "libvirt-bin deletes /etc/dnsmasq.d/libvirt-bin on upgrade" [Medium,Triaged] https://launchpad.net/bugs/1113821
16:16:40 <hallyn> oh i own it :)
16:16:49 <hallyn> tsk tsk
16:17:02 <hallyn> ok, moving on,
16:17:07 <hallyn> Blueprints - http://status.ubuntu.com/ubuntu-raring/group/topic-raring-servercloud-overview.html
16:17:22 <hallyn> arosales: Daviey: did you want to say somethin gon blueprints?
16:17:39 <Daviey> Only the usual :)
16:17:52 <Daviey> Make sure they are accurate, we look a little behind where i think we actually *are*
16:18:07 <Daviey> So everybody should check that bluepritns assigned to them are in accurate state
16:18:27 <Daviey> (and talk with elither myself, or jamespage or smoser about defering thing)
16:18:48 <hallyn> Daviey: meaning at this point we should talk to you before deferring anything,
16:18:53 <hallyn> or ping you if we have questions?
16:19:42 <Daviey> yeah.. ideally not just defer things.. disucss with me, or scott or james.. first
16:19:52 <hallyn> ok
16:19:54 <hallyn> moving on,
16:19:56 <hallyn> #topic Ubuntu Server Team Events
16:20:20 <hallyn> anything to mention here?
16:20:24 <Daviey> none come to mind.
16:20:33 <hallyn> #topic Weekly Updates & Questions for the QA Team (hggdh)
16:20:48 <hallyn> three cheers for hggdh ?
16:21:41 <hallyn> plars:
16:21:47 <plars> Hi
16:21:50 <hallyn> hey :)
16:21:57 <plars> Just a couple of things
16:22:05 <plars> 1. LXC failures
16:22:11 <plars> https://bugs.launchpad.net/ubuntu-test-cases/+bug/1130029
16:22:13 <ubottu> Ubuntu bug 1130029 in Ubuntu Test Cases "testcase: test_lxc_api returns error in raring lxc server smoke tests" [High,Confirmed]
16:22:24 <plars> hallyn: you seem to have a mp for this at https://code.launchpad.net/~serge-hallyn/ubuntu-test-cases/server-lxc2/+merge/150491
16:22:27 <hallyn> merge proposal is pending to fix that
16:22:31 <hallyn> yup
16:22:43 <hallyn> (though i'm still getting the hang of utah, still testing locally, might have more changes coming)
16:23:14 <plars> If someone can get that reviewed and in soon, we'd like to test it out.  I was talking to psivaa this morning about it and he thinks there may be other issues lurking once we get past this one
16:23:41 <hallyn> plars: who has the rights to review that?
16:23:48 <plars> I'm not as well aware of what's going on with this bug, so if he or you want to discuss what further steps might be needed, that would be useful
16:24:01 <plars> hallyn: it seems to be pointed at https://launchpad.net/~ubuntu-server-dev right now
16:24:10 <hallyn> ?
16:24:22 <hallyn> ok will fix that, thanks :)
16:24:34 <plars> but as far as merging it, anyone in the https://launchpad.net/~ubuntu-test-case-dev group could do it
16:24:46 <hallyn> no here it says lp:ubuntu-test-cases/server
16:25:02 <hallyn> oh you mean reviewer
16:25:04 <plars> hallyn: I'm talking about the reviewer
16:25:05 <plars> right
16:25:07 <hallyn> i just used the default
16:25:23 <plars> ubuntu-server-dev is the default reviewer?
16:25:24 <plars> odd
16:25:25 <hallyn> is that something that should be changed in the ubuntu-test-case lp settings?
16:25:32 <plars> perhaps
16:25:58 <plars> I'll talk to others about it, but since it's a test for lxc, I figured it was something that you wanted reviewed by ubuntu-server-dev
16:25:59 <hallyn> ok thanks we'll straighten the mp out - moving on?
16:26:02 <plars> it made sense to me at least
16:26:03 <plars> ok
16:26:06 <hallyn> oh i see, ok
16:26:15 <plars> only other thing I wanted to raise (and it's minor) is conffile failures
16:26:15 <hallyn> no perhaps ubuntu-lxc
16:26:18 <plars> ex. https://jenkins.qa.ubuntu.com/view/Raring/view/Smoke%20Testing/job/raring-upgrade-quantal-server/ARCH=amd64,LTS=non-lts,PROFILE=server-tasks,label=upgrade-test/lastSuccessfulBuild/artifact/results/obsolete_conffiles.log
16:26:20 <hallyn> not ubuntu-server-dev
16:26:31 <plars> These are no longer reported as individual bugs
16:26:44 <plars> but we get a good log of them in the test runs that can be referred to
16:27:40 <plars> We realize that they are low priority as bugs go, and in some cases they stack up to dozens that would need to be tracked against every daily test run indefinitely.  So if you have some cycles and want to clean them up, it would be useful
16:27:53 <hallyn> these are confiles no longer used by cups in raring?
16:28:02 <plars> apparently not
16:28:10 <plars> or if they are, their location changed
16:28:47 <hallyn> and so they should be handled by the packaging somehow.  k.  does someone go look at those log pages regularly?
16:29:00 <hallyn> do they get emailed somewhere?
16:29:25 <plars> hallyn: not currently, but they always end up in the same place, so they are pretty easy to find
16:29:53 <plars> hallyn: the url I pointed to will take you to the lastSuccessfulBuild in jenkins and show you the current obsolete_conffiles log
16:30:09 <hallyn> perhaps that url s hould be added to the server team knowledgebase weekly bug triaging section
16:30:37 <hallyn> the url may be consistent, but if noone is in the habit of looking at it, bugs won't get raised...  course you're right about low prio,
16:30:42 <plars> hallyn: that sounds reasonable - we were looking for a better way of dealing with these and nobody wanted spam about it, but I don't think it makes sense to ignore them entirely. So just making you aware
16:30:55 <hallyn> ok, thanks
16:31:13 <hallyn> #action serge consider putting the obsolete_conffiles.log url in weekly triaging knowledgebase section
16:31:13 * meetingology serge consider putting the obsolete_conffiles.log url in weekly triaging knowledgebase section
16:31:17 <plars> hallyn: the problem with bugs is it got to be quite a lot of overhead - in this case with one or 2 it's not so bad, but in others you're talking 30-40 bugs that have to be updated across each daily test run
16:31:30 <plars> ...for something that just gets ignored
16:31:37 <plars> sanity kicked in at some point
16:31:44 <hallyn> plars: yup :)
16:31:48 <plars> that's all from me
16:31:53 <hallyn> plars: thanks
16:31:56 <hallyn> moving on,
16:31:58 <hallyn> #topic Weekly Updates & Questions for the Kernel Team (smb)
16:32:06 <smb> Hello, I would like to take this opportunity to re-advertise for http://people.canonical.com/~smb/lucid-ec2-ng/ ... I know not very subtly but I am a developer and not a sales guy. :-P Otherwise raring kernel ddebs will be actually usable after next upload (in case anybody actually was wondering why the heck they were so small).
16:32:14 <smb> Oh, one other thing: have not run into this myself but it seems
16:32:14 <smb> that recent raring kvm/qemu packages are a bit insulted if
16:32:14 <smb> post-install does not get /dev/kvm. This might not be the "normal"
16:32:14 <smb> case but it is possible to have the kvm package installed and dual
16:32:15 <smb> boot between xen and non-xen mode and its also possibleto do a
16:32:17 <smb> dist-upgrade in xen dom0 which won't allow for /dev/kvm...
16:32:25 <smb> Beside that, any questions? :)
16:32:57 <smoser> smb, i'm confused about /dev/kvm
16:33:01 <hallyn> smb: the /dev/kvm bit *should* be fixed, please shout at me if you see it again
16:33:08 <smoser> right.
16:33:17 <smb> hallyn, Ah ok, it was a few days ago
16:33:23 <smoser> hallyn, that is bug 1103022 ?
16:33:24 <ubottu> bug 1103022 in udev (Ubuntu) "70-udev-acl.rules needs to put g+rw on /dev/kvm" [High,Confirmed] https://launchpad.net/bugs/1103022
16:33:34 <hallyn> smoser: no
16:33:43 <hallyn> smoser: it was a bug from my bad fixing of that one
16:33:52 <hallyn> smoser: if /dev/kvm did not exist, getfacl failed, causing postinst to fail
16:33:58 <smoser> ah. k.
16:34:18 <smb> Ah ok, as said it wasn't me and it was probably last week
16:35:02 <hallyn> smb: feb 20 the fix went up
16:35:15 <hallyn> so yeah shout at me if you see it again.  thx
16:35:32 <smb> hallyn, sure. will do :)
16:35:32 <hallyn> lucid-ec2-ng - i assume the right folks know what that means :)
16:35:45 <smb> hallyn, I suppose yes.
16:35:56 <hallyn> thanks, smb.  moving on,
16:35:58 <hallyn> #topic Weekly Updates & Questions regarding Ubuntu ARM Server (rbasak)
16:36:08 <rbasak> Nothing new to report. Any questions for me?
16:36:49 <hallyn> sounds like no, moving on,
16:36:54 <hallyn> #topic Open Discussion
16:37:33 <hallyn> anything to discuss?
16:37:35 <hallyn> if not,
16:38:00 <hallyn> hggdh: o/  see you around!
16:38:02 <hallyn> #topic Announce next meeting date and time
16:38:21 <hallyn> Next meeting will be same time, 16:00 UTC on March 5.
16:38:24 <hallyn> thanks all,
16:38:30 <hallyn> #endmeeting