21:07:18 <pitti> #startmeeting
21:07:18 <meetingology> Meeting started Mon Feb 18 21:07:18 2013 UTC.  The chair is pitti. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
21:07:18 <meetingology> 
21:07:18 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
21:07:22 <pitti> #topic action review
21:07:48 <pitti> (sorry, didn't prepare; wiki said kees)
21:08:18 <pitti> no actions that I can see at https://wiki.ubuntu.com/TechnicalBoard/TeamReports
21:08:36 <cjwatson> There was one for me to update the SRU page
21:08:39 <pitti> #topic Flavor of UbuntuKylin
21:08:49 <cjwatson> Which I did
21:08:56 <pitti> oh, I saw that
21:08:59 <pitti> right
21:09:20 <pitti> JackYu: are you here?
21:09:31 <JackYu> Hi, I am Jack from UbuntuKylin team
21:09:33 * pitti was reading https://wiki.ubuntu.com/UbuntuKylin in the meantime
21:10:03 <JackYu> Yes, pitti:)
21:11:11 <pitti> JackYu: we have had http://china-images.ubuntu.com/ for some time now, but it's fairly undermaintained from what I know; are you aware of this?
21:11:23 <stgraber> wiki doc for new flavours is at: https://wiki.ubuntu.com/RecognizedFlavors
21:11:27 <cjwatson> pitti: (Foundations would like Kylin to supersede china-images)
21:11:27 <pitti> JackYu: i. e. is this meant to continue this project, or a completely separate effort?
21:12:05 * soren had never heard of china-images
21:12:06 <pitti> ah, so this will use/change/extend the existing customizations and build machinery?
21:12:16 <JackYu> Pitti: no, it's a new.
21:12:23 <cjwatson> pitti: I wouldn't expect so
21:12:38 <soren> JackYu: The wiki page speaks about goals. What is the current state?
21:12:41 <cjwatson> china-images more or less works if you basically have nobody maintaining it
21:12:53 <cjwatson> That system isn't so good for a full-fledged flavour
21:12:59 <cjwatson> The one thing that concerns me in that is the "System Assistant" item - that's the sort of thing that I would say should be done as part of core Ubuntu rather than a flavour, even if it's implemented by Kylin developers (and you should be aware of the previous attempt at something like this, Computer Janitor, which has been removed and we reckon that any subsequent attempt should probably live in Software Center)
21:13:12 <pitti> indeed
21:13:26 <pitti> I'm also a bit sceptical about fctix, that's something I'd like to discuss
21:13:28 <cjwatson> There's no reason why that kind of tool ought to be specific to a locale or a region of the world
21:13:40 <cjwatson> Or particularly customised for it
21:13:43 <pitti> and "photo handling" also isn't China specific
21:14:17 <cjwatson> Right, so worth splitting this out into things that are specific to your flavour, and general problems in the wider Ubuntu project that your developers would like to work on
21:14:32 <cjwatson> Both are definitely welcome, but we should only consider the former to be part of UbuntuKylin IMO
21:14:53 <soren> JackYu: Just to be clear: These things may be great improvements, they're just..
21:14:54 <JackYu> cjwatson: Yes, it should be in Ubuntu, not only for a flavor.
21:14:57 <soren> Right, what cjwatson just said :)
21:14:59 <pitti> JackYu: do you have a set of proposals and topics for the meeting, or should we just go through one by one?
21:16:34 <pitti> ok, so let's just do that then
21:16:37 <pitti> = Online Music Search on Dash =
21:16:59 <pitti> that's just changing the searched providers, not changing the client?
21:17:06 <JackYu> soren: we have finished the goals in UbuntuKyli13.04. packages are in Ubuntu Archive.
21:17:11 <pitti> AFAIK this is already country specific, so that sounds straightforward
21:17:18 <soren> JackYu: Oh, excellent.
21:18:31 <JackYu> pitti: I have sent an email to your maillist...
21:19:12 <pitti> I didn't see it yuet
21:19:23 <soren> Perhaps stuck in the moderation queue?
21:19:30 <pitti> ah, I moderated it now
21:19:58 <pitti> JackYu: so is the music search changing the searched servers only, or also the GUI?
21:21:03 <JackYu> Pitti: we add a scope to searching Baidu music. Yes, only servers
21:21:11 <pitti> thanks
21:21:32 <pitti> calendar and weather indicator seem straightforward to me, any questions anyone?
21:22:20 <pitti> = input method =
21:22:25 <JackYu> Another PM of this team, Anthony from Canonical, is online. He will join:)
21:22:40 <pitti> JackYu: why are you using fcitx, OOI? Ubuntu, GNOME, etc. all use ibus
21:22:48 <pitti> this seems to be a rather large diversion
21:23:41 <JackYu> fcitx is good at Chinese input, as we tested.
21:24:14 <JackYu> It provides better intelligent association
21:25:19 <pitti> I'm asking because unlike ibus that doesn't have any GUI configuration support in e. g. control-center or the indicator, as these all talk to ibus
21:26:14 <pitti> if (and that may well be the case), fcitx is indeed better than sunpinyin or googlepinyin, then IMHO that should become the default in regular Ubuntu as well, but that should be discussed with e. g. GNOME and the desktop team
21:27:20 <pitti> JackYu: perhaps you can update the wiki page with the pros and cons, and how that affects configuration, indicators, the language selector, and so on?
21:27:37 <ypwong> pitti, for gui, I think JackYu plans to do that for fcitx post 13.04
21:28:18 <ypwong> agree to put the pros and cons on wiki, action for JackYu
21:28:27 <JackYu> Yes, we are going to do some work on fcitx.
21:28:51 <pitti> #action JackYu to document reasons for switching to fcitx, and impact on control center, indicators, application support
21:28:51 * meetingology JackYu to document reasons for switching to fcitx, and impact on control center, indicators, application support
21:29:03 <JackYu> pitti: OK, thanks.
21:29:41 <pitti> JackYu: also, please note that just like fcitx, ibus also has several modules such as various pinyin flavours; they changed several times in the past, but they all use the common ibus API for configuration and switching between them
21:29:52 <pitti> = WPS =
21:30:13 <pitti> that sounds like "MS Works", is it really that, or something different?
21:30:31 <pitti> i. e. you're not using LibreOffice?
21:30:40 <JackYu> It is a Chinese office tools
21:31:00 <ypwong> pitti, it's a complete office suite, but proprietary
21:31:17 <JackYu> by Kingsoft Corp. of China
21:31:19 <cjwatson> So this is interoperability with it, rather than shipping it?
21:31:41 <pitti> ypwong: i. e. you want to ship import/export filters for LibO, or provide a WPS installer and drop LibO?
21:31:47 <ypwong> there's talks with the company to put it on software center
21:31:56 <pitti> I think this could also be clarified on the wiki
21:32:09 <cjwatson> I really question shipping proprietary software as the preferred option (even via an installer) in a recognised Ubuntu flavour
21:32:27 <cjwatson> Even if it's the preferred local option, it dilutes the Ubuntu brand rather badly
21:32:47 <cjwatson> If it's not presented as the preferred option I'm not so concerned
21:33:14 <pitti> yeah, same here; we still present Ubuntu as "all free software"
21:33:21 <pitti> s/still//
21:34:49 <JackYu> There is a link on desktop to download WPS, not pre-installed.
21:34:49 <ypwong> we are thinking it's like suggesting codecs or binary drivers vs free ones in ubuntu
21:35:08 <cjwatson> It's not - drivers occupy an explicitly different status
21:35:09 <pitti> no, it's not like drivers
21:35:22 <cjwatson> We have always treated proprietary applications quite differently
21:35:28 <pitti> drivers allow you to use free software/ubuntu at all
21:36:09 <pitti> I think it's fine to add it to SC for easy installation, we do that with plenty of software; but I feel that presenting it as something which most users will just click anyway is the wrong direction
21:36:19 <ypwong> LibO won't be dropped, it should still be installed by default in ubuntukylin 13.04. JackYu am I correct?
21:36:28 <cjwatson> TBH having a link on the desktop is something of a concern to me as well.  I don't think we necessarily need to resolve it in this meeting, but I'd like to feel confident that the people running a new flavour share our general position on free software
21:36:48 <JackYu> Yes, LibO is default.
21:37:21 <cjwatson> We don't want to position Ubuntu as just a cheap way to get hold of proprietary software - it's meant to be a quality product in itself and I think our flavours should be proud of the free software in the archive
21:37:32 <cjwatson> If you see what I mean
21:37:57 <cjwatson> (Agreed regarding adding things to Software Center for easy installation)
21:38:01 <JackYu> cjwatson: Yes, I got.
21:39:21 <pitti> as for the other points, we already discussed the system assistant, same with photo handling
21:39:33 <cjwatson> Then let's make sure its status is clear in UbuntuKylin documentation too - I didn't get the proprietary bit at all from the wiki page
21:39:52 <pitti> the other points seem like genuine localization to me; opinions?
21:40:00 <cjwatson> Me too
21:40:17 * pitti JackYu to clarify on the wiki page what WPS is and how it's going to be integrated
21:40:20 <pitti> JackYu: ^ sounds ok?
21:40:37 <JackYu> sure.
21:41:13 <pitti> JackYu: for the record, we were picking on the unclear bits, which might have sounded a bit negative; thanks for working on this project, it's really quite appreciated that some actual Chinese developers are taking this up!
21:42:34 <cjwatson> Yeah, the existing images have mostly been maintained by non-Chinese people, which is ... not ideal
21:42:41 <JackYu> Thanks your suggestions:)
21:43:04 <pitti> ypwong, JackYu, soren, stgraber: do you see anything else which we need to discuss still?
21:43:19 <cjwatson> And I agree that the customary facilities people in China expect to be available in their OS appear to be sufficiently divergent from what we ship elsewhere that it's worth a separate flavour
21:43:50 <soren> pitti: No, I think this is good for now.
21:43:59 <stgraber> pitti: well, I think we ought to go through the current requirements for flavours and decide whether we make an exception for this one and if so, set some conditions around that
21:44:08 <cjwatson> I have a latent concern about the possibility of lots of localised flavours and scaling problems arising from that - but TBH China appears to be the most complex and divergent case and I'm not seeing the same pressures elsehere
21:44:28 <JackYu> The default-settings and theme packages are also prepared.
21:44:36 <cjwatson> There are a few things still in NEW
21:44:42 <cjwatson> But that's not your fault :-)
21:44:54 <ypwong> cjwatson, good that you see the point of this flavor :)
21:45:03 <ypwong> cjwatson, yes, the default-settings still in NEW
21:45:09 <stgraber> I definitely apprecaite having someone work on the Chinese images and getting that rolling as a real flavour, however as far as I can tell, none of the people in this meeting are Ubuntu members, none of which have upload rights and most of which haven't even signed the CoC
21:45:18 <pitti> stgraber: I'm still not quite clear about fcitx vs. ibus, and I'm assuming that the WPS situation will be clarified; do you see other major exceptions from the general understanding of what a localized flavour is?
21:45:23 <stgraber> so I guess I want to discuss who's going to be responsible for the flavour
21:45:47 <stgraber> if that's Canonical Foundations through slangasek, I'm happy with it, if not, I can't +1 this in its current state
21:46:02 <pitti> stgraber: oh, you mean the community structure, not the technical aspects?
21:46:08 <stgraber> righ
21:46:10 <stgraber> *right
21:46:49 <pitti> my gut feeling is that membership needs to come during doing actual work on Kylin here
21:46:50 <cjwatson> slangasek has expressed to me (er, [1] personal communication) a general willingness to see this through and a request for Foundations to generally help out
21:47:13 <stgraber> I perfectly agree with what was said earlier as to what should be included in the flavour and I definitely agree with the goal behind the flavour. I'm just concerned about who will be responsible for it
21:47:16 <cjwatson> I do think you absolutely ought to be aiming for at least two developers with upload rights on their own behalf
21:47:17 <pitti> past experience didn't show that maintaining the Chinese flavour from the existing ~ubuntu-dev team has worked well
21:48:05 <cjwatson> I think this is the first new flavour since we wrote/approved RecognizedFlavours?
21:48:12 <stgraber> what the TB and canonical agreed on for flavours was that leading members would need to have the CoC signed, one or more developers have upload rights, show 6 months activity and have a QA contact
21:48:32 <cjwatson> I'd suggest that we ought to start by ensuring that the criteria from "Guidelines to have an image added to the dailies" are met, and that "Guidelines to become and remain a recognized flavor" are on track
21:48:34 <stgraber> cjwatson: I think so, yes, we used the document to approve LTS status but not to approve new flavours
21:48:45 <cjwatson> (It's a bit unclear, reading it in this light)
21:48:57 <pitti> signing the CoC is certainly something that can be done quickly at leats?
21:48:59 <pitti> least
21:49:11 <cjwatson> But you clearly can't establish a "track record" until you've been going for a while
21:49:41 <stgraber> so I'm generally happy to ignore some of those conditions on the basis that the Foundations team will be responsible for the flavour and that this responsability will be transferred to a separate Kylin team once they meet the criteria
21:50:13 <pitti> stgraber: I understand "responsible" in the sense of mentoring and perhaps sponsoring here?
21:50:22 <JackYu> Stgraber: It seems that Members from NUDT have signed the CoC.
21:51:02 <stgraber> pitti: right, mentoring, help with release management and sponsoring
21:51:16 <cjwatson> I think we can check off most of the "dailies" items; 1) is what we're talking about now, 2) is underway, 3) means that JackYu and ypwong should ensure that some appropriate team is subscribed to bugs on all the relevant packages, 4) I can say that we have plenty of image publishing space right now without needing to explicitly check with IS, 5) that can be somebody from Foundations and I can check up with slangasek on ...
21:51:22 <cjwatson> ... it tomorrow, 6) ...
21:52:06 <stgraber> pitti: then in 6 months (to meet the time criteria), we can re-evaluate and then have the Kylin team be fully responsible for it assuming they have enough uploaders, QA, release contact people by then familiar with our processes
21:52:06 <cjwatson> "Community member lined up to test image and provide feedback at milestones"  what do NUDT/UbuntuKylin's QA plans look like?
21:52:23 <pitti> sorry, what is NUDT?
21:52:35 <stgraber> hehe, was about to ask the same question ;)
21:52:37 <pitti> stgraber: sounds good to me, too
21:53:04 <pitti> (trying to pronounce the acronym really doesn't help clarifying..)
21:53:12 <ypwong> let me describe what has been done so far: we've been talking with JackYu for several months about this flavour idea, now JackYu's and his team do the coding, seb128/slangasek/et al helped reviewed their work and upload them
21:53:20 <cjwatson> National University of Defense Technology, says google
21:54:32 <pitti> ok, we have to hurry up a bi
21:54:33 <ypwong> cjwatson, right, JackYu's team mostly from the university
21:54:33 <pitti> t
21:54:39 <stgraber> JackYu: you didn't sign it according to Launchpad, which is a bit troubling for someone who wants to become a flavour lead ;)
21:54:53 * stgraber checks that LP isn't lying
21:55:26 <pitti> JackYu, ypwong: can we review this again in two weeks, when we have above clarifications, CoC signed, etc?
21:55:29 <JackYu> Oh, if not, I will do it soon.
21:55:42 * pitti JackYu and ypwong to sort out CoC signing
21:56:09 <pitti> JackYu, ypwong: thanks for attending!
21:56:13 <ypwong> pitti, I'm ok with that, how about you, JackYu?
21:56:21 <JackYu> OK. Thank you.
21:56:49 <cjwatson> JackYu: If you folks haven't already been discussing daily building of images with slangasek, feel free to do so with me
21:57:00 <pitti> #topic Scan the mailing list archive for anything we missed
21:57:11 <pitti> # topic SRU Minor Release Exception for Ceph
21:57:13 <cjwatson> (Perhaps at a more sociable time for both of us, if I'm guessing your timezone correctly)
21:57:17 <pitti> #link https://lists.ubuntu.com/archives/technical-board/2013-February/001475.html
21:57:26 <pitti> can we move this to email?
21:57:27 <JackYu> cjwatson: Sure. Thanks.
21:57:46 <cjwatson> pitti: I will confess I haven't really absorbed that one yet
21:57:50 <pitti> reviewing the details of this will be too tight for the remaining 3 mins, I think; or did someone already?
21:57:54 <stgraber> I guess I'll be talking with slangasek on whether he'd be happy to be a temporary flavour lead for Kylin (or have Foundations do that) until they are familiar enough with everything and have upload rights to do all that themselves
21:58:35 <pitti> ok, so let's move that to mail
21:59:01 <pitti> nothing else on the ML that I can see
21:59:20 <pitti> #topic chair for next meeting
21:59:37 <pitti> continuing with kees
21:59:39 <pitti> ?
21:59:55 <pitti> #topic AOB
21:59:57 <pitti> anyone?
22:00:15 <stgraber> yeah, I guess we can continue with kees, mdz then skip you (if we remember ;))
22:00:24 <pitti> 10 secs
22:00:40 * pitti rings the bell, thanks everyone!
22:00:47 <cjwatson> thanks!
22:00:50 <stgraber> pitti: thanks for chairing!
22:00:50 <soren> ta
22:00:52 <soren> o/
22:01:05 <ypwong> thanks everyone
22:01:40 * ypwong goes back to bed
22:02:10 <pitti> bonne nuit tout le monde
22:02:36 <stgraber> pitti: bonne nuit
22:14:38 <JackYu> Thanks, all. goes back to bed too:)
00:24:11 <xnox> interesting meeting =)
00:58:35 <freeflying> I missed it :)
12:46:18 * smartboyhw wonders why the topic is AOB....
12:46:58 <ogra_> likely because someone forgot to close their meeting
12:47:24 <soren> That would be pitti.
12:47:40 <smartboyhw> oops
12:47:56 <ogra_> yeah, the backlog says so
12:48:20 <soren> I've just poked him about it.
12:48:22 <soren> #endmeeting
12:48:28 <soren> Yeah, he has to do it.
12:48:32 <soren> Was worth a try, though :)
13:01:44 <xnox> #endmeeting
13:02:05 * xnox failed at highjacking pitti's nickname
13:02:11 <smartboyhw> Eh doesn't work:P
13:19:23 <pitti> #endmeeting