18:02:24 <AlanBell> #startmeeting
18:02:24 <meetingology> Meeting started Sun Nov 25 18:02:24 2012 UTC.  The chair is AlanBell. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:02:24 <meetingology> 
18:02:24 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
18:02:28 <lhavelund> I'll be doing a bit of running back and forth, but thought I'd pop in.
18:02:41 <AlanBell> well I would like to start by wishing everyone a very happy "Today"
18:03:14 <AlanBell> https://wiki.ubuntu.com/IRC/IrcCouncil/MeetingAgenda
18:03:28 <AlanBell> #meetingname IRC Team
18:03:28 <meetingology> The meeting name has been set to 'irc_team'
18:03:31 <Pici> happy today
18:04:24 <AlanBell> #topic Review last meetings action items
18:04:46 <AlanBell> https://wiki.ubuntu.com/MeetingLogs/IRCC/20121028 was the last meeting
18:05:05 <AlanBell> and we did get the ban management code into ubottu
18:05:23 <AlanBell> and sorted out and blogged about the uds channels
18:05:36 <AlanBell> so that is all good
18:05:41 <Pici> woo
18:05:45 * lhavelund cheers.
18:05:50 <AlanBell> #topic Open items in the IRCC tracker
18:06:13 <AlanBell> don't think we have any
18:06:23 <Pici> I'm pretty sure we don't either.
18:06:53 <AlanBell> err, maybe we do have one
18:07:25 <AlanBell> Ticket #819361 appears to exist
18:07:46 <AlanBell> um, we should look at that, I totally missed it happening
18:08:02 <IdleOne> If it involves me I apologize and it won't happen again
18:08:07 <IdleOne> :)
18:09:13 <AlanBell> hmm, we can look at that later, I think it is something that has already been resolved in -ops
18:09:45 <Pici> Its a bit stale...
18:09:45 <AlanBell> #action ircc to sort out issue in the tracker
18:09:45 * meetingology ircc to sort out issue in the tracker
18:09:52 <AlanBell> it is stale I think
18:09:56 <AlanBell> #topic Review Bugs related to the Ubuntu IRC Council
18:10:10 <AlanBell> we have none \o/
18:10:35 <Pici> Well, we have one. But its sort of in limbo.
18:10:43 <AlanBell> yeah, it is incomplete
18:11:07 <AlanBell> we have closed bug #913541 (however I think a bunch of people since expired)
18:11:09 <ubottu> Launchpad bug 913541 in ubuntu-community "there are a number of people with Ubuntu IRC cloaks who have expired from the ubuntumembers group" [Undecided,Fix released] https://launchpad.net/bugs/913541
18:11:12 <Pici> If anyone can come up with an idea so that we can do something about it, that would be good.
18:11:30 <AlanBell> and bug 892500 is now closed
18:11:32 <ubottu> Launchpad bug 892500 in ubuntu-community "eir is still not fit for purpose in #ubuntu" [Undecided,Fix released] https://launchpad.net/bugs/892500
18:11:38 <Pici> A bunch of people expired from the team that votes on IRCC elections, not from membership.
18:11:59 <AlanBell> yeah, but they might have had membership through that team only, I haven't checked
18:12:33 <AlanBell> but anyhow, we are looking pretty good on the bugs front
18:12:37 <AlanBell> #topic quarterly review of #ubuntu-ops-team channel
18:12:54 <AlanBell> so, how are people finding the ops team channel and conversations in it?
18:14:00 <Pici> I personally find it useful, but I'd like to see what other people think.
18:14:13 <AlanBell> I know I find it very useful to have that channel distinct from -ops and separate from the ban resolution discussions
18:14:17 <lhavelund> I recently returned to these parts after a long period of other obligations. I enjoy not having to feel like I have to filter everything I say, making sure that under no circumstances can it be taking the wrong way, etc.
18:14:52 <lhavelund> On top of that, previously when resolving issues in -ops, you'd often have multiple queries going with other operators to get another opinion on situations. Now, this can be handled through the -team channel, and it seems to work really well.
18:16:11 <IdleOne> +1 for the team channel
18:16:24 <AlanBell> yup, there were concerns when the channel was set up about having a private channel, so it was agreed to review it quarterly to check that the general standard of discussion and usefulness was as originally intended, and I think it is.
18:16:30 <lhavelund> yeah, exactly.
18:16:51 <lhavelund> i remember this being brought up a very, very long time ago, and was dismissed for those very reasons. although, having participated for a bit, the fears were unfounded. :)
18:16:53 <AlanBell> anyone got any concerns about it?
18:17:18 <IdleOne> Sometimes the topic does get a little OT in there but I think it is good because it helps the team members get to know each other better.
18:17:31 <lhavelund> IdleOne: I don't see why that's necessarily a bad thing, for the same reason you mention.
18:17:44 <IdleOne> right, I don't think it is a bad thing at all.
18:18:00 <lhavelund> -ops was the same back when I was very active.
18:18:09 <lhavelund> :)
18:18:16 <AlanBell> ok, lets move on from that and review it again in another three months or so
18:18:24 <AlanBell> #topic #ubuntu-discuss is it working?
18:18:26 <x1k> as someone outside of the invitees, I don't see why there would be any issues with a private chan for ops team... wish I could weigh in more on it lol
18:19:04 <Pici> x1k: there were concerns that things happening 'in the shadows' would be bad for a team whose purpose is to police other users.
18:19:42 <IdleOne> AlanBell: It needs work, doesn't cost us anything to keep it open. I vote we keep it going.
18:20:18 <Pici> I think we should remind people (including myself) to use it more often.
18:20:18 <AlanBell> so #ubuntu-discuss was put on the agenda because it was something we set up and it wasn't getting much traction, however there have been a number of decent conversations in there recently
18:20:55 <AlanBell> and I still have concerns about flinging people into -offtopic for all non-support discussions
18:21:14 <Pici> AlanBell: +1
18:21:19 <lhavelund> What was the original intention with -discuss?
18:21:26 <x1k> from the discussion on the mailing list, it should stay open but more work should be done to advertise it and get people in there
18:21:34 <AlanBell> lhavelund: discussion around the topic of ubuntu
18:21:44 <x1k> I never heard of it other than the irc mailing list
18:21:56 <Pici> lhavelund: it grew out of the anti-unity sentiment, to have somewhere for people to discuss where Ubuntu was going that wasn't -offtopic
18:21:59 <AlanBell> so not talking about utter randomness which is fine in -offtopic
18:22:09 * lhavelund nods.
18:22:11 <AlanBell> and not clogging up #ubuntu with non-support questions
18:22:19 <lhavelund> makes sense, cheers.
18:22:36 <AlanBell> plus Canonical were directing people to #ubuntu to "join the conversation"
18:22:51 <Pici> Yah, which wasn't good.
18:22:59 <AlanBell> which wasn't entirely helpful, but neither would directing people to -offtopic make any sense
18:23:21 <IdleOne> Do we know if Canonical has modified that practice?
18:24:06 <Pici> I think we did something about it... but my mind is fuzzy
18:24:34 <AlanBell> I am fairly sure they have modified it in some way, sabdfl was pretty clear in his agreement with our point
18:25:20 <AlanBell> I am not sure if they are directing people to IRC at all now, but we have told them that they are welcome to direct people to #ubuntu-discuss
18:25:59 <IdleOne> That would surely help increase traffic and discussion if they did
18:26:04 <AlanBell> ok, so anyone feel strongly that #ubuntu-discuss should be dropped?
18:26:36 <x1k> the push to IRC has to be dummy proof though.... if I told my wife to get on #ubuntu-discuss, I would get a blank stare lol... web based client?
18:27:27 <Pici> I think the link to IRC that was provided was through the webchat.
18:27:34 <AlanBell> x1k: oh, absolutely agreed, but that is all about the context of where it is publicised
18:27:45 <x1k> +1
18:27:56 <x1k> sorry, back to lurking
18:28:17 <Pici> :)
18:28:22 <AlanBell> #agreed keep #ubuntu-discuss
18:28:28 <AlanBell> lets move along
18:28:34 <AlanBell> #topic How is Ubottu ban removal going?
18:28:46 <AlanBell> any thoughts or comments on this one?
18:28:56 <IdleOne> bot seems to do what it is supposed to do.
18:29:02 <AlanBell> better than eir?
18:29:11 <IdleOne> not in all aspects
18:29:23 <Pici> Where can it be improved?
18:29:41 <IdleOne> I would like the floodbot bans /noticed to -ops-monitor so that we can set comments/duration
18:29:44 <AlanBell> how about the times counting from initial ban point? is that OK or an issue?
18:30:21 <AlanBell> m4v: o/
18:30:39 <m4v> yes I'm here
18:30:46 <AlanBell> just checking :)
18:32:02 <IdleOne> Also would be helpful if when we did @duration banID it gave the date the ban was set
18:32:04 <m4v> the ban notices can be moved to any channel, is a config setting. The where to count from the duration of a ban depends on what you folks need.
18:32:31 <m4v> IdleOne: can be done
18:33:24 <IdleOne> AlanBell: m4v I kinda liked that all the bans were noticed in -ops-monitor.
18:34:12 <IdleOne> but for now I really think that we need a way of seeing and being asked to set comments on the floobot bans
18:34:22 <m4v> I think, once you get into ubottu's code you see that it isn't so easy (i think bantracker doesn't keep ban's information updated at all times in memory, so more fetching form the db will be needed)
18:34:51 <m4v> but I need bug reports so I don't forget about it ;)
18:35:06 <AlanBell> fair enough :)
18:35:55 <AlanBell> https://bugs.launchpad.net/ubuntu-bots?field.searchtext=bantracker
18:36:00 <AlanBell> in with those ones?
18:36:28 <m4v> IdleOne: I'm pretty sure there's an option for request the channel to make a comment for flootbot's bans, if it isn't doing it now is because is disabled.
18:38:26 <AlanBell> ok, so lets file bugs and have a bit more discussion with the rest of the team, generally I am happy that it is being used and there are not howls of anguish :)
18:38:41 <AlanBell> ok, moving onwards
18:38:43 <AlanBell> #topic review the #ubuntu AKICK list
18:39:16 <Pici> Do we want to do that here, or break it up and do it offline?
18:39:36 <AlanBell> http://www.privatepaste.com/377d188b5c/ubuntu
18:39:43 <jussi> Offline methinks
18:39:52 <IdleOne> err that isn't so private
18:39:55 <AlanBell> well I was going to suggest a general discussion about whether there should be one
18:40:01 <AlanBell> it isn't private anyway is it?
18:40:04 <jussi> and Hai everyone
18:40:13 <AlanBell> hai jussi
18:40:23 <IdleOne> there should be one.for sure
18:40:28 <IdleOne> hey jussi
18:40:31 <AlanBell> so we have akick lists for -offtopic and #ubuntu
18:40:45 <AlanBell> why do we use them instead of bans?
18:40:48 <Pici> Perhaps we should send it to the mailing list to get people's opinions who aren't here?
18:41:00 <AlanBell> are there stuff that should stay, and what stuff should go, and why?
18:41:09 <lhavelund> AlanBell: it was my understanding that earlier, ban lists were just... getting filled too quickly.
18:41:16 <lhavelund> whether or not that's still an issue, i don't know.
18:41:27 <Pici> go: tor, gateway/cgiirc/
18:42:00 <Pici> akicks can't be accidentally removed.
18:42:06 <AlanBell> there are some things which are kicking out users with nicks containing rude words, others that ban specific dynamic IP addresses
18:42:36 <AlanBell> not sure it is the right place for IP level bans, what do you think?
18:43:00 <Pici> I probably agree.
18:43:10 <jussi> akick should be for those things that don't change
18:44:14 <jussi> ie. Rude words, particular service bans
18:44:54 <AlanBell> ok, so if the IRCC go through offline and prune the list fairly agressively that would be a good thing?
18:45:14 <AlanBell> limit it to rude words and known bad networks
18:45:21 <IdleOne> I don't think I have seen services auto kick anybody in years
18:45:21 <jussi> IMHO yes
18:45:32 <Pici> IdleOne: its very rare
18:45:47 <IdleOne> right, prune away. keep the obviously rude ones
18:46:06 <AlanBell> IdleOne: I did see one a few weeks ago, hence this being on the agenda
18:46:15 <lhavelund> +1 IdleOne
18:46:24 <Pici> Any naysayers?
18:47:07 <AlanBell> #action ircc to prune the akick lists
18:47:07 * meetingology ircc to prune the akick lists
18:47:24 <jussi> Perhaps move those bans to the normal ban list?
18:47:35 <AlanBell> yeah, that might be something we do for some of them
18:47:53 <jussi> Where they get revewed etc
18:48:26 <AlanBell> right, couple more topics to insert
18:48:53 <AlanBell> we have the membership application of m4v, however we are not quorate right now :(
18:49:13 <Pici> :|
18:49:15 <IdleOne> how many do you need for quorum?
18:49:25 <AlanBell> three of five
18:49:41 <x1k> bummer
18:49:51 <IdleOne> you, pici and me ( I am a Membership board member) make 3
18:50:02 <Pici> I don't think thats how it works.
18:50:21 <IdleOne> There is precedent of other board memmbers voting in membershiop meetings
18:50:25 <IdleOne> members*
18:50:45 <jussi> l also am on a council that grants membership
18:50:50 <IdleOne> but if you prefer to wait that is fine also
18:51:33 <IdleOne> I also think jussi and I have enough IRC experience to make a fair judgment on this application.
18:51:34 <m4v> I'm ok with waiting, is not like I have been in a hurry to get membership
18:52:33 * AlanBell reads the charter :)
18:53:45 <jussi> we have done It before with CZ<tab>
18:53:58 <AlanBell> yeah, when we had a CC member filling one of the seats
18:54:02 <jussi> On mobile no tab complete
18:54:35 <AlanBell> I think it would be best to wait until the next meeting where there are more of us to congratulate m4v on awesomeness \o/
18:54:58 <Pici> As long as m4v is okay with waiting.
18:55:10 <Pici> Not that we're going to give him much choice ;)
18:55:11 <jussi> l don't have an issue with that.
18:55:16 <x1k> lol
18:55:43 <AlanBell> lets do that then, sorry we couldn't sort it out today m4v, but lets do it properly at the next meeting :)
18:56:06 <m4v> yes
18:56:10 * IdleOne thanks m4v for his awesomeness
18:56:41 <AlanBell> the other thing we should have put on the agenda is going through the operator applications, which I need to run my little script to list out and we need to discuss them, so lets postpone that to the next meeting too.
18:56:55 <AlanBell> #action m4v membership to go on next agenda
18:56:55 * meetingology m4v membership to go on next agenda
18:57:19 <AlanBell> #action AlanBell to sort out list of operator applicants for next meeting
18:57:19 * meetingology AlanBell to sort out list of operator applicants for next meeting
18:57:27 <Pici> We've gotten a bunch of applications lately, unfortunately I don't really recognize many of the applicants.
18:57:48 <x1k> raises hand... ooo oooo pick me
18:57:57 <AlanBell> !canibeanop
18:57:57 <ubottu> If you are interested in joining the Ops team, take a look at both http://www.siltala.net/2010/03/24/ops-teams-applications-announcement/ and https://wiki.ubuntu.com/IRC/IrcTeam/OperatorRequirements for info on the process and requirements.  You can also learn about what the job entails from people in #ubuntu-irc.
18:57:59 <IdleOne> This round is taking much longer than previous ops calls
18:58:18 <lhavelund> I'd rather it takes longer, and we get better suited and more capable candidates.
18:58:29 <IdleOne> that makes sense
18:58:52 <Pici> And filters people that just clicked the button instead of being serious about it.
18:58:57 <lhavelund> Indeed.
18:59:17 <AlanBell> x1k: http://ubottu.com/ircc/2012/11/03/call-for-irc-operators-2/
18:59:25 <x1k> ty
18:59:25 <lhavelund> Run script, check if Wiki page has been updated in the past month or so, if not, scrap.
19:00:01 * IdleOne scrapes lhavelund and greps for gold
19:00:06 <lhavelund> none. :(
19:00:13 <czajkowski> jussi: why the highlight?
19:00:13 <IdleOne> silver?
19:00:23 <Pici> heh
19:00:26 <AlanBell> hi czajkowski
19:00:30 <IdleOne> hehe czajkowski highlights on czTAB
19:00:40 <IdleOne> hello czajkowski :)
19:00:51 <czajkowski> have to as sometimes folks not on desktop are on phones and ping me that way :/
19:01:01 <AlanBell> czajkowski: we had a quorum issue, but decided to put it off to the next meeting anyway
19:01:17 <czajkowski> okie
19:01:28 <AlanBell> #topic Any Other Business
19:01:31 <IdleOne> Since you are here, what does the CC think of quorum issues being settled by using other board members to fill in?
19:02:11 <czajkowski> IdleOne: it's what has been done in past events like RMBs before and not a problem as far as I can remember
19:02:31 <IdleOne> cool, thank you.
19:02:36 <czajkowski> we've not had a case where a CC person has stepped in uusally someone from one of the other membership boards tbh
19:02:49 * chilicuil waves, he's here to support m4v membership process
19:03:16 <AlanBell> o/ chilicuil, we are going to do that next time when there are more people to woot!
19:03:25 <AlanBell> anyhow, any other business?
19:03:46 <chilicuil> wop, ok AlanBell, I'll be here then =)
19:04:01 <AlanBell> going once
19:04:04 <AlanBell> going twice
19:04:11 <AlanBell> #endmeeting