19:10:36 <bdrung> #startmeeting
19:10:36 <meetingology> Meeting started Mon Oct 15 19:10:36 2012 UTC.  The chair is bdrung. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:10:36 <meetingology> 
19:10:36 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:11:10 <bdrung> #meetingtopic DMB meeting
19:11:36 <bdrung> #topic Review of previous action items
19:12:08 <bdrung> micahg to document the zentyal packageset
19:12:38 <tumbleweed> doesn't appear to have happened yet: http://people.canonical.com/~stgraber/package_sets/quantal/zentyal
19:12:55 <bdrung> laney to delete network-manager packageset
19:13:16 <bdrung> #subtopic laney to delete network-manager packageset
19:13:54 <tumbleweed> that was deleted todya
19:14:03 <bdrung> okay
19:14:13 <bdrung> #subtopic laney to contact menesis about schooltool packageset
19:14:29 <Laney> seems used
19:14:41 <Laney> there was an upload to that stuff recently
19:14:50 <bdrung> so we keep that package set
19:15:11 <bdrung> #subtopic netbook/unr/mobile packagesets
19:16:07 <bdrung> these packagesets still appear on http://people.canonical.com/~stgraber/package_sets/quantal/
19:16:56 * micahg waves
19:16:57 <tumbleweed> yeah, they still exist
19:17:38 <bdrung> who took this action item?
19:18:36 <Laney> we have to ask the tb to deal with it
19:18:44 <Laney> or did we?
19:18:51 <tumbleweed> I thought we did
19:19:20 <Laney> well, someone there has to delete them
19:19:33 <Laney> can we action our TB friend? :-)
19:20:53 <bdrung> we will give him the action item unless he objects. ;)
19:21:11 <bdrung> #subtopic stefanor to create a UDS session
19:21:17 <Laney> err, stgraber
19:21:25 <Laney> oh, sorry, thought that was you giving the action
19:21:28 <tumbleweed> done
19:21:39 <bdrung> Laney: yes, i was referring to stgraber
19:21:47 <Laney> you didn't #action
19:22:11 <bdrung> #action stgraber to delete netbook/unr/mobile packagesets
19:22:11 * meetingology stgraber to delete netbook/unr/mobile packagesets
19:23:11 <bdrung> now back to the UDS session. tumbleweed, do we have a timeslot?
19:23:47 <tumbleweed> bdrung: no. Is there anything I should request?
19:25:24 <bdrung> tumbleweed: i think having the blueprint should be enough.
19:25:35 <bdrung> do you have the blueprint at hand?
19:25:38 <tumbleweed> yes, it should be
19:25:43 <tumbleweed> https://blueprints.launchpad.net/ubuntu/+spec/other-q-dmb-discussion
19:26:28 <bdrung> #subtopic micahg to ask docs people if they want to apply for a packageset
19:26:43 <micahg> bdrung: sorry, not yet, will try to do before UDS
19:27:18 <bdrung> #topic PerPackageUploader Applications
19:27:45 <bdrung> #suptopic Luis Henriques' PerPackageUploader Application
19:27:50 * henrix waves
19:28:06 <bdrung> henrix: can you introduce yourself?
19:28:11 <henrix> bdrung: sure
19:28:16 <henrix> Hi!  So, my name's Luis Henriques and I've joined the Ubuntu kernel team early this year.
19:28:22 <henrix> I've been working on the stable kernel team, focusing on preparing the kernels for the Ubuntu stable releases.
19:28:26 <henrix> Since the SRU process has been one of my main activities within the team, I believe its now time for me to stop bugging my team for sponsoring my packages and get upload rights for the kernel packages.
19:28:44 <henrix> and i guess that's pretty much if for an intro :)
19:28:52 <henrix> s/if/it
19:29:30 * ogasawara gives henrix a big +1 for kernel upload rights
19:29:54 <sconklin> +1, I've sponsored a number of his packages
19:30:09 <bdrung> henrix: have you (as long time Linux user) any packaging experience before joining the kernel team?
19:30:43 <henrix> bdrung: well, not much. i maintain a small debian pkg (a web browser named xxxterm)
19:30:58 <bjf> i'm very happy with the work henrix has been doing, +1
19:31:14 <henrix> bdrung: don't blame me for the package name :)
19:31:55 <herton> +1 from me as well, I think henrix is prepared, has been working on all latest SRU kernel packages
19:33:29 <bdrung> henrix: how involved are you in the community outside of the kernel team?
19:34:13 <henrix> bdrung: currently i'm mainly involved with the kernel.
19:35:55 <henrix> bdrung: i've been doing bug triagging, etc but pretty much on the kernel packages
19:37:29 <bdrung> has someone else questions?
19:37:36 * tumbleweed doesn't
19:38:47 <bdrung> henrix: you wrote that you dislike the complexity of required interactions between different teams within Ubuntu. Does this apply to SRU process or other areas, too?
19:39:10 <bdrung> s/apply to/only apply to the/
19:39:37 <henrix> bdrung: well, i don't exactly "dislike", it was just a little bit difficult to put all the pieces together
19:40:01 <henrix> bdrung: the information regarding all these different interactions is all in the wiki... somewhere :)
19:40:13 <henrix> bdrung: that's what i'm referring to in my application form
19:40:42 <bdrung> all information is in the wiki, but you do not know where to find them.
19:41:42 <henrix> bdrung: i meant that initially i had to search for it, or bug someone on the team to point me to that info.
19:41:51 <bdrung> henrix: have you any ideas how reduce the complexity and/or show how these pieces fit together?
19:42:58 <henrix> bdrung: well, i guess that's what the wiki is for -- maybe there are links missing between some of the pages/categories, but i don't see any easy solution
19:43:56 <bdrung> are we ready to vote or are there questions?
19:43:56 <henrix> bdrung: that's the typical information management problem: it all makes sense now that i know where to look
19:44:34 * bdrung nods.
19:46:20 <bdrung> #vote Should Luis Henriques become upload rights for the linux-* packages?
19:46:20 <meetingology> Please vote on: Should Luis Henriques become upload rights for the linux-* packages?
19:46:20 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
19:46:37 <bdrung> +1
19:46:37 <meetingology> +1 received from bdrung
19:46:41 <tumbleweed> +1
19:46:41 <meetingology> +1 received from tumbleweed
19:46:46 <micahg> +1
19:46:46 <meetingology> +1 received from micahg
19:46:48 <Laney> (~ubuntu-kernel-uploaders)
19:46:49 <Laney> +1
19:46:49 <meetingology> +1 received from Laney
19:46:57 <cody-somerville> +1 based on endorsements and upload history
19:46:57 <meetingology> +1 based on endorsements and upload history received from cody-somerville
19:48:19 <bdrung> #endvote
19:48:19 <meetingology> Voting ended on: Should Luis Henriques become upload rights for the linux-* packages?
19:48:19 <meetingology> Votes for:5 Votes against:0 Abstentions:0
19:48:19 <meetingology> Motion carried
19:48:30 <bdrung> henrix: congrats.
19:48:38 <henrix> thanks!
19:48:39 <Laney> :>
19:48:40 <bjf> nice job henrix
19:48:55 <Laney> go forth and break^wfix things
19:49:00 <tumbleweed> :)
19:49:12 <henrix> heh, i'll try :)
19:49:45 <bdrung> the kernel team is doing good work. my last few kernel crashes were all caused by hardware problem (and not software problem).
19:50:10 <bdrung> #subtopic Andreas Hasenack's PerPackageUploader Application
19:50:21 <ahasenack> hello
19:50:32 <bdrung> ahasenack: hello. can you introduce yourself?
19:50:53 <ahasenack> I'm Andreas Hasenack, I started working on the Landscape project in March 2008
19:51:13 <ahasenack> it has a client component called landscape-client, which is a package in Ubuntu main nowadays, and we do periodic releases
19:51:28 <ahasenack> including SRUs, which I have been doing in the past few years
19:51:30 <Laney> got a lunk handy?
19:51:34 <Laney> link
19:51:39 <ahasenack> https://landscape.canonical.com
19:51:43 <bdrung> #link https://wiki.ubuntu.com/AndreasHasenack/LandscapeClientPerPackageUploadApplication
19:51:45 <Laney> not that, to your application :P
19:51:47 <Laney> thanks
19:51:49 <ahasenack> :)
19:51:52 <ahasenack> sorry :)
19:52:10 <bdrung> Laney: sorry
19:52:16 <ahasenack> So for the past few SRUs the sponsors have asked me to apply for a per-package upload application for landscape-client
19:52:54 <ahasenack> and here I am
19:53:32 <ahasenack> oh, sorry, I failed to mention that my work in Landscape is QA
19:54:51 <Laney> how come seb128 hasn't endorsed? :)
19:54:58 <Laney> (common recent sponsor)
19:55:18 <mdz> o/
19:55:42 <Laney> oh looked like he had sponsored more
19:55:43 <Laney> nm
19:55:54 <ahasenack> I don't remember now if I asked him
19:56:35 <Laney> we'll need to get out of the way of the TB, so let's speed up
19:56:46 <Laney> is there anything particular/tricky about the landscape packaging?
19:57:02 <ahasenack> I think the fact that one source builds in many releases of ubuntu without changes
19:57:23 <ahasenack> meaning, we have some | in the depends line, and the rules file also tries to be smart about it
19:57:42 <ahasenack> we use substvars for that
19:57:45 <micahg> ahasenack: I assume the changelogs are preserved for in archive builds?
19:58:00 <ahasenack> micahg: yes, I take special note of the changelogs for each sru
19:58:03 <ahasenack> for each release
19:58:38 <ahasenack> in the beginning I didn't, and that was flagged in the review
19:59:52 <bdrung> ahasenack: landscape-client 12.04-0ubuntu0.12.04.0 closes a big bunch of bugs with one changelog entry. wouldn't it be better to just close one bug and mark the other as duplicates of the first one?
20:00:16 <ahasenack> bdrung: well, they weren't really duplicates
20:00:26 <ahasenack> bdrung: we introduced a big new feature
20:00:31 <ahasenack> bdrung: ideally, that would have been a blueprint
20:00:51 <micahg> they were all upstream bugs as well AFAICT...
20:00:53 <ahasenack> bdrung: each bug basically mapped to a branch of code that slowly introduced the new feature
20:01:13 <bdrung> aha, okay
20:01:13 <ahasenack> bdrung: it was the way we found to not pollute the changelog too much, but still record all the bugs
20:01:44 <ahasenack> otherwise it would be like a commit log
20:01:57 <bdrung> ahasenack: are there plans to bring the landscape client to other distributions like Debian?
20:02:11 <ahasenack> bdrung: that's more of a business decision, not a technical one
20:03:11 <bdrung> #vote Should Andreas Hasenack become upload rights for package landscape-client?
20:03:11 <meetingology> Please vote on: Should Andreas Hasenack become upload rights for package landscape-client?
20:03:11 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:03:11 <ahasenack> bdrung: out of my pay grade :)
20:04:56 <tumbleweed> +1 [ package is in fairly good shape and ahasenack has been looking after it for a long time ]
20:04:56 <meetingology> +1 [ package is in fairly good shape and ahasenack has been looking after it for a long time ] received from tumbleweed
20:06:39 <bdrung> +1
20:06:39 <meetingology> +1 received from bdrung
20:07:10 <micahg> +1, good history, takes criticism well
20:07:10 <meetingology> +1, good history, takes criticism well received from micahg
20:08:04 <cody-somerville> +1
20:08:04 <meetingology> +1 received from cody-somerville
20:08:18 <bdrung> #endvote
20:08:18 <meetingology> Voting ended on: Should Andreas Hasenack become upload rights for package landscape-client?
20:08:18 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:08:18 <meetingology> Motion carried
20:08:46 <bdrung> we had one +1 from Laney via our private channel
20:09:00 <bdrung> ahasenack: congrats to your new upload rights.
20:09:06 <ahasenack> bdrung: thanks
20:09:07 <ahasenack> thank you all
20:09:19 <bdrung> #topic Next chair.
20:09:22 <tumbleweed> next chair: stgraber [again]. next meeting: UDS
20:09:30 <bdrung> #endmeeting