15:00:37 <skaet> #startmeeting
15:00:37 <meetingology> Meeting started Fri Aug 10 15:00:37 2012 UTC.  The chair is skaet. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00:37 <meetingology> 
15:00:37 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
15:00:48 <Riddell> hi
15:01:05 * stgraber waves
15:01:10 * smartboyhw waves
15:01:17 <sil2100> Hi everyone
15:01:19 <skaet> Agenda (and minute location):
15:01:19 <skaet> https://wiki.ubuntu.com/ReleaseTeam/Meeting/2012-08-10
15:01:19 <skaet> .
15:01:19 <skaet> Upcoming dates:
15:01:19 <skaet> 12.10
15:01:20 <phillw> o/
15:01:21 <skaet> 2012/08/23: Quantal FeatureFreeze
15:01:22 <gema> o/
15:01:23 <skaet> 2012/09/06: 12.10 Beta 1
15:01:25 <skaet> 12.04.1
15:01:27 <skaet> 2012/08/16: FinalFreeze, ReleaseNoteFreeze
15:01:29 <skaet> 2012/08/23: Ubuntu 12.04.1
15:01:31 <skaet> .
15:01:33 <skaet> Work Items:
15:01:35 <skaet> 2012/08/10 -  3010 (was 3001  (last  week):   We�ve gotten behind the trendline for some of the projects.    There are only 2 weeks left until FeatureFreeze, so getting us back on track would be appreciated.
15:01:38 <skaet> Please help get us back where we should be by making sure https://launchpad.net/~/+upcomingwork is up to date for your tasks.
15:01:41 <skaet> .
15:01:50 <skaet> Bugs:
15:01:50 <skaet> Quantal: http://reports.qa.ubuntu.com/reports/rls-mgr/rls-q-tracking-bug-tasks.html
15:01:50 <skaet> 12.04.1: http://reports.qa.ubuntu.com/reports/rls-mgr/milestone-12.04.1.html
15:01:51 <skaet> 12.04.1: https://bugs.launchpad.net/ubuntu/precise/+bugs?field.milestone%3Alist=49926
15:01:53 <skaet> .
15:01:55 <skaet> Weekly Status Received:
15:01:58 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001712.html - PS(Unity) - sil2001
15:01:59 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001713.html - Security - mdeslaur
15:02:01 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001714.html - Community Testing - balloons
15:02:04 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001715.html - Ubuntu One - joshuahoover
15:02:07 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001716.html - Kernel - ogasawara
15:02:09 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001717.html - Desktop - seb128
15:02:11 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001720.html - Edubuntu - stgraber
15:02:13 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001721.html - QA - gema
15:02:15 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001722.html - Linaro - fabo
15:02:17 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001723.html - Xubuntu - astraljava
15:02:19 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001724.html - Kubuntu - Riddell
15:02:23 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001725.html - Foundations - ogra_
15:02:25 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001727.html - Server - arosales
15:02:27 <skaet> https://lists.ubuntu.com/archives/ubuntu-release/2012-August/001729.html - HW Cert - roadmr
15:02:29 <skaet> ?? - Ubuntu Studio - ScottL
15:02:31 <skaet> ?? - Lubuntu - gilir
15:02:33 <skaet> ..
15:02:35 <skaet> #Questions and Comments
15:02:37 <skaet> #topic Questions and Comments
15:02:46 <phillw> o/
15:02:50 <mdeslaur> o/
15:03:10 <skaet> hello everyone.  :)
15:03:21 <skaet> phillw do you have a question,  or just waving hello?
15:03:44 <smartboyhw> He meant a question, he o/ed before.
15:03:52 <phillw> skaet: a Question
15:03:57 <skaet> go ahead phillw
15:04:13 <phillw> what do you need from Lubuntu, you state no update.
15:04:32 <phillw> If Julien is busy (and I know he is), I can possibly furnish it
15:04:38 <skaet> phillw,  email status update to ubuntu-release mail list.
15:04:58 <Riddell> phillw: https://wiki.ubuntu.com/ReleaseTeam/Meeting/Agenda/TeamTemplate
15:05:27 <skaet> look at the format of the other ones,   just want to know what work has been happening, and if there are blockers/dependencies you're waiting on from other teams (or if you're landing something that other teams may care about)
15:05:29 <phillw> skaet: okies, he does fill one in each week at https://wiki.ubuntu.com/Lubuntu/ReleaseStatus/Quantal i
15:05:55 <phillw> I'll have a look at the format and have a chat with Julien to ensure it gets filed.
15:06:39 <skaet> phillw,  thanks.   Please mail a copy to the list though so others can look at it before meeting,  without having to remember separate paths.
15:06:58 <skaet> ..
15:07:04 <phillw> no worries, I will get it added to your template so you all have it.
15:07:29 <skaet> goodness.  thanks!   ..?
15:08:06 <skaet> phillw,  done?  ..?
15:08:17 * slangasek has a comment
15:08:19 <phillw> done :)
15:08:24 <skaet> coolio
15:08:42 <skaet> go mdeslaur
15:08:52 * skaet will ask slangasek after
15:08:52 <mdeslaur> hrm?
15:09:12 <mdeslaur> oh, sorry, I was just waving hello
15:09:15 <mdeslaur> ..
15:09:16 <skaet> mdeslaur,  ah,  just a hello after the Q&C part started then...   ok,  skipping.
15:09:22 <skaet> go slangasek
15:09:32 <slangasek> skaet: I'm very concerned about bug #1017001
15:09:34 <ubottu> Launchpad bug 1017001 in apt (Ubuntu Quantal) "package resolvconf 1.63ubuntu14 failed to install/upgrade: ErrorMessage: pre-dependency problem - not installing resolvconf" [Critical,Confirmed] https://launchpad.net/bugs/1017001
15:09:35 <slangasek> for 12.04.1
15:10:11 <slangasek> we have not been able to reproduce this bug under lab conditions, so although it's still milestoned, there's been no forward progress on resolution, and it's a quite bad LTS->LTS upgrade bug
15:10:55 <slangasek> with bdmurray's help there've been some fixes to the apport handling that *should* let us capture better info the next time the issue hits a user
15:11:19 <seb128> hey
15:11:31 <slangasek> but we don't know how widespread it is going to turn out to be once we turn on LTS->LTS upgrades by default - it could be very spectacularly bad, or it could be a non-event
15:11:34 <seb128> sorry, calendar integration is broken on my quantal, I missed the reminder
15:12:53 <slangasek> skaet: so I would like to propose that, at the 12.04.1 release time, we *tentatively* turn on the LTS upgrades in meta-release, watch for new incoming traffic for a bit, and be prepared to revert meta-release if it turns out to be a problem... and only announce the point release after we've done this test
15:13:54 <skaet> slangasek,  thanks for flagging.     Would it be possible to do this test when we hit final freeze?   since we shouldn't be changing after that,  and that would give us a window to react before the point release is announced?
15:14:08 <gema> since we
15:14:08 <gema> shouldn't be changing after that,  and that would give us
15:14:22 <gema> sorry, hit the wront button
15:14:35 <slangasek> skaet: well, it's possible, but that means some random selection of our users will get a surprise update to 12.04 a week before the announced milestone release
15:15:14 <skaet> slangasek,  we could announce it as a candidate?   and make it visible to minimize surprises?
15:15:26 <slangasek> personally I think it would be better to wait until the scheduled date to flip the switch
15:15:57 <stgraber> the alternative would be to release the point release at the announced date but saying that 12.04.1 upgrades will be made available to users over the coming days
15:16:10 <slangasek> I don't see any way to actually message it as a candidate... the users are going to find out about it when their computer suddenly tells them a new version is available
15:16:16 <stgraber> where we set the flag, wait a few hours, revert and then look for what bug traffic we got during the interval
15:16:54 <gema> shouldn't we be warning them that they may hit problems?
15:16:58 <skaet> slangasek,  stgraber,   ok,  that will be the plan then.   (was thinking an email to ubuntu-announce, but probably will cause more confusion than solve issue)
15:17:53 <stgraber> gema: we certainly need to have the bug in the release notes, though as we were never able to reproduce it, we don't know exactly in what state the system is, so we don't know how to recover from it
15:17:57 <slangasek> gema: it's a tradeoff.  We have a total of 6 reports of this upgrade failure, from an unknown number of early-adopter upgraders from lucid; we have no idea if they're representative of the larger userbase or even how the error happened, as we've tried and failed to reproduce the failure using apt-clone data
15:18:40 <gema> stgraber:
15:18:43 <gema> slangasek: ack
15:19:11 <stgraber> I'm still hoping to hit that bug during my manual upgrades test, but out of the 20 or so I've done this week, it hasn't happened to me yet
15:19:14 <slangasek> skaet: sorry, to be clear, which will be the plan?
15:19:26 <stgraber> though I'm using clean and up to date 10.04.4 systems
15:19:59 <skaet> slangasek,  we'll go with what you and stgraber recommend,   put a release note in place,  and make sure we have active monitoring after we flip the switch on release day.
15:20:01 <slangasek> gema: the other issue is that thanks to the previous security issues that led to us scrubbing apt-clone attachments, there's a good chance we'll never be able to reproduce the bug until we get another report of it :/
15:20:40 <slangasek> skaet: and hold off on the announcement until we've gathered the data?
15:21:01 <slangasek> (which is what I'm recommending, but I don't think that's the same thing stgraber recommended :)
15:21:40 <skaet> slangasek,  not sure I see the benefit of holding off on the announcement,  but let me review the notes and talk to you about it next week.
15:21:50 <slangasek> ok
15:21:57 <slangasek> yeah, we can iron out the details outside the meeting :)
15:21:57 <stgraber> right, my recommendation was to publish the announcement for 12.04.1 as the media will be good but stating that upgrades will be progressively rolled out over the coming days. Letting us turn them on for a few hours, then off if we notice bug trafic
15:22:10 <skaet> also want to make sure we have a good monitoring plan in place.   :)
15:22:56 <gema> skaet: I will ask someone in the team to try to reproduce next week
15:23:02 <gema> QA team, that is
15:23:05 <skaet> #action skaet, slangasek, stgraber - determine announcement and monitoring plan for https://launchpad.net/bugs/1017001
15:23:05 * meetingology skaet, slangasek, stgraber - determine announcement and monitoring plan for https://launchpad.net/bugs/1017001
15:23:08 <ubottu> Launchpad bug 1017001 in apt (Ubuntu Quantal) "package resolvconf 1.63ubuntu14 failed to install/upgrade: ErrorMessage: pre-dependency problem - not installing resolvconf" [Critical,Confirmed]
15:23:15 <skaet> thanks gema.   would appreciate that.
15:23:30 <slangasek> gema: any help reproducing it is certainly appreciated, but I don't have high hopes that you'll succeed in reproducing it
15:23:46 <gema> slangasek: we will at least try
15:24:36 <skaet> ..
15:25:00 <skaet> and since I don't see any more queued up o/,  will go into some of mine,  first of which is related ;)
15:25:05 <skaet> gema,  is there anything showing up from the daily automated testing from precise that should be considered a blocker at this point,  and can�t be release noted?   (I agree that the left over files should be cleaned up,  but figure that they can be release noted).
15:25:40 * skaet didn't see anything in the report from this week, but wants to double check since we're getting close now.
15:25:48 <ogra_> o/ ... /me has the general unpleasant compiz question for seb128 :)
15:26:15 <gema> skaet: nothing so far
15:26:27 <gema> skaet: will let you know as soon as we hit something like that
15:26:37 <skaet> thanks gema.  :)
15:26:50 <seb128> ogra_, lol, I've the usual reply for you :p
15:26:58 <ogra_> :)
15:27:04 <ogra_> ..
15:27:42 <gema> skaet: just for the record, we are working on verifying 1029531, but I believe it is already fixed
15:27:59 <gema> ..
15:28:03 <stgraber> bug 1029531
15:28:05 <ubottu> Launchpad bug 1029531 in update-manager (Ubuntu Precise) "cdromupgrade from Lucid to Precise failed with unmet dependencies without network connection" [Critical,Fix committed] https://launchpad.net/bugs/1029531
15:28:07 <skaet> based on discussion with stgraber this morning,  we'll switch to build from -updates on monday,  rather than today,  so if there's any surprises on the monday night runs,  please flag soonest.
15:28:31 <skaet> ..
15:29:19 * skaet sees that ogra_ and seb128 have handled ogra_'s question out of band,  so....  continuing on.  ;)
15:29:29 <seb128> he
15:29:31 <seb128> heh
15:29:35 <ogra_> *g*
15:29:37 <seb128> ogra_, to give a more complete reply
15:29:49 <seb128> they finally put the merge request for merging in trunk up today
15:29:54 <seb128> so I hope it's really close
15:30:08 <seb128> they consider it ready to be merged at least
15:30:15 <seb128> so if no surprise next week...
15:30:44 <seb128> ..
15:30:59 <skaet> seb128,  The g-c-c patches are still blocked on taking a decision about llvmpipe.    where are you waiting on a decision about llvmpipe from - upstream?   likely to make before feature freeze?
15:31:17 <ogra_> yay
15:31:18 <seb128> that got decided
15:31:33 <seb128> basically llvmpipe is the answer they hopped it to be
15:31:37 <sil2100> From what I know we'll be trying to get the gsettings patches released tomorrow
15:31:39 <seb128> so we are dropping unity-2d
15:31:48 <seb128> and claiming that we stop supporting low end hardware
15:31:52 <sil2100> s/tomorrow/next week
15:31:59 <seb128> we will redirect those users to 12.04LTS probably
15:32:04 <seb128> that's still being discussed
15:32:09 <seb128> since that's quite a big shift
15:32:18 <seb128> ..
15:32:35 <ogra_> seb128, how much has that llvmpipe stuff been tested on arm ?
15:32:45 <ogra_> (or on anything we ship)
15:32:46 <seb128> ogra_, it doesn't work on arm
15:32:51 <seb128> as said it's not a reply
15:32:59 <ogra_> so whats my fallback on the arm images then ?
15:33:02 <seb128> it's 3d driver or use 12.04LTS
15:33:12 <seb128> ogra_, I though gles was working on the pandaboard?
15:33:20 <ogra_> so i should ship 120.04 alongside on  arm ?
15:33:28 <ogra_> no, it doesnt
15:33:32 <ogra_> we cant ship the dirver
15:33:32 <seb128> :-(
15:33:50 <ogra_> it does once you have (like on an nvidia PC) installed the third party driver
15:34:04 <ogra_> but there is only framebuffer X on first boot
15:34:06 <seb128> "great"
15:34:20 <balloons> There *was* a project that seems to have dried up to create an OSS driver for it
15:34:21 <seb128> well, those questions are actively discussed between PS, Jason, Rick, etc atm
15:34:32 <ogra_> thats the same for all arm platforms btw, all are like nvidia (even worse most of the time) wrt licensing
15:34:38 <seb128> so I've no reply yet on what we will suggest for you
15:35:00 <ogra_> would have been good to have an arm person involved ;)
15:35:10 <ogra_> anyway, not your prob ..
15:35:11 <ogra_> ..
15:36:16 <skaet> seb128,  where will this end up getting documented,  since its going to be pretty visible?   (am thinking that the beta release notes at a minimum, but probably want something wider)
15:36:49 <seb128> skaet, I will have responses to that we will have decisions on what we do exactly
15:36:57 <seb128> it's an hot topic and still being actively discussed
15:37:08 <seb128> I will let the release list and people know when we have a decision
15:37:14 <skaet> seb128, fair enough.   :)   Thanks.
15:37:15 <seb128> then we can figure where to announce it
15:37:17 <seb128> yw
15:37:21 <skaet> ..
15:38:25 <skaet> balloons,  you asked are we tracking things that failed to make it into the previous milestone and marking them for the next milestone?   yes,  its one of the checklist steps for a release to work through all the milestoned bugs and retarget them to the next milestone.   A3 pass is still needs to be finished,  A1/A2 have been done.
15:38:52 <balloons> skaet, thank you. I assumed so, I just hadn't seen it happen for a3 yet, so :-)
15:39:26 <skaet> balloons,  :)  will be finished this afternoon.   Was working on 12.04.1 stuff.  ;)
15:39:40 <skaet> ..
15:40:44 <skaet> astraljava,  any smoke testing of 12.04.1 images been done?   if so,  any issues/concerns showing up?
15:41:23 <astraljava> skaet: Some testing has happened, but I haven't compiled results thus far.
15:41:32 <astraljava> I'll try to do so over the weekend, and report back.
15:41:35 <astraljava> ..
15:41:40 <skaet> Thanks astraljava :)
15:41:41 <skaet> ..
15:41:58 * skaet looks around if anyone else has questions (o/)?
15:42:51 <skaet> If not,   last comment is that some teams have burn down charts that are starting to look seriously behind.
15:43:26 <skaet> Please mark the features that are clearly not going to make it in by feature freeze in 2 weeks.
15:43:53 <seb128> skaet, stop looking at the foundation team :p
15:44:01 <skaet> lol
15:44:16 <seb128> joke aside I'm concerned that the upstart improvements we were said would land this cycle will not
15:44:18 * skaet was trying to be tactful,  but there are a few others as well...
15:44:30 <seb128> it's somewhat a concern for desktop
15:44:34 * sil2100 hides
15:44:43 <skaet> slangasek, ogra_ ^
15:45:12 * ogra_ thoght jodh just landed a bunch
15:45:34 <ogra_> seb128, which are missing ?
15:45:44 <seb128> ogra_, things discussed at UDS I didn't see yet
15:45:51 <seb128> XDG_RUNTIME_SUPPORT
15:45:58 <seb128> logind support
15:46:05 <seb128> user session jobs
15:46:14 <ogra_> oh
15:46:15 <seb128> I guess some of those will not land this cycle
15:46:24 <seb128> but having a status update would be good, we have work blocked on those
15:46:31 <seb128> the XDG_RUNTIME_SUPPORT one is important
15:46:36 <ogra_> ok if i get you one next meeting ?
15:46:42 <seb128> dconf segfaults on NFS and ecryptfs regularly without it
15:46:45 <ogra_> i need to collect info on that
15:46:50 <seb128> it's one of the most common errors on e.u.c
15:46:55 <seb128> ogra_, sure
15:46:58 <seb128> ogra_, thanks
15:47:04 <ogra_> thx, will update you as soon as i have it
15:47:08 <ogra_> ..
15:47:10 <skaet> seb128:  any update on http://status.ubuntu.com/ubuntu-quantal/group/topic-quantal-desktop-greeter-lockscreen.html  ?
15:47:27 <skaet> since we're going into specifics... ;)
15:48:24 <seb128> skaet, I postponed it to next cycle
15:48:41 <skaet> seb128, can you update the blueprints to reflect that.
15:48:47 <seb128> yes
15:48:51 <skaet> Thanks!
15:48:56 <seb128> I updated https://blueprints.launchpad.net/ubuntu/+spec/desktop-q-system-compositor
15:49:01 <seb128> but forgot about the topic one
15:49:22 <skaet> thanks seb128   :)
15:49:34 <skaet> anyone else?
15:49:35 <skaet> ..
15:50:03 <skaet> #endmeeting