14:02:34 <stgraber> #startmeeting 12.04.1 team meeting
14:02:34 <meetingology> Meeting started Thu Aug  2 14:02:34 2012 UTC.  The chair is stgraber. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:02:34 <meetingology> 
14:02:34 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
14:02:45 <smartboyhw> Good...
14:02:46 <Daviey> smoser is here, he is just slacking.
14:02:51 <stgraber> #topic Action items review
14:02:58 <arges> o/
14:03:13 <stgraber> so, only action on the list is xnox's usual item but he's not around, so keeping on the list ;)
14:03:19 <stgraber> #topic Review of upcoming deadlines
14:03:23 <stgraber> Daviey: good to know ;)
14:03:24 <smartboyhw> o/
14:03:32 <stgraber> - today 21:00 UTC: Beginning of PointReleaseProcess and DesktopInfrastructureFreeze
14:03:34 <stgraber> - 2012/08/09: KernelFreeze, LanguageTranslationDeadline, SRU Fix Validation Testing
14:03:38 <stgraber> - 2012/08/16: FinalFreeze, ReleaseNoteFreeze
14:03:40 <stgraber> - 2012/08/23: Ubuntu 12.04.1
14:04:05 <smartboyhw> o/
14:04:06 <stgraber> please remind all your team members that uploads for the point release need to happen by TODAY 21:00 UTC (7 hours from now)
14:04:25 <stgraber> smartboyhw: yes?
14:04:47 <smartboyhw> Er, thank you for giving us, the QA team, to test daily builds
14:05:07 <smartboyhw> We will be testing the builds progressively in the weeks...
14:05:08 <smartboyhw> ..
14:05:19 <stgraber> cool, thanks
14:05:23 <stgraber> #topic Quick look through the current bug lists, checking for progress.
14:05:29 <stgraber> The number of targeted bugs went from 106 last week to 75!
14:05:29 <stgraber> Of these 75, 32 are in fix commited state (likely waiting in -proposed)
14:05:30 <stgraber> and 9 are marked "in progress" (waiting to be approved).
14:05:39 <stgraber> So that's 34 bugs that still need fixing of which 12 aren't assigned to somebody.
14:05:46 <seb128> it would help if http://people.canonical.com/~arges/point-release/milestone-12.04.1.html was updated
14:05:53 <seb128> the current page is from july 26
14:06:04 <stgraber> arges: ^
14:06:31 <arges> seb128, yes
14:06:38 <arges> seb128, so i'm trying to get it set up as a cronjob on cranberry
14:06:41 <smoser> o/
14:06:50 <arges> seb128, working with DAs on getting that going
14:06:58 <arges> and skaet , Ursinha , bdmurray etc
14:07:00 <seb128> can you run it manually once today?
14:07:07 <arges> seb128, yea i'll just do that
14:07:16 <seb128> thanks
14:07:34 <stgraber> The full list of bugs can be found at: https://bugs.launchpad.net/ubuntu/precise/+bugs?field.milestone%3Alist=49926
14:07:37 <stgraber> The list of remaining bugs to fix can be found at: http://goo.gl/RUiZe
14:07:40 <stgraber> Some of these aren't assigned to someone yet: http://goo.gl/22zV2
14:07:42 <stgraber> Any bug that's on the list and doesn't have a fix in -proposed or waiting in the unapproved queue will be re-targeted to 12.04.2 shortly after 21:00 UTC today.
14:07:45 <stgraber> It'd be good if all teams could go through the bug list and re-target bugs to realistic milestones before I re-target the rest to 12.04.2.
14:07:57 <stgraber> If you have any bug that absolutely needs to be fixed for 12.04.1 and needs to stay on the list, please ping me with the bug number so I make sure not to move it to 12.04.2. Current list is: bug 1017001, bug 991982, bug 1029531 and bug 987411.
14:08:00 <ubottu> Launchpad bug 1017001 in apt (Ubuntu Quantal) "package resolvconf 1.63ubuntu14 failed to install/upgrade: ErrorMessage: pre-dependency problem - not installing resolvconf" [Critical,Confirmed] https://launchpad.net/bugs/1017001
14:08:02 <ubottu> Error: Launchpad bug 991982 could not be found
14:08:03 <ubottu> Launchpad bug 1029531 in update-manager (Ubuntu Precise) "cdromupgrade from Lucid to Precise failed with unmet dependencies without network connection" [Critical,Confirmed] https://launchpad.net/bugs/1029531
14:08:04 <ubottu> Launchpad bug 987411 in ubiquity-slideshow-ubuntu (Ubuntu Quantal) "layout of browser slide in Lubuntu slide show broken (german)" [Low,Triaged] https://launchpad.net/bugs/987411
14:09:00 <smartboyhw> how to ping?
14:09:18 <stgraber> any other bugs that you know won't make it by the deadline but is needed for the point release?
14:09:34 <smartboyhw> I thoughy 1029531 is a serious one
14:10:11 <stgraber> yes, and if you look up, you'll see that it's on the list of bugs that are allowed to be fixed post-deadline
14:10:29 <smartboyhw> What is bug 991982/
14:10:30 <ubottu> Error: Launchpad bug 991982 could not be found
14:10:34 <smartboyhw> See...
14:10:36 <stgraber> critical security bug
14:11:07 <stgraber> can't give more details than that, sorry. I have the fix for it but because of its nature, it'll only be uploaded very shortly before we build the final images.
14:11:35 <stgraber> #topic Media oversizedness
14:11:44 <stgraber> Just wanted to give a quick status update on that one.
14:11:48 <smartboyhw> Yeah, they really need to be fixed
14:11:59 <smartboyhw> Thanks, stgraber
14:12:03 <stgraber> infinity uploaded a new live-build fixing the duplication of kernel headers
14:12:11 <stgraber> this should free around 2MB per affected livefs
14:12:36 <stgraber> so that's still between 5MB and 7MB that need to be tracked down and fixed by either changing whatever's taking the extra space or removing langpacks
14:12:55 <smartboyhw> Removing langpacks would be a good idea, I think
14:13:01 <smartboyhw> Put it in the DVDs:)
14:13:26 <stgraber> removing some langpacks is the usual last option, sadly we've been using that trick quite a lot lately so there's pretty much nothing to remove
14:14:07 <stgraber> anyway, I'll be looking into that later this week (after the deadline), it might require some uploads or if we're lucky, just seed changes
14:14:09 <smartboyhw> HAHA
14:15:24 <seb128> do we know what took the place between 12.04 and 12.04.1
14:15:24 <seb128> ?
14:15:35 <smartboyhw> Daily builds?
14:16:13 <seb128> what about daily builds?
14:16:25 <stgraber> seb128: nope, though the current guess is firefox/thunderbird/libreoffice, but that's just a guess
14:16:38 <smartboyhw> It's the Daily Builds compiled for 12.04.1 and 12.10, which we QA Team test...
14:17:35 <stgraber> skaet: hmm, I thought the upper limit was 703MB bug I see a kubuntu build at 704MB not marked as oversized... will have to check if that's just a rounding issue or if something's broken with the check
14:17:37 <skaet> seb128,  we've got scripts that will pull the changelogs
14:17:47 <smartboyhw> It is 703MiB...
14:18:07 <seb128> skaet, I though we had tools telling us what changed between isos?
14:18:29 <smartboyhw> I mean the limit
14:18:56 <stgraber> seb128: I believe we have tools to diff the manifests though we don't have enough history data to pinpoint the image where we went oversized
14:18:58 <skaet> stgraber, yeah,  all of the flavors will need to be double checked.
14:19:02 <stgraber> so will have to go through a pretty long list
14:19:26 <smartboyhw> Lubuntu, Kubuntu, Edubuntu, Ubuntu Studio, Normal Ubuntu...
14:19:30 <smartboyhw> Xubuntu
14:19:47 <smartboyhw> ..
14:20:04 <stgraber> #topic Round table
14:20:09 <stgraber> stgraber@castiana:~$ echo $(shuf -e NCommander seb128 stgraber stokachu arges jibel skaet smoser jamespage)
14:20:13 <stgraber> smoser stokachu seb128 jibel NCommander stgraber skaet jamespage arges
14:20:13 <stgraber> smoser: you win :)
14:20:19 <smartboyhw> Congrats...
14:20:24 <skaet> seb128,  there are some tools,  but improvements needed. :/
14:20:29 <smoser> ok.
14:20:46 <smoser> we have made some progress.. again, maas is our big thing that is left out
14:20:55 <smoser> roaksoax is working on that.
14:21:16 <smoser> i had told him that today is deadline, but honestly i think that next week is a better target for his work (and more realisitic)
14:21:30 <smoser> fi there are other thing sthat you feel need priority, then i'm willing to go find a stick.
14:21:30 <Daviey> .. well today is simply not viable.
14:21:37 <smartboyhw> I agree...
14:21:38 <smoser> other than that, i think we're doing ok, and that is all from me.
14:22:08 <stgraber> smoser, Daviey, jamespage: can you give me a list of server bugs that you will fix for the point release but won't make it today?
14:22:27 <smoser> stgraber, can i come back to you with that?
14:22:48 <stgraber> sure, just make sure you give me that before 21:00 UTC if you don't want to see your bugs getting milestoned to .2 :)
14:23:02 <stgraber> stokachu:
14:23:07 <smartboyhw> Could one of you go to the Ubuntu QA Meeting on 8th August?
14:23:18 <smartboyhw> I will add it to the agenda to discuss about 12.04.1
14:23:23 <smartboyhw> 1400UTC
14:23:54 <smoser> k
14:24:53 <stgraber> smartboyhw: can you wait until we're done with the roundtable and get to the AOB part of the meeting? (I won't make it at least, meeting conflict)
14:24:58 <smartboyhw> Sorry...
14:25:03 <stgraber> seb128: you're up (no stokachu apparently)
14:25:19 <seb128> hey
14:25:41 <seb128> so desktop is mostly done for .1, some bugs didn't made it but that's not end of the world and not important for the iso
14:25:44 <arges> stgraber, yea no stokes. i know he's been heads down with multiarch work
14:25:50 <seb128> we still have a nux and some easy updates in the proposed queue
14:26:03 <seb128> upload date is counted for what goes in right?
14:26:09 <stgraber> yes
14:26:18 <stgraber> if it's in unapproved, it's fine by me
14:26:23 <seb128> we delayed the unity performances improvement to after .1, too risky that late
14:26:33 <seb128> otherwise something to sort for .1
14:26:45 <seb128> the desktop team really wants whoopsie off by default
14:26:55 <seb128> what's the right place, people to discuss, decide this?
14:27:09 <skaet> seb128,  start a thread on ubuntu-release
14:27:13 <seb128> ok
14:27:25 <smartboyhw> I will go to #ubuntu-release now to see...
14:27:32 <seb128> ..
14:27:35 <smartboyhw> Hmm...
14:27:37 <seb128> I'm done otherwise
14:27:47 <seb128> what's the opinion of people here on whoopsie by default?
14:27:49 <arges> seb128, skaet : i've been noticing its popping up a lot less with the latest precise...  does it not pop up if its a known crash?
14:28:29 <seb128> arges, it does stop bothering you after 3 times, but that's considered a bug by the whoopsie guys, it should bother you every time you hit the bug
14:29:16 <arges> seb128, hmm. whats the bug #?
14:29:21 <arges> i've love to make sure i'm sending those reports
14:29:23 <skaet> arges,   ev will know for certain and should be part of the discussion at any rate.
14:29:38 <seb128> arges, not sure
14:29:42 <arges> ok
14:30:14 <stgraber> I think it'll be an interesting discussion, whoopsie was definitely designed to be always on but I can also see how it's annoying for some users.
14:30:39 <seb128> the cost-benefit seems in our disfavor at this point imho
14:30:51 <seb128> (I discussed that with pitti and didrocks and some others last week)
14:31:10 <arges> either way it would be good for it to be switchable for those of us that want to send those reports
14:31:11 <seb128> we bother lot of users and give the impression that the system is unstable
14:31:18 <stgraber> I'm wondering if we couldn't get away with changing the popup message and offering to "always silently report" and "never report for that user" in that same dialog, so that user can choose to stop being poked all the time but still send the crashes (making the choice to send us data without reviewing it first)
14:31:46 <seb128> imho we should have it always one, but not for the lts since it's too early
14:32:18 <seb128> errors.ubuntu.com is still buggy and we still have backlog of issues and annoy users too much
14:32:20 <skaet> seb128,   can you include the bug number info in the email thread (and if no bug number exists create one?)
14:32:26 <seb128> ok
14:32:32 <stgraber> so yeah, I think it's a good discussion to have and one where we definitely need Evan involved, so ubuntu-release@lists.u.c sounds like the right place for that
14:32:41 <seb128> is ev on that list?
14:32:53 <stgraber> good question
14:33:04 <stgraber> skaet: can you check? (I don't have mailman access to that one)
14:33:06 <skaet> seb128,  I'll check,  but make it explicit to him,  just in case
14:33:13 <seb128> ok
14:33:13 <smartboyhw> I'm back
14:33:30 <stgraber> jibel:
14:33:36 <stgraber> around? (I know you're sprinting)
14:33:37 <jibel> hi
14:33:48 <jibel> Ran manual upgrade tests, found 1029531
14:34:01 <jibel> Continued with SRU verification
14:34:08 <jibel> Found a little confusion around Wubi images that were overwritting Quantal ones.
14:34:18 <jibel> infinity fixed it 1 hour ago, waiting for Precise wubi images to show up and proceed to verification.
14:34:19 <smartboyhw> Bug 1029531
14:34:22 <ubottu> Launchpad bug 1029531 in update-manager (Ubuntu Precise) "cdromupgrade from Lucid to Precise failed with unmet dependencies without network connection" [Critical,Confirmed] https://launchpad.net/bugs/1029531
14:34:31 <jibel> wubi.exe will need an update to point to the location of 12.04.1 disk images.
14:34:35 <smartboyhw> I know that one
14:34:49 <jibel> smartboyhw, please wait until ..
14:34:55 <smartboyhw> I mean the bug
14:35:02 <jibel> Not much otherwise since I've been sprinting all week, will continue with SRU verification next week.
14:35:10 <jibel> ..
14:35:23 <skaet> jibel, I've put a ping in to ev on update to 12.04.1
14:35:34 <jibel> skaet, ta
14:35:37 <seb128> did we sort out https://bugs.launchpad.net/ubuntu/+source/gsettings-desktop-schemas/+bug/1022864 btw
14:35:38 <ubottu> Launchpad bug 1022864 in gsettings-desktop-schemas (Ubuntu Quantal) "Lucid to Precise upgrade test failed: User settings are not preserved on upgrade" [High,New]
14:35:45 <skaet> for wubi,  but haven't heard back.   will keep it on the radar.
14:36:03 <jibel> seb128, no, not yet, it's on my todo first thing next week
14:36:05 <seb128> nobody replied to pitti's comment
14:36:11 <seb128> jibel, thanks
14:38:05 <stgraber> NCommander:
14:38:22 <NCommander> Highbank migrated to updates and is set for 12.04.1
14:38:59 <NCommander> I'm getting armadaxp checked in prep for 12.04.1 and we're looking pretty solid for the release
14:39:20 <NCommander> ..
14:41:43 <stgraber> stgraber:
14:42:27 <stgraber> I've been going through the foundations bug, clearing the list quite a bit. We're now left with an eglibc update and the security bugs to upload
14:42:50 <stgraber> eglibc should land this weekend at the latest, the others will land just before final freeze
14:43:21 <stgraber> I've been doing a bit of verification, trying to get that list a bit shorter, uploaded and tested a refreshed ubiquity (picking up the ARM stuff and the d-i-u fix)
14:44:09 <stgraber> I'll continue with the nagging for the rest of today, deal with the freeze (+ re-target) and then start looking into the oversizedness problem
14:44:12 <stgraber> ..
14:44:19 <stgraber> skaet:
14:44:37 <skaet> New translations are being uploaded to -proposed now.
14:44:37 <skaet> Daily Precise builds have been enabled for all the images on the manifest.
14:44:38 <skaet> #action Flavor leads participating,  please verify that the images are as you expect,  and start smoke testing tomorrow to make sure all the right 12.04.1 bits are in place.
14:44:38 <skaet> #link http://iso.qa.ubuntu.com/qatracker/milestones/204/builds
14:44:38 <skaet> Will be starting on updating the Release Notes for 12.04.1 this week, and pulling information from the various leads.
14:44:38 * meetingology Flavor leads participating,  please verify that the images are as you expect,  and start smoke testing tomorrow to make sure all the right 12.04.1 bits are in place.
14:44:40 <skaet> What's new is that we will be snapshotting (and saving) what is currently there for 12.04 and then updating the notes to reflect the 12.04.1 status and changelogs.
14:44:55 <skaet> ..
14:45:24 <skaet> stgraber,  there's an ABI bump on the new kernel,  will you be handling it as well?
14:45:41 <skaet> s/it/d-i changes/
14:45:46 <stgraber> skaet: I can do that, yes.
14:45:54 <skaet> stgraber,  thanks!  :)
14:45:55 <stgraber> skaet: what's the ETA for the new kernel?
14:46:36 <stgraber> I know they have an extra week to have their things uploaded
14:46:59 <skaet> stgraber,  I'll get with you offline about it.    There's one that just went up,  but not sure if there will be another.
14:48:21 * skaet trying to get some more info on that
14:48:22 <skaet> ..
14:48:42 <stgraber> jamespage:
14:49:00 <Daviey> stgraber: he is away today
14:49:21 <stgraber> ok
14:49:22 <stgraber> arges:
14:49:46 <arges> stgraber, been trying to get my reports on cranberry, working on this.
14:49:58 <arges> in the meantime will get it working on my desktop. just updated the report.
14:50:07 <arges> ..
14:51:18 <stgraber> #topic AOB
14:51:31 <smartboyhw> o/
14:51:38 <stgraber> smartboyhw: go ahead
14:51:41 <smartboyhw> Yep
14:51:54 <smartboyhw> As I said before, I invite you to one of our QA meetings
14:52:10 <smartboyhw> Since the QA team would like to talk about 12.04.1
14:52:27 <smartboyhw> Er... Maybe on 8th August or 15th August..
14:52:32 <smartboyhw> ..
14:52:45 <skaet> smartboyhw, I'll try to be there
14:53:03 <skaet> ..
14:53:09 <stgraber> I have a conflict at that time but might still be looking at IRC, we'll see.
14:53:16 <smartboyhw> The 8th August or 15th August?
14:53:25 <smartboyhw> I only need 1 representative.
14:54:02 <smartboyhw> ..
14:54:27 <skaet> smartboyhw,  I can do the 8th.
14:54:46 <stgraber> my conflict is on every Wednesdays, so if skaet can make it, that's good. Though it sounds like we're having a lot of meetings (release + 12.04.1) and we already have jibel from QA in the 12.04.1 meeting to coordinate the work.
14:54:59 <smartboyhw> Good. I will add it to the agenda
14:55:06 <smartboyhw> 1400UTC, chair phillw.
14:55:09 <smartboyhw> ..
14:55:31 <stgraber> alright, time to get back to trying to fix these 34 remaining bugs ;)
14:55:34 <stgraber> #endmeeting