19:05:36 <bdrung> #startmeeting
19:05:36 <meetingology> Meeting started Mon Jul 16 19:05:36 2012 UTC.  The chair is bdrung. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:05:36 <meetingology> 
19:05:36 <meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired
19:07:16 <bdrung> #topic Review of previous action items
19:07:28 <bdrung> #subtopic micahg to document the zentyal packageset
19:07:38 <micahg> nope, /me is a slacker
19:08:03 <bdrung> micahg: should we increase the pressure? ;)
19:08:08 <Laney> one beer per meeting undone
19:08:10 <Laney> each.
19:08:18 <micahg> heh
19:08:22 <bdrung> good idea.
19:08:46 <bdrung> should we vote on that? :P
19:08:49 <micahg> as long as it's not retroactive :)
19:09:20 * cody-somerville grins.
19:09:57 <bdrung> we are not politicians. :)
19:09:59 <bdrung> #subtopic everyone try and be at CC meeting July 5th 17:00 UTC
19:10:15 <Laney> some people did
19:10:28 <Laney> we mainly discussed the PPU-membership thing
19:11:01 <bdrung> which leads to the next item
19:11:07 <bdrung> #subtopic micahg to start a discussion on dmb@ about whether PPU should confer membership
19:11:20 * micahg forgets if he did that or not
19:11:47 * micahg started one before the CC meeting
19:11:48 <bdrung> beer, beer, beer!
19:11:53 <Laney> yeah, there is one ther
19:11:54 <Laney> e
19:12:00 <Laney> we should get some kind of consensus
19:12:08 <Laney> weren't we supposed to start one with the cc or something?
19:12:21 <micahg> Laney: no, I think that was bueno's action
19:12:31 <Laney> oh, great
19:12:33 <micahg> beuno I mean
19:14:58 * Laney eyes bdrung
19:15:23 <bdrung> shouldn't we come to some kind of consensus?
19:15:34 <beuno> yes, apologies, I have not sent out the proper emails
19:15:37 <beuno> will do so today
19:15:51 <Laney> we should, in ^ thread
19:15:59 <Laney> put it on the agenda for the next meeting
19:16:42 * stgraber waves
19:17:21 <bdrung> #action add PPU-membership thing discussion for getting a consensus on the agenda
19:17:21 * meetingology add PPU-membership thing discussion for getting a consensus on the agenda
19:17:29 <stgraber> sorry for not showing up earlier, was debugging some cdimage script and missed the beginning of the meeting :(
19:18:09 <bdrung> #topic Ubuntu Core Developer Applications
19:18:48 <bdrung> #subtopic Iain Lane's core-dev application
19:18:59 <bdrung> #link https://wiki.ubuntu.com/IainLane/CoreDevApplication
19:19:38 <bdrung> Laney: do you like to introduce yourself? ;)
19:19:47 <Laney> ok
19:20:13 <Laney> My name is Iain. I live in Nottingham, which is in the East Midlands in England.
19:20:19 <Laney> It's raining.
19:20:26 <Laney> It's been raining for about three months constantly.
19:20:48 <Laney> I'm a MOTU and I've been one for something over three years now. I've been a DD for a bit over a year.
19:20:51 <bdrung> then you have enough time to code ;)
19:21:21 <Laney> In Ubuntu I'm a backporter, I'm on the release team and I'm also on this DMB.
19:21:34 <Laney> I just joined Canonical on the Desktop team, as you might be able to tell from my endorsers.
19:21:38 <Laney> ..
19:23:31 <micahg> Laney: as you're in ubuntu-desktop know, do you see yourself uploading things outside of MOTU and the desktop package set?
19:23:39 <micahg> s/know/now/
19:24:07 <Laney> yeah, desktop can be kind of limited
19:24:21 <Laney> I have a glib2.0 and poppler upload planned, both of which I don't think are in the desktop set.
19:24:28 <Laney> (the former uploaded to exp already)
19:25:33 <Laney> Also, it would be good to be able to sponsor stuff.
19:25:42 <Laney> Oh. I also found myself looking after emacs a bit.
19:25:59 <bdrung> Laney: will you help to reduce the sponsors queue to zero?
19:27:06 <Laney> I'd like to think so. I've not been a very active sponsor in Ubuntu to date really.
19:27:15 <Laney> I'm much better at sponsoring stuff in Debian for some reason.
19:27:40 <bdrung> Laney: do you know our sponsors queue list?
19:27:49 <Laney> do I know it?
19:27:54 <Laney> You mean do I know where it is?!
19:28:00 <bdrung> http://reports.qa.ubuntu.com/reports/sponsoring/
19:28:21 <Laney> yes
19:28:23 <bdrung> have you looked at it?
19:28:26 <Laney> I even submitted a patch to it before
19:28:30 <Laney> which broke it and got reverted
19:29:15 <bdrung> Laney: do you know why you are better sponsor in debian than in ubuntu?
19:29:26 <Laney> more focused teams I guess
19:29:37 <Laney> sometimes people email me directly which works quite well
19:29:57 <Laney> I have a much higher chance of being able to review one of those changes well than any random Ubuntu package
19:30:10 <bdrung> Laney: would grouping by package set help?
19:30:18 <Laney> it does that
19:30:26 <Laney> and yeah, I do sometimes cherry-pick those sponsor request
19:30:37 <Laney> but cli-mono hasn't historically had that many. Maybe it'll be better now with desktop
19:31:36 <bdrung> we could create separate tables for each package set
19:32:35 <Laney> not sure it would add much over being able to sort the columns as you can do currently
19:33:42 <bdrung> would it help to group by debian teams?
19:34:15 <Laney> maybe
19:34:23 <Laney> does it have a feed?
19:34:33 <Laney> or some kind of machine readable output
19:34:36 <bdrung> no, it has no rss feed
19:34:41 <Laney> it would be easy enough to hook it up to whatever fancy stuff if so
19:34:49 <Laney> maybe it should just export json or something
19:35:43 <bdrung> we have a json export
19:35:59 <bdrung> http://reports.qa.ubuntu.com/reports/sponsoring/sponsoring.json
19:36:48 <bdrung> i like to discuss your "What I like least in Ubuntu" section
19:36:50 <Laney> should be easy enough to compute whatever lists you want then
19:36:53 <Laney> yes! yes let's!
19:37:12 * skaet also thinks from release team perspective that Laney have wider upload permissions beyond desktop would be good.  :)
19:37:34 <bdrung> you wrote that there are not enough people working on universe.
19:37:52 * Laney hugs skaet - cheers :-)
19:38:01 <bdrung> it seems to me that the number of MOTUs decrease.
19:38:20 <Laney> right
19:38:25 <bdrung> in contrast, debian seems to grow and grow
19:38:34 <Laney> we barely get any new MOTU though the DMB any more, do we?
19:38:47 <micahg> I think we've had a handful in the last year
19:39:29 <Laney> 5 or so
19:39:29 <bdrung> what can be done?
19:39:56 <Laney> heh
19:40:12 <Laney> we've discussed this for the past several UDS
19:40:31 <bdrung> anything that was successful?
19:40:33 <Laney> this developer advisory team seems like a good idea, but I still don't see very many new active peopl in the channel
19:40:54 <Laney> in Debian you get to own your own stuff, maybe that's why people stick there
19:41:07 <Laney> you can also get involved with the whole of the distro, not just a few teams
19:41:48 <Laney> it's set up differently, which is my second point here
19:43:22 <Laney> perhaps the presence of the company somehow makes people less willing?
19:44:14 <micahg> well, QA is always hard to find, and MOTU kinda acts like Debian QA for universe
19:44:30 <bdrung> maybe, the press sometimes have a strange view on Ubuntu and write "Canonical does this and that", but instead it's done by the community
19:45:06 <Laney> even so, Debian QA is more proactive than MOTU is
19:45:45 <Laney> possibly because there's a higher chance of there being a 'hit' on any bug over there, because each package has a maintainer (at least in theory)
19:45:53 <Laney> whereas in MOTU you have to do it yourself really
19:49:14 <bdrung> your second point was that we do not focus enough on user freedom. can you explain what user freedom means to you? FLOSS?
19:50:40 <bdrung> what can we improve?
19:50:51 <Laney> I get a feeling that we're reluctant to put the freedom of this project we're making as promenantly as we could.
19:51:18 <Laney> People talk about trying to toggle the little 'non-free software' button on in the installer.
19:51:29 <Laney> Teams rely on non-free software for their infrastructure.
19:52:27 <Laney> I dunno, I feel like somehow the Free-ness is a bit more incidental than I'd like it to be.
19:53:59 <bdrung> so we should make it more visible to our developers that Free-ness is very important to us?
19:55:39 <Laney> well, it is to me.
19:55:53 <Laney> I'd like it if the front page of the website held this up.
19:56:37 <bdrung> Laney: did you talked to the web team (or whatever team is responsible for the website)?
19:58:18 <bdrung> Laney: can we MIR unar and get it installed by default? then we can drop unrar from ubuntu-restricted-extras
19:58:19 <Laney> no, mainly because I neither have a good suggestion nor know if other people agree.
19:58:53 <bdrung> how about starting a discussion on the mailing list?
19:59:00 <Laney> no idea what that is. is it a 100% replacement? why does it need to be in main/installed by default?
19:59:53 <bdrung> unar can extract rar files and should be a 100% replacement. the upcoming file-roller can use unar to extract rar files.
20:00:29 <bdrung> we passed the 1 hour mark. let's vote and continue the discussion later.
20:00:51 <Laney> possibly. it could be added as depends/recommends/whatever there and unrar dropped if so.
20:00:54 <Laney> that would be good.
20:01:23 <bdrung> #vote Should Iain Lane become a core-dev?
20:01:23 <meetingology> Please vote on: Should Iain Lane become a core-dev?
20:01:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (private votes don't work yet, but when they do it will be by messaging the channel followed by +1/-1/+0 to me)
20:01:28 <stgraber> +1
20:01:28 <meetingology> +1 received from stgraber
20:01:39 <bdrung> +1
20:01:39 <meetingology> +1 received from bdrung
20:02:35 <micahg> +1 good work all around
20:02:35 <meetingology> +1 good work all around received from micahg
20:02:44 <micahg> and we have +1 from tumbleweed as well
20:02:48 <Laney> cody-somerville: ?
20:03:05 <cody-somerville> +1 for sure
20:03:05 <meetingology> +1 for sure received from cody-somerville
20:03:30 <cody-somerville> strong evidence of leadership and technical merit
20:03:48 <bdrung> there is one +1 from tumbleweed via email
20:04:15 <bdrung> #endvote
20:04:15 <meetingology> Voting ended on: Should Iain Lane become a core-dev?
20:04:15 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:04:15 <meetingology> Motion carried
20:04:22 <stgraber> Laney: added
20:04:26 <Laney> \o/
20:04:35 <stgraber> Laney: did you have any PPU?
20:04:39 <Laney> no
20:04:39 <bdrung> Laney: welcome in the core-dev team
20:04:48 <stgraber> good, no need to fight with edit_acl then
20:04:49 <Laney> motu, desktop, cli-mono
20:04:54 <Laney> oh yeah, did that get fixed?
20:04:58 <Laney> also, thanks all!
20:05:05 <micahg> Laney: congrats
20:05:08 <bdrung> #topic Select a chair for the next meeting
20:05:22 <bdrung> next chair will be barry
20:05:42 <bdrung> should i add the we go alphabetical through our list?
20:06:00 <stgraber> well, it still takes half an hour to list the upload rights because of the remaining duplicates and some packagesets can't be changed because they are duplicates and the API and DB disagree on the index...
20:06:06 <stgraber> so short answer, no, edit_acl is still a mess
20:06:31 <stgraber> I believe cjwatson fixed the code to create a new series in LP, so it shouldn't get any worse at least
20:06:45 <Laney> ah, so we need SQL-fu to dedup
20:06:50 <stgraber> yeah
20:07:08 <stgraber> I have a bug and ticket open on LP for months now... might go poke #launchpad-ops about getting that stuff done
20:07:31 <Laney> would be good
20:07:54 <bdrung> #endmeeting